kdemultimedia-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599
  1. Name: kdemultimedia
  2. Summary: Multimedia applications for the K Desktop Environment (KDE).
  3. Summary(ja): K デスクトップ環境 - マルチメディアアプリケーション集
  4. Version: 4.5.0
  5. Release: 2%{?_dist_release}
  6. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdemultimedia-%{version}.tar.bz2
  7. Patch1: kdemultimedia-4.3.75-nomplayerthumbs.patch
  8. # FIXME
  9. Patch2: kdemultimedia-4.3.75-kscd_doc.patch
  10. # Vine Patches
  11. # build with taglib < 1.6
  12. Patch700: kdemultimedia-4.4.5-juk_taglib.patch
  13. # not build with ffmpeg
  14. Patch701: kdemultimedia-4.5.0-noffmpeg.patch
  15. URL: http://www.kde.org/
  16. Group: Applications/Multimedia
  17. License: GPLv2+
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. # This one is normal, FLAC_OGG_LIBRARY is not actually used anyway:
  20. # FLAC_OGG_LIBRARY:FILEPATH=FLAC_OGG_LIBRARY-NOTFOUND
  21. BuildRequires: alsa-lib-devel
  22. BuildRequires: cdparanoia-devel
  23. BuildRequires: flac-devel
  24. BuildRequires: glib2-devel
  25. BuildRequires: kdebase-workspace-devel >= %{version}
  26. BuildRequires: kdelibs4-devel
  27. BuildRequires: libtheora-devel
  28. ## needed to build Kscd, keep for now -- Kevin
  29. #BuildRequires: libtunepimp-devel
  30. BuildRequires: libmusicbrainz-devel
  31. BuildRequires: libvorbis-devel
  32. # KMix PulseAudio integration is not anywhere near shippable.
  33. # Almost everything is commented out, it basically does nothing.
  34. BuildRequires: pulseaudio-libs-devel
  35. BuildRequires: taglib-devel
  36. BuildRequires: xine-lib-devel libxcb-devel
  37. Requires: %{name}-libs = %{version}-%{release}
  38. Requires: kdelibs4 >= %{version}
  39. Requires: kdebase-workspace >= %{version}
  40. Provides: dragonplayer = 2.0.2-0.1
  41. Obsoletes: dragonplayer < 2.0.2-0.1
  42. Obsoletes: %{name}-extras < %{version}-%{release}
  43. Obsoletes: kmidi koncd
  44. Provides: kdemultimedia4 = %{version}-%{release}
  45. Obsoletes: kdemultimedia4 < %{version}-%{release}
  46. %description
  47. Multimedia applications for the K Desktop Environment.
  48. What it is
  49. ----------
  50. * dragonplayer (a simple video player)
  51. * juk (a music manager and player)
  52. * kmix (an audio mixer)
  53. * kscd (an Audio-CD player)
  54. %package libs
  55. Summary: Runtime libraries for %{name}
  56. Summary(ja): %{name} のランタイムライブラリ
  57. Group: System Environment/Libraries
  58. License: LGPLv2+ and GPLv2+
  59. Obsoletes: %{name}-extras-libs < %{version}-%{release}
  60. Conflicts: dragonplayer < 2.0.2-0.1
  61. %description libs
  62. %{summary}.
  63. %package devel
  64. Summary: Developer files for %{name}
  65. Summary(ja): %{name} の開発用ファイル
  66. Group: Development/Libraries
  67. Requires: %{name}-libs = %{version}-%{release}
  68. Requires: kdelibs4-devel
  69. Provides: kdemultimedia4-devel = %{version}-%{release}
  70. Obsoletes: kdemultimedia4-devel < %{version}-%{release}
  71. %description devel
  72. %{summary}.
  73. %prep
  74. %setup -q -n kdemultimedia-%{version}
  75. #patch1 -p1 -b .nomplayerthumbs
  76. #patch2 -p1 -b .kscd_doc
  77. %if %{?_dist_release} == "vl4" || %{?_dist_release} == "vl5"
  78. %patch700 -p1 -b .taglib
  79. %endif
  80. %patch701 -p1 -b .ffmpeg
  81. %build
  82. mkdir -p %{_target_platform}
  83. pushd %{_target_platform}
  84. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  85. %cmake \
  86. -DCMAKE_BUILD_TYPE=release \
  87. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  88. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  89. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  90. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  91. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  92. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  93. ..
  94. popd
  95. make %{?_smp_mflags} -C %{_target_platform}
  96. %install
  97. rm -rf $RPM_BUILD_ROOT
  98. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  99. %clean
  100. rm -rf $RPM_BUILD_ROOT
  101. %post
  102. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  103. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  104. %posttrans
  105. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  106. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  107. update-desktop-database -q &> /dev/null ||:
  108. %postun
  109. if [ $1 -eq 0 ] ; then
  110. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  111. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  112. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  113. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  114. update-desktop-database -q &> /dev/null ||:
  115. fi
  116. %post libs -p /sbin/ldconfig
  117. %postun libs -p /sbin/ldconfig
  118. %files
  119. %defattr(-,root,root)
  120. %{_bindir}/*
  121. %{_datadir}/kde4/apps/dragonplayer
  122. %{_datadir}/kde4/apps/juk
  123. %{_datadir}/kde4/apps/kmix
  124. %{_datadir}/kde4/apps/kconf_update/*
  125. %{_datadir}/kde4/apps/konqsidebartng
  126. %{_datadir}/kde4/apps/kscd
  127. %{_datadir}/kde4/apps/solid/actions/dragonplayer-opendvd.desktop
  128. %{_datadir}/kde4/apps/solid/actions/kscd-play-audiocd.desktop
  129. %{_datadir}/kde4/apps/solid/actions/solid_audiocd.desktop
  130. %{_datadir}/kde4/apps/videothumbnail/
  131. %{_datadir}/config/dragonplayerrc
  132. %{_datadir}/applications/kde4/*
  133. %{_datadir}/autostart/*
  134. %{_datadir}/kde4/services/*
  135. %{_datadir}/config.kcfg/*
  136. %{_datadir}/dbus-1/interfaces/*
  137. %{_docdir}/HTML/en/dragonplayer/
  138. %{_docdir}/HTML/en/juk/
  139. %{_docdir}/HTML/en/kcontrol/
  140. %{_docdir}/HTML/en/kioslave/
  141. %{_docdir}/HTML/en/kmix/
  142. %{_datadir}/icons/hicolor/*/*/*
  143. %{_datadir}/icons/oxygen/*/actions/player-volume-muted.*
  144. %{_datadir}/icons/oxygen/*/actions/kscd-dock.*
  145. %{_libdir}/libkdeinit*.so
  146. %files libs
  147. %defattr(-,root,root,-)
  148. %{_libdir}/lib*.so.*
  149. %{_libdir}/kde4/*
  150. %files devel
  151. %defattr(-,root,root)
  152. %{_includedir}/kde4/audiocdencoder.h
  153. %{_includedir}/kde4/libkcddb
  154. %{_includedir}/kde4/libkcompactdisc
  155. %{_libdir}/lib*.so
  156. %exclude %{_libdir}/libkdeinit*.so
  157. %changelog
  158. * Tue Aug 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
  159. - added Provides: kdemultimedia4
  160. - added Provides: kdemultimedia4-devel to devel package
  161. * Sat Aug 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  162. - new upstream release
  163. - added Patch701 to avoid link with ffmpeg
  164. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  165. - new upstream release
  166. - added Conflicts: kdemultimedia3
  167. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  168. - new upstream release
  169. * Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  170. - new upstream release
  171. * Sun Mar 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  172. - new upstream release
  173. * Sat Mar 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
  174. - new upstream release
  175. - built with new toolchain
  176. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  177. - new upstream release
  178. * Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
  179. - new upstream release
  180. * Mon Sep 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  181. - new upstream release
  182. - used %%cmake macro
  183. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  184. - new upstream release
  185. - split libs sub-package
  186. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-3
  187. - added Japanese summary, spec in UTF-8
  188. - updated BR
  189. * Sat Mar 2 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 3.5.8-2vl4
  190. - Change BuildPrereq: (Use BuildRequires)
  191. - Change BuildRequires: self-build-libmad
  192. - applied vine versioning policy
  193. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  194. - rebuild for VineSeed
  195. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  196. - new upstream release
  197. * Thu Sep 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl4
  198. - rebuild without acl
  199. * Tue Aug 21 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl3
  200. - rebuild with flac-1.2.0
  201. * Tue Jul 3 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  202. - rebuild for VineSeed
  203. - add BuildPrereq: cdparanoia-devel
  204. - delete our own copy of cdparanoia and BuildConflicts: cdparanoia-devel
  205. * Tue May 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  206. - new upstream release
  207. - enable-cdparanoia
  208. * Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  209. - new upstream release
  210. * Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
  211. - added --with-qt-libraries and --enable-libsuffix option
  212. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  213. - rebuild for VineSeed
  214. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  215. - new upstream release
  216. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  217. - rebuild for VineSeed
  218. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  219. - new upstream release
  220. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  221. - rebuild for VineSeed
  222. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  223. - new upstream release
  224. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  225. - rebuild for VineSeed
  226. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  227. - new upstream release
  228. - remove BuildPrereq: gstreamer-plugins-devel
  229. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  230. - rebuild for VineSeed
  231. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  232. - new upstream release
  233. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
  234. - rebuild for VineSeed
  235. * Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
  236. - new upstream release
  237. * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
  238. - new upstream release
  239. - add --includedir=%%{_includedir}/kde to configure option
  240. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
  241. - new upstream release
  242. * Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
  243. - new upstream release
  244. * Thu Aug 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl4
  245. - rebuild for VineSeed
  246. * Thu Aug 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl3
  247. - rebuild with kdelibs-3.4.2
  248. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
  249. - build for VineSeed
  250. - add --disable-rpath to configure option
  251. - add alsa support for VineSeed
  252. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
  253. - new upstream release
  254. - use %%{?_smp_mflags} for make option
  255. * Sat Mar 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
  256. - rebuild for VineSeed
  257. * Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
  258. - new upstream release
  259. - change configure option
  260. - add BuildPrereq: gstreamer-plugins-devel libmad-devel
  261. * Sat Feb 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl3
  262. - rebuild with flac-1.1.2 (VineSeed)
  263. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  264. - rebuild for VineSeed
  265. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  266. - new upstream release
  267. - move all files under %%{_libdir} to main package
  268. - add --sysconfdir=/etc to configure option
  269. - add /etc/xdg/menus/applications-merged/kde-multimedia-music.menu to %%files
  270. * Sat Oct 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl2
  271. - rebuild with flac-1.1.1 (VineSeed)
  272. * Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  273. - source upgrade
  274. - add patch0 again
  275. - update %%files
  276. * Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
  277. - rebuild with qt32
  278. * Mon Jun 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
  279. - source upgrade
  280. - remove lines about vine26
  281. - add URL: http://www.kde.org/
  282. - remove patch0 and patch1
  283. - add BuildPrereq: audiofile-devel flac-devel taglib-devel gstreamer-devel
  284. - add BuildConflicts: cdparanoia-devel
  285. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  286. - source upgrade
  287. - kernel-2.4.26 does not need patch0
  288. * Sun Mar 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  289. - source upgrade
  290. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
  291. - rebuild for VineSeedPlus
  292. * Mon Jan 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
  293. - source upgrade
  294. - build for VinePlus/2.6
  295. - (VinePlus/2.6) BuildPrereq: autoconf258
  296. - build without cdparanoia
  297. * Thu Jan 8 2004 Tomoya TAKA <taka@vinelinux.org> 3.1.4-0vl2
  298. - add Patch1 to resolve conflicting typedef on alpha
  299. - remove ExcludeArch: alpha
  300. * Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
  301. - source upgrade
  302. - change spec to build with gcc3
  303. - add Patch0 to build kaudiocreator
  304. (patch to /usr/include/asm/byteorder.h)
  305. - include our own copy of cdparanoia, nuke FixupTOC() from it
  306. - build without cdparanoia-devel
  307. - revised description
  308. - change spec to make monolithic package only
  309. - add Obsoletes: kmidi koncd
  310. - remove KOnCD configuration
  311. - rename timidity to avoid conflict with timidy++
  312. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
  313. - source upgrade
  314. - change spec to build with gcc295
  315. - change make option for SMP and add script
  316. * Sat Jun 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  317. - source upgrade
  318. - change spec to build both VineSeed and Vine2.5/2.6
  319. - remove all patches
  320. - add BuildPrereq: cdparanoia-devel cdrtools-devel
  321. - built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
  322. - change spec to build with g++-2.95.3
  323. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  324. - objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
  325. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  326. - source upgrade
  327. - BuildPrereq: autoconf253 objprelink2
  328. * Mon Aug 26 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  329. - source upgrade
  330. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-1vl2
  331. - rebuild with libvorbis-1.0-0vl1
  332. * Tue Jul 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-1vl1
  333. - build for Vine Linux 2.5 / VineSeed
  334. - delete Epoch
  335. - objprelink (i386 only)
  336. - add %%define monolithic 1
  337. - add BuildPrereq: autoconf252 automake15 libogg-devel libvorbis-devel
  338. - delete BuildPrereq: desktop-file-utils and use default .desktop files
  339. - koncd: delete Requires: mkisofs and add Requires: cdrdao
  340. - kmidi: change Requires: timidity++ -> TiMidity++
  341. delete Obsoletes: kdemultimedia
  342. - devel: Requires: kdemultimedia = %%{version}-%%{rel}
  343. * Wed Jul 10 2002 Than Ngo <than@redhat.com> 3.0.2-1
  344. - 3.0.2
  345. - use desktop-file-install
  346. * Thu Jun 06 2002 Than Ngo <than@redhat.com> 3.0.1-3
  347. - rebuild
  348. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  349. - automated rebuild
  350. * Fri May 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.1-1
  351. - 3.0.1
  352. * Wed Apr 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
  353. - Make sure we link to the just built libraries instead of libs in the
  354. build environment from older releases
  355. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
  356. - Update ABI
  357. - Add cdrecord/mkisofs requirements for KOnCD (#63606)
  358. - Tell koncd where to find cdrecord and mkisofs (#63604)
  359. * Wed Mar 27 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-1
  360. - 3.0.0 final
  361. * Thu Mar 21 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020321.1
  362. - Adapt spec file to recent changes in base
  363. * Thu Mar 7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020307.1
  364. - Update
  365. - Rename subpackages
  366. * Fri Feb 1 2002 Tim Powers <timp@redhat.com>
  367. - kdemultimedia-devel shouldn't obsolete itself
  368. - temporarily ExcludeArch ia64
  369. * Mon Aug 6 2001 Than Ngo <than@redhat.com> 2.2-1
  370. - update to 2.2 release
  371. * Fri Aug 3 2001 Than Ngo <than@redhat.com> 2.2-0.cvs20010803.1
  372. - update
  373. - fix bug #24132
  374. - get rid of aktion
  375. * Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
  376. - Update
  377. - move devel files to a separate package
  378. - Add BuildPrereqs (#44914)
  379. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  380. - 2.1-respin
  381. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  382. - 2.1
  383. * Tue Feb 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  384. - Remove copyrighted midi files (#26431)
  385. - Use a real file list rather than find/sed (#26565)
  386. - Fix build with current glibc
  387. * Thu Feb 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  388. - Replace absolute symlinks with relative ones (#24794)
  389. - Don't use more than 2 CPUs at build time to shut up asok
  390. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  391. - Update
  392. * Mon Jan 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  393. - Update
  394. - Don't optimize on sparc, compiler breakage
  395. * Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  396. - Update to CVS
  397. - re-exclude ia64, the compiler can't handle this package
  398. * Sun Oct 22 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  399. - 2.0 final
  400. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  401. - 2.0
  402. * Thu Aug 24 2000 Than Ngo <than@redhat.com>
  403. - update kdemultimedia-1.93
  404. - fix to rebuilt with gcc-2.96
  405. * Mon Aug 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  406. - new version
  407. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  408. - fix to build against gcc-2.96-40 on sparc, alpha
  409. - disable motif
  410. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  411. - SMPify
  412. - don't hardcode QTDIR
  413. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  414. - use gcc 2.96
  415. - new snapshot
  416. * Sun Jul 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  417. - use kernelcc
  418. - new snapshot
  419. * Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  420. - Obsoletes: aktion (it's included now)
  421. * Wed Jun 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  422. - new snapshot
  423. - ExcludeArch ia64 for now
  424. * Sat Apr 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  425. - 2.0 snapshot
  426. * Tue Feb 29 2000 Preston Brown <pbrown@redhat.com>
  427. - fix localkscd patch, broken since 6.1 (#9404).
  428. * Fri Feb 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  429. - Remove (world!) write permissions to %%{prefix}/share/apps/kscd/cddb/*
  430. - fix description
  431. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  432. - Change the kmix error message (Bug #9065)
  433. - Fix kmidi behavior when trying to play an empty playlist (Bug #8843)
  434. - Fix compilation with kernel 2.3.x headers
  435. * Sat Jan 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  436. - current version from KDE_1_1_BRANCH
  437. - work around make install-strip breakage
  438. - Rebuild for 6.2
  439. * Sat Sep 25 1999 Preston Brown <pbrown@redhat.com>
  440. - patched kscd to use local user directory for cddb entries
  441. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  442. - mark doc files as such
  443. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  444. - 1.1.2 release.
  445. * Mon Jun 14 1999 Preston Brown <pbrown@redhat.com>
  446. - snapshot, includes kde 1.1.1 + fixes
  447. * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
  448. - last snapshot before release
  449. * Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
  450. - snapshot from today fixed kmid freeze issues
  451. * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
  452. - latest stable snapshot
  453. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  454. - Injected new description and group.
  455. * Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
  456. - upgraded to KDE 1.1 final.
  457. * Sat Feb 06 1999 Preston Brown <pbrown@redhat.com>
  458. - complies w/new RPM, newer libstdc++
  459. * Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
  460. - re-merged in updates from Duncan Haldane