gnome-shell-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168
  1. %define pkg_version 3.1.4
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.xz
  8. # settings for Vine
  9. Patch101: gnome-shell-vine-settings.patch
  10. Patch102: gnome-shell-vine-customize.patch
  11. Patch103: gnome-shell-3.1.4-ja.po.patch
  12. License: GPLv2+
  13. Group: User Interface/Desktops
  14. URL: http://live.gnome.org/GnomeShell
  15. Requires(post,postun): scrollkeeper >= 0.1.4
  16. Requires(post,pre,preun): GConf2 >= 2.14
  17. Requires: mutter
  18. BuildRequires: gnome-common
  19. BuildRequires: libtool
  20. BuildRequires: automake
  21. BuildRequires: autoconf
  22. BuildRequires: pkgconfig
  23. BuildRequires: gtk2-devel
  24. BuildRequires: clutter-devel
  25. BuildRequires: mutter-devel
  26. BuildRequires: gjs-devel
  27. BuildRequires: gnome-desktop3-devel
  28. BuildRequires: gnome-menus-devel
  29. BuildRequires: libSM-devel
  30. BuildRequires: libffi-devel
  31. BuildRequires: GConf2-devel
  32. BuildRequires: startup-notification-devel
  33. BuildRequires: gnome-doc-utils
  34. BuildRequires: desktop-file-utils
  35. BuildRequires: libcroco-devel
  36. BuildRequires: librsvg2-devel
  37. BuildRequires: gobject-introspection-devel
  38. BuildRequires: gstreamer-devel
  39. BuildRequires: dbus-glib-devel
  40. BuildRequires: telepathy-logger-devel
  41. BuildRequires: polkit-devel
  42. BuildRequires: pulseaudio-libs-devel
  43. BuildRequires: evolution-data-server-devel
  44. BuildRequires: intltool
  45. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. Packager: Takemikaduchi
  49. %description
  50. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  51. It provides core interface functions like switching to windows and launching
  52. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  53. hardware and introduces innovative user interface concepts to provide a delightful
  54. and easy to use experience.
  55. %prep
  56. %setup -q
  57. %patch101 -p1 -b .vine
  58. %patch102 -p1 -b .vine
  59. %patch103 -p1 -b .old_po
  60. %build
  61. %configure --disable-static
  62. %{__make} %{?_smp_mflags}
  63. %install
  64. %{__rm} -rf ${RPM_BUILD_ROOT}
  65. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  66. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  67. %find_lang %{name}
  68. %clean
  69. %{__rm} -rf ${RPM_BUILD_ROOT}
  70. %post
  71. /sbin/ldconfig
  72. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  73. gconftool-2 --makefile-install-rule \
  74. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  75. > /dev/null || :
  76. touch --no-create %{_datadir}/icons/hicolor
  77. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  78. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  79. fi
  80. %pre
  81. if [ "$1" -gt 1 ]; then
  82. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  83. gconftool-2 --makefile-uninstall-rule \
  84. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  85. > /dev/null || :
  86. fi
  87. %preun
  88. if [ "$1" -eq 0 ]; then
  89. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  90. gconftool-2 --makefile-uninstall-rule \
  91. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  92. > /dev/null || :
  93. fi
  94. %postun
  95. scrollkeeper-update -q || :
  96. /sbin/ldconfig
  97. touch --no-create %{_datadir}/icons/hicolor
  98. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  99. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  100. fi
  101. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  102. %posttrans
  103. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  104. %files -f %{name}.lang
  105. %defattr(-,root,root)
  106. %doc COPYING NEWS README
  107. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
  108. %{_bindir}/gnome-shell
  109. %{_bindir}/gnome-shell-extension-tool
  110. %{_libdir}/gnome-shell/*
  111. %{_libexecdir}/gnome-shell-calendar-server
  112. %{_libexecdir}/gnome-shell-hotplug-sniffer
  113. %{_libexecdir}/gnome-shell-perf-helper
  114. %{_datadir}/applications/gnome-shell.desktop
  115. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  116. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  117. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  118. %{_datadir}/gnome-shell/*
  119. %{_datadir}/man/man1/*.1.gz
  120. %changelog
  121. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  122. - new upstream release
  123. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  124. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  125. - remove BuildRequires: xulrunner-devel
  126. - add Patch101 (gnome-shell-vine-settings.patch)
  127. - add Patch102 (gnome-shell-vine-customize.patch)
  128. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  129. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  130. - add Requires: mutter
  131. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  132. - new upstream release
  133. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  134. - initial build for Vine Linux