gnome-power-manager-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359
  1. %define dbus_version 1.4.0
  2. %define dbus_glib_version 0.88
  3. %define gnome_panel_version 2.32.0
  4. Summary: GNOME power management service
  5. Summary(ja): GNOME 電源管理ツール
  6. Name: gnome-power-manager
  7. Version: 3.1.3
  8. Release: 1%{?_dist_release}
  9. License: GPLv2+ and GFDL
  10. Group: Applications/System
  11. URL: http://projects.gnome.org/gnome-power-manager/
  12. Source0: http://download.gnome.org/sources/gnome-power-manager/3.1/gnome-power-manager-%{version}.tar.xz
  13. # ja.po from l10n
  14. Source101: gnome-power-manager.gnome-2-32.ja.po
  15. # for Vine Linux
  16. Patch10: gnome-power-manager-2.28.2-warningflags.patch
  17. Patch11: gnome-power-manager-2.28.2-math.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: autoconf >= 2.65
  20. BuildRequires: gtk3-devel
  21. BuildRequires: libgnomeui-devel
  22. BuildRequires: libglade2-devel
  23. BuildRequires: libwnck-devel
  24. BuildRequires: dbus-devel >= %{dbus_version}
  25. BuildRequires: libnotify-devel
  26. BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
  27. BuildRequires: scrollkeeper
  28. BuildRequires: gnome-doc-utils >= 0.3.2
  29. BuildRequires: desktop-file-utils
  30. BuildRequires: gettext
  31. BuildRequires: libtool
  32. BuildRequires: cairo-devel
  33. BuildRequires: libcanberra-gtk3-devel
  34. BuildRequires: unique3-devel >= 3.0.0
  35. ## BuildRequires: DeviceKit-power-devel >= 008
  36. BuildRequires: upower-devel >= 0.9.0
  37. BuildRequires: control-center-devel
  38. BuildRequires: intltool
  39. BuildRequires: docbook-utils
  40. Requires: gtk3 >= 3.0.0
  41. Requires: gnome-mime-data
  42. Requires: gnome-icon-theme
  43. Requires: libnotify >= 0.4.3
  44. Requires: dbus-glib >= %{dbus_glib_version}
  45. Requires: dbus-x11 >= %{dbus_version}
  46. Requires: libcanberra-gtk3 >= 0.10
  47. Requires: unique3 >= 3.0.0
  48. Requires: upower >= 0.9.0
  49. Requires(post,postun): scrollkeeper
  50. Requires(post,pre,preun): GConf2
  51. Obsoletes: gnome-power-manager-extra < 3.0.0
  52. Provides: gnome-power-manager-extra
  53. Vendor: Project Vine
  54. Distribution: Vine Linux
  55. Packager: daisuke, Takemikaduchi
  56. %description
  57. GNOME Power Manager uses the information and facilities provided by HAL
  58. displaying icons and handling user callbacks in an interactive GNOME session.
  59. GNOME Power Preferences allows authorised users to set policy and
  60. change preferences.
  61. %prep
  62. %setup -q
  63. #%setup -q -n %{?name}-%{?version}-%{?alphatag}
  64. ## %patch10 -p1 -b .warnings
  65. ## %patch11 -p1 -b .math
  66. # copy ja.po
  67. #cp -f %{SOURCE101} po/ja.po
  68. # autoreconf -i
  69. %build
  70. %configure \
  71. --disable-scrollkeeper
  72. make
  73. # strip unneeded translations from .mo files
  74. # ideally intltool (ha!) would do that for us
  75. # http://bugzilla.gnome.org/show_bug.cgi?id=474987
  76. #cd po
  77. #grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
  78. #mv POTFILES.keep POTFILES.in
  79. #intltool-update --pot
  80. #for p in *.po; do
  81. # msgmerge $p %{name}.pot > $p.out
  82. # msgfmt -o `basename $p .po`.gmo $p.out
  83. #done
  84. %install
  85. rm -rf $RPM_BUILD_ROOT
  86. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  87. make install DESTDIR=$RPM_BUILD_ROOT
  88. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  89. #desktop-file-install --vendor gnome --delete-original \
  90. # --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart \
  91. # $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
  92. # save space by linking identical images in translated docs
  93. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  94. for f in $helpdir/C/figures/*.png; do
  95. b="$(basename $f)"
  96. for d in $helpdir/*; do
  97. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  98. g="$d/figures/$b"
  99. if [ -f "$g" ]; then
  100. if cmp -s $f $g; then
  101. rm "$g"; ln -s "../../C/figures/$b" "$g"
  102. fi
  103. fi
  104. fi
  105. done
  106. done
  107. %find_lang %name --with-gnome
  108. %clean
  109. rm -rf $RPM_BUILD_ROOT
  110. %post
  111. scrollkeeper-update -q &> /dev/null || :
  112. touch --no-create %{_datadir}/icons/hicolor
  113. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  114. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  115. fi
  116. %postun
  117. scrollkeeper-update -q &> /dev/null || :
  118. touch --no-create %{_datadir}/icons/hicolor
  119. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  120. gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
  121. fi
  122. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  123. %posttrans
  124. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  125. %files -f %{name}.lang
  126. %defattr(-,root,root)
  127. %doc AUTHORS COPYING README
  128. #%{_sysconfdir}/xdg/autostart/*.desktop
  129. #%{_bindir}/gnome-power-manager
  130. %{_bindir}/gnome-power-statistics
  131. %{_sbindir}/gnome-power-backlight-helper
  132. %dir %{_datadir}/gnome-power-manager
  133. %{_datadir}/gnome-power-manager/acme.ui
  134. %{_datadir}/gnome-power-manager/gpm-feedback-widget.ui
  135. %{_datadir}/gnome-power-manager/gpm-statistics.ui
  136. %{_datadir}/GConf/gsettings/org.gnome.power-manager.gschema.migrate
  137. %{_datadir}/applications/gnome-power-statistics.desktop
  138. #%{_datadir}/dbus-1/services/gnome-power-manager.service
  139. %{_datadir}/glib-2.0/schemas/*.xml
  140. %{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
  141. %{_datadir}/icons/hicolor/*/apps/*
  142. %{_datadir}/icons/gnome/scalable/status/keyboard-brightness-symbolic.svg
  143. %{_datadir}/polkit-1/actions/org.gnome.power.policy
  144. #%{_mandir}/man1/gnome-power-manager.1.gz
  145. %{_mandir}/man1/gnome-power-statistics.1.gz
  146. %changelog
  147. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
  148. - new upstream release
  149. - add BuildRequires: gtk3-devel, control-center-devel
  150. - change BuildRequires: libcanberra-gtk3-devel instead of licanberra-devel
  151. - change BuildRequires: unique3-devel instead of unique-devel
  152. - delete -extra sub package
  153. * Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
  154. - add Source101(gnome-power-manager.gnome-2-32.ja.po)
  155. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  156. - new upstream release
  157. - change BuildRequires: gnome-panel-devel instead of gnome-panel
  158. - fix %files
  159. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  160. - new upstream release
  161. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  162. - new upstream release
  163. - remove Patch1, Patch2, Patch3
  164. - change BuildRequires: DeviceKit-power-devel -> upower-devel
  165. - change Requires: DeviceKit-power -> upower
  166. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  167. - new upstream release
  168. - change BuildRequires: xmlto -> docbook-utils
  169. - remove BuildReuiqres: hal-devel
  170. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  171. - new upstream release
  172. * Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  173. - merge spec file from FC package
  174. - add Patch1, Patch2 and Patch3 from FC package
  175. - add Patch10 and Patch11 for Vine Linux
  176. - remove configure option --enable-policykit
  177. - add new package (extra)
  178. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
  179. - new upstream release
  180. * Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  181. - new upstream release
  182. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  183. - new upstream release
  184. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  185. - new upstream release
  186. * Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
  187. - new upstream release
  188. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
  189. - rebuild with new environment/toolchain
  190. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
  191. - new upstream release
  192. - drop Patch10 to enable suspend-to-ram.
  193. * Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
  194. - new upstream release
  195. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
  196. - new upstream release
  197. * Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
  198. - new upstream release
  199. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
  200. - new upstream release
  201. * Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
  202. - new upstream release
  203. * Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
  204. - new upstream release
  205. * Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
  206. - new upstream release
  207. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  208. - new upstream release
  209. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
  210. - add Patch10 to disable suspend-to-ram by default.
  211. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  212. - update ja.po from CVS head.
  213. * Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  214. - new upstream release
  215. * Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
  216. - initial build for Vine Linux based on FC package
  217. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
  218. - fix the fix in -2 and -3
  219. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
  220. - fix the fix in -2
  221. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
  222. - fix icon in bubbles (bug 184192).
  223. * Fri Mar 3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
  224. - Update to 2.13.93
  225. - ignore d-bus timeout errors
  226. * Thu Mar 2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
  227. - Add patch from Richard Hughes to potentially fix a
  228. crasher bug (bug 183127)
  229. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
  230. - Buildrequires: gnome-doc-utils
  231. * Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
  232. - Update to 2.13.92
  233. * Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
  234. - Update to 2.13.91
  235. - Drop upstreamed patch
  236. * Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
  237. - Update to 2.13.90
  238. - Require dbus-x11 (#176656)
  239. * Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
  240. - remove Hibernate and Suspend from menus as part of
  241. panel/g-p-m integration effort
  242. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
  243. - bump again for double-long bug on ppc(64)
  244. * Tue Feb 7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
  245. - pull cvs snapshot from HEAD and drop the patches caillon
  246. just added
  247. * Tue Feb 7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
  248. - Install into the autostart directory
  249. - Don't suspend on lid close while on AC power
  250. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
  251. - rebuilt for new gcc4.1 snapshot and glibc changes
  252. * Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
  253. - rebuild
  254. * Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
  255. - packaging tweaks
  256. * Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
  257. - Update to 2.13.5
  258. * Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
  259. - Left clicking on the applet should bring up the menu
  260. * Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
  261. - update to 0.3.4
  262. - disable updating scrollkeeper database in buildroot
  263. (move to %%post)
  264. * Fri Jan 6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
  265. - update to a cvs snap so that it works with hal cvs snap
  266. - make sure we use libnotify
  267. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
  268. - rebuilt
  269. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
  270. - rebuild for new dbus
  271. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
  272. - Update to 0.3.1
  273. * Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
  274. - Update to 0.3.0
  275. * Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
  276. - update to 0.2.8
  277. * Wed Oct 3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
  278. - update to 0.2.6
  279. * Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
  280. - update to 0.2.4
  281. * Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
  282. - Initial import based on an SRPM from Richard Hughes