gnome-bluetooth-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386
  1. Summary: GNOME Bluetooth Subsystem
  2. Summary(ja): GNOME Bluetooth サブシステム
  3. Name: gnome-bluetooth
  4. Version: 3.1.4
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Libraries
  8. URL: http://live.gnome.org/GnomeBluetooth
  9. Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.1/%{name}-%{version}.tar.bz2
  10. Source1: 61-gnome-bluetooth-rfkill.rules
  11. #----------------------------------------------------------------------------
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. #----------------------------------------------------------------------------
  14. #BuildRequires: autoconf >= 2.57
  15. BuildRequires: bluez-libs-devel >= 2.8
  16. #BuildRequires: bluez-utils
  17. BuildRequires: libbonobo-devel >= 2.32.0
  18. BuildRequires: libbonoboui-devel >= 2.24.4
  19. BuildRequires: GConf2-devel >= 2.32
  20. BuildRequires: hal-devel
  21. BuildRequires: unique3-devel
  22. BuildRequires: libnotify-devel
  23. BuildRequires: gnome-doc-utils
  24. BuildRequires: control-center-devel
  25. BuildRequires: intltool, automake, libtool, gettext
  26. Requires: %{name}-libs = %{version}-%{release}
  27. Requires(pre): GConf2
  28. Requires(post): GConf2
  29. Requires(preun): GConf2
  30. Requires: bluez >= 4.42
  31. Requires: obexd
  32. Requires(post): desktop-file-utils
  33. Requires(postun): desktop-file-utils
  34. ExcludeArch: s390 s390x
  35. ## Patch1: gnome-bluetooth-0.8.0-desktop.patch
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: Takemikaduchi
  39. #----------------------------------------------------------------------------
  40. %description
  41. This package contains a library with widgets for Bluetooth applications.
  42. %description -l ja
  43. このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
  44. ライブラリが含まれます。
  45. #----------------------------------------------------------------------------
  46. %package libs
  47. Summary: Libraries for applications, which use gnome-bluetooth
  48. Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
  49. Group: Development/Libraries
  50. %description libs
  51. This package contains the libraries for applications,
  52. which use gnome-bluetooth.
  53. %description libs -l ja
  54. このパッケージには Gnome-bluetoothを使用するアプリケーション用の
  55. ライブラリが含まれています。
  56. #----------------------------------------------------------------------------
  57. %package devel
  58. Summary: Files for the development of applications, which use gnome-bluetooth
  59. Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
  60. Group: Development/Libraries
  61. License: LGPLv2+
  62. Requires: %{name}-libs = %{version}-%{release}
  63. Requires: gtk-doc pkgconfig
  64. Requires: glib2-devel
  65. Requires: libbtctl-devel
  66. %description devel
  67. This package contains the files for the development of applications,
  68. which will use gnome-bluetooth.
  69. %description devel -l ja
  70. このパッケージにはGnome-bluetoothを使用するアプリケーションを
  71. 開発するためのヘッダーファイルなどが含まれています(develパッケージ)
  72. #----------------------------------------------------------------------------
  73. %prep
  74. %setup -q -n gnome-bluetooth-%{version}
  75. ## %patch1 -p1 -b .dfix
  76. %build
  77. %configure --disable-desktop-update --disable-icon-update --disable-nautilus-sendto --enable-introspection=yes
  78. make %{?_smp_mflags}
  79. #----------------------------------------------------------------------------
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  83. make DESTDIR=$RPM_BUILD_ROOT install
  84. # we do not want .la files
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
  86. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
  87. rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
  88. rm -f $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
  89. install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  90. # Remove the gnome-obex-server
  91. # rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
  92. %find_lang gnome-bluetooth2
  93. %find_lang %{name} --with-gnome
  94. cat %{name}.lang >> gnome-bluetooth2.lang
  95. # save space by linking identical images in translated docs
  96. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  97. for f in $helpdir/C/figures/*.png; do
  98. b="$(basename $f)"
  99. for d in $helpdir/*; do
  100. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  101. g="$d/figures/$b"
  102. if [ -f "$g" ]; then
  103. if cmp -s $f $g; then
  104. rm "$g"; ln -s "../../C/figures/$b" "$g"
  105. fi
  106. fi
  107. fi
  108. done
  109. done
  110. %clean
  111. rm -rf $RPM_BUILD_ROOT
  112. %post
  113. update-desktop-database -q
  114. %postun
  115. update-desktop-database -q
  116. if [ $1 -eq 0 ] ; then
  117. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  118. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  119. fi
  120. %post libs
  121. /sbin/ldconfig
  122. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  123. %posttrans libs
  124. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  125. %postun libs
  126. /sbin/ldconfig
  127. if [ $1 -eq 0 ] ; then
  128. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  129. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  130. fi
  131. #----------------------------------------------------------------------------
  132. %files -f %{name}.lang
  133. %defattr(-, root, root)
  134. %doc README NEWS COPYING
  135. %{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
  136. %{_bindir}/bluetooth-*
  137. %{_libdir}/gnome-bluetooth/
  138. %{_libdir}/control-center-1/panels/libbluetooth.so
  139. %{_datadir}/applications/*.desktop
  140. %{_datadir}/gnome-bluetooth/
  141. %{_datadir}/locale/*
  142. %{_mandir}/man1/*
  143. /lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  144. %files libs
  145. %defattr(-,root,root,-)
  146. %doc COPYING.LIB
  147. %{_libdir}/libgnome-bluetooth.so.*
  148. %{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
  149. %{_datadir}/icons/hicolor/*/apps/*
  150. %{_datadir}/icons/hicolor/*/status/*
  151. %files devel
  152. %defattr(-,root,root,-)
  153. %{_includedir}/gnome-bluetooth/
  154. %{_libdir}/libgnome-bluetooth.so
  155. %{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
  156. %{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
  157. %{_datadir}/gtk-doc/html/gnome-bluetooth/
  158. #----------------------------------------------------------------------------
  159. %changelog
  160. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  161. - new upstream release
  162. - change BuildRequires: unique3-devel instead of unique-devel
  163. - add BuildRequires: control-center-devel
  164. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  165. - new upstream release
  166. - remove BuildRequires: gir-repository-devel
  167. - add Requires(post) and Requires(postun): desktop-file-utils
  168. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
  169. - rebuild with rpm-4.8.1 for pkg-config file
  170. * Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  171. - new upstream release
  172. - add BuildRequires: gir-repository-devel
  173. - add configure option (--disable-nautilus-sendto)
  174. * Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  175. - new upstream release
  176. - merge spec file from FC package
  177. * Fri Oct 24 2008 Seiichirou Babasaki 0.11.0-6
  178. - Update to 0.11.0 (VineSeed)
  179. - added "# Maintainers: " comments.
  180. - changed UTF-8 encode at gnome-bluetooth.vsc.spec
  181. - FedoraCore - LOGS
  182. -- 0.11.0-5
  183. -- Rebuild against new bluez-libs
  184. -- 0.11.0-4
  185. -- Changed name of icon file(#444811)
  186. -- 0.11.0-3
  187. -- Remove gnome-obex-server, we should use gnome-user-share now
  188. -- 0.11.0-1
  189. -- gcc43 rebuild
  190. -- 0.11.0 - Update to 0.11.0
  191. -- 0.10.0 - Update to 0.10.0
  192. -- 0.9.1-4
  193. -- marked gnome-obex-server.schemas as config file
  194. -- changed upstream URL
  195. -- 0.9.1-3
  196. -- fixed wrong source URL
  197. -- 0.9.1-2
  198. -- rebuilt for F8
  199. -- changed license tag to GPLv2 and LGPLv2+
  200. -- 0.9.1-1
  201. -- Upgrade to 0.9.1 to fix a crasher in the server
  202. -- 0.9.0-1
  203. -- Update for 0.9.0
  204. -- Fix installation of the python bindings
  205. -- 0.8.0-4
  206. -- Remove unncessary gconfd killing from scripts (#224561)
  207. -- 0.8.0-3
  208. -- corrected BuildRoot
  209. -- smp flags added
  210. -- specfile cleanup
  211. -- fixed desktop file
  212. - Updated specfile
  213. * Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
  214. - Updated specfile
  215. * Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
  216. - Import gnome-bluetooth - Packager: Babasaki
  217. - Updated specfile (downgrade -> 0.8.0-0vl1)
  218. #----------------------------------------------------------------------------
  219. * Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
  220. - version 0.8.0
  221. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
  222. - rebuild
  223. * Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
  224. - bump for new openobex
  225. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
  226. - Missing automake, libtool, gettext BR
  227. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
  228. - Bump for new libbluetooth
  229. * Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
  230. - add dependency on bluez-utils, cosmetic tweaks (bug #190280)
  231. * Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
  232. - install schemata correctly (bug #193518)
  233. * Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
  234. - more build requires (bug #193374)
  235. * Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
  236. - pydir fixes for lib64
  237. * Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
  238. - version 0.7.0
  239. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
  240. - bump again for double-long bug on ppc(64)
  241. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
  242. - rebuilt for new gcc4.1 snapshot and glibc changes
  243. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  244. - rebuilt
  245. * Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
  246. - Fix relative path for the icons in desktop files which no longer works
  247. with the icon cache.
  248. * Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
  249. - new version 0.6.0
  250. * Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
  251. - rebuild for new cairo
  252. * Thu Jul 7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
  253. - Minor spec file cleanups.
  254. - Fix relative path for the icons in desktop files which no longer works
  255. with the icon cache.
  256. - Remove useless zero epochs.
  257. - Remove explicit python abi requirement, it's automatic for FC4 and up.
  258. * Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
  259. - removed base requirement from libs
  260. * Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
  261. - devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
  262. * Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
  263. - rebuilt
  264. * Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
  265. - added gnome hbox patch for bug rh#149215
  266. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
  267. - added requires for python-abi
  268. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
  269. - split package into app, libs and devel
  270. * Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
  271. - fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
  272. * Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
  273. - buildrequire pygtk2-devel (bug 135032)
  274. - fixed gnome-bluetooth-manager script for 64bit (bug 134864)
  275. - fixed segfault on file receive (bug 133041)
  276. * Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
  277. - buildrequire libbtctl-devel
  278. - buildrequire openobex-devel >= 1.0.1
  279. - pythondir -> pyexecdir
  280. * Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
  281. - added build dependency for librsvg2-devel
  282. * Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
  283. - added pydir patch
  284. * Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
  285. - version 0.5.1
  286. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  287. - rebuilt
  288. * Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
  289. - corrected BuildRequires
  290. * Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
  291. - added EggToolBar patch for gcc34
  292. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  293. - rebuilt
  294. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  295. - rebuilt
  296. * Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
  297. - added autofoo patch
  298. * Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
  299. - add .so to gnome-vfs module, if libtool does not!
  300. * Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
  301. - call libtool finish
  302. * Wed Aug 6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
  303. - new version 0.4.1
  304. * Wed Jun 5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
  305. - initial RPM