gdk-pixbuf2-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # biarch support
  3. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  4. %define _query_suffix %{nil}
  5. %if %{build_compat32}
  6. %define _query_suffix -32
  7. %endif
  8. Name: gdk-pixbuf2
  9. Version: 2.23.5
  10. Release: 1%{?_dist_release}
  11. Summary: An image loading library
  12. Group: System Environment/Libraries
  13. License: LGPLv2+
  14. URL: http://www.gt.org
  15. Source0: http://download.gnome.org/sources/gdk-pixbuf/2.23/gdk-pixbuf-%{version}.tar.xz
  16. BuildRequires: glib2-devel >= 2.26.0
  17. BuildRequires: libpng-devel
  18. BuildRequires: libjpeg-turbo-devel
  19. BuildRequires: libtiff-devel
  20. BuildRequires: jasper-devel
  21. BuildRequires: libX11-devel
  22. BuildRequires: gobject-introspection-devel
  23. # gdk-pixbuf does a configure time check which uses the GIO mime
  24. # layer; we need to actually have the mime type database.
  25. BuildRequires: shared-mime-info
  26. BuildRequires: gtk-doc
  27. ## BuildRequires: libtool >= 2.2.10
  28. BuildRequires: libtool
  29. BuildRequires: gettext
  30. # We also need MIME information at runtime
  31. Requires: shared-mime-info
  32. # gdk-pixbuf was included in gtk2 until 2.21.2
  33. Conflicts: gtk2 <= 2.21.2
  34. # https://bugzilla.gnome.org/show_bug.cgi?id=624712
  35. Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: Takemikaduchi
  39. %description
  40. gdk-pixbuf is an image loading library that can be extended by loadable
  41. modules for new image formats. It is used by toolkits such as GTK+ or
  42. clutter.
  43. %package devel
  44. Summary: Development files for gdk-pixbuf
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. Requires: glib2-devel
  48. Requires: gobject-introspection-devel
  49. Requires: libpng-devel
  50. # gdk-pixbuf was included in gtk2 until 2.21.2
  51. Conflicts: gtk2-devel <= 2.21.2
  52. %description devel
  53. This package contains the libraries and header files that are needed
  54. for writing applications that are using gdk-pixbuf.
  55. %if %{build_compat32}
  56. #######################################################################
  57. # compat32
  58. %package -n compat32-%{name}
  59. Summary: An image loading library
  60. Group: System Environment/Libraries
  61. Requires(post): compat32-glib2 >= %{glib2_version}
  62. # gdk-pixbuf was included in gtk2 until 2.21.2
  63. Conflicts: compat32-gtk2 <= 2.21.2
  64. %description -n compat32-%{name}
  65. gdk-pixbuf is an image loading library that can be extended by loadable
  66. modules for new image formats. It is used by toolkits such as GTK+ or
  67. clutter.
  68. %package -n compat32-%{name}-devel
  69. Summary: Development files for gdk-pixbuf
  70. Group: Development/Libraries
  71. Requires: compat32-%{name} = %{version}-%{release}
  72. Requires: %{name} = %{version}-%{release}
  73. Requires: compat32-libpng-devel
  74. # gdk-pixbuf was included in gtk2 until 2.21.2
  75. Conflicts: compat32-gtk2-devel <= 2.21.2
  76. %description -n compat32-%{name}-devel
  77. This package contains the libraries and header files that are needed
  78. for writing applications that are using gdk-pixbuf.
  79. %endif
  80. %prep
  81. %setup -q -n gdk-pixbuf-%{version}
  82. ## %patch0 -p1 -b .libpng-linking
  83. %build
  84. libtoolize --copy --force
  85. autoreconf
  86. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  87. %configure $CONFIGFLAGS \
  88. --with-libjasper \
  89. --with-included-loaders=png \
  90. --enable-introspection=yes )
  91. make %{?_smp_mflags}
  92. %install
  93. make install DESTDIR=$RPM_BUILD_ROOT \
  94. RUN_QUERY_LOADER_TEST=false
  95. # Remove unpackaged files
  96. rm $RPM_BUILD_ROOT%{_libdir}/*.la
  97. rm $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.la
  98. touch $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  99. %if %{build_compat32}
  100. cp $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders \
  101. $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
  102. %endif
  103. %find_lang gdk-pixbuf
  104. %post
  105. /sbin/ldconfig
  106. gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
  107. %postun
  108. /sbin/ldconfig
  109. if [ $1 -gt 0 ]; then
  110. gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
  111. fi
  112. %if %{build_compat32}
  113. %post -n compat32-%{name}
  114. /sbin/ldconfig
  115. gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
  116. %postun -n compat32-%{name}
  117. /sbin/ldconfig
  118. if [ $1 -gt 0 ]; then
  119. gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
  120. fi
  121. %endif
  122. %files -f gdk-pixbuf.lang
  123. %defattr(-,root,root,-)
  124. %doc AUTHORS COPYING NEWS
  125. %{_libdir}/libgdk_pixbuf-2.0.so.*
  126. %{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
  127. %{_libdir}/girepository-1.0
  128. %dir %{_libdir}/gdk-pixbuf-2.0
  129. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
  130. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  131. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
  132. %ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  133. %{_bindir}/gdk-pixbuf-query-loaders
  134. %{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
  135. %files devel
  136. %defattr(-,root,root,-)
  137. %{_includedir}/gdk-pixbuf-2.0
  138. %{_libdir}/libgdk_pixbuf-2.0.so
  139. %{_libdir}/libgdk_pixbuf_xlib-2.0.so
  140. %{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
  141. %{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
  142. %{_bindir}/gdk-pixbuf-csource
  143. %{_datadir}/gtk-doc/html/*
  144. %{_datadir}/gir-1.0
  145. %{_mandir}/man1/gdk-pixbuf-csource.1.gz
  146. %if %{build_compat32}
  147. %files -n compat32-%{name}
  148. %defattr(-,root,root,-)
  149. %{_libdir}/libgdk_pixbuf-2.0.so.*
  150. %{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
  151. %dir %{_libdir}/gdk-pixbuf-2.0
  152. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
  153. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  154. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
  155. %ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  156. %{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
  157. %files -n compat32-%{name}-devel
  158. %defattr(-,root,root,-)
  159. %{_libdir}/libgdk_pixbuf-2.0.so
  160. %{_libdir}/libgdk_pixbuf_xlib-2.0.so
  161. %{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
  162. %{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
  163. %endif
  164. %changelog
  165. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.23.5-1
  166. - new upstream release
  167. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
  168. - new upstream release
  169. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
  170. - new upstream release
  171. - add configure option (--enable-introspection=yes)
  172. - drop Patch0
  173. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
  174. - initial build for Vine Linux
  175. * Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
  176. - Require libpng for linking
  177. * Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
  178. - Rebuild with new gobject-introspection
  179. * Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
  180. - Update to 2.21.6
  181. * Fri Jul 2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
  182. - Also Require shared-mime-info for same reason
  183. * Fri Jul 2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
  184. - BR shared-mime-info; see comment above it
  185. * Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
  186. - Changes to support snapshot builds
  187. * Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
  188. - Update to 2.21.5
  189. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
  190. - Rename to gdk-pixbuf2 to avoid conflict with the
  191. existing gdk-pixbuf package
  192. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
  193. - Update to 2.21.4
  194. - Incorporate package review feedback
  195. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
  196. - Initial packaging