empathy-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434
  1. %define major_ver 3.1
  2. %define minor_ver 4
  3. %define rel 1
  4. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  5. ## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
  6. ## respectively.
  7. %global gtk3_min_version 3.0.0
  8. %global glib2_min_version 2.28.0
  9. %global tp_mc_min_version 5.6.0
  10. %global tp_glib_min_version 0.13.0
  11. %global tp_logger_min_version 0.1.5
  12. #global enchant_version 1.4.0
  13. %global aspell_version 0.50
  14. %global libcanberra_version 0.4
  15. %global gnome_keyring_version 2.32
  16. %global libnotify_version 0.4.4
  17. Summary: GNOME Instant Messaging Client
  18. Summary(ja): GNOME インスタントメッセージクラアイント
  19. Name: empathy
  20. Version: %{major_ver}.%{minor_ver}
  21. Release: %{rel}%{?_dist_release}
  22. Group: Applications/Communications
  23. License: GPLv2+
  24. URL: http://live.gnome.org/Empathy
  25. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
  26. Source1: %{name}-README.ConnectionManagers
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. #BuildRequires: enchant-devel >= %{enchant_version}
  29. BuildRequires: aspell-devel >= %{aspell_version}
  30. BuildRequires: iso-codes
  31. BuildRequires: desktop-file-utils
  32. BuildRequires: evolution-data-server-devel
  33. BuildRequires: GConf2-devel
  34. BuildRequires: gettext
  35. BuildRequires: glib2-devel >= %{glib2_min_version}
  36. BuildRequires: gnome-doc-utils >= 0.17.3
  37. BuildRequires: gnome-panel
  38. BuildRequires: gtk3-devel >= %{gtk3_min_version}
  39. BuildRequires: intltool
  40. BuildRequires: libxml2-devel
  41. BuildRequires: perl(XML::Parser)
  42. BuildRequires: pygtk2-devel
  43. BuildRequires: telepathy-glib-devel >= %{tp_glib_min_version}
  44. BuildRequires: telepathy-mission-control-devel >= %{tp_mc_min_version}
  45. BuildRequires: farsight2-devel
  46. BuildRequires: telepathy-farsight-devel
  47. BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
  48. BuildRequires: libgnome-keyring-devel >= %{gnome_keyring_version}
  49. BuildRequires: unique3-devel
  50. BuildRequires: libnotify-devel >= %{libnotify_version}
  51. BuildRequires: libtelepathy-devel
  52. BuildRequires: libgnomecanvas-devel
  53. BuildRequires: libbonoboui-devel
  54. BuildRequires: folks-devel
  55. BuildRequires: telepathy-logger-devel >= %{tp_logger_min_version}
  56. BuildRequires: gnome-keyring-devel >= %{gnome_keyring_version}
  57. BuildRequires: openssl-devel
  58. BuildRequires: NetworkManager-glib-devel
  59. BuildRequires: WebKit3-gtk-devel
  60. BuildRequires: geoclue-devel
  61. BuildRequires: enchant-devel
  62. BuildRequires: gsettings-desktop-schemas
  63. BuildRequires: libICE-devel
  64. BuildRequires: cheese-devel
  65. BuildRequires: libchamplain-gtk-devel
  66. Requires: telepathy-filesystem
  67. ## Empathy is useless without a proper Telepathy connection manager installed.
  68. ## We hardcode dependencies on Salut and Gabble to support XMPP on a default
  69. ## install, in both the link-local and Jabber/GoogleTalk incarnations.
  70. ## (RHBZ: 308871 and 334221)
  71. ## TODO: Perhaps we can configure these to be installed "on demand" with
  72. ## PackageKit and friends?
  73. Requires: telepathy-gabble
  74. Requires: telepathy-salut
  75. ## Also hardcode Haze dependency since Empathy is the default IM client in F10+
  76. ## and I'd hate for people to simply disregard it for lack of the "out of the
  77. ## box" protocol support that Pidgin has. (RHBZ: 458935)
  78. BuildRequires: telepathy-haze
  79. # Require this for VOIP support
  80. Requires: telepathy-stream-engine
  81. Requires: telepathy-mission-control >= %{tp_mc_min_version}
  82. Requires(post): GConf2
  83. Requires(post): scrollkeeper
  84. Requires(postun): scrollkeeper
  85. ## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
  86. Obsoletes: telepathy-haze-mission-control < 0.2.0-3
  87. Provides: telepathy-haze-mission-control = 0.2.0-3
  88. ## upstream 2.29.1 removed shared libraries: #599086
  89. Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
  90. ## upstream 2.29.1 removed python bindings' #599039
  91. Obsoletes: empathy-python < 2.29.1
  92. Vendor: Project Vine
  93. Distribution: Vine Linux
  94. %description
  95. Empathy provides a powerful multiple protocol instant messaging
  96. client using the Telepathy framework.
  97. %package -n nautilus-sendto-empathy
  98. License: GPLv2+
  99. Summary: Nautilus-sendto plugin for empathy
  100. Summary(ja): empathy 用 nautilus-sendto プラグイン
  101. Group: User Interface/Desktop
  102. Requires: %{name} = %{version}-%{release}
  103. Requires: nautilus-sendto
  104. BuildRequires: nautilus-sendto-devel
  105. %description -n nautilus-sendto-empathy
  106. This package contains nautilus-sendto plugin for the Empathy IM application.
  107. %prep
  108. %setup -q
  109. %build
  110. ## GCC complains about some unused functions, so we forcibly show those as
  111. ## simple warnings instead of build-halting errors.
  112. %configure \
  113. --with-compile-warnings=yes \
  114. --disable-static \
  115. --enable-nautilus-sendto=yes \
  116. --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
  117. ## RPATHs are yucky.
  118. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  119. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  120. ##make %{?_smp_mflags}
  121. ## don't use _smp_mflags at empathy-2.18.1
  122. make
  123. install -m 0644 %{SOURCE1} ./README.ConnectionManagers
  124. %install
  125. rm -rf $RPM_BUILD_ROOT
  126. make install DESTDIR=$RPM_BUILD_ROOT
  127. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  128. %find_lang %{name}
  129. desktop-file-install --vendor "" --delete-original \
  130. --dir %{buildroot}%{_datadir}/applications \
  131. %{buildroot}%{_datadir}/applications/%{name}.desktop
  132. %clean
  133. rm -rf %{buildroot}
  134. %post
  135. scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
  136. touch --no-create %{_datadir}/icons/hicolor ||:
  137. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  138. %postun
  139. scrollkeeper-update -q || :
  140. touch --no-create %{_datadir}/icons/hicolor || :
  141. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  142. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  143. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  144. fi
  145. %posttrans
  146. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
  147. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  148. %files -f %{name}.lang
  149. %defattr(-,root,root,-)
  150. %doc AUTHORS COPYING README README.ConnectionManagers NEWS
  151. %{_bindir}/empathy
  152. %{_bindir}/empathy-accounts
  153. %{_bindir}/empathy-debugger
  154. %{_libexecdir}/empathy-auth-client
  155. %{_libexecdir}/empathy-av
  156. %{_libexecdir}/empathy-chat
  157. %{_datadir}/dbus-1/services/*
  158. %{_datadir}/empathy
  159. %{_datadir}/glib-2.0/schemas/*.xml
  160. %{_datadir}/GConf/gsettings/*
  161. %{_datadir}/applications/*.desktop
  162. %{_datadir}/gnome/help/%{name}/
  163. #{_datadir}/omf/%{name}/
  164. %{_datadir}/icons/hicolor/*/apps/%{name}*
  165. #{_datadir}/mission-control/profiles/*.profile
  166. %{_datadir}/telepathy/clients/*.client
  167. %{_mandir}/man1/empathy*.1*
  168. %files -n nautilus-sendto-empathy
  169. %defattr(-,root,root,-)
  170. %{_libdir}/nautilus-sendto/plugins/libnstempathy.so
  171. %changelog
  172. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  173. - new upstream release
  174. - change BuildRequires: gtk3-devel instead of gtk2-devel
  175. - change BuildRequires: unique3-devel instead of unique-devel
  176. - change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
  177. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  178. - add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
  179. * Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  180. - new upstream release
  181. - add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
  182. geoclue-devel, enchant-devel
  183. - add Requires: telepathy-mission-control
  184. - add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
  185. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
  186. - new upstream release
  187. - add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
  188. - fix %files
  189. - fix %post, %postun
  190. - drop %pre, %preun
  191. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
  192. - rebuild with evolution-data-server-2.30.2
  193. - add nautilus-sendto-empathy package
  194. - add configure option (--enable-nautilus-sendto=yes)
  195. - add BuildRequires: nautilus-sendto-devel
  196. * Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
  197. - add Obsoletes: empathy-python < 2.29.1
  198. * Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
  199. - new upstream release
  200. - add new files: %%{_bindir}/empathy-{accounts,debugger}
  201. - drop -libs, -devel, -python sub packages: upstream removed
  202. - Obsoletes: empathy-{libs,devel} < 2.29.1
  203. - drop BuildRequires: python-devel
  204. - drop %%{_bindir}/empathy-logs in %%files: upstream don not install
  205. - drop applet files in %%files: upstream removed the panel applets
  206. - update %%post, %pre and %%preun
  207. - update BuildRequires version for glib2 and tp_glib
  208. - defined major_ver, minor_ver and rel
  209. - fix BuildRequires for gnome-keyring
  210. * Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  211. - new upstream release
  212. - add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
  213. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
  214. - rebuilt with python-2.6.4
  215. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
  216. - unuse %%{?_smp_mflags} option to make
  217. * Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
  218. - add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
  219. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  220. - new upstream release
  221. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  222. - new upstream release
  223. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  224. - initial build for Vine Linux
  225. * Tue Sep 9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
  226. - Update to 2.23.92
  227. * Thu Sep 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
  228. - Update to 2.23.91
  229. * Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
  230. - Now that Empathy will be the default IM client in F10+, hardcode a dependency
  231. on telepathy-haze to keep the same protocol functionality across upgrades,
  232. for a much improved "out of the box" experience.
  233. - Reference: bug 458935.
  234. * Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
  235. - Update to new upstream release (2.23.90)
  236. * Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
  237. - Apply patch from Colin Walters to automagically update profile namings for
  238. the switch to using Empathy's provided profiles.
  239. - Drop the upgrade script (no longer needed since it's automatically done).
  240. - upgrade-haze-profiles.sh
  241. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
  242. - Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
  243. the telepathy-haze-mission-control package. (The Haze-provided ones have grown
  244. horribly stale...). This makes for better automagic functionality (if Haze is
  245. installed, Empathy/MC will autodetect it) and tracks upstream more closely.
  246. + upgrade-haze-profiles.sh
  247. * Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
  248. - Update to new upstream release (2.23.6)
  249. - Use the in-tarball libtool scripts instead of the system copy to workaround
  250. 'make install' errors.
  251. * Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
  252. - Update to 0.23.4.
  253. - Update source url.
  254. * Mon Jun 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
  255. - Update to 0.23.3.
  256. - Remove reference to stream-engine in connections managers readme.
  257. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
  258. - Update to 0.23.2.
  259. - Add man pages.
  260. - Use enchant-devel, instead of aspell-devel.
  261. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
  262. - Rebuild for new e-d-s.
  263. * Sun May 4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
  264. - Drop multiple copies of COPYING file.
  265. - Drop BR on gnome-vfs2-devel.
  266. - Require telepathy-stream-engine for VOIP support.
  267. - Add BR on iso-codes-devel, so spell-checking is enabled.
  268. * Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
  269. - Update to new upstream release (0.23.1)
  270. - Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
  271. * Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
  272. - Update to new upstream release (0.22.1)
  273. * Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
  274. - Update to new upstream release (0.22.0)
  275. * Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
  276. - Update to new upstream release (0.21.91)
  277. * Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
  278. - Update to new upstream release (0.21.90)
  279. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
  280. - Autorebuild for GCC 4.3
  281. * Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
  282. - Update to new upstream release (0.21.4)
  283. * Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
  284. - Update to new upstream release (0.21.2)
  285. - Drop backported drag-and-drop patch (fixed upstream):
  286. - svn380-fix-contact-DnD.patch
  287. - Update README.ConnectionManagers: Include Haze package note, remove Galago
  288. note (a feed-only connection manager isn't useful for instant messaging),
  289. and fix some wording.
  290. * Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
  291. - Backport upstream patch to fixes crashes when using drag-and-drop of a
  292. contact from the buddy list to the current conversation window to initiate a
  293. conversation:
  294. + svn380-fix-contact-DnD.patch
  295. - Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
  296. dragged a contact ...)
  297. * Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
  298. - Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
  299. is essentially useless due to the need to install an external connection
  300. manager. Also, add a README.ConnectionManagers to the installed
  301. documentation which lists other possibilities.
  302. - Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
  303. and bug 334221 (Default empathy install is useless).
  304. * Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
  305. - Enable VoIP support for those brave enough to test/break/debug it (F9+
  306. only). Though it is functional, it is still deemed rather unstable by
  307. upstream. Use it at your own risk. :)
  308. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
  309. - Disable VoIP support at this time, since it is deemed unstable by upstream
  310. for now. (Thanks to Brian Pepple for the notice.)
  311. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
  312. - Update to new upstream release (0.14).
  313. * Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
  314. - Update to new upstream release (0.13), which adds a panel applet (Megaphone)
  315. and python bindings.
  316. - Split shared libraries into a libs subpackage for easier handling
  317. in multi-lib environments.
  318. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
  319. - Add ldconfig invocations to %%post and %%postun scriptlets.
  320. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
  321. - Update to new upstream release (0.12).
  322. - Build against new mission-control stack.
  323. - Update License tag (GPLv2+).
  324. - Alphabetize BuildRequires list (aesthetic-only change).
  325. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
  326. - Rebuild for selinux ppc32 issue.
  327. * Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
  328. - Update to new upstream release (0.11)
  329. * Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
  330. - bump to 0.8
  331. - Now with aspell support (deat to teh speeling mistaks)
  332. * Sat Jun 9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
  333. - bump to 0.7
  334. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
  335. - Add telepathy-filesystem to Requires
  336. - Move .desktop from autostart to applications
  337. - Nasty hackery to make empathy launch from the menu
  338. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
  339. - Add gettext to BuildRequires
  340. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
  341. - Bump to 0.6
  342. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
  343. - Let Empathy own the directory and not just the files in it
  344. * Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
  345. - Initial package