compiz-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836
  1. # build with kde4
  2. %bcond_with kde
  3. %define dialogversion 0.7.18
  4. %define kde_dialogversion 0.0.5
  5. %define core_plugins blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
  6. %define gnome_plugins annotate gconf glib svg gnomecompat
  7. # List of plugins passed to ./configure. The order is important
  8. %define plugins core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
  9. Summary: OpenGL window and compositing manager
  10. Summary(ja): OpenGL ウィンドウ・コンポジットマネージャ
  11. Name: compiz
  12. URL: http://www.go-compiz.org
  13. License: X11/MIT/GPL
  14. Group: User Interface/Desktops
  15. Version: 0.8.8
  16. Release: 1%{?_dist_release}
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. # libdrm is not available on these arches
  19. ExcludeArch: s390 s390x ppc64
  20. Requires: xorg-x11-server-Xorg
  21. Requires: mesa-libGL
  22. Requires(post): desktop-file-utils
  23. BuildRequires: mesa-libGLU-devel
  24. BuildRequires: libdrm-devel
  25. BuildRequires: libwnck-devel
  26. BuildRequires: libX11-devel
  27. BuildRequires: libXcomposite-devel
  28. BuildRequires: libXdamage-devel
  29. BuildRequires: libXext-devel
  30. BuildRequires: libXfixes-devel
  31. BuildRequires: libXmu-devel
  32. BuildRequires: libXrandr-devel
  33. BuildRequires: libXrender-devel
  34. BuildRequires: libXt-devel
  35. BuildRequires: libSM-devel
  36. BuildRequires: GConf2-devel
  37. BuildRequires: control-center-devel
  38. BuildRequires: dbus-devel
  39. BuildRequires: fuse-devel
  40. BuildRequires: gnome-desktop-devel >= 2.30.0
  41. BuildRequires: libglade2-devel
  42. BuildRequires: librsvg2-devel
  43. BuildRequires: libxslt-devel
  44. BuildRequires: metacity-devel
  45. BuildRequires: desktop-file-utils
  46. BuildRequires: intltool >= 0.35
  47. BuildRequires: gettext
  48. %if %{with kde}
  49. BuildRequires: kdebase-workspace-devel
  50. BUildRequires: dbus-qt-devel
  51. %endif
  52. Conflicts: control-center < 2.32.1-2
  53. # Make sure that former beryl users still have bling
  54. Obsoletes: beryl-core
  55. Source0: http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
  56. Source1: desktop-effects-%{dialogversion}.tar.bz2
  57. Source2: kde-desktop-effects-%{kde_dialogversion}.tar.bz2
  58. # Patches from fedora
  59. Patch102: desktop-effects-0.7.17-wall-plugin.patch
  60. Patch103: composite-cube-logo.patch
  61. Patch111: gconf-core-plugin-loopfix.patch
  62. # Make sure configuration plugins never get unloaded
  63. Patch123: compiz-0.7.8-pin-initial-plugins.patch
  64. # Patches from ubuntu
  65. Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
  66. Patch1150: 015_optional-fbo.patch
  67. Patch1160: 016_call_glxwaitx_before_drawing.patch
  68. Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
  69. Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
  70. Patch1490: 049-damage-report-non-empty.patch
  71. Patch1600: 060_move_checks_to_compiz.patch
  72. # Patches from upstream
  73. Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
  74. Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
  75. # Vine default options
  76. Patch3000: compiz-0.8.6-vine-default.patch
  77. Vendor: Project Vine
  78. Distribution: Vine Linux
  79. %description
  80. Compiz is one of the first OpenGL-accelerated compositing window
  81. managers for the X Window System. The integration allows it to perform
  82. compositing effects in window management, such as a minimization
  83. effect and a cube workspace. Compiz is an OpenGL compositing manager
  84. that use Compiz use EXT_texture_from_pixmap OpenGL extension for
  85. binding redirected top-level windows to texture objects.
  86. %package devel
  87. Summary: Development packages for compiz
  88. Summary(ja): compiz の開発パッケージ
  89. Group: Development/Libraries
  90. Requires: compiz = %{version}-%{release}
  91. Requires: pkgconfig
  92. Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
  93. Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
  94. Requires: libxslt-devel startup-notification-devel
  95. %description devel
  96. The compiz-devel package includes the header files,
  97. and developer docs for the compiz package.
  98. Install compiz-devel if you want to develop plugins for the compiz
  99. windows and compositing manager.
  100. %package gnome
  101. Summary: Compiz gnome integration bits
  102. Summary(ja): Compiz gnome integration bits
  103. Group: User Interface/Desktops
  104. Requires: gnome-session
  105. Requires: metacity
  106. Requires: libwnck
  107. Requires: glx-utils
  108. Requires: %{name} = %{version}
  109. Requires(pre): GConf2
  110. Requires(post): GConf2
  111. Requires(preun): GConf2
  112. Obsoletes: compiz < 0.5.2-8
  113. Obsoletes: beryl-gnome
  114. %description gnome
  115. The compiz-gnome package contains gtk-window-decorator,
  116. and other gnome integration related stuff.
  117. %if %{with kde}
  118. %package kde
  119. Summary: Compiz kde integration bits
  120. Summary(ja): Compiz kde integration bits
  121. Group: User Interface/Desktops
  122. Requires: %{name} = %{version}
  123. Requires: compiz-manager
  124. Obsoletes: beryl-kde
  125. %description kde
  126. The compiz-kde package contains kde-window-decorator,
  127. and other kde integration related stuff.
  128. %endif
  129. %prep
  130. %setup -q -T -b1 -n desktop-effects-%{dialogversion}
  131. #%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
  132. %setup -q
  133. pushd ../desktop-effects-%{dialogversion}
  134. %patch102 -p1 -b .wall-plugin
  135. popd
  136. %patch103 -p1 -b .composite-cube-logo
  137. %patch111 -p1 -b .gconf-core-loop
  138. ## %patch123 -p1 -b .initial-plugins
  139. # ubuntu patch
  140. %patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
  141. %patch1150 -p1 -b .disable-fbo
  142. %patch1160 -p1 -b .call_glxwaitx_before_drawing
  143. %patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
  144. %patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
  145. %patch1490 -p1 -b .damage-report-non-empty
  146. %patch1600 -p1 -b .move-check-to-compiz
  147. # upstream patch
  148. #%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
  149. #%patch2010 -p1 -b .fix-pixmap-size-calculation
  150. # vine patch
  151. %patch3000 -p1 -b .vine-default
  152. %build
  153. rm -rf $RPM_BUILD_ROOT
  154. CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
  155. export CPPFLAGS
  156. #needed to find kde4 libs
  157. #LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
  158. #export LDFLAGS
  159. libtoolize
  160. autoreconf
  161. %configure \
  162. %{?with_kde: --enable-kde4 } \
  163. %{!?with_kde: --disable-kde4 } \
  164. --disable-kde \
  165. --enable-gconf \
  166. --enable-dbus \
  167. --enable-place \
  168. --enable-librsvg \
  169. --enable-gtk \
  170. --enable-metacity \
  171. --enable-gnome \
  172. --with-default-plugins=%{plugins} \
  173. --enable-gnome-keybindings
  174. make LIBTOOL=/usr/bin/libtool %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
  175. # desktop-effects
  176. cd ../desktop-effects-%{dialogversion}
  177. %configure
  178. %install
  179. rm -rf $RPM_BUILD_ROOT
  180. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  181. make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
  182. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  183. echo INSTALLING DESKTOP EFFECTS
  184. pushd ../desktop-effects-%{dialogversion}
  185. make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
  186. #desktop-file-install --vendor vine --delete-original \
  187. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  188. # $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  189. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  190. popd
  191. %if %{with kde}
  192. # kde-desktop-effects
  193. echo INSTALLING KDE DESKTOP EFFECTS
  194. pushd ../kde-desktop-effects-%{kde_dialogversion}
  195. cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
  196. mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  197. cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  198. iconlist="16 24 32 36 48 96"
  199. for i in $iconlist; do
  200. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
  201. cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
  202. done
  203. desktop-file-install --vendor="" \
  204. --dir=%{buildroot}%{_datadir}/applications/kde \
  205. kde-desktop-effects.desktop
  206. popd
  207. %endif
  208. %if !%{with kde}
  209. rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
  210. %endif
  211. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  212. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
  213. %find_lang compiz
  214. %find_lang desktop-effects
  215. cat compiz.lang > core-files.txt
  216. cat desktop-effects.lang > gnome-files.txt
  217. for f in %{core_plugins}; do
  218. echo %{_libdir}/compiz/lib$f.so
  219. echo %{_datadir}/compiz/$f.xml
  220. done >> core-files.txt
  221. for f in %{gnome_plugins}; do
  222. echo %{_libdir}/compiz/lib$f.so
  223. echo %{_datadir}/compiz/$f.xml
  224. done >> gnome-files.txt
  225. %post -p /sbin/ldconfig
  226. %postun -p /sbin/ldconfig
  227. %post gnome
  228. update-desktop-database -q %{_datadir}/applications
  229. export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
  230. for f in %{core_plugins} %{gnome_plugins} core; do
  231. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  232. | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
  233. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  234. touch --no-create %{_datadir}/icons/hicolor
  235. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  236. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  237. fi
  238. %pre gnome
  239. if [ "$1" -gt 1 ]; then
  240. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  241. for f in %{core_plugins} %{gnome_plugins} core; do
  242. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  243. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
  244. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  245. fi
  246. %preun gnome
  247. if [ "$1" -eq 0 ]; then
  248. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  249. for f in %{core_plugins} %{gnome_plugins} core; do
  250. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  251. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
  252. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  253. fi
  254. %postun gnome
  255. touch --no-create %{_datadir}/icons/hicolor
  256. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  257. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  258. fi
  259. %if %{with kde}
  260. %post kde
  261. update-desktop-database -q %{_datadir}/applications/kde
  262. touch --no-create %{_datadir}/icons/hicolor
  263. %postun kde
  264. touch --no-create %{_datadir}/icons/hicolor
  265. %endif
  266. %clean
  267. rm -rf $RPM_BUILD_ROOT
  268. %files -f core-files.txt
  269. %defattr(-, root, root)
  270. %doc AUTHORS ChangeLog COPYING* README TODO
  271. %{_bindir}/compiz
  272. %{_libdir}/libdecoration.so.*
  273. %dir %{_libdir}/compiz
  274. %dir %{_datadir}/compiz
  275. %{_datadir}/compiz/*.png
  276. %{_datadir}/compiz/core.xml
  277. %files gnome -f gnome-files.txt
  278. %defattr(-, root, root)
  279. %{_bindir}/gtk-window-decorator
  280. %{_bindir}/desktop-effects
  281. #%{_libdir}/window-manager-settings/libcompiz.so
  282. #%{_datadir}/gnome/wm-properties/compiz-wm.desktop
  283. #%{_datadir}/applications/compiz.desktop
  284. #%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
  285. #%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
  286. %{_datadir}/compiz/desktop-effects.glade
  287. %{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
  288. %{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
  289. %{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
  290. %{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
  291. %{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
  292. %{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
  293. %{_sysconfdir}/gconf/schemas/*.schemas
  294. %if %{with kde}
  295. %files kde
  296. %defattr(-, root, root)
  297. %{_bindir}/kde4-window-decorator
  298. %{_docdir}/compiz-kde-%{version}
  299. %{_bindir}/kde-desktop-effects.sh
  300. %{_datadir}/applications/kde/kde-desktop-effects.desktop
  301. %{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
  302. %{_datadir}/compiz/kconfig.xml
  303. %endif
  304. %files devel
  305. %defattr(-, root, root)
  306. %{_libdir}/pkgconfig/compiz.pc
  307. %{_libdir}/pkgconfig/libdecoration.pc
  308. %{_libdir}/pkgconfig/compiz-cube.pc
  309. %{_libdir}/pkgconfig/compiz-gconf.pc
  310. %{_libdir}/pkgconfig/compiz-scale.pc
  311. %{_datadir}/compiz/schemas.xslt
  312. %{_includedir}/compiz
  313. %{_libdir}/libdecoration.so
  314. %changelog
  315. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-1
  316. - new upstream release
  317. - add BuildRequires: libxslt-devel, libglade2-devel
  318. - drop Patch2000,2010
  319. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
  320. - add Patch3000
  321. - disable Sync to vblank
  322. - increase drop-shadow radius
  323. - set default decorator to gtk-window-decorator
  324. - change default daces in cube plugin
  325. - use "smart" placement mode
  326. * Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
  327. - drop compiz-gtk
  328. - add Conflicts: control-center < 2.32.1-2
  329. * Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
  330. - rebuild with mesa-7.10.1
  331. - add cherry picked ubuntu patch
  332. - Patch1150: add --no-fbo option
  333. - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
  334. - Patch1160: call glxwaitx before drawing
  335. - Patch1170: always unredirect screensaver on nvidia
  336. - Patch1490: damage report non empty
  337. - Patch1600: move check to compiz
  338. - add upstream patch
  339. - Patch2000: replace gdk_draw_drawable with cairo equivalents
  340. - Patch2010: fix pixmap size calculation
  341. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
  342. - rebuild with rpm-4.8.1 for pkg-config file
  343. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  344. - new upstream release (build on GNOME-2.30)
  345. - drop Patch123, Patch300
  346. * Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
  347. - rebuild with mesa-7.6
  348. - add Patch300 to build with gconf-2.28
  349. * Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
  350. - disable glib plugin in compiz-gtk
  351. - use direct rendering on virtualbox video adaptor.
  352. * Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
  353. - add Requires: glx-utils to compiz-gnome
  354. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  355. - new upstream release
  356. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
  357. - re-enable metacity decoration on gtk-window-decorator
  358. - BR: metacity-devel instead of metacity
  359. * Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
  360. - fix pre/post scripts for speeding up gconf schema installation
  361. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
  362. - add ccp compiz option to compiz-gtk
  363. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
  364. - remove desktop-effect.desktop
  365. - we use gnome-appearance-properties integrated version.
  366. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
  367. - add Patch121,122 from upstream fix.
  368. - add Patch123: make sure configuration plugins never get unloaded
  369. - add Patch124: memleak fix from upstream
  370. - add Patch125: make the terminal keybind work
  371. - add Patch120,126,127 for kde42
  372. - add Patch128: gwd fix from upstream
  373. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
  374. - rebuild with gnome-desktop-2.26.0
  375. * Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
  376. - add compiz-gtk scripts and desktop file from fedora
  377. * Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
  378. - new upstream release
  379. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
  380. - rebuild with gnome-desktop-2.24.0
  381. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
  382. - new upstream release
  383. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
  384. - new upstream release
  385. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
  386. - initial build for Vine Linux
  387. * Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
  388. - Fix gconf plugin loop RH #438794, patch based on
  389. older one from Guillaume Seguin
  390. - Add core to default plugin list
  391. * Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
  392. - Reword kde-desktop-effects messages to mention Compiz by name (#438883)
  393. * Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
  394. - Update to 0.7.2
  395. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
  396. - Autorebuild for GCC 4.3
  397. * Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
  398. - Update to desktop-effects version 0.7.17 which include more
  399. translations and move desktop-effects translations to compiz-gnome.
  400. - Fix spelling in beryl-core obsoletes.
  401. * Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
  402. - Update buildrequires (kwd uses the kde3 api)
  403. * Tue Nov 6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
  404. - Fix a typo in description of the main package.
  405. - All descriptions should end with a dot (unlike the summary line)
  406. * Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
  407. - Include kde-desktop-effects in kde subpackage
  408. * Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
  409. - Obsolete berly-core
  410. * Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
  411. - 0.6.2
  412. * Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
  413. - Disable scale corner initiate and install a GNOME key config entry.
  414. * Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
  415. - 0.6.0 final
  416. - always-restack-windows-on-map
  417. * Tue Oct 9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
  418. - Make compiz behave with gnome-terminal (#304051)
  419. * Fri Oct 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
  420. - Also install gwd.schemas (#319621)
  421. * Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
  422. - Update to more recent 0.6 branch snapshot (fixes #253575).
  423. * Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
  424. - compiz-gnome: install core schema so it actually works
  425. - remove unnecessary gconf stuff from %%install
  426. * Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
  427. - Make compiz-gnome Obsolete the older compiz package so yum/anaconda
  428. will pull it in (thans to Adel Gadllah).
  429. * Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
  430. - Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
  431. up dialog.
  432. - Fix broken gconf install and uninstall rules.
  433. - Pick up shadowman logo for RHEL builds (#232398).
  434. * Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
  435. - Add more-sm-junk.patch so we set SM restart style to
  436. SmRestartIfRunning on exit (#247163, #245971).
  437. - Add Requires to compiz-devel (#253407).
  438. - Update to desktop-effects 0.7.6, which terminates decorator when
  439. switching to metacity or on compiz failure (#215247, #215032).
  440. * Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
  441. - Split into gnome and kde subpackages
  442. - Minor cleanups
  443. * Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
  444. - Reorder plugin list to avoid 'place' getting removed on startup.
  445. - Add run-command-key.patch to put the run command key in the GNOME
  446. keyboard shortcut dialog (#213576).
  447. - Drop a bunch of obsolete patches.
  448. - Bump mesa-libGL and X server requires to fix TFP bugs for
  449. power-of-two textures (#251935).
  450. - Rebase fedora-logo and composite-cube-logo patch.
  451. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
  452. - Build with desktop-effects so we don't pick up metacity work spaces.
  453. Fixes #250568.
  454. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
  455. - Build git snapshot from fedora branch at
  456. git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
  457. branch.
  458. - Fixes #237486.
  459. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
  460. - Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
  461. 'glib' on the command line too.
  462. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
  463. - Move xml meta data files to main package.
  464. * Thu Aug 9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
  465. - Update to 0.5.2.
  466. - Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
  467. with LIBGL_ALWAYS_INDIRECT set.
  468. * Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
  469. - Update to 0.5.0
  470. * Tue Jun 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
  471. - Update to 0.4.0
  472. * Mon Jun 4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
  473. - Rebuild against new libwnck
  474. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
  475. - Don't install INSTALL
  476. * Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
  477. - Update metacity build requires to metacity-devel.
  478. * Wed Apr 4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
  479. - Fix typo in ./configure option.
  480. * Wed Apr 4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
  481. - Add place and clone plugins to default plugin list.
  482. * Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
  483. - Update URL (#208214).
  484. - Require at least metacity 2.18 (#232831).
  485. - Add close-session.patch to deregister from SM when replaced (#229113).
  486. * Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
  487. - Explicitly disable KDE parts (#234128).
  488. * Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
  489. - Fix some directory ownership issues (#233825)
  490. - Small spec cleanups
  491. * Tue Feb 6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
  492. - Require gnome-session > 2.16 so it starts gtk-window-decorator.
  493. - Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
  494. * Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
  495. - Update to 0.3.6, update patches.
  496. - Drop autotool build requires.
  497. - Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
  498. - Add libdecoration.so
  499. - Update to desktop-effects-0.7.0, which spawns the right decorator
  500. and plays nicely with unknown plugins.
  501. * Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
  502. - Update the fedora logo patch (#217224)
  503. * Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  504. - Update to 0.3.4
  505. * Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
  506. - Use cow by default, bug 208044
  507. * Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  508. - Update to 0.3.2
  509. - Drop upstreamed patches
  510. - Work with new metacity theme api
  511. * Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
  512. - Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
  513. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  514. - Add buildrequires on intltool
  515. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  516. - Build
  517. * Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
  518. - Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
  519. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
  520. - Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
  521. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
  522. - Change default plugin list to not include the plane plugin. (Bug 208448).
  523. - Change default keybinding for shrink to be Pause (Bug 206187).
  524. * Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
  525. - Add patch to show a menu when the window icon is clicked. (Bug 201629).
  526. * Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
  527. - Add restart.patch to make compiz ask the session manager to restart it
  528. if it crashes (bug 200280).
  529. * Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
  530. - Change plane.patch to not do cyclical window movement in dimensions
  531. where the desktop has size 1 (bug 207263).
  532. * Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
  533. - Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
  534. * Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
  535. - Change .plane patch to
  536. (a) not set the background color to pink in the plane plugin.
  537. (b) allow workspaces with horizontal sizes less then 4.
  538. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
  539. - Change plane patch to correctly initialize the screen size to the
  540. defaults (bug 206088).
  541. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  542. - Run update-desktop-database and gtk-update-icon-cache in post. Add icons
  543. to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
  544. directories before attempting to install to them).
  545. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  546. - Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
  547. that the new version has icons.
  548. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  549. - Add patch to fix mispositioning of window decorator event windows (bug 201624)
  550. * Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
  551. - Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
  552. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  553. - Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
  554. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  555. - Add patch to fix thumbnail sorting (bug 201605)
  556. * Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
  557. - Add patch to fix double clicking (bug 201783).
  558. * Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
  559. - Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
  560. * Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
  561. - Fix plane.patch to draw correctly when no timeout is running. (206088).
  562. * Wed Sep 6 2006 Kristian H淡gsberg <krh@redhat.com>
  563. - Update fbconfig-depth-fix.patch to also skip fbconfigs without
  564. corresponding visuals.
  565. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
  566. - Make number of vertical size configurable
  567. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
  568. - Fix vertical viewport support in the plane patch.
  569. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
  570. - Upgrade to 0.6.61 of the dialog
  571. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  572. - Add libtool to BuildRequires
  573. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  574. - Add automake and autoconf to BuildRequires
  575. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  576. - Add a patch to put viewports on a plane.
  577. * Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
  578. - Drop gl-include-inferiors.patch now that compiz uses COW and the X
  579. server evicts offscreen pixmaps automatically on
  580. GLX_EXT_texture_from_pixmap usage.
  581. * Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
  582. - Add cow.patch to make compiz use the composite overlay window.
  583. * Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
  584. - Rebase to desktop-effects 0.6.41
  585. * Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
  586. - Rebase to desktop-effects 0.6.19 and drop
  587. desktop-effects-0.6.1-delete-session.patch
  588. * Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
  589. - Add patch from upstream to also use sync protocol for override
  590. redirect windows (sync-override-redirect-windows.patch).
  591. * Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
  592. - Rebase to latest upstream changes which has the rest of the bindings
  593. rewrite. Add resize-move-keybindings.patch to make move and resize
  594. bindings work like metacity.
  595. - Add back scale plugin.
  596. * Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
  597. - Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
  598. - unlink session file on changing wms (bug 201473)
  599. * Thu Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
  600. - Add Requires: gnome-session 2.15.4-3
  601. * Wed Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  602. - New version of dialog box. Macro the version number.
  603. * Wed Aug 2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  604. - Add 'desktop effects' dialog box.
  605. * Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
  606. - Add libwnck requires.
  607. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
  608. - Bump and build for fc5 AIGLX repo.
  609. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
  610. - Fix gconf hooks.
  611. * Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
  612. - Require system-logos instead.
  613. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
  614. - Bump version to work around tagging weirdness.
  615. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
  616. - Add devel package and require redhat-logos instead of fedora-logos (#199757).
  617. * Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
  618. - Add workaround for AIGLX throttling problem.
  619. * Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
  620. - Drop scale plugin from snapshot.
  621. * Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
  622. - Don't build on s390
  623. * Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
  624. - Do some changes forced upon us by package review
  625. * Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
  626. - Use sane numbering scheme.
  627. * Fri Jul 7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
  628. - Drop the fullscreen hardcode patch and require X server that has
  629. GLX_MESA_copy_sub_buffer.
  630. * Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
  631. - Unbreak --replace.
  632. * Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
  633. - Add Requires, fix start-compiz.sh.
  634. * Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
  635. - Spec file for compiz, borrowing bits and pieces from Alphonse Van
  636. Assches spec file (#192432).