clutter-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311
  1. %define clutter_version 1.7.6
  2. %define clutter_release 1%{?_dist_release}
  3. Name: clutter
  4. Version: %{clutter_version}
  5. Release: %{clutter_release}
  6. Summary: Open Source software library for creating rich graphical user interfaces
  7. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://www.clutter-project.org/
  11. Source0: http://www.clutter-project.org/sources/%{name}/1.7/%{name}-%{version}.tar.xz
  12. Patch0: clutter-fixdso.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: gobject-introspection
  15. # FIXME to remove when all the bits have been merged into their
  16. # libraries
  17. BuildRequires: glib2-devel
  18. BuildRequires: mesa-libGL-devel
  19. BuildRequires: gdk-pixbuf2-devel
  20. BuildRequires: atk-devel
  21. BuildRequires: pkgconfig
  22. BuildRequires: pango-devel
  23. BuildRequires: libXdamage-devel
  24. BuildRequires: libXcomposite-devel
  25. BuildRequires: libXi-devel
  26. BuildRequires: gettext
  27. BuildRequires: gtk-doc
  28. BuildRequires: gobject-introspection-devel >= 0.9.5
  29. BuildRequires: json-glib-devel
  30. BuildRequires: cogl-devel >= 1.7.4
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. %description
  34. Clutter is an open source software library for creating fast,
  35. visually rich graphical user interfaces. The most obvious example
  36. of potential usage is in media center type applications.
  37. We hope however it can be used for a lot more.
  38. %description -l ja
  39. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  40. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  41. しかしながら、我々はいろいろな分野で使用されることを願っています。
  42. %package devel
  43. Summary: Clutter development environment
  44. Summary(ja): Clutterの開発環境
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
  48. Requires: mesa-libGL-devel
  49. Requires: gobject-introspection-devel
  50. Requires: json-glib-devel
  51. %description devel
  52. Header files and libraries for building a extension library for the
  53. clutter
  54. %package doc
  55. Summary: Documentation for %{name}
  56. Summary(ja): %{name}用のドキュメント
  57. Group: Documentation
  58. Requires: %{name} = %{version}-%{release}
  59. BuildArch: noarch
  60. %description doc
  61. Clutter is an open source software library for creating fast,
  62. visually rich graphical user interfaces. The most obvious example
  63. of potential usage is in media center type applications.
  64. We hope however it can be used for a lot more.
  65. This package contains documentation for clutter.
  66. %prep
  67. %setup -q
  68. %patch0 -p1 -b .dso
  69. %build
  70. #%configure --enable-gtk-doc \
  71. # --enable-introspection=yes \
  72. # --disable-silent-rules \
  73. # --enable-xinput \
  74. # --disable-static
  75. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  76. %configure $CONFIGFLAGS \
  77. --enable-introspection=yes \
  78. --disable-silent-rules \
  79. --enable-xinput \
  80. --disable-static
  81. # clutter git ships with some magic to put the git log in shipped tarballs
  82. # which gets listed in files; don't blow up if it's missing
  83. if ! test -f ChangeLog; then
  84. echo "Created from snapshot" > ChangeLog
  85. fi
  86. )
  87. make V=0
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. #make DESTDIR=$RPM_BUILD_ROOT install
  91. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  92. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  93. %find_lang %{name}-1.0
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %post -p /sbin/ldconfig
  97. %postun -p /sbin/ldconfig
  98. %files -f %{name}-1.0.lang
  99. %defattr(-,root,root,-)
  100. %doc AUTHORS COPYING NEWS README
  101. %{_libdir}/*.so.*
  102. %{_libdir}/girepository-1.0/*.typelib
  103. %files devel
  104. %defattr(-, root, root)
  105. %doc ChangeLog
  106. %{_includedir}/clutter-1.0
  107. %{_libdir}/*.so
  108. %{_libdir}/pkgconfig/*.pc
  109. %{_datadir}/gir-1.0/*.gir
  110. %files doc
  111. %defattr(-, root, root)
  112. %{_datadir}/gtk-doc/html/clutter
  113. %{_datadir}/gtk-doc/html/cally
  114. %changelog
  115. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
  116. - new upstream release
  117. - add BuildRequires: cogl-devel
  118. - add "BuildArch: noarch" to doc sub package
  119. - add Patch0 (clutter-fixdso.patch)
  120. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  121. - new upstream release
  122. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  123. - new upstream release
  124. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  125. - new upstream release
  126. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
  127. - new upstream release
  128. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  129. - new upstream release
  130. - change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
  131. - add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
  132. - drop Patch0
  133. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  134. - new upstream release
  135. - drop Patch1
  136. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  137. - new upstream release
  138. - add BuildRequires: json-glib-devel
  139. - delete Requires: gir-repository
  140. - delete BuildRequires: gir-repository-devel
  141. - add Requires: json-glib-devel (devel package)
  142. - add Patch0, Patch1
  143. - fix %build
  144. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  145. - rebuild with rpm-4.8.1 for pkg-config file
  146. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  147. - new upstream release
  148. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  149. - new upstream release
  150. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  151. - new upstream release
  152. - add configure option (--enable-xinput)
  153. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  154. - new upstream release
  155. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  156. - new upstream release
  157. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  158. - new upstream release
  159. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  160. - new upstream release
  161. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  162. - new upstream release
  163. - build for Vine Linux
  164. - add Summary(ja)
  165. - fix BuildRoot
  166. - remove Obsolete and Provides
  167. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  168. - Update to 1.0.6
  169. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  170. - Update to 1.0.4, update gobject-introspection requirement
  171. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  172. - Update to 1.0.2
  173. * Sun Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  174. - Move ChangeLog to -devel to save some space
  175. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  176. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  177. onto the live cd
  178. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  179. - Update to 1.0.0
  180. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  181. - fix bz #507389
  182. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  184. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  185. - Update to 0.9.8
  186. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  187. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  188. introspection support to clutter (#512260)
  189. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  190. - Update to 0.9.6
  191. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  192. - Update to 0.9.4
  193. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  194. - Update to 0.9.2
  195. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  196. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  197. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  198. - Remove noarch from doc subpackage
  199. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  200. - Added gtk-doc for cogl
  201. - Created doc subpackage
  202. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  203. - Update to 0.8.6
  204. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  205. - Update to 0.8.2
  206. - Removed clutter-0.8.0-clutter-fixed.patch
  207. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  208. - Update to 0.8.0
  209. - Added clutter-0.8.0-clutter-fixed.patch
  210. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  211. - Update to 0.6.4
  212. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  213. - Update to 0.6.2
  214. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  215. - Update to 0.6.0
  216. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  217. - Autorebuild for GCC 4.3
  218. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  219. - Update to 0.4.2
  220. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  221. - Update to 0.4.1
  222. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  223. - Update to 0.3.1
  224. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  225. - Update to 0.2.3
  226. * Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  227. - Changed buildrequires and requires
  228. * Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  229. - Fix .spec
  230. * Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  231. - Fix .spec
  232. * Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  233. - Initial RPM release