WebKit3-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit3
  15. Version: 1.5.1
  16. Release: 1%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: Takemikaduchi
  25. Source0: http://www.webkitgtk.org/webkit-%{version}.tar.gz
  26. # upstream patch
  27. Patch100: WebKit-icu44-36381.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  29. BuildRequires: bison
  30. BuildRequires: flex
  31. BuildRequires: gperf
  32. BuildRequires: gtk3-devel
  33. BuildRequires: libicu-devel
  34. BuildRequires: libjpeg-turbo-devel
  35. BuildRequires: libtool
  36. BuildRequires: libxslt-devel
  37. BuildRequires: libXt-devel
  38. BuildRequires: pcre-devel
  39. BuildRequires: sqlite3-devel
  40. BuildRequires: geoclue-devel
  41. BuildRequires: gnome-keyring-devel
  42. BuildRequires: gstreamer-devel
  43. BuildRequires: gstreamer-plugins-base-devel
  44. BuildRequires: enchant-devel
  45. BuildRequires: gobject-introspection-devel
  46. %if %{with pango}
  47. BuildRequires: pango-devel
  48. %else
  49. BuildRequires: cairo-devel
  50. BuildRequires: fontconfig-devel
  51. BuildRequires: freetype2-devel
  52. %endif
  53. BuildRequires: libsoup-devel >= 2.28.2
  54. %description
  55. WebKit is an open source web browser engine.
  56. %package gtk
  57. Summary: GTK+ port of WebKit
  58. Summary(ja): WebKit の GTK+ ポート
  59. Group: Development/Libraries
  60. %description gtk
  61. %{name} is an open-source Web content engine library. This package contains
  62. the shared libraries for the WebKit GTK+ port as well as the sample
  63. GtkLauncher tool.
  64. %package gtk-devel
  65. Summary: Development package for %{name}
  66. Summary(ja): %{name} の開発パッケージ
  67. Group: Development/Libraries
  68. Requires: %{name}-gtk = %{version}-%{release}
  69. Requires: pkgconfig
  70. Requires: gtk3-devel
  71. Requires: libsoup-devel >= 2.28.2
  72. %description gtk-devel
  73. The %{name}-gtk-devel package contains libraries, build data, and header
  74. files for developing applications that use %{name}-gtk.
  75. Please note that the WebKit/GTK+ API is not yet stable. This should
  76. only be used as a "preview" rather than a stable platform library.
  77. %package doc
  78. Summary: Documentation for %{name}
  79. Summary(ja): %{name} のドキュメント
  80. Group: Documentation
  81. %description doc
  82. %{name} is an open-source Web content engine library. This package contains
  83. the documentation for %{name}, including various LICENSE, README, and
  84. AUTHORS files.
  85. %prep
  86. %setup -q -n webkit-%{version}
  87. # upstream
  88. ## %patch100 -p0
  89. %build
  90. %configure \
  91. --with-gtk=3.0 \
  92. --enable-icon-database \
  93. --enable-geolocation \
  94. --enable-introspection=yes \
  95. %{?with_coverage: --enable-coverage } \
  96. %{?with_pango: --with-font-backend=pango } \
  97. %{?with_wml: --enable-wml }
  98. make %{?_smp_mflags}
  99. # workaround for bug 488112
  100. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  101. ##touch JavaScriptCore/AllInOneFile.cpp
  102. ##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  103. %install
  104. rm -rf %{buildroot}
  105. make install DESTDIR=%{buildroot}
  106. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  107. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  108. # Finally, copy over and rename the various files for %%doc inclusion.
  109. %add_to_doc_files Source/WebKit/LICENSE
  110. %add_to_doc_files Source/WebKit/gtk/po/README
  111. %add_to_doc_files Source/WebKit/gtk/NEWS
  112. %add_to_doc_files Source/WebCore/icu/LICENSE
  113. %add_to_doc_files Source/WebCore/LICENSE-APPLE
  114. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2
  115. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
  116. %add_to_doc_files Source/JavaScriptCore/COPYING.LIB
  117. %add_to_doc_files Source/JavaScriptCore/THANKS
  118. %add_to_doc_files Source/JavaScriptCore/AUTHORS
  119. %add_to_doc_files Source/JavaScriptCore/icu/README
  120. %add_to_doc_files Source/JavaScriptCore/icu/LICENSE
  121. %find_lang webkit-3.0
  122. %clean
  123. rm -rf %{buildroot}
  124. %post gtk -p /sbin/ldconfig
  125. %posttrans gtk
  126. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  127. %postun gtk
  128. /sbin/ldconfig
  129. if [ $1 -eq 0 ] ; then
  130. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  131. fi
  132. # %files -f webkit.lang gtk
  133. %files gtk -f webkit-3.0.lang
  134. %defattr(-,root,root,-)
  135. %doc
  136. %{_libdir}/*.so.*
  137. %{_libexecdir}/WebKit3/
  138. %{_bindir}/jsc-3
  139. %{_libdir}/girepository-1.0/*.typelib
  140. %{_datadir}/glib-2.0/schemas/org.webkitgtk-3.0.gschema.xml
  141. %{_datadir}/webkitgtk-3.0/*
  142. %files gtk-devel
  143. %defattr(-,root,root,-)
  144. %exclude %{_libdir}/*.la
  145. %{_includedir}/webkit-3.0
  146. %{_libdir}/*.so
  147. %{_libdir}/pkgconfig/*.pc
  148. %{_datadir}/gir-1.0/*.gir
  149. %files doc -f docfiles.list
  150. %defattr(-,root,root,-)
  151. %{_docdir}/%{name}-%{version}/
  152. %changelog
  153. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
  154. - initial build for Vine Linux