WebKit-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit
  15. Version: 1.5.1
  16. Release: 1%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: yasumichi
  25. Source0: http://www.webkitgtk.org/webkit-%{version}.tar.gz
  26. # upstream patch
  27. Patch100: WebKit-icu44-36381.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  29. BuildRequires: bison
  30. BuildRequires: flex
  31. BuildRequires: gperf
  32. BuildRequires: gtk2-devel
  33. BuildRequires: libicu-devel
  34. BuildRequires: libjpeg-turbo-devel
  35. BuildRequires: libtool
  36. BuildRequires: libxslt-devel
  37. BuildRequires: libXt-devel
  38. BuildRequires: pcre-devel
  39. BuildRequires: sqlite3-devel
  40. BuildRequires: geoclue-devel
  41. BuildRequires: gnome-keyring-devel
  42. BuildRequires: gstreamer-devel
  43. BuildRequires: gstreamer-plugins-base-devel
  44. BuildRequires: enchant-devel
  45. BuildRequires: gobject-introspection-devel
  46. %if %{with pango}
  47. BuildRequires: pango-devel
  48. %else
  49. BuildRequires: cairo-devel
  50. BuildRequires: fontconfig-devel
  51. BuildRequires: freetype2-devel
  52. %endif
  53. BuildRequires: libsoup-devel >= 2.28.2
  54. %description
  55. WebKit is an open source web browser engine.
  56. %package gtk
  57. Summary: GTK+ port of WebKit
  58. Summary(ja): WebKit の GTK+ ポート
  59. Group: Development/Libraries
  60. %description gtk
  61. %{name} is an open-source Web content engine library. This package contains
  62. the shared libraries for the WebKit GTK+ port as well as the sample
  63. GtkLauncher tool.
  64. %package gtk-devel
  65. Summary: Development package for %{name}
  66. Summary(ja): %{name} の開発パッケージ
  67. Group: Development/Libraries
  68. Requires: %{name}-gtk = %{version}-%{release}
  69. Requires: pkgconfig
  70. Requires: gtk2-devel
  71. Requires: libsoup-devel >= 2.28.2
  72. %description gtk-devel
  73. The %{name}-gtk-devel package contains libraries, build data, and header
  74. files for developing applications that use %{name}-gtk.
  75. Please note that the WebKit/GTK+ API is not yet stable. This should
  76. only be used as a "preview" rather than a stable platform library.
  77. %package doc
  78. Summary: Documentation for %{name}
  79. Summary(ja): %{name} のドキュメント
  80. Group: Documentation
  81. %description doc
  82. %{name} is an open-source Web content engine library. This package contains
  83. the documentation for %{name}, including various LICENSE, README, and
  84. AUTHORS files.
  85. %prep
  86. %setup -q -n webkit-%{version}
  87. # upstream
  88. ## %patch100 -p0
  89. %build
  90. %configure \
  91. --with-gtk=2.0 \
  92. --enable-icon-database \
  93. --enable-geolocation \
  94. --enable-introspection=yes \
  95. %{?with_coverage: --enable-coverage } \
  96. %{?with_pango: --with-font-backend=pango } \
  97. %{?with_wml: --enable-wml }
  98. make %{?_smp_mflags}
  99. # workaround for bug 488112
  100. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  101. ##touch JavaScriptCore/AllInOneFile.cpp
  102. ##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  103. %install
  104. rm -rf %{buildroot}
  105. make install DESTDIR=%{buildroot}
  106. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  107. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  108. # Finally, copy over and rename the various files for %%doc inclusion.
  109. %add_to_doc_files Source/WebKit/LICENSE
  110. %add_to_doc_files Source/WebKit/gtk/po/README
  111. %add_to_doc_files Source/WebKit/gtk/NEWS
  112. %add_to_doc_files Source/WebCore/icu/LICENSE
  113. %add_to_doc_files Source/WebCore/LICENSE-APPLE
  114. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2
  115. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
  116. %add_to_doc_files Source/JavaScriptCore/COPYING.LIB
  117. %add_to_doc_files Source/JavaScriptCore/THANKS
  118. %add_to_doc_files Source/JavaScriptCore/AUTHORS
  119. %add_to_doc_files Source/JavaScriptCore/icu/README
  120. %add_to_doc_files Source/JavaScriptCore/icu/LICENSE
  121. %find_lang webkit-2.0
  122. %clean
  123. rm -rf %{buildroot}
  124. %post gtk -p /sbin/ldconfig
  125. %posttrans gtk
  126. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  127. %postun gtk
  128. /sbin/ldconfig
  129. if [ $1 -eq 0 ] ; then
  130. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  131. fi
  132. # %files -f webkit.lang gtk
  133. %files gtk -f webkit-2.0.lang
  134. %defattr(-,root,root,-)
  135. %doc
  136. %{_libdir}/*.so.*
  137. %{_libexecdir}/WebKit/
  138. %{_bindir}/jsc-1
  139. %{_libdir}/girepository-1.0/*.typelib
  140. %{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
  141. %{_datadir}/webkitgtk-1.0/*
  142. %files gtk-devel
  143. %defattr(-,root,root,-)
  144. %exclude %{_libdir}/*.la
  145. %{_includedir}/webkit-1.0
  146. %{_libdir}/*.so
  147. %{_libdir}/pkgconfig/*.pc
  148. %{_datadir}/gir-1.0/*.gir
  149. %files doc -f docfiles.list
  150. %defattr(-,root,root,-)
  151. %{_docdir}/%{name}-%{version}/
  152. %changelog
  153. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
  154. - new upstream release
  155. * Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
  156. - new upstream release
  157. - delete Patch0
  158. - add BuildRequires: gtk-doc
  159. * Sat Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
  160. - new upstream release
  161. * Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
  162. - new upstream release
  163. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
  164. - new upstream release
  165. - add BuildRequires: gobject-introspection-devel
  166. - add configure option (--enable-introspection=yes)
  167. - add Patch0 (WebKit-1.2.5-gir.patch)
  168. * Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
  169. - new upstream release (built with rpm-4.8.1-1 for pkg-config file)
  170. - changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
  171. * Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
  172. - new upstream release
  173. - add Requires: libsoup-devel (devel package)
  174. - fix configure (remove unrecognized option)
  175. - drop Patch100
  176. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
  177. - rebuilt again on ppc
  178. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  179. - new upstream release
  180. - rebuilt with libicu-4.4
  181. - added Patch100 for compiling with libicu-4.4
  182. - s/sqlite-devel/sqlite3-devel/
  183. - s/freetype-devel/freetype2-devel/
  184. * Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
  185. - updated to 1.1.18
  186. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
  187. - change BR from libsoup to libsoup-devel
  188. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
  189. - new upstream release.
  190. - add Vendor, Distribution and Packager.
  191. * Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
  192. - update to webkit-1.1.10 release version
  193. - added BuildRequires: enchant-devel
  194. * Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
  195. - update to webkit-1.1.6 release version
  196. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
  197. - update to new upstream snapshot (svn r41944)
  198. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
  199. - update to new upstream snapshot (svn r40471)
  200. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
  201. - update to new upstream snapshot (svn r37056)
  202. - disable html5video by default
  203. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
  204. - update to new upstream snapshot (svn r36882)
  205. - build with gnome-2.24
  206. * Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
  207. - build without pango by default.
  208. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
  209. - update to new upstream snapshot (svn r36053)
  210. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
  211. - update to new upstream snapshot (svn r34655)
  212. * Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1.svn34279
  213. - initial build for Vine Linux
  214. * Tue Jun 3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
  215. - rebuild for new icu
  216. * Tue Jun 3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
  217. - Update to new upstream snapshot (SVN 34279) anyway
  218. - Add BR: libXt-devel
  219. * Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
  220. - Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
  221. of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
  222. subdirectories either.)
  223. - Reference: bug 442200 (RFE: WebKit Migration)
  224. - Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
  225. tree).
  226. * Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
  227. - Update to new upstream snapshot (SVN 32531).
  228. - Fix bug 443048 and hopefully fix bug 444445
  229. - Modify the process of building GTK+ port a bit
  230. - on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
  231. * Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
  232. - Update to new upstream snapshot (SVN 31787).
  233. - Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
  234. CVE-2008-1011 (bug 438531: Cross-Site Scripting).
  235. - Switch to using autotools for building the GTK+ port.
  236. * Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
  237. - Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
  238. bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
  239. - Thanks to Mamoru Tasaka for helping find and squash these many bugs.
  240. * Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
  241. - Fix include directory naming. Resolves: bug 435561 (Header file <> header
  242. file location mismatch)
  243. - Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
  244. Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
  245. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
  246. - Update to new upstream snapshot (SVN 30667)
  247. - Add some build fixes for GCC 4.3:
  248. + gcc43.patch
  249. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
  250. - Autorebuild for GCC 4.3
  251. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
  252. - Update to new upstream snapshot (SVN 29336).
  253. - Drop TCSpinLock pthread workaround (fixed upstream):
  254. - TCSpinLock-use-pthread-stubs.patch
  255. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
  256. - Add proper %%defattr line to qt, qt-devel, and doc subpackages.
  257. - Add patch to forcibly build the TCSpinLock code using the pthread
  258. implementation:
  259. + TCSpinLock-use-pthread-stubs.patch
  260. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
  261. - Package renamed from WebKitGtk.
  262. - Update to SVN 28482.
  263. - Build both the GTK and Qt ports, putting each into their own respective
  264. subpackages.
  265. - Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
  266. the build-webkit script from upstream.
  267. - Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
  268. * Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
  269. - Initial packaging for Fedora.