mew-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378
  1. %define _docdir %{_defaultdocdir}
  2. %define _noVersionedDependencies 1
  3. # %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  4. %define _libdir %{_prefix}/lib
  5. %define origver 6.3
  6. %define pkgver %{origver}
  7. %define origname mew
  8. Summary: Mew - Messaging in the Emacs World
  9. Summary(ja): Emacs でメールを読むためのインターフェース
  10. Name: %{origname}
  11. Version: %{origver}
  12. Release: 2%{?_dist_release}
  13. License: distributable
  14. Group: Applications/Editors/Emacs
  15. URL: http://www.mew.org/
  16. Source0: http://www.mew.org/Release/mew-%{pkgver}.tar.gz
  17. Source1: %{origname}-install.sh
  18. Source2: %{origname}-remove.sh
  19. Source3: vine.dot.mew
  20. Source4: %{name}-init.el
  21. Source5: vine-default-%{name}.el
  22. Patch11: mew-6.3-icondir.diff
  23. Requires: emacsen
  24. Requires: perl >= 5.004_jp-4
  25. Provides: %{origname} = %{origver}
  26. #Conflicts: %{origname}-el
  27. Obsoletes: mew-mule, mew-el
  28. Obsoletes: mew-xemacs, mew-xemacs-extra
  29. Requires: mew-common = %{version}
  30. # PreReq: /sbin/install-info
  31. BuildRequires: emacsen
  32. BuildRoot: %{_tmppath}/%{name}-%{origver}-root
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. Messaging in the Emacs World. It provides a very easy user interface
  37. to e-mail, MIME and PGP (Pretty Good Privacy) on Emacsen.
  38. Please install Perl5 to use mew.
  39. Don't forget to copy %{_docdir}/mew-%{version}/vine.dot.mew
  40. to your ~/.mew.el file, and modify the site configurations, e.g.
  41. (setq mew-mail-domain-list '("your mail domain"))
  42. %description -l ja
  43. 電子メールを Emacs / XEmacs 上で簡単に読み書きすることができるインター
  44. フェース mew です。MIME や PGP にも対応しています。mewを使うためには、
  45. perlが必要です。
  46. %{_docdir}/mew-common-%{version}/vine.dot.mew を ~/.mew.el としてコピー
  47. し、適切に設定してください。
  48. (setq mew-mail-domain-list '("your mail domain"))
  49. また、%{_docdir}/mew-common-%{version}/contrib/以下にもいくつかのMewを便利に使う
  50. 為のelispを収録しています。
  51. %package -n mew-common
  52. Summary: Common files/programs for Mew Emacs/XEmacs
  53. Summary(ja): Emacs/XEmacs 用 Mew 両方で利用するファイル/プログラム
  54. Group: Applications/Internet
  55. Obsoletes: mew-xemacs-extra
  56. %description -n mew-common
  57. This package contains common files/programs for Mew Emacs/XEmacs.
  58. %description -n mew-common -l ja
  59. Emacs/XEmacs 用 Mew に共通するファイル/プログラムです.
  60. %prep
  61. %setup -q -n mew-%{pkgver}
  62. %patch11 -p1
  63. cp %{SOURCE3} .
  64. %build
  65. %configure
  66. make PREFIX="/usr" CFLAGS="$RPM_OPT_FLAGS" bin
  67. %install
  68. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  69. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  70. mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/install
  71. mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/remove
  72. mkdir -p %{buildroot}/usr/info
  73. mkdir -p %{buildroot}%{_datadir}/pixmaps/%{origname}
  74. # install el files
  75. # Add here commands to install the package into debian/mew.
  76. cp *.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  77. cp %{SOURCE4} %{SOURCE5} \
  78. %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  79. make install-bin prefix=%{buildroot}%{_prefix} \
  80. mandir=%{buildroot}%{_mandir}/man1 \
  81. bindir=%{buildroot}%{_bindir}
  82. # contrib
  83. #install -m 755 contrib/mewinc contrib/incdir contrib/incmbox \
  84. # $RPM_BUILD_ROOT/%{_docdir}/%{origname}/contrib/
  85. ## install icons
  86. cp etc/*.xpm %{buildroot}/usr/share/pixmaps/%{origname}
  87. cp etc/*.png %{buildroot}/usr/share/pixmaps/%{origname}
  88. cp etc/*.img %{buildroot}/usr/share/pixmaps/%{origname}
  89. ## install contrib
  90. #cp -a contrib $(CURDIR)/debian/mew/usr/share/doc/mew
  91. # install {info,jinfo} for mew-emacs
  92. make infodir="%{buildroot}%{_infodir}" \
  93. INSTALLINFO="/sbin/install-info" install-info install-jinfo
  94. rm -f %{buildroot}%{_infodir}/dir
  95. gzip -9nf %{buildroot}%{_infodir}/*
  96. %_installemacsenscript %{origname} %{SOURCE1}
  97. %_removeemacsenscript %{origname} %{SOURCE2}
  98. %post
  99. if [ "$1" = 2 ]; then
  100. %_emacsenPackageRemove %{origname}
  101. fi
  102. %_addemacsenlist %{origname}
  103. %_emacsenPackageInstall %{origname}
  104. /sbin/install-info %{_infodir}/mew.info.gz %{_infodir}/dir \
  105. --section="Message User Agent"
  106. /sbin/install-info %{_infodir}/mew.jis.info.gz %{_infodir}/dir \
  107. --section="Message User Agent"
  108. %preun
  109. if [ "$1" = 0 ]; then
  110. %_emacsenPackageRemove %{origname}
  111. %_removeemacsenlist %{origname}
  112. /sbin/install-info --delete %{_infodir}/mew.info.gz %{_infodir}/dir \
  113. --section="Message User Agent"
  114. /sbin/install-info --delete %{_infodir}/mew.jis.info.gz %{_infodir}/dir \
  115. --section="Message User Agent"
  116. fi
  117. %clean
  118. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  119. %files
  120. %defattr(-,root,root)
  121. %{_infodir}/mew.info*
  122. %{_infodir}/mew.jis.info*
  123. %{_datadir}/emacs/site-lisp/%{origname}/
  124. %{_libdir}/emacsen-common/packages/install/%{origname}
  125. %{_libdir}/emacsen-common/packages/remove/%{origname}
  126. %{_datadir}/pixmaps/%{origname}
  127. %files -n mew-common
  128. %defattr(-,root,root)
  129. %doc 00changes 00copyright 00copyright.jis 00diff 00readme
  130. %doc mew.dot.emacs vine.dot.mew
  131. %doc contrib/
  132. %{_bindir}/*
  133. %{_mandir}/man1/*
  134. %changelog
  135. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.3-2
  136. - rebuild with rpm-4.8.1
  137. - change pixmap directory
  138. - fix Patch11
  139. * Mon Dec 21 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.3-1
  140. - new upstream release
  141. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-3
  142. - fixed mew-init.el
  143. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-2
  144. - added mew-init.el, vine-default-mew.el
  145. - updated mew-install.sh, mew-remove.sh for vine-default-mew.el
  146. * Fri Jan 16 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.2-1
  147. - new upstream release
  148. * Sun Jun 15 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-1
  149. - applied new versioning policy
  150. * Tue Jun 10 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-0vl1
  151. - new upstream release
  152. * Thu Aug 30 2007 Shu KONNO <owa@bg.wakwak.com> 5.2-0vl3
  153. - added %%define _lib lib (for x86_64 support)
  154. * Mon Mar 05 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl2
  155. - added support X-Spam-Flag header in vine.dot.mew
  156. * Tue Jan 23 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl1
  157. - new upstream release
  158. * Mon Nov 26 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.1-0vl1
  159. - new upstream release
  160. - modified vine.dot.mew for Mew-5.1 feature support
  161. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl3
  162. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  163. * Tue Jul 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl2
  164. - changed Group to Applications/Editors/EmacsLisp
  165. - changed common package's Group to Applications/Internet
  166. * Mon Feb 14 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.2-0vl1
  167. - source update
  168. * Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.1-0vl1
  169. - source update
  170. * Mon Jul 28 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.3-0vl1
  171. - source update
  172. * Thu Mar 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2-0vl1
  173. - source update
  174. - update vine.dot.mew
  175. Obsoleting the following variables:
  176. mew-noreplyto-to-list
  177. mew-noreplyto-cc-list
  178. mew-replyto-to-list
  179. mew-replyto-cc-list
  180. mew-fromme-to-list
  181. mew-fromme-cc-list
  182. And defining the following variables:
  183. mew-reply-all-alist
  184. mew-reply-sender-alist
  185. mew-reply-fromme-alist
  186. * Sat Jan 11 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl3
  187. - added vine.dot.mew(Source3)
  188. * Wed Dec 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl2
  189. - source update
  190. * Tue Dec 03 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl1
  191. - update to mew-3.1
  192. * Thu Nov 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.2
  193. - test package: update to mew-3.1rc2
  194. * Fri Nov 01 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.1
  195. - test package: update to mew-3.1rc1
  196. * Mon Mar 18 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2-0vl4
  197. - changed License to distributable (not GPL2)
  198. * Mon Mar 18 2002 Hironobu MORIGUCHI <moriguti@luna.email.ne.jp> 2.2-0vl3
  199. - incm and man pages are included in common subpackage
  200. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 2.2-0vl2
  201. - corrected Group for common subpackage
  202. * Mon Feb 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2-0vl1
  203. - update to mew-2.2
  204. * Thu Feb 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.99.4-0vl1
  205. - update to mew-2.2rc4
  206. * Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2..99.2-0vl1
  207. - update to mew-2.2rc2
  208. * Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl3
  209. - mew-el -> mew
  210. - added Patch11 to set default icon directory for Vine
  211. * Wed Dec 12 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl2
  212. - added Obsoletes: mew-xemacs, mew-xemacs-extra
  213. - install-info gzipped info files :)
  214. * Thu Nov 01 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1-0vl1
  215. - update 2.1
  216. * Sat Oct 6 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0-0vl5
  217. - change package name ( mew -> mew-el)
  218. - apply emacsenc-oomon
  219. * Thu Sep 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  220. - Oops, forgot to add %%defattr for mew-common. Fixed.
  221. * Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  222. - split mew-common, obsoletes mew-xemacs-extra
  223. * Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
  224. - 2.0-0vl2: eliminate executable bit in %%doc and bin files install 755
  225. - install info files into %%{_infodir}
  226. * Sun Aug 20 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
  227. - 2.0-0vl1
  228. - update
  229. * Tue Oct 24 2000 Tomoya TAKA <tomoya@olive.plala.or.jp>
  230. - 1.94.2-3
  231. - fixed %files section to handle compressed info pages
  232. * Wed Jun 7 2000 Toru Sagami <czs14350@nifty.ne.jp>
  233. - fix description: mess up with mule/emacs/xemacs...
  234. - added BuildRequires and Conflicts
  235. * Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
  236. - updated 1.94.2
  237. * Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
  238. - added PreReq: /sbin/install-info
  239. - attrib +x for /usr/bin/uumerge
  240. - CFLAGS="$RPM_OPT_FLAGS"
  241. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  242. - 1.94.1-2
  243. - changed destination to /usr/share/emacs/site-lisp/mew
  244. * Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  245. - 1.94.1-1
  246. - updated in sync with 1.94.1 release
  247. - fixed %post and %preun section
  248. - Obsoletes: mew now changed to Obsoletes: mew-mule
  249. * Fri Oct 8 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
  250. - fixed info path & install info
  251. - fixed '%description'
  252. * Sat Oct 2 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
  253. - removed extra packages
  254. - fixed char-set "euc" of the spec file.
  255. - slight modifications for Vine-1.9
  256. * Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  257. - 1.94-3
  258. - package name changed from mew-emacs to mew
  259. - make info, make jinfo now processed even under emacs
  260. * Thu Sep 16 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  261. - Released as version "1.94-2".
  262. Changed from "mew-emacs 1.94-1".
  263. - Deleted "NoSource: 0", the definition part of data.
  264. - Revised some, the definition part of data.
  265. - Revised some, part of "%post, %postun".
  266. - Changerd "%postun" => "%preun".
  267. * Mon Sep 6 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  268. - First release.