123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518 |
- %define make_cvs 1
- # These games are already in KDE 4.
- %define donotcompilelist katomic kbattleship kblackbox kbounce kgoldrunner kjumpingcube klines klickety kmahjongg kmines knetwalk kolf konquest kpat kreversi ksame kshisen kspaceduel ktron ktuberling kwin4 lskat
- Name: kdegames3
- Summary: KDE Games not ported to KDE 4
- Summary(ja): KDE 4 に移植されていない KDE ゲーム集
- Version: 3.5.10
- Release: 2%{?_dist_release}
- License: GPLv2
- Group: Applications/Games
- URL: http://www.kde.org/
- Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegames-%{version}.tar.bz2
- Patch0: kdegames-3.5.10-trademarks.patch
- # fix build with make_cvs enabled and autoconf >= 2.64
- Patch1: arts-acinclude.patch
- # fix FTBFS with the new stricter ld in F13 (#565113)
- Patch2: kdegames-3.5.10-ftbfs.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: kdelibs3-devel >= %{version}
- BuildRequires: zlib-devel libpng-devel libjpeg-devel
- %if %{make_cvs}
- BuildRequires: automake libtool
- %endif
- Requires: kdelibs3 >= %{version}
- Requires: hicolor-icon-theme
- %description
- Games and gaming libraries for KDE which have not been ported to KDE 4 yet.
- Included with this package are: atlantik, kasteroids, kbackgammon, kboxpush,
- kenolaba, kfouleggs, kpoker, ksirtet, ksmiletris, ksnake.
- %package devel
- Summary: Development files for kdegames3
- Summary(ja): kdegames3 の開発用ファイル
- Group: Development/Libraries
- License: LGPLv2
- Requires: %{name} = %{version}-%{release}
- Requires: kdelibs3-devel >= %{version}
- %description devel
- Development files for the KDE gaming libraries.
- Install kdegames-devel if you wish to develop or compile games for the
- KDE desktop.
- %prep
- %setup -q -n kdegames-%{version}
- %patch0 -p1
- %patch1 -p1 -b .autoconf
- %patch2 -p1 -b .ftbfs
- export DO_NOT_COMPILE="%{donotcompilelist}"
- %if %{make_cvs}
- # hack/fix for newer automake
- sed -iautomake -e 's|automake\*1.10\*|automake\*1.1[0-5]\*|' admin/cvs.sh
- make -f admin/Makefile.common cvs
- %endif
- %build
- unset QTDIR || : ; . /etc/profile.d/qt.sh
- export DO_NOT_COMPILE="%{donotcompilelist}"
- %configure \
- --with-qt-libraries=$QTDIR/lib \
- --enable-new-ldflags \
- --disable-dependency-tracking \
- --disable-rpath \
- --enable-final \
- --disable-debug \
- --disable-warnings \
- --includedir=%{_includedir}/kde \
- --disable-setgid
- make %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- export DO_NOT_COMPILE="%{donotcompilelist}"
- make DESTDIR=$RPM_BUILD_ROOT install
- # locales
- %find_lang %{name} || touch %{name}.lang
- HTML_DIR=$(kde-config --expandvars --install html)
- if [ -d $RPM_BUILD_ROOT$HTML_DIR ]; then
- for lang_dir in $RPM_BUILD_ROOT$HTML_DIR/* ; do
- if [ -d $lang_dir ]; then
- # remove documentation for games we don't ship
- pushd $lang_dir
- for i in *; do
- case "%{donotcompilelist}" in
- *$i*)
- # $i is listed in %{donotcompilelist}, zap
- [ -d $i ] && rm -rf $i
- ;;
- esac
- done
- rm -rf kdegames-apidocs
- popd
- lang=$(basename $lang_dir)
- echo "%lang($lang) $HTML_DIR/$lang/*" >> %{name}.lang
- # replace absolute symlinks with relative ones
- pushd $lang_dir
- for i in *; do
- [ -d $i -a -L $i/common ] && ln -nsf ../common $i/common
- done
- popd
- fi
- done
- fi
- # rpmdocs
- for dir in atlantik k* ; do
- case "%{donotcompilelist}" in
- *$dir*)
- # $dir is listed in %{donotcompilelist}, skip
- ;;
- *)
- for file in AUTHORS ChangeLog README TODO ; do
- test -s "$dir/$file" && install -p -m644 -D "$dir/$file" "rpmdocs/$dir/$file"
- done
- ;;
- esac
- done
- # remove libkdegames devel stuff, not used by anything and conflicts with KDE 4
- rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/k* $RPM_BUILD_ROOT%{_libdir}/libkdegames.so
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/ldconfig
- for f in crystalsvg hicolor ; do
- touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
- gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
- done
- update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
- %postun
- /sbin/ldconfig
- for f in crystalsvg hicolor ; do
- touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
- gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
- done
- update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
- %files
- %defattr(-,root,root)
- %doc %{_datadir}/doc/HTML/en/*
- %{_bindir}/*
- %{_libdir}/lib*.so.*
- %{_libdir}/lib*.la
- %{_libdir}/kde3/*
- %{_datadir}/applications/kde/*.desktop
- %{_datadir}/apps/*
- %{_datadir}/config.kcfg/*
- %{_datadir}/icons/crystalsvg/*/*/*
- %{_datadir}/icons/hicolor/*/*/*
- %{_datadir}/services/*
- %files devel
- %defattr(-,root,root)
- %{_includedir}/kde/*
- %{_libdir}/lib*.so
- %changelog
- * Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-2
- - dropt klickety
- * Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
- - updated to 3.5.10 based on FC
- - built with new toolchain
- * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
- - renamed kdegames3
- * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
- - applied new versioning policy, spec in UTF-8
- * Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
- - rebuild for VineSeed
- * Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
- - new upstream release
- * Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
- - rebuild for VineSeed
- * Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
- - new upstream release
- * Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
- - new upstream release
- * Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
- - added --with-qt-libraries and --enable-libsuffix option
- * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
- - rebuild for VineSeed
- * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
- - new upstream release
- * Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-0vl3
- - changed Group to Applications/Games
- - added Japanese summary
- * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
- - rebuild for VineSeed
- * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
- - new upstream release
- * Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
- - rebuild for VineSeed
- * Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
- - new upstream release
- * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
- - rebuild for VineSeed
- * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
- - new upstream release
- * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
- - rebuild for VineSeed
- * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
- - new upstream release
- * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
- - rebuild for VineSeed
- * Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
- - new upstream release
- * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
- - new upstream release
- * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
- - new upstream release
- * Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
- - new upstream release
- * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
- - rebuild for VineSeed
- * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
- - new upstream release
- * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
- - build for VineSeed
- - add --disable-rpath to configure option
- * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
- - new upstream release
- - use %%{?_smp_mflags} for make option
- * Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
- - rebuild for VineSeed
- * Mon Mar 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
- - new upstream release
- * Fri Mar 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
- - new upstream release (3.4.0-rc1)
- - update %%files
- * Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
- - rebuild for VineSeed
- * Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
- - source upgrade
- - build for Vine Linux 3.1
- * Thu Oct 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
- - source upgrade
- * Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
- - rebuild with qt32
- * Sun Jun 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
- - source upgrade
- - remove lines about vine26
- - add URL: http://www.kde.org/
- * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
- - source upgrade
- * Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
- - move *.so to main package
- * Tue Mar 9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
- - source upgrade
- * Thu Feb 5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
- - source upgrade
- * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
- - rebuild for VineSeedPlus
- * Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
- - source upgrade
- - build for VinePlus/2.6
- - (VinePlus/2.6) BuildPrereq: autoconf258
- * Fri Dec 26 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
- - build for VineSeed with new toolchain and qt-3.2.3
- * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
- - rebuild with qt-3.2.1-0.26vl3
- * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
- - rebuild with qt-3.2.1-0vl3
- * Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
- - source upgrade
- - build with gcc-3.2.3
- * Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
- - source upgrade
- - change spec to build with gcc295
- - change make option for SMP and add script
- * Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
- - change spec to build with g++-2.95.3
- * Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
- - source upgrade
- - built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
- * Sat Mar 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
- - source upgrade
- - change spec to build both VineSeed and Vine2.5/2.6
- * Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
- - source upgrade to 3.1-stable
- * Mon Jan 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0.rc7vl1
- - source upgrade to 3.1rc7
- - stop using objprelink2, it does not work with gcc3
- - change spec to make monolithic package only
- - move %{_libdir}/*.la and %{_libdir}/*.so to devel package
- - add %{_libdir}/kde3/*
- - cleanup spec
- * Sun Dec 29 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.5a-0vl1
- - source upgrade
- * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
- - objprelink2 support only ix86 (add %ifarch %{ix86} ... )
- - add Prereq: ldconfig
- - add Requires: XFree86-libs XFree86-gl freetype2 libjpeg libmng libpng zlib
- - add Requires: qt >= 3.0.5 arts >= 1:1.0.4 kdelibs >= %{version}
- * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
- - source upgrade
- - BuildPrereq: autoconf253 objprelink2
- * Mon Sep 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
- - source upgrade
- * Fri Jul 5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
- - source upgrade
- * Fri Jun 7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-0vl1
- - source update to 3.0.1
- * Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
- - source update to 3.0
- - add configure option `--with-xinerama --enable-final'
- - add kbounce
- * Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
- - merged with rawhide 3.0.0-0.cvs20020306.1
- - source update to cvs-20020329
- - add BuildPrereq: autoconf252 automake15
- - There is Vine's previous changes, hacked for Vine
- -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
- - update to 2.2.2
- -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
- - Delete Epoch
- - Change BuildRequires and Requires
- - objprelink (i386 only)
- - Build for VineSeed
- * Wed Mar 6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
- - Fix packaging glitch in monolithic version
- * Tue Mar 5 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020305.1
- - Make splits a buildtime option (off by default) on request
- * Mon Jan 7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020107.1
- - Update to work with latest kdelibs changes
- * Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
- - Update
- - Add missing %{_bindir}/kbattleship
- * Sat Dec 15 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011215.1
- - Update
- - Split into several packages (one package per game)
- * Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
- - Update
- - Work around ia64 breakages
- - Add build requirements (#48977)
- * Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- - Fix problem when changing the card type (Bug #28824)
- * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- - 2.1-respin
- * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- - 2.1
- * Sun Feb 11 2001 Than Ngo <than@redhat.com>
- - don't use make -j CPU, it's broken
- * Thu Feb 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- - Run ldconfig in %%post and %%postun to make libkdegames happy
- - Replace absolute symlinks with relative symlinks (#24787)
- * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- - Update
- - includedir=/usr/include/kde,
- now that libkdegames installs kcarddeck.h
- * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- - Get rid of the gcc bug workaround, it's no longer needed
- * Mon Jan 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- - Update
- - Don't exclude ia64
- * Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - Update to HEAD
- * Sat Oct 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
- * Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - 2.0 final
- * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - 2.0
- * Mon Oct 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - new CVS
- - work around g++ bugs (in kjumpingcube)
- * Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - 1.93
- * Mon Aug 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - new version
- * Wed Jul 19 2000 Than Ngo <than@redhat.de>
- - fix docdir
- - rebuild 16 July snapshot
- * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - SMPify
- - don't hardcode QTDIR
- * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - use gcc 2.96
- - new snapshot
- * Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - new snapshot
- - ExcludeArch ia64 for now
- * Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - new snapshot
- - move it to /usr, where it belongs
- * Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
- - 2.0 snapshot
- * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
- - mark doc files as such
- * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
- - 1.1.2 release.
- * Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
- - snapshot, includes kde 1.1.1 + fixes
- * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
- - last snapshot before release
- - ripped out asteroids and sirtet
- * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
- - latest stable snapshot
- * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
- - Injected new description and group.
- * Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
- - upgraded to KDE 1.1 final.
- * Fri Feb 05 1999 Preston Brown <pbrown@redhat.com>
- - rebuilt for new libstdc++ etc.
- * Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
- - re-merged updates from Duncan Haldane, change /opt/kde --> /usr
|