git-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  2. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  3. # Pass --without docs to rpmbuild if you don't want the documentation
  4. Name: git
  5. Version: 1.8.4.4
  6. Release: 1%{?_dist_release}
  7. Summary: Core git tools
  8. Summary(ja): Core git ツール
  9. License: GPLv2
  10. Group: Development/Tools
  11. URL: http://git-scm.com/
  12. Source: http://git-core.googlecode.com/files/%{name}-%{version}.tar.gz
  13. Source1: vine-default-git.el
  14. Source2: git.xinetd
  15. Source3: git.conf.httpd
  16. Source4: gitweb.conf.in
  17. Source10: %{name}-install.sh
  18. Source11: %{name}-remove.sh
  19. Source12: git-init.el
  20. Patch0: git-1.5-gitweb-home-link.patch
  21. # Security
  22. # none
  23. BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel,
  24. BuildRequires: expat-devel, gettext, asciidoc
  25. BuildRequires: pcre-devel
  26. BuildRequires: xmlto
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. Requires: perl-Git = %{version}-%{release}
  29. Requires: zlib
  30. Provides: git-core = %{version}-%{release}
  31. Obsoletes: git-core <= 1.5.4.3
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: iwaim
  35. %description
  36. Git is a fast, scalable, distributed revision control system with an
  37. unusually rich command set that provides both high-level operations
  38. and full access to internals.
  39. The git rpm installs the core tools with minimal dependencies. To
  40. install all git packages, including tools for integrating with other
  41. SCMs, install the git-all meta-package.
  42. %package all
  43. Summary: Meta-package to pull in all git tools
  44. Summary(ja): すべての git ツール
  45. Group: Development/Tools
  46. Requires: git = %{version}-%{release}
  47. Requires: git-svn = %{version}-%{release}
  48. Requires: git-cvs = %{version}-%{release}
  49. %if "%{?_dist_release}" != "vl4"
  50. Requires: git-arch = %{version}-%{release}
  51. %endif
  52. Requires: git-email = %{version}-%{release}
  53. Requires: gitk = %{version}-%{release}
  54. Requires: git-gui = %{version}-%{release}
  55. Requires: perl-Git = %{version}-%{release}
  56. Requires: emacs-git = %{version}-%{release}
  57. Requires: git-contrib = %{version}-%{release}
  58. Obsoletes: git <= 1.5.4.3
  59. %description all
  60. Git is a fast, scalable, distributed revision control system with an
  61. unusually rich command set that provides both high-level operations
  62. and full access to internals.
  63. This is a dummy package which brings in all subpackages.
  64. %package daemon
  65. Summary: Git protocol daemon
  66. Summary(ja): Git プロトコルデーモン
  67. Group: Development/Tools
  68. Requires: git = %{version}-%{release}
  69. %description daemon
  70. The git daemon for supporting git:// access to git repositories
  71. %package -n gitweb
  72. Summary: Simple web interface to git repositories
  73. Summary(ja): git リポジトリへのシンプルな Web インタフェース
  74. Group: Development/Tools
  75. Requires: git = %{version}-%{release}
  76. %description -n gitweb
  77. Simple web interface to track changes in git repositories
  78. %package svn
  79. Summary: Git tools for importing Subversion repositories
  80. Summary(ja): Subversion リポジトリを git へインポートするためのツール
  81. Group: Development/Tools
  82. Requires: git = %{version}-%{release}, subversion, perl(Term::ReadKey)
  83. Requires: perl(SVN::Core)
  84. %description svn
  85. Git tools for importing Subversion repositories.
  86. %package cvs
  87. Summary: Git tools for importing CVS repositories
  88. Summary(ja): CVS リポジトリを git へインポートするためのツール
  89. Group: Development/Tools
  90. Requires: git = %{version}-%{release}, cvs, cvsps
  91. %description cvs
  92. Git tools for importing CVS repositories.
  93. %package contrib
  94. Summary: Git contrib tools
  95. Group: Development/Tools
  96. Requires: git = %{version}-%{release}
  97. %description contrib
  98. Git contrib tools
  99. %if "%{?_dist_release}" != "vl4"
  100. %package arch
  101. Summary: Git tools for importing Arch repositories
  102. Summary(ja): Arch リポジトリを git へインポートするためのツール
  103. Group: Development/Tools
  104. Requires: git = %{version}-%{release}, tla
  105. %description arch
  106. Git tools for importing Arch repositories.
  107. %endif
  108. %package email
  109. Summary: Git tools for sending email
  110. Summary(ja): Eメールを送るための git ツール
  111. Group: Development/Tools
  112. Requires: git = %{version}-%{release}, perl-Git = %{version}-%{release}
  113. %description email
  114. Git tools for sending email.
  115. %package gui
  116. Summary: Git GUI tool
  117. Summary(ja): Git の GUI ツール
  118. Group: Development/Tools
  119. Requires: git = %{version}-%{release}, tk
  120. %description gui
  121. Git GUI tool.
  122. %package -n gitk
  123. Summary: Git revision tree visualiser
  124. Summary(ja): Git リビジョンツリー可視化ツール
  125. Group: Development/Tools
  126. Requires: git = %{version}-%{release}, tk
  127. %description -n gitk
  128. Git revision tree visualiser.
  129. %package -n perl-Git
  130. Summary: Perl interface to Git
  131. Summary(ja): Git の perl インタフェース
  132. Group: Development/Libraries
  133. Requires: git = %{version}-%{release}, perl(Error)
  134. %if "%{?_dist_release}" == "vl4"
  135. Requires: perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
  136. %else
  137. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  138. %endif
  139. #BuildRequires: perl(Error), perl(ExtUtils::MakeMaker)
  140. %description -n perl-Git
  141. Perl interface to Git.
  142. %package -n emacs-git
  143. Summary: Git version control system support for Emacs
  144. Summary(ja): Emacs の Git サポート
  145. Group: Applications/Editors
  146. Requires: git = %{version}-%{release}, emacsen-common
  147. %description -n emacs-git
  148. %{summary}.
  149. %package devel
  150. Summary: Header files for git-core
  151. Summary(ja): git-core 用ヘッダファイル
  152. Group: Development/Libraries
  153. %description devel
  154. Header files for git-core.
  155. %prep
  156. %setup -q
  157. %patch0 -p1
  158. %__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
  159. %build
  160. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
  161. ETC_GITCONFIG=/etc/gitconfig \
  162. USE_LIBPCRE=1 \
  163. GITWEB_PROJECTROOT=/var/lib/git \
  164. gitwebdir=/var/www/git \
  165. prefix=%{_prefix} all %{!?_without_docs: doc}
  166. %install
  167. rm -rf $RPM_BUILD_ROOT
  168. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
  169. prefix=%{_prefix} mandir=%{_mandir} \
  170. ETC_GITCONFIG=/etc/gitconfig \
  171. USE_LIBPCRE=1 \
  172. NO_PYTHON=1 \
  173. GITWEB_PROJECTROOT=/var/lib/git \
  174. gitwebdir=/var/www/git \
  175. INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
  176. # perl-Git
  177. # Error.pm provide by perl-Error package
  178. rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
  179. # emacs-git
  180. mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
  181. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
  182. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
  183. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
  184. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
  185. # install el files
  186. install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  187. # install vine-default file
  188. install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  189. # install script( bytecompile el and install elc , remove )
  190. %_installemacsenscript git %{SOURCE10}
  191. %_removeemacsenscript git %{SOURCE11}
  192. mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
  193. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
  194. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
  195. perl -p \
  196. -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
  197. -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
  198. %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
  199. ## for gitweb sub package
  200. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
  201. install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
  202. sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
  203. %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
  204. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  205. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  206. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  207. (find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
  208. (find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
  209. %if %{!?_without_docs:1}0
  210. (find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
  211. %else
  212. rm -rf $RPM_BUILD_ROOT%{_mandir}
  213. %endif
  214. mkdir -p $RPM_BUILD_ROOT/srv/git
  215. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
  216. install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
  217. install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
  218. # header files and lib
  219. install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  220. install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
  221. install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  222. install libgit.a $RPM_BUILD_ROOT%{_libdir}
  223. install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
  224. %clean
  225. rm -rf $RPM_BUILD_ROOT
  226. %post -n emacs-git
  227. # bytecompile and install
  228. if [ "$1" = 2 ]; then
  229. %_emacsenPackageRemove git
  230. fi
  231. %_addemacsenlist git
  232. %_emacsenPackageInstall git
  233. %preun -n emacs-git
  234. if [ "$1" = 0 ]; then
  235. %_emacsenPackageRemove git
  236. %_removeemacsenlist git
  237. fi
  238. %files -f bin-man-doc-files
  239. %defattr(-,root,root)
  240. %{_bindir}/git
  241. %{_bindir}/git-receive-pack
  242. %{_bindir}/git-upload-archive
  243. %{_bindir}/git-upload-pack
  244. %{_bindir}/git-shell
  245. %{_datadir}/git-core/
  246. %doc README COPYING Documentation/*.txt contrib/hooks
  247. %{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
  248. %{!?_without_docs: %doc Documentation/howto Documentation/technical}
  249. %{_sysconfdir}/bash_completion.d
  250. %files svn
  251. %defattr(-,root,root)
  252. %{_libexecdir}/git-core/*svn*
  253. %doc Documentation/*svn*.txt
  254. %{!?_without_docs: %{_mandir}/man1/*svn*.1*}
  255. %{!?_without_docs: %doc Documentation/*svn*.html }
  256. %files cvs
  257. %defattr(-,root,root)
  258. %doc Documentation/*git-cvs*.txt
  259. %{_bindir}/git-cvsserver
  260. %{_libexecdir}/git-core/*cvs*
  261. %{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
  262. %{!?_without_docs: %doc Documentation/*git-cvs*.html }
  263. %files contrib
  264. %defattr(-,root,root)
  265. %doc diff-highlight/README.diff-highlight
  266. %{_bindir}/diff-highlight
  267. %if "%{?_dist_release}" != "vl4"
  268. %files arch
  269. %defattr(-,root,root)
  270. %doc Documentation/git-archimport.txt
  271. %{_libexecdir}/git-core/git-archimport
  272. %{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
  273. %{!?_without_docs: %doc Documentation/git-archimport.html }
  274. %endif
  275. %files email
  276. %defattr(-,root,root)
  277. %doc Documentation/*email*.txt
  278. %{_libexecdir}/git-core/*email*
  279. %{!?_without_docs: %{_mandir}/man1/*email*.1*}
  280. %{!?_without_docs: %doc Documentation/*email*.html }
  281. %files gui
  282. %defattr(-,root,root)
  283. %{_libexecdir}/git-core/git-gui*
  284. %{_libexecdir}/git-core/git-citool
  285. %{_datadir}/git-gui/
  286. %{!?_without_docs: %{_mandir}/man1/git-gui.1*}
  287. %{!?_without_docs: %doc Documentation/git-gui.html}
  288. %{!?_without_docs: %{_mandir}/man1/git-citool.1*}
  289. %{!?_without_docs: %doc Documentation/git-citool.html}
  290. %files -n gitk
  291. %defattr(-,root,root)
  292. %doc Documentation/*gitk*.txt
  293. %{_bindir}/gitk
  294. %{_datadir}/gitk
  295. %{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
  296. %{!?_without_docs: %doc Documentation/*gitk*.html }
  297. %files -n perl-Git -f perl-files
  298. %defattr(-,root,root)
  299. %files -n emacs-git
  300. %defattr(-,root,root)
  301. %{_datadir}/emacs/site-lisp/git
  302. #%{_libdir}/emacsen-common/packages/install/git
  303. #%{_libdir}/emacsen-common/packages/remove/git
  304. %{emacsen_pkgdir}/install/git
  305. %{emacsen_pkgdir}/remove/git
  306. %files daemon
  307. %defattr(-,root,root)
  308. %{_var}/lib/git
  309. %{_libexecdir}/git-core/git-daemon
  310. %config(noreplace)%{_sysconfdir}/xinetd.d/git
  311. /srv/git
  312. %files -n gitweb
  313. %defattr(-,root,root)
  314. %doc gitweb/README
  315. /var/www/git/
  316. %config(noreplace)%{_sysconfdir}/gitweb.conf
  317. %config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
  318. %files devel
  319. %defattr(644,root,root,755)
  320. %{_includedir}/git
  321. %{_libdir}/libgit.a
  322. %{_libdir}/libgit_xdiff.a
  323. %files all
  324. # No files for you!
  325. %changelog
  326. * Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
  327. - update to 1.8.4.4-1
  328. - new sub package: contrib
  329. * Fri Feb 8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
  330. - new upstream release
  331. * Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
  332. - new upstream release
  333. * Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
  334. - new upstream release
  335. * Thu Jan 3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
  336. - new upstream release
  337. * Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
  338. - new upstream release
  339. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
  340. - new upstream release
  341. * Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  342. - new upstream release
  343. - enable libpcre support, add BR: pcre-devel
  344. - add /etc/gitweb.conf
  345. - add /var/lib/git for PROJECTROOT
  346. * Mon Sep 3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
  347. - new upstream release
  348. * Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
  349. - new upstream release
  350. * Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
  351. - new upstream release
  352. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
  353. - new upstream release
  354. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
  355. - build with perl 5.12.3
  356. * Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
  357. - new upstream release
  358. - build with openssl 1.0.0c for VineSeed
  359. * Sat Jan 1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
  360. - new upstream release: include security fix: CVE-2010-3906
  361. * Fri Oct 1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
  362. - new upstream release
  363. - drop CVE-2010-2542 patch (Patch100): upstream fixed
  364. - apply vine-default
  365. - rename Source1: git-init.el -> vine-default-git.el
  366. - add new git-init.el file (Source12)
  367. - update git-install.sh
  368. - update %%build and %%install section for gitweb subpackage
  369. - add README in gitweb subpackage
  370. * Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
  371. - add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
  372. * Wed Jun 9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
  373. - new upstream release
  374. - fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
  375. - disable building of unused python remote helper libs
  376. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
  377. - new upstream release with security fix
  378. - drop patch10 (included in new release)
  379. * Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
  380. - new upstream release
  381. - add patch10 git daemon extra arg parsing fix
  382. * Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
  383. - fix install script for Emacs Lisp: <BTS:VineLinux:685>
  384. - update git-install.sh (Source10) using contributed patch
  385. * Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
  386. - new upstream release
  387. * Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
  388. - delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
  389. - spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
  390. - fix summary and description in daemon sub package
  391. * Sun Feb 1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
  392. - drop Error.pm: provide by perl-Error package
  393. * Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
  394. - new upstream relase
  395. - update URL tag
  396. - add Requires: perl(SVN::Core) for svn subpackage
  397. * Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
  398. - add git-shell in git package
  399. - do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
  400. * Mon Jan 5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
  401. - added BuildRequires: xmlto
  402. * Mon Jan 5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
  403. - new upstream release
  404. - add devel subpackage (see [wishes:0165])
  405. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
  406. - new upstream release
  407. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
  408. - new upstream release
  409. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
  410. - new upstream release
  411. * Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
  412. - use %%emacsen_pkgdir macro
  413. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  414. - new upstream release
  415. * Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6.4-1
  416. - initial build for Vine Linux
  417. * Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
  418. - git-1.5.6.4
  419. * Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
  420. - git-1.5.6
  421. * Tue Jun 3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
  422. - use tar.bz2 instead of tar.gz
  423. * Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
  424. - git-1.5.5.3
  425. * Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
  426. - git-1.5.5.2
  427. * Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
  428. - git-1.5.5.1
  429. * Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
  430. - git-1.5.5
  431. * Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
  432. - Remove the last two requires on git-core.
  433. * Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
  434. - Remove a patch that's already upstream.
  435. * Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
  436. - git-1.5.4.5
  437. * Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
  438. - Own /etc/bash_completion.d in case bash-completion isn't installed.
  439. * Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
  440. - Include the sample hooks from contrib/hooks as docs (bug 321151).
  441. - Install the bash completion script from contrib (bug 433255).
  442. - Include the html docs in the 'core' package again (bug 434271).
  443. * Wed Mar 19 2008 James Bowes 1.5.4.4-2
  444. - Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
  445. * Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
  446. - git-1.5.4.4
  447. * Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
  448. - rebuild for new perl (again)
  449. * Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
  450. - Do not silently overwrite /etc/httpd/conf.d/git.conf
  451. * Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
  452. - git-1.5.4.3
  453. - Include Kristian Høgsberg's changes to rename git-core to
  454. git and git to git-all.
  455. * Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
  456. - git-1.5.4.2
  457. * Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
  458. - Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
  459. gitweb rss feeds point be commitdiffs instead of commit
  460. * Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
  461. - git-1.5.4.1
  462. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
  463. - rebuild for new perl
  464. * Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  465. - Add BuidRequires on gettext.
  466. * Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  467. - git-1.5.4
  468. * Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
  469. - git-1.5.3.8
  470. * Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
  471. - Have git metapackage require explicit versions (bug 247214)
  472. * Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
  473. - git-1.5.3.7
  474. * Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
  475. - git-1.5.3.6
  476. - git-core requires perl(Error) (bug 367861)
  477. - git-svn requires perl(Term:ReadKey) (bug 261361)
  478. - git-email requires perl-Git (bug 333061)
  479. * Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
  480. - git-Perl requires Error package
  481. * Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
  482. - git-1.5.3.4
  483. * Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
  484. - git-1.5.3.3
  485. * Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
  486. - git-1.5.3.2
  487. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
  488. - Include git-gui and git-citool docs
  489. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
  490. - git-1.5.3.1-1
  491. * Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
  492. - git-1.5.2.5-1
  493. * Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
  494. - git-1.5.2.4-1
  495. * Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
  496. - Add git-daemon and gitweb packages
  497. * Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
  498. - Add emacs-git package (#235431)
  499. * Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
  500. - git-1.5.2.2
  501. * Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
  502. - git-1.5.2.1
  503. * Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
  504. - Added lib files for git-gui
  505. - Added Documentation/technical (As needed by Git Users Manual)
  506. * Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
  507. - Added howto files
  508. * Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
  509. - git-1.5.0.6
  510. * Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
  511. - git-1.5.0.5
  512. * Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
  513. - git-1.5.0.3
  514. * Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
  515. - BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
  516. * Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
  517. - git-1.5.0.2
  518. * Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
  519. - Update core package description (Git isn't as stupid as it used to be)
  520. * Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
  521. - Add git-gui and git-citool.
  522. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
  523. - no need to install manpages executable (bz 216790)
  524. - use bytes for git-cvsserver
  525. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
  526. - git-1.4.4.2
  527. * Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
  528. - rebuild against the new curl
  529. * Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
  530. - git-1.4.2.4
  531. * Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
  532. - git-1.4.2.3
  533. * Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
  534. - git-1.4.2.1
  535. * Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
  536. - git-1.4.2
  537. * Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
  538. - git-1.4.1
  539. * Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
  540. - git-1.4.0
  541. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
  542. - git-1.3.3
  543. - enable git-email building, prereqs have been relaxed
  544. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
  545. - git-1.3.2
  546. * Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
  547. - git-1.3.1
  548. * Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
  549. - git-1.3.0
  550. * Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
  551. - git-1.2.6
  552. * Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
  553. - git-1.2.5
  554. * Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
  555. - git-1.2.4
  556. * Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
  557. - git-1.2.3
  558. * Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
  559. - git-1.2.2
  560. * Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
  561. - git-1.2.1
  562. * Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
  563. - git-1.2.0
  564. * Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
  565. - git-1.1.6
  566. * Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
  567. - git-1.1.4
  568. * Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
  569. - git-1.1.2
  570. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
  571. - git-1.1.1
  572. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
  573. - Update to latest git-1.1.0 (drop git-email for now)
  574. - Now creates multiple packages:
  575. - git-core, git-svn, git-cvs, git-arch, gitk
  576. * Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
  577. - Change subpackage names to git-<name> instead of git-core-<name>
  578. - Create empty root package which brings in all subpackages
  579. - Rename git-tk -> gitk
  580. * Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
  581. - zlib dependency fix
  582. - Minor cleanups from split
  583. - Move arch import to separate package as well
  584. * Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
  585. - Move programs with non-standard dependencies (svn, cvs, email)
  586. into separate packages
  587. * Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
  588. - parallelize build
  589. - COPTS -> CFLAGS
  590. * Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
  591. - update to 0.99.6
  592. * Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  593. - Linus noticed that less is required, added to the dependencies
  594. * Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  595. - Updated dependencies
  596. - Don't assume manpages are gzipped
  597. * Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
  598. - drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
  599. - use RPM_OPT_FLAGS in spec file, drop patch0
  600. * Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
  601. - use dist tag to differentiate between branches
  602. - use rpm optflags by default (patch0)
  603. - own %{_datadir}/git-core/
  604. * Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
  605. - update spec file to fix Buildroot, Requires, and drop Vendor
  606. * Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  607. - Redid the description
  608. - Cut overlong make line, loosened changelog a bit
  609. - I think Junio (or perhaps OSDL?) should be vendor...
  610. * Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
  611. - Add the man pages, and the --without docs build option
  612. * Wed Jul 7 2005 Chris Wright <chris@osdl.org>
  613. - initial git spec file