ulogd-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311
  1. Summary: Userspace logging daemon for netfilter
  2. Name: ulogd
  3. Version: 2.0.4
  4. Release: 1%{?_dist_release}
  5. License: GPLv2+
  6. Group: System Environment/Daemons
  7. URL: http://www.netfilter.org/projects/%{name}/
  8. Source0: http://ftp.netfilter.org/pub/%{name}/%{name}-%{version}.tar.bz2
  9. Source1: %{name}.init
  10. BuildRequires: libnetfilter_conntrack-devel >= 0.0.95
  11. BuildRequires: libnetfilter_log-devel >= 1.0.0
  12. BuildRequires: libnfnetlink-devel >= 0.0.39
  13. BuildRequires: libnetfilter_acct-devel >= 1.0.1
  14. BuildRequires: libmnl-devel
  15. BuildRequires: linuxdoc-tools
  16. BuildRequires: texlive-collection-fontsrecommended
  17. Requires(post): /sbin/service
  18. Requires(post): /sbin/chkconfig
  19. Requires(preun): /sbin/chkconfig
  20. Requires(preun): /sbin/service
  21. Requires(postun): /sbin/service
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: tomop
  25. %description
  26. %{name} is a logging daemon that reads event messages coming from the Netfilter
  27. connection tracking and the Netfilter packet logging subsystem. You have to
  28. enable support for connection tracking event delivery; ctnetlink and the NFLOG
  29. target in your Linux kernel 2.6.x or load their respective modules. The
  30. deprecated ULOG target (which has been superseded by NFLOG) is also supported.
  31. %package libdbi
  32. Summary: Libdbi framework output plugin for %{name}
  33. Group: System Environment/Daemons
  34. BuildRequires: libdbi-devel
  35. Requires: %{name} = %{version}
  36. %description libdbi
  37. %{name}-libdbi is a libdbi output plugin for %{name}. It enables logging of
  38. firewall information through a libdbi interface.
  39. %package mysql
  40. Summary: MySQL output plugin for %{name}
  41. Group: System Environment/Daemons
  42. BuildRequires: libmysqlclient-devel
  43. Requires: %{name} = %{version}
  44. %description mysql
  45. %{name}-mysql is a MySQL output plugin for %{name}. It enables logging of
  46. firewall information into a MySQL database.
  47. %package pgsql
  48. Summary: PostgreSQL output plugin for %{name}
  49. Group: System Environment/Daemons
  50. BuildRequires: libpq-devel
  51. Requires: %{name} = %{version}
  52. %description pgsql
  53. %{name}-pgsql is a PostgreSQL output plugin for %{name}. It enables logging of
  54. firewall information into a PostgreSQL database.
  55. %package pcap
  56. Summary: PCAP output plugin for %{name}
  57. Group: System Environment/Daemons
  58. BuildRequires: libpcap-devel
  59. Requires: %{name} = %{version}
  60. %description pcap
  61. %{name}-pcap is a output plugin for %{name} that saves packet logs as PCAP
  62. file. PCAP is a standard format that can be later analyzed by a lot of tools
  63. such as tcpdump and wireshark.
  64. %package sqlite
  65. Summary: SQLITE output plugin for %{name}
  66. Group: System Environment/Daemons
  67. BuildRequires: sqlite3-devel
  68. Requires: %{name} = %{version}
  69. %description sqlite
  70. %{name}-sqlite is a SQLITE output plugin for %{name}. It enables logging of
  71. firewall information into an SQLITE database.
  72. %prep
  73. %setup -q
  74. %{__sed} -i -e 's|/var/log/|%{_localstatedir}/log/%{name}/|g' %{name}.conf.in
  75. %build
  76. %configure \
  77. --disable-static \
  78. --enable-shared \
  79. --with-dbi-lib=%{_libdir} \
  80. --with-pcap-lib=%{_libdir} \
  81. --with-sqlite3-lib=%{_libdir}
  82. %{__make} %{?_smp_mflags}
  83. %{__make} %{?_smp_mflags} -C doc
  84. %install
  85. %{__rm} -rf %{buildroot}
  86. %{__make} DESTDIR=%{buildroot} install
  87. %{__mkdir_p} -m 0755 %{buildroot}%{_localstatedir}/log/%{name}/
  88. %{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/
  89. %{__install} -m 0644 %{name}.conf %{buildroot}%{_sysconfdir}/
  90. %{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/logrotate.d/
  91. %{__install} -m 0644 %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  92. %{__mkdir_p} -m 0755 %{buildroot}%{_initrddir}/
  93. %{__install} -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  94. %post
  95. /sbin/chkconfig --add %{name}
  96. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  97. %preun
  98. # if we are uninstalling...
  99. if [ "$1" = 0 ]; then
  100. /sbin/service %{name} stop > /dev/null 2>&1 ||:
  101. /sbin/chkconfig --del %{name}
  102. fi
  103. %postun
  104. # if we are upgrading...
  105. if [ "$1" -ge "1" ]; then
  106. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  107. fi
  108. %check
  109. %{__make} %{?_smp_mflags} check
  110. %clean
  111. %{__rm} -rf %{buildroot}
  112. %files
  113. %defattr(0755,root,root,0755)
  114. %{_sbindir}/%{name}
  115. %{_initrddir}/%{name}
  116. %{_libdir}/%{name}
  117. %defattr(0644,root,root,0755)
  118. %doc COPYING
  119. %doc AUTHORS README
  120. %doc doc/%{name}.txt doc/%{name}.ps doc/%{name}.html
  121. %doc %{_mandir}/man?/*
  122. %config(noreplace) %{_sysconfdir}/%{name}.conf
  123. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  124. %dir %{_localstatedir}/log/%{name}
  125. %exclude %{_libdir}/%{name}/*.la
  126. %exclude %{_libdir}/%{name}/%{name}_output_DBI.so
  127. %exclude %{_libdir}/%{name}/%{name}_output_MYSQL.so
  128. %exclude %{_libdir}/%{name}/%{name}_output_PGSQL.so
  129. %exclude %{_libdir}/%{name}/%{name}_output_PCAP.so
  130. %exclude %{_libdir}/%{name}/%{name}_output_SQLITE3.so
  131. %files libdbi
  132. %defattr(0755,root,root,0755)
  133. %{_libdir}/%{name}/%{name}_output_DBI.so
  134. %defattr(0644,root,root,0755)
  135. %doc COPYING
  136. %files mysql
  137. %defattr(0755,root,root,0755)
  138. %{_libdir}/%{name}/%{name}_output_MYSQL.so
  139. %defattr(0644,root,root,0755)
  140. %doc COPYING
  141. %files pgsql
  142. %defattr(0755,root,root,0755)
  143. %{_libdir}/%{name}/%{name}_output_PGSQL.so
  144. %defattr(0644,root,root,0755)
  145. %doc COPYING
  146. %files pcap
  147. %defattr(0755,root,root,0755)
  148. %{_libdir}/%{name}/%{name}_output_PCAP.so
  149. %defattr(0644,root,root,0755)
  150. %doc COPYING
  151. %files sqlite
  152. %defattr(0755,root,root,0755)
  153. %{_libdir}/%{name}/%{name}_output_SQLITE3.so
  154. %defattr(0644,root,root,0755)
  155. %doc COPYING
  156. %changelog
  157. * Sun Jun 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
  158. - new upstream release.
  159. - initial build for Vine Linux.
  160. * Tue Sep 24 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-2
  161. - added accidentaly removed dist suffix in release
  162. - fixed up bogus dates in changelog
  163. * Mon Sep 09 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-1
  164. - update version
  165. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-5.beta4
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  167. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4.beta4
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  169. * Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-3.beta4
  170. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  171. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-2.beta4
  172. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  173. * Wed Nov 23 2011 Stephen Beahm <stephenbeahm@comcast.net> - 2.0.0-1.beta4
  174. - update version.
  175. - spec review.
  176. - (rebased on top of the remaining 1.24 changes, original date was Nov 16 2010)
  177. * Wed Mar 23 2011 Dan Horák <dan@danny.cz> - 1.24-15
  178. - rebuilt for mysql 5.5.10 (soname bump in libmysqlclient)
  179. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-14
  180. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  181. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.24-13
  182. - rebuilt with new openssl
  183. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-12
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  185. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-11
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  187. * Sat Jan 24 2009 Aurelien Bompard <abompard@fedoraproject.org> 1.24-10
  188. - rebuild for mysql
  189. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.24-9
  190. - Autorebuild for GCC 4.3
  191. * Wed Jan 9 2008 Leopold Aichinger <linuxtrainer@gmx.at> 1.24-8
  192. - Support for libpcap added
  193. * Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.24-7
  194. - Rebuild for deps
  195. * Tue Aug 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-5
  196. - Fix the deprecated way of getting the DSO initializers run, causing
  197. builds to fails with rpm-build > 4.4.2.1-3 (new find-debuginfo.sh script)
  198. * Sat Jul 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-4
  199. - add patch to fix bug 247345
  200. - update URL
  201. - fix initscript (bug 247083)
  202. - unmark init script as %%config (Fedora policy)
  203. * Sat Dec 09 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-3
  204. - rebuild
  205. * Thu Aug 31 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-2
  206. - rebuild
  207. * Wed Feb 22 2006 Aurelien Bompard <gauret[AT]free.fr> 1.24-1
  208. - version 1.24
  209. - drop patch3 (applied upstream)
  210. - drop patch4 (upstream uses mysql-config to detect libdir now)
  211. - drop patch5 (applied upstream)
  212. * Tue Feb 21 2006 Aurelien Bompard <gauret[AT]free.fr> 1.23-3
  213. - rebuild for FC5
  214. * Sun Jul 24 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-2
  215. - compress rotated logs
  216. - start after mysql in the init process
  217. - use dist tag
  218. * Tue Apr 19 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-1.fc4
  219. - version 1.23
  220. - change release tag for FC4
  221. - add patch for GCC4 (upstream bug #323)
  222. * Thu Apr 07 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  223. - rebuilt
  224. * Wed Mar 09 2005 Aurelien Bompard <gauret[AT]free.fr> 1.22-1
  225. - version 1.22
  226. - add gpg signature to sources
  227. * Sun Feb 20 2005 Aurelien Bompard <gauret[AT]free.fr> 1.21-1
  228. - version 1.21
  229. * Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-8
  230. - revise x86_64 patch to remove more hardcoded /lib badness
  231. * Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-7
  232. - x86_64, patch configure to look for mysql/pgsql below %%_libdir.
  233. - delete undefined %%epoch in mysql/pgsql sub package dep.
  234. * Sun Oct 31 2004 Aurelien Bompard <gauret[AT]free.fr> 1.02-6
  235. - apply Michael Schwendt's suggestions in bug 1598
  236. * Wed Oct 20 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.5
  237. - enable MySQL and PostgreSQL in subpackages
  238. - add man page from Debian
  239. * Wed Oct 06 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.4
  240. - apply QA suggestions (bug 1598)
  241. * Sat Jul 10 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.3
  242. - disable parallel builds
  243. - add chkconfig to Requires(pre,post)
  244. - set the right mode for /etc/logrotate.d/ulogd
  245. - rotate weekly
  246. * Sun May 16 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.2
  247. - Add Epoch: 0