pinentry-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376
  1. Name: pinentry
  2. Version: 1.1.0
  3. Release: 1%{?_dist_release}
  4. Summary: Collection of simple PIN or passphrase entry dialogs
  5. Vendor: Project Vine
  6. Distribution: Vine Linux
  7. # qt & qt4 subpackage have different license, see subpackage definitions
  8. License: GPLv2+
  9. URL: http://www.gnupg.org/aegypten/
  10. Source0: ftp://ftp.gnupg.org/gcrypt/pinentry/%{name}-%{version}.tar.bz2
  11. Source1: ftp://ftp.gnupg.org/gcrypt/pinentry/%{name}-%{version}.tar.bz2.sig
  12. # borrowed from opensuse
  13. Source10: pinentry-wrapper
  14. BuildRequires: gcr-devel
  15. BuildRequires: gtk2-devel
  16. BuildRequires: libcap-devel
  17. BuildRequires: ncurses-devel
  18. BuildRequires: libgpg-error-devel
  19. BuildRequires: libassuan-devel
  20. BuildRequires: libsecret-devel
  21. BuildRequires: pkgconfig(Qt5Core) pkgconfig(Qt5Gui) pkgconfig(Qt5Widgets)
  22. Requires(pre): %{_sbindir}/update-alternatives
  23. Requires(post): /sbin/install-info
  24. Requires(preun): /sbin/install-info
  25. Provides: %{name}-curses = %{version}-%{release}
  26. %description
  27. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  28. utilize the Assuan protocol as described by the aegypten project; see
  29. http://www.gnupg.org/aegypten/ for details.
  30. This package contains the curses (text) based version of the PIN entry dialog.
  31. %package gnome3
  32. Summary: Passphrase/PIN entry dialog for GNOME 3
  33. Requires: %{name} = %{version}-%{release}
  34. Provides: %{name}-gui = %{version}-%{release}
  35. %description gnome3
  36. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  37. utilize the Assuan protocol as described by the aegypten project; see
  38. http://www.gnupg.org/aegypten/ for details.
  39. This package contains the GNOME 3 version of the PIN entry dialog.
  40. %package gtk
  41. Summary: Passphrase/PIN entry dialog based on GTK+
  42. Requires: %{name} = %{version}-%{release}
  43. Provides: %{name}-gui = %{version}-%{release}
  44. Provides: pinentry-gtk2 = %{version}-%{release}
  45. %description gtk
  46. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  47. utilize the Assuan protocol as described by the aegypten project; see
  48. http://www.gnupg.org/aegypten/ for details.
  49. This package contains the GTK GUI based version of the PIN entry dialog.
  50. %package qt
  51. Summary: Passphrase/PIN entry dialog based on Qt5
  52. Requires: %{name} = %{version}-%{release}
  53. Provides: %{name}-gui = %{version}-%{release}
  54. Obsoletes: pinentry-qt4 < 0.8.0-2
  55. Provides: pinentry-qt5 = %{version}-%{release}
  56. %description qt
  57. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  58. utilize the Assuan protocol as described by the aegypten project; see
  59. http://www.gnupg.org/aegypten/ for details.
  60. This package contains the Qt5 GUI based version of the PIN entry dialog.
  61. %package emacs
  62. Summary: Passphrase/PIN entry dialog based on emacs
  63. Requires: %{name} = %{version}-%{release}
  64. %description emacs
  65. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  66. utilize the Assuan protocol as described by the aegypten project; see
  67. http://www.gnupg.org/aegypten/ for details.
  68. This package contains the emacs based version of the PIN entry dialog.
  69. %prep
  70. %setup -q
  71. %build
  72. %if 0%{?fedora} > 22
  73. # FTBFS on f23/gcc5 without this
  74. CXXFLAGS="%{optflags} -std=c++11"
  75. %endif
  76. %configure \
  77. --disable-rpath \
  78. --disable-dependency-tracking \
  79. --without-libcap \
  80. --enable-pinentry-gnome3 \
  81. --enable-pinentry-gtk2 \
  82. --enable-pinentry-qt \
  83. --enable-pinentry-emacs \
  84. --enable-libsecret
  85. make %{?_smp_mflags}
  86. %install
  87. make install DESTDIR=$RPM_BUILD_ROOT
  88. # Symlink for Backward compatibility
  89. ln -s pinentry-gtk-2 $RPM_BUILD_ROOT%{_bindir}/pinentry-gtk
  90. ln -s pinentry-qt $RPM_BUILD_ROOT%{_bindir}/pinentry-qt4
  91. install -p -m755 -D %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/pinentry
  92. # unpackaged files
  93. rm -fv $RPM_BUILD_ROOT%{_infodir}/dir
  94. %post
  95. if [ -f %{_infodir}/pinentry.info* ]; then
  96. /sbin/install-info %{_infodir}/pinentry.info %{_infodir}/dir ||:
  97. fi
  98. %preun
  99. if [ $1 -eq 0 -a -f %{_infodir}/pinentry.info* ] ; then
  100. /sbin/install-info --delete %{_infodir}/pinentry.info %{_infodir}/dir ||:
  101. fi
  102. %files
  103. %{!?_licensedir:%global license %%doc}
  104. %license COPYING
  105. %doc AUTHORS ChangeLog NEWS README THANKS TODO
  106. %{_bindir}/pinentry-curses
  107. %{_bindir}/pinentry
  108. %{_infodir}/pinentry.info*
  109. %files gnome3
  110. %{_bindir}/pinentry-gnome3
  111. %files gtk
  112. %{_bindir}/pinentry-gtk
  113. %{_bindir}/pinentry-gtk-2
  114. %files qt
  115. %{_bindir}/pinentry-qt
  116. # symlink for backward compatibility
  117. %{_bindir}/pinentry-qt4
  118. %files emacs
  119. %{_bindir}/pinentry-emacs
  120. %changelog
  121. * Thu Mar 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-1
  122. - new upstream release.
  123. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 0.9.7-4
  124. - rebuild with gcc-5.4.0
  125. * Sun May 22 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.7-3
  126. - initial build for Vine Linux.
  127. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.7-2
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  129. * Mon Dec 07 2015 Boris Ranto <branto@redhat.com> - 0.9.7-1
  130. - Rebase to latest upstream version
  131. * Tue Oct 27 2015 Stef Walter <stefw@redhat.com> - 0.9.6-4
  132. - Enable libsecret, which enables password caching in pinentry-gnome3
  133. - Resolves rhbz#1275567
  134. * Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 0.9.6-3
  135. - Add pinentry-gnome3 support to pinentry wrapper
  136. * Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 0.9.6-2
  137. - Build pinentry-gnome3
  138. * Fri Sep 11 2015 Boris Ranto <branto@redhat.com> - 0.9.6-1
  139. - Rebase to latest upstream version
  140. - Modify backwards compatible symlink for qt(4)
  141. - Enable pinentry-emacs since it was enabled by default in 0.9.5
  142. * Thu Jul 02 2015 Boris Ranto <branto@redhat.com> - 0.9.5-1
  143. - Rebase to latest upstream version
  144. - Removing qt4 pinentry patch -- got merged upstream
  145. - New package pinentry-emacs that hosts pinentry-emacs
  146. - New dependencies on libassuan and libgpg-error (de-bundling)
  147. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
  148. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  149. * Thu May 14 2015 Boris Ranto <branto@redhat.com> - 0.9.2-1
  150. - Rebase to latest upstream version
  151. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.9.1-2
  152. - Rebuilt for GCC 5 C++11 ABI change
  153. * Wed Mar 25 2015 Boris Ranto <branto@redhat.com> - 0.9.1-1
  154. - Rebase to latest upstream version
  155. - There are no longer any moc files so there is no need to patch them
  156. * Fri Mar 13 2015 Rex Dieter <rdieter@fedoraproject.org> - 0.9.0-3
  157. - fix FTBFS on f23/gcc5
  158. - drop deprecated configure flags
  159. * Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.9.0-2
  160. - Rebuilt for Fedora 23 Change
  161. https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
  162. * Wed Nov 12 2014 Boris Ranto <branto@redhat.com> - 0.9.0-1
  163. - Rebase to latest upstream version
  164. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
  165. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  166. * Tue Aug 12 2014 Boris Ranto <branto@redhat.com> - 0.8.3-6
  167. - fix bogus dates
  168. - upgrade pinentry-wrapper to handle corner cases better
  169. * Wed Jul 30 2014 Tom Callaway <spot@fedoraproject.org> - 0.8.3-5
  170. - fix license handling
  171. * Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> 0.8.3-4
  172. - /usr/bin/pinentry should not check if stderr is opened (#787775)
  173. * Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> - 0.8.3-3
  174. - .spec cleanup (drop support for old releases)
  175. - -gtk: Provides: pinentry-gtk2
  176. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-2
  177. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  178. * Thu Jan 30 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.3-1
  179. - Update to latest upstream version (0.8.3)
  180. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-11
  181. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  182. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-10
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  184. * Wed Nov 14 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-9
  185. - Fix macros expansions so that conditionals work
  186. * Mon Nov 12 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-8
  187. - Fix up licenses for qt and qt4 subpackages (#875875)
  188. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-7
  189. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  190. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-6
  191. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  192. * Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 0.8.1-5
  193. - Rebuild for new libpng
  194. * Tue Jul 26 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-4
  195. - Improve wrapper to fallback to curses even with DISPLAY set (#622077)
  196. * Fri Feb 18 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-3
  197. - Fix pinentry-curses running as root by disabling capabilities (#677670)
  198. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
  199. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  200. * Tue Feb 1 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-1
  201. - Updated to latest upstream version (0.8.1)
  202. * Fri May 7 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-3
  203. - Fix X11 even race with gtk (#589998)
  204. - Fix qt4 problems with creating window in the background (#589532)
  205. * Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.8.0-2
  206. - -qt: build as qt4 version, and drop qt3 support (f13+ only)
  207. * Tue Apr 27 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-1
  208. - pinentry-0.8.0
  209. - pinentry-gtk keyboard grab fail results in SIGABRT (#585422)
  210. * Sun Apr 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-5
  211. - pinentry-gtk -g segfaults on focus change (#520236)
  212. * Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-4
  213. - Errors installing with --excludedocs (#515925)
  214. * Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-3
  215. - drop alternatives, use app-wrapper instead (borrowed from opensuse)
  216. - -qt4 experimental subpkg, -qt includes qt3 version again (#523488)
  217. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.6-2
  218. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  219. * Mon Jun 22 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-1
  220. - pinentry-0.7.6
  221. - -qt switched qt4 version, where applicable (f9+, rhel6+)
  222. - fixup scriptlets
  223. * Sat Apr 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.5-1
  224. - pinentry-0.7.5
  225. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-6
  226. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  227. * Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-5
  228. - pinentry failed massrebuild attempt for GCC 4.3 (#434400)
  229. * Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-4
  230. - s/qt-devel/qt3-devel/ (f9+)
  231. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.7.4-3
  232. - Autorebuild for GCC 4.3
  233. * Sun Feb 17 2008 Adam Tkac <atkac redhat com> - 0.7.4-2
  234. - rebuild against new libcap
  235. * Sun Dec 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.4-1
  236. - pinentry-0.7.4
  237. - BR: libcap-devel
  238. * Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-2
  239. - respin (BuildID)
  240. * Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-1
  241. - pinentry-0.7.3
  242. - License: GPLv2+
  243. * Thu May 10 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.2-15
  244. - respin (for ppc64)
  245. * Mon Dec 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-14
  246. - -14 respin (to help retire ATrpms pinentry pkg)
  247. * Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-3
  248. - fc6 respin
  249. * Wed Aug 09 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-2
  250. - fc6 respin
  251. * Wed Mar 01 2006 Rex Dieter <rexdieter[AT]users.sf.net>
  252. - fc5: gcc/glibc respin
  253. * Tue Oct 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.7.2-1
  254. - 0.7.2, docs patch applied upstream.
  255. - Switch to GTK2 in -gtk.
  256. - Fine tune dependencies.
  257. - Build with dependency tracking disabled.
  258. - Clean up obsolete pre-FC2 support.
  259. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.7.1-4
  260. - rebuilt
  261. * Wed Jun 30 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.3
  262. - BuildRequires qt-devel >= 3.2.
  263. * Sat May 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.2
  264. - Spec cleanups.
  265. * Sat Apr 24 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.1
  266. - Update to 0.7.1.
  267. * Fri Dec 26 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.0-0.fdr.1
  268. - Update to 0.7.0.
  269. - Split GTK+ and QT dialogs into subpackages.
  270. * Thu Jul 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.9-0.fdr.1
  271. - Update to 0.6.9.
  272. - Smoother experience with --excludedocs.
  273. - Don't change alternative priorities on upgrade.
  274. * Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.fdr.1
  275. - Update to current Fedora guidelines.
  276. * Wed Feb 12 2003 Warren Togami <warren@togami.com> 0.6.8-1.fedora.3
  277. - info/dir temporary workaround
  278. * Sat Feb 8 2003 Ville Skyttä <ville.skytta at iki.fi> - 0.6.8-1.fedora.1
  279. - First Fedora release.