unixODBC-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317
  1. Name: unixODBC
  2. Version: 2.3.9
  3. Release: 1%{?_dist_release}
  4. Summary: A complete ODBC Driver Manager for Linux
  5. Summary(ja): Linux 用 ODBC ドライバマネージャー
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. # Programs are GPL, libraries are LGPL, except News Server library is GPL.
  10. License: GPLv2+ and LGPLv2+
  11. URL: http://www.unixODBC.org/
  12. Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
  13. Source1: odbcinst.ini
  14. Source4: conffile.h
  15. Source5: README.dist
  16. Patch8: so-version-bump.patch
  17. Patch9: keep-typedefs.patch
  18. Conflicts: iodbc
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
  21. BuildRequires: readline-devel
  22. %description
  23. Install unixODBC if you want to access databases through ODBC.
  24. You will also need the mysql-connector-odbc package if you want to access
  25. a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
  26. %package devel
  27. Summary: Development files for programs which will use the unixODBC library.
  28. Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
  29. Group: programming
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. The unixODBC package can be used to access databases through ODBC
  33. drivers. If you want to develop programs that will access data through
  34. ODBC, you need to install this package.
  35. %debug_package
  36. %prep
  37. %setup -q
  38. %patch8 -p1
  39. %patch9 -p1
  40. chmod 0644 Drivers/MiniSQL/*.c
  41. chmod 0644 Drivers/nn/*.c
  42. chmod 0644 Drivers/template/*.c
  43. chmod 0644 doc/ProgrammerManual/Tutorial/*.html
  44. chmod 0644 doc/lst/*
  45. chmod 0644 include/odbcinst.h
  46. %build
  47. autoreconf -ivf
  48. # unixODBC 2.2.14 is not aliasing-safe
  49. CFLAGS="%{optflags} -fno-strict-aliasing"
  50. CXXFLAGS="$CFLAGS"
  51. export CFLAGS CXXFLAGS
  52. %configure --with-gnu-ld=yes --enable-threads=yes \
  53. --enable-drivers=yes --enable-driverc=yes
  54. # Get rid of the rpaths
  55. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  56. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  57. make all
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. make DESTDIR=$RPM_BUILD_ROOT install
  61. install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
  62. # multilib header hacks
  63. # we only apply this to known Red Hat multilib arches, per bug #181335
  64. case `uname -i` in
  65. i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
  66. mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
  67. rm -f unixodbc_conf.h
  68. sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
  69. install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
  70. ;;
  71. *)
  72. ;;
  73. esac
  74. # add some explanatory documentation
  75. cp %{SOURCE5} README.dist
  76. # remove obsolete Postgres drivers from the package (but not the setup code)
  77. rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
  78. # copy text driver documentation into main doc directory
  79. # currently disabled because upstream no longer includes text driver
  80. # mkdir -p doc/Drivers/txt
  81. # cp -pr Drivers/txt/doc/* doc/Drivers/txt
  82. # don't want to install doc Makefiles as docs
  83. find doc -name 'Makefile*' | xargs rm
  84. # we do not want to ship static libraries
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  86. # remove unpackaged files from the buildroot
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  88. rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
  89. rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
  90. # initialize lists of .so files
  91. find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
  92. find $RPM_BUILD_ROOT%{_libdir} -name "*.so" | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
  93. # move these to main package, they're often dlopened...
  94. for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so libtdsS.so
  95. do
  96. echo "%{_libdir}/$lib" >> base-so-list
  97. grep -v "/$lib$" devel-so-list > devel-so-list.x
  98. mv -f devel-so-list.x devel-so-list
  99. done
  100. %clean
  101. rm -rf $RPM_BUILD_ROOT
  102. %files -f base-so-list
  103. %license COPYING
  104. %doc README AUTHORS ChangeLog NEWS doc
  105. %doc README.dist
  106. %config(noreplace) %{_sysconfdir}/odbc*
  107. %{_bindir}/odbcinst
  108. %{_bindir}/isql
  109. %{_bindir}/dltest
  110. %{_bindir}/iusql
  111. %{_bindir}/odbc_config
  112. %{_bindir}/slencheck
  113. %{_mandir}/man*/*
  114. %files devel -f devel-so-list
  115. %{_includedir}/*
  116. %{_libdir}/pkgconfig/*.pc
  117. %changelog
  118. * Sat Mar 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.9-1
  119. - new upstream release.
  120. - dropped scriptlets.
  121. - updated odbcinst.ini.
  122. * Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 2.3.7-2
  123. - rebuild with readline-8.0
  124. * Wed Dec 12 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.7-1
  125. - new upstream release.
  126. - dropped Patch6: fixed in upstream.
  127. * Sat Jan 20 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.5-1
  128. - new upstream release.
  129. * Tue Jan 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
  130. - new upstream release.
  131. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
  132. - rebuilt with readline 6.3
  133. - removed kde-subpackage-related BuildRequires
  134. - added Japanese summary
  135. * Tue Jul 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
  136. - new upstream release.
  137. - gui was discontinued in upstream.
  138. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
  139. - rebuild with VineSeed environment
  140. * Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
  141. - add --with-qt-includes option for configure
  142. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
  143. - updated to 2.2.14
  144. * Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
  145. - applied new versioning policy
  146. - removed *.la files from devel package
  147. * Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
  148. - updated to 2.2.12
  149. - rebuilt with new toolchain
  150. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
  151. - use installed libltdl
  152. - added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
  153. * Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
  154. - rebuilt with readline 5.1
  155. * Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
  156. - updated to 2.2.11
  157. - not libtoolize
  158. * Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
  159. - added Patch100 to fix typo in doc/Makefile.am from failure on compiling
  160. * Fri Jun 6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
  161. - source upgrade
  162. - remove patch (no need)
  163. - run libtoolize etc for VineSeed
  164. * Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
  165. - enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
  166. * Sun Feb 9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
  167. - source upgrade
  168. - change spec to build both VineSeed and Vine2.5/2.6
  169. - add patch from rawhide 2.2.3-6
  170. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
  171. - Requires: libjpeg (not libjpeg-6b)
  172. * Sun Oct 6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
  173. - source upgrade
  174. - add BuildPrereq: autoconf253 automake15
  175. - add PreReq: ldconfig
  176. - fix %files section and clean up spec
  177. - for unixODBC-kde package
  178. - add Requires: unixODBC = %{version}
  179. - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
  180. - delete .desktop files
  181. * Thu Apr 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
  182. - rebuild with KDE3
  183. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
  184. - updated unixODBC-2.2.0
  185. - fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
  186. * Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
  187. - remove -kde package on alpha
  188. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
  189. - Rebuild for Vine.
  190. * Sun Jun 24 2001 Than Ngo <than@redhat.com>
  191. - rebuild against qt-2.3.1, kde-2.1.x
  192. * Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
  193. - Better default odbcinst.ini
  194. - Minor cleanups
  195. * Wed Jun 6 2001 Trond Eivind Glomsrød <teg@redhat.com>
  196. - 2.0.7
  197. * Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
  198. - Fix for isql segfault on EOF/ctrl-d exit
  199. * Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
  200. - 2.0.6
  201. - add patch for 64 bit archs (dword shouldn't be "long int")
  202. * Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
  203. - rebuild
  204. * Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  205. - 1.8.13
  206. * Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
  207. - enable GUI now that we have KDE compiled with the standard
  208. compiler
  209. - move the applnk entries to the KDE package
  210. * Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  211. - add the missing shared libs to the non-devel package
  212. * Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
  213. - 1.8.12 fixes problems with the postgresql driver
  214. * Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
  215. - disable KDE subpackage to avoid the mess that is C++ binary
  216. compatibility
  217. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  218. - automatic rebuild
  219. * Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
  220. - improved QTDIR detection
  221. * Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  222. - 1.8.10
  223. - use %%{_tmppath}
  224. - update URL
  225. - including two missing libraries
  226. * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
  227. - 1.8.9
  228. * Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
  229. - adopted for Winston, changed to Red Hat packaging standards
  230. * Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
  231. - added a unixODBC-devel RPM to the group, added KDE links and icons to system
  232. - all of which came from recommendations from Fredrick Meunier
  233. - <Fredrick.Meunier@computershare.com.au>
  234. * Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
  235. - unixODBC-1.8.7
  236. - moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.