kdevplatform-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204
  1. %if %{?_dist_release} != "vl5"
  2. %define kde KDE
  3. %else
  4. %define kde KDE4
  5. %endif
  6. Name: kdevplatform
  7. Summary: Libraries for use by %{kde} development tools
  8. Summary(ja): %{kde} 開発ツールが使用するライブラリ
  9. Version: 1.3.1
  10. Release: 1%{?_dist_release}
  11. Group: Development/Tools
  12. License: GPLv2
  13. URL: http://www.kdevelop.org/
  14. Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.2.0/src/kdevplatform-%{version}.tar.bz2
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: libboost-devel
  17. BuildRequires: gettext
  18. BuildRequires: kdelibs-devel >= 4.6
  19. BuildRequires: kdesdk-devel >= 4.6
  20. BuildRequires: pcre-devel
  21. BuildRequires: subversion-devel
  22. BuildRequires: apr-util-devel
  23. BuildRequires: soprano-devel
  24. Requires: %{name}-libs = %{version}-%{release}
  25. Requires(postun): gtk2
  26. Requires(posttrans): gtk2
  27. %description
  28. %{kde} Development platform, the foundations upon which
  29. KDevelop and Quanta are built.
  30. %package libs
  31. Summary: Runtime libraries for %{name}
  32. Summary(ja): %{name} のランタイムライブラリ
  33. Group: System Environment/Libraries
  34. Requires: kdelibs4
  35. %description libs
  36. %{summary}.
  37. %package devel
  38. Summary: Developer files for %{name}
  39. Summary(ja): %{name} の開発用ファイル
  40. Group: Development/Libraries
  41. Requires: %{name}-libs = %{version}-%{release}
  42. Requires: libboost-devel
  43. Requires: commoncpp2-devel
  44. Requires: kdelibs4-devel
  45. Requires: subversion-devel
  46. %description devel
  47. %{summary}.
  48. %prep
  49. %setup -q -n kdevplatform-%{version}
  50. %build
  51. mkdir -p %{_target_platform}
  52. pushd %{_target_platform}
  53. %cmake \
  54. -DCMAKE_BUILD_TYPE=release \
  55. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  56. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  57. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  58. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  59. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  60. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  61. ..
  62. popd
  63. make %{?_smp_mflags} -C %{_target_platform}
  64. %install
  65. rm -rf %{buildroot}
  66. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  67. %find_lang %{name} --all-name --with-kde
  68. %clean
  69. rm -rf %{buildroot}
  70. %post
  71. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  72. %posttrans
  73. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  74. %postun
  75. if [ $1 -eq 0 ] ; then
  76. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  77. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  78. fi
  79. %post libs -p /sbin/ldconfig
  80. %postun libs -p /sbin/ldconfig
  81. %files -f %{name}.lang
  82. %defattr(-,root,root,-)
  83. %doc COPYING.PLUGINS COPYING.SRC
  84. %{_bindir}/kdev_dbus_socket_transformer
  85. %{_bindir}/kdev_format_source.sh
  86. %{_bindir}/kdevplatform_shell_environment.sh
  87. %{_datadir}/kde4/apps/kdev*/
  88. %{_datadir}/kde4/services/*.desktop
  89. %{_datadir}/kde4/servicetypes/*.desktop
  90. %{_datadir}/icons/hicolor/*/*/*
  91. %files libs
  92. %defattr(-,root,root,-)
  93. %{_libdir}/lib*.so.*
  94. %{_libdir}/kde4/*.so
  95. %files devel
  96. %defattr(-,root,root,-)
  97. %{_libdir}/lib*.so
  98. %{_includedir}/kde4/kdevplatform/
  99. %{_libdir}/cmake/kdevplatform/
  100. %changelog
  101. * Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-1
  102. - new upstream release
  103. * Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.3-1
  104. - new upstream release
  105. * Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.0-2
  106. - add BuildRequires: soprano-devel
  107. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  108. - new upstream release
  109. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.1.2-1
  110. - new upstream release
  111. - added Japanese summary
  112. * Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
  113. - removed R: kdevplatform from libs package
  114. * Sat May 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
  115. - Initial build for Vine Linux
  116. * Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-1
  117. - kdevplatform-1.0.0
  118. * Sat Apr 17 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.10.2-1
  119. - kdevplatform-0.10.2
  120. * Thu Apr 08 2010 Rex Dieter <rdieter@fedoraproject.org. - 0.10.0-1
  121. - kdevplatform-0.10.0
  122. * Mon Mar 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.99-1
  123. - kdevplatform-0.9.99
  124. * Mon Feb 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.98-1
  125. - kdevplatform-0.9.98
  126. * Sat Jan 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.97-2
  127. - rebuild (boost)
  128. - BR: kdelibs4-devel
  129. * Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> 0.9.97-1
  130. - kdevplatform-0.9.97
  131. - kdevplatform: file conflict with kdelibs (FindKDevPlatform.cmake) (#541690)
  132. * Sun Nov 22 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.95-0.6.20091015svn1035382
  133. - rebuild (fc13+, qt-4.6.0-rc1)
  134. * Thu Oct 15 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.5.20091015svn1035382
  135. - New snapshot
  136. * Sun Oct 11 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.4.beta5
  137. - Fix finding Kompare includes
  138. * Tue Sep 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.3.beta5
  139. - Use official release
  140. * Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.2
  141. - Add icon scriptlets
  142. * Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.1
  143. - Update tarball
  144. * Fri May 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.93-0.1
  145. - 1.0 Beta 3
  146. * Sat Feb 21 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.91-0.2.20090221svn929301
  147. - Post KDevplatform 1.0 Beta 1 snapshot
  148. * Fri Jan 09 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.85-1
  149. - 0.9.85 snapshot