libxml++-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187
  1. %global apiver 2.6
  2. Name: libxml++
  3. Version: 2.30.0
  4. Release: 3%{?_dist_release}
  5. Summary: C++ wrapper for the libxml2 XML parser library
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://libxmlplusplus.sourceforge.net/
  9. Source: http://ftp.gnome.org/pub/GNOME/sources/libxml++/2.26/libxml++-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  11. BuildRequires: libxml2-devel >= 2.6.1
  12. BuildRequires: glibmm-devel >= 2.4.0
  13. BuildRequires: doxygen, graphviz
  14. %description
  15. libxml++ is a C++ wrapper for the libxml2 XML parser library. It's original
  16. author is Ari Johnson and it is currently maintained by Christophe de Vienne
  17. and Murray Cumming.
  18. %package devel
  19. Summary: Development files for %{name}
  20. Group: Development/Libraries
  21. Requires: %{name} = %{version}-%{release}
  22. Requires: pkgconfig, libxml2-devel, glibmm-devel
  23. %description devel
  24. This package contains the headers and libraries for libxml++ development.
  25. %prep
  26. %setup -q
  27. # fix wrong end of line
  28. sed -i s'#\r##' examples/dom_parser/example_with_namespace.xml
  29. %build
  30. %configure --disable-static
  31. make %{?_smp_mflags}
  32. %install
  33. rm -rf $RPM_BUILD_ROOT
  34. %makeinstall
  35. find $RPM_BUILD_ROOT -name "*.la" -o -name '*.a' | xargs rm -f
  36. # Modify temporary working directories for files section.
  37. rm -rf _reference _examples _manual
  38. mkdir -m 755 _reference _examples _manual
  39. cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{apiver}/reference/html _reference/reference
  40. #cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{apiver}/manual _manual/manual
  41. mv docs/manual/html _manual/manual
  42. rm -rf $RPM_BUILD_ROOT%{_docdir}
  43. cp -a examples _examples/examples
  44. # Delete non-working makefiles, object files, prebuilt binaries and
  45. # empty files.
  46. find _examples -type f -a \( -name Makefile\* -o -name \*.o \
  47. -o \( -name example -a -perm +0111 \) -o -empty \) | xargs rm -f
  48. find _examples -type d -name '*.libs' -o -name '.deps' | xargs rm -rf
  49. # fix devhelp index file
  50. sed -i "s#"$RPM_BUILD_ROOT"##g" \
  51. $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-%{apiver}/%{name}-%{apiver}.devhelp2
  52. sed -i "s#"/%{name}-%{apiver}/reference/html"#"/%{name}-devel-%{version}/reference"#" \
  53. $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-%{apiver}/%{name}-%{apiver}.devhelp2
  54. %post -p /sbin/ldconfig
  55. %postun -p /sbin/ldconfig
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %files
  59. %defattr (-,root,root,-)
  60. %doc AUTHORS COPYING NEWS README ChangeLog
  61. %{_libdir}/*.so.*
  62. %files devel
  63. %defattr (-,root,root,-)
  64. %doc _examples/examples _reference/reference _manual/manual
  65. %{_includedir}/*
  66. %{_libdir}/*.so
  67. %{_libdir}/pkgconfig/*
  68. %dir %{_libdir}/%{name}-%{apiver}
  69. %dir %{_libdir}/%{name}-%{apiver}/include
  70. %{_libdir}/%{name}-%{apiver}/include/*.h
  71. %{_datadir}/devhelp/books/%{name}-%{apiver}/%{name}-%{apiver}.devhelp2
  72. %changelog
  73. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-3
  74. - rebuild with rpm-4.8.1 for pkg-config file
  75. * Thu Sep 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.30.0-2
  76. - Initial build for VineLinux
  77. * Fri Apr 09 2010 Haïkel Guémar <hguemar@gmail.com> - 2.30.0-1
  78. - Update to upstream 2.30.0
  79. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.26.0-2
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  81. * Sun Apr 12 2009 Denis Leroy <denis@poolshark.org> - 2.26.0-1
  82. - Update to upstream 2.26.0 (to match Gnome release)
  83. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.24.2-2
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  85. * Thu Jan 15 2009 Denis Leroy <denis@poolshark.org> - 2.24.2-1
  86. - Update to 2.24.2 (memleak fixes)
  87. - Fixed Gnome FTP URL
  88. * Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.23.2-2
  89. - Include unowned directories
  90. * Tue Aug 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.2-1
  91. - update to 2.23.2
  92. * Tue May 13 2008 Denis Leroy <denis@poolshark.org>
  93. - Removed unneeded example binaries from devel package
  94. * Thu Mar 13 2008 Denis Leroy <denis@poolshark.org> - 2.22.0-1
  95. - Update to upstream 2.22.0
  96. - GCC 4.3 patch upstreamed
  97. * Sun Feb 17 2008 Denis Leroy <denis@poolshark.org> - 2.20.0-2
  98. - Added patch for gcc 4.3 rebuild
  99. * Thu Sep 20 2007 Denis Leroy <denis@poolshark.org> - 2.20.0-1
  100. - Update to new 2.20 stable branch
  101. * Thu Aug 16 2007 Denis Leroy <denis@poolshark.org> - 2.18.2-2
  102. - Update to upstream 2.18.2 (mem leak fix)
  103. - Fixed License tag
  104. * Wed Jul 25 2007 Jesse Keating <jkeating@redhat.com> - 2.18.1-2
  105. - Rebuild for RH #249435
  106. * Tue Jul 24 2007 Denis Leroy <denis@poolshark.org> - 2.18.1-1
  107. - Update to version 2.18.1
  108. * Sun Sep 03 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.14.0-1.1
  109. - FC6 rebuild
  110. * Tue May 02 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.14.0-1
  111. - Version 2.14.0
  112. * Mon Feb 13 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.12.0-2.1
  113. - FC5 Rebuild
  114. * Thu Jan 26 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.12.0-2
  115. - Rebuilt to address RH #178592
  116. * Thu Sep 08 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 2.12.0-1
  117. - Version 2.12.0
  118. - Use --disable-static for configure.
  119. * Thu Jul 21 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 2.10.0-1
  120. - Version 2.10.0
  121. - Rearrange and conform to new FE standards
  122. - Buildrequire glibmm24-devel
  123. - Add devel requires to -devel
  124. * Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 0.26.0-5
  125. - rebuild on all arches
  126. * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  127. - rebuilt
  128. * Tue Nov 04 2003 Panu Matilainen <pmatilai@welho.com> - 0:0:26.0-0.fdr.3
  129. - remove empty .libs directories
  130. * Mon Nov 3 2003 Michael Schwendt <mschwendt[AT]users.sf.net> - 0:0.26.0-0.fdr.2
  131. - buildrequires graphviz
  132. - devel package requires main package and pkgconfig
  133. - own %%_includedir/libxml++-1.0
  134. - clean up examples tree
  135. * Tue Oct 21 2003 Panu Matilainen <pmatilai@welho.com>
  136. - Initial Fedora packaging