libsigc++12-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. %define version 1.2.7
  2. %define release 2%{?_dist_release}
  3. %define lib_name sigc++-1.2
  4. Summary: The Typesafe Signal Framework for C++
  5. Summary(ja): C++ 用の型安全なシグナルフレームワーク
  6. Name: libsigc++12
  7. Version: %{version}
  8. Release: %{release}
  9. Source: libsigc++-%{version}.tar.bz2
  10. License: LGPL
  11. Group: System Environment/Libraries
  12. URL: http://libsigc.sourceforge.net/
  13. BuildRequires: gcc-c++ m4
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. %description
  16. This library implements a full callback system for use in widget libraries,
  17. abstract interfaces, and general programming. Originally part of the Gtk--
  18. widget set, libsigc++ is now a seperate library to provide for more general
  19. use. It is the most complete library of its kind with the ablity to connect
  20. an abstract callback to a class method, function, or function object. It
  21. contains adaptor classes for connection of dissimilar callbacks and has an
  22. ease of use unmatched by other C++ callback libraries.
  23. Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
  24. %package devel
  25. Summary: development tools for the Typesafe Signal Framework for C++
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}
  28. Requires: pkgconfig
  29. %description devel
  30. The %{name}-devel package contains the static libraries and header files
  31. needed for development with %{name}.
  32. %package examples
  33. Summary: examples and tests for the Typesafe Signal Framework for C++
  34. Group: Development/Libraries
  35. Requires: %{name}-devel = %{version}
  36. %description examples
  37. The %{name}-devel package contains source code of example and test
  38. programs for libsigc++.
  39. %prep
  40. %setup -q -n libsigc++-%{version}
  41. %build
  42. %configure
  43. export tagname=CC
  44. make %{_smp_mflags} LIBTOOL=/usr/bin/libtool
  45. %install
  46. rm -rf $RPM_BUILD_ROOT
  47. export tagname=CC
  48. %makeinstall LIBTOOL=/usr/bin/libtool
  49. # Clean up the docs
  50. find doc -name "Makefile*" | xargs rm -f
  51. mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  52. cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  53. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
  54. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
  55. grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
  56. for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/examples/Makefile; do
  57. rm -f $i.*
  58. cp -p scripts/examples.Makefile $i
  59. done
  60. for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/tests/Makefile; do
  61. rm -f $i.*
  62. cp -p scripts/tests.Makefile $i
  63. done
  64. ## remove unuse files
  65. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %clean
  69. rm -rf $RPM_BUILD_ROOT
  70. %files
  71. %defattr(-,root,root,755)
  72. %doc AUTHORS COPYING.LIB README IDEAS NEWS ChangeLog TODO
  73. %attr(755,root,root) %{_libdir}/lib*.so.*
  74. %files devel
  75. %defattr(-,root,root,755)
  76. %doc doc/*
  77. %{_includedir}/*
  78. %{_libdir}/%{lib_name}/include
  79. %{_libdir}/pkgconfig/*.pc
  80. %attr(755,root,root) %{_libdir}/lib*.so
  81. %attr(644,root,root) %{_libdir}/*a
  82. %files examples
  83. %defattr(-,root,root,755)
  84. %{_libdir}/%{lib_name}/examples
  85. %{_libdir}/%{lib_name}/tests
  86. %changelog
  87. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-2
  88. - rebuild with rpm-4.8.1 for pkg-config file
  89. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.7-1vl5
  90. - applied new versioning policy, spec in utf-8
  91. - removed *.la
  92. * Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl2
  93. - rebuilt with new toolchain
  94. * Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
  95. - new upstream release
  96. * Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl2
  97. - package name changed to libsigc++12
  98. * Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  99. - update to 1.2.5
  100. - add Requires: pkgconfig
  101. * Sat Oct 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
  102. - rebuild to remove dependance <5371>
  103. - add Japanese summary
  104. - use better macros
  105. - s/Copyright/License/
  106. * Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
  107. - rebuild with new toolchain
  108. * Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
  109. - 1.0.4-0vl1
  110. - Build for Vine Linux 2.5
  111. * Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
  112. - packaged for Vine Linux 2.1
  113. * Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
  114. - updated Url and Source fileds
  115. - 1.0.0 stable release
  116. * Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
  117. - filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
  118. - minor install section cleanup
  119. * Wed Jan 19 2000 Allan Rae <rae@lyx.org>
  120. - autogen just creates configure, not runs it, so cleaned that up too.
  121. * Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
  122. - minor attr fix
  123. - removed unnecessary curly braces
  124. - fixed Herbert's adjustement
  125. * Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
  126. - minor package dependence fix
  127. * Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
  128. - fixed typo of mine
  129. - added traditional CUSTOM_RELEASE stuff
  130. - added SMP support
  131. * Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
  132. - adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
  133. * Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
  134. - split into three packages: %name, %name-devel and %name-examples
  135. * Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  136. - updated source field and merged conflicts between revisions.
  137. * Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
  138. - updated Prefix and BuildRoot fields
  139. * Thu Aug 5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
  140. - made sure configure works on all alphas
  141. * Wed Jul 7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  142. - Added autoconf macro for sigc.
  143. * Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  144. - Made into a .in to keep version field up to date
  145. - Still need to do release by hand
  146. * Mon Jun 7 1999 Dmitry V. Levin <ldv@fandra.org>
  147. - added Vendor and Packager fields
  148. * Sat Jun 5 1999 Dmitry V. Levin <ldv@fandra.org>
  149. - updated to 0.8.0
  150. * Tue Jun 1 1999 Dmitry V. Levin <ldv@fandra.org>
  151. - initial revision