w3m-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416
  1. #define __perl_requires %{_rpmconfigdir}/perl.req | grep -v w3mhelp
  2. #define __find_requires /bin/true
  3. %define _docdir %{_defaultdocdir}
  4. #%define cvsdate 20060815
  5. Summary: A Pager with WWW capability
  6. Summary(ja): World Wide Web に対応したページャ
  7. Name: w3m
  8. Version: 0.5.3
  9. Release: 3%{?_dist_release}
  10. License: BSD
  11. Group: Applications/Internet
  12. URL: http://w3m.sourceforge.net/
  13. Source0: %{name}-%{version}.tar.gz
  14. Source1: w3m.sh
  15. Source2: w3m.csh
  16. Source10: w3m-term
  17. Source11: filter-requires-w3m.sh
  18. Patch200: w3m-fh-def.patch
  19. Patch201: w3m-gc7.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: gc-devel >= 7.0
  22. BuildRequires: gtk2-devel
  23. BuildRequires: ncurses-devel
  24. BuildRequires: openssl-devel >= 0.9
  25. BuildRequires: sed
  26. Requires: perl
  27. Requires: openssl >= 0.9
  28. Requires(post): alternatives
  29. Requires(preun): alternatives
  30. Provides: webclient, pager
  31. Obsoletes: w3m-m17n
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: shaolin
  35. # work around for [VineSeed-x86_64:00178]
  36. %define __perl_requires %{SOURCE11}
  37. %description
  38. w3m is a pager with WWW capability. It IS a pager, but it can be
  39. used as a text-mode WWW browser. The features of w3m are as follows:
  40. - When reading HTML document, you can follow links and view images
  41. (using external image viewer).
  42. - It has 'internet message mode', which determines the type of document
  43. from header. If the Content-Type: field of the document is text/html,
  44. that document is displayed as HTML document.
  45. - You can change URL description like 'http://hogege.net' in plain text
  46. into link to that URL.
  47. %description -l ja
  48. w3m は,ページャfmをベースに開発された World Wide Web に対応したページャ
  49. です.fm の機能に加えて、w3m の特徴には,次のようなものがあります.
  50. ・WWW 対応なので,HTML の文書を読んでいる時には,その中のリンクを辿った
  51. り,画像を見ることができる.
  52. ・Internet message 表示のためのモードがある.この時,Content-Type: が
  53. text/html の場合は,自動的に HTML の文書として表示する.また,自力で
  54. MIME header のデコードをする.
  55. ・見ている plain text 文書中に URL 表記があった場合,その部分からリンク
  56. をたどることができる.
  57. %package img
  58. Summary: inline image extension support utilities for w3m
  59. Summary(ja): w3m 用インライン画像拡張サポートユーティリティ
  60. Group: Applications/Internet
  61. Requires: %{name} = %{version}-%{release}
  62. %description img
  63. w3m-img provides some utilities to support inline
  64. images for w3m
  65. on terminal emulator in X Window System environments.
  66. %description -l ja img
  67. w3m-img は X 環境のターミナルエミュレータ上の w3m でインライン画像を
  68. 表示するためのユーティリティです。
  69. %prep
  70. %setup -q
  71. %patch200 -p0 -b .fh
  72. %patch201 -p1 -b .gc7
  73. find Bonus -type f | \
  74. xargs sed -i -e "s|/usr/local/bin/ruby|/usr/bin/ruby|g;"
  75. %build
  76. %configure \
  77. --enable-japanese=E \
  78. --with-termlib=ncurses \
  79. --enable-image=x11 \
  80. --with-imagelib=gtk2 \
  81. --with-browser=gnome-open \
  82. --with-mailer=gnome-open \
  83. --with-editor=%{_sysbindir}/vi
  84. sed -i -e 's|#define USE_GPM 1|/* #undef USE_GPM */|' config.h
  85. sed -i -e 's|\-lgpm||g' Makefile
  86. sed -i -e 's|\-ldl|\-ldl \-lX11|g' Makefile
  87. make %{?_smp_mflags}
  88. %install
  89. rm -rf %{buildroot}
  90. make install DESTDIR=%{buildroot}
  91. mkdir -p %{buildroot}/etc/profile.d
  92. cp %{SOURCE1} %{buildroot}/etc/profile.d/w3m.sh
  93. cp %{SOURCE2} %{buildroot}/etc/profile.d/w3m.csh
  94. mkdir -p %{buildroot}%{_bindir}
  95. cp %{SOURCE10} %{buildroot}%{_bindir}/w3m-term
  96. chmod +x %{buildroot}%{_bindir}/w3m-term
  97. mkdir -p %{buildroot}%{_mandir}/{man1,ja/man1}
  98. install -p -m 644 doc-jp/w3m.1 %{buildroot}%{_mandir}/ja/man1
  99. install -p -m 644 doc/w3m.1 %{buildroot}%{_mandir}/man1
  100. # dont include duplicated man pages and CVS directory in doc
  101. rm -f doc-jp/w3m.1 doc/w3m.1
  102. find . -type d -name "CVS" | xargs rm -rf
  103. # prepare system-wide preference file
  104. mkdir -p %{buildroot}%{_sysconfdir}/w3m
  105. mkdir -p %{buildroot}%{_datadir}/applications
  106. cat > %{buildroot}%{_datadir}/applications/%{name}.desktop <<EOF
  107. [Desktop Entry]
  108. Name=%{name}
  109. Type=Application
  110. Comment=A Pager with WWW capability
  111. Comment[ja]=WWW対応ページャ
  112. Exec=w3m-term
  113. Terminal=false
  114. Categories=Network;
  115. EOF
  116. # eliminate executable bit in %doc
  117. find Bonus/ -type f -perm +111 | xargs -r chmod -x
  118. %clean
  119. rm -rf %{buildroot}
  120. %post
  121. %{_syssbindir}/update-alternatives --install /usr/bin/pager pager /usr/bin/w3m 30
  122. %preun
  123. if [ "$1" = "0" ]; then
  124. %{_syssbindir}/update-alternatives --remove pager /usr/bin/w3m
  125. fi
  126. %files
  127. %defattr(-,root,root)
  128. %doc Bonus ChangeLog NEWS README doc doc-jp
  129. %attr(755,root,root) %config /etc/profile.d/*
  130. %dir %{_sysconfdir}/w3m
  131. %{_bindir}/w3m*
  132. %exclude %{_libexecdir}/w3m/w3mimgdisplay
  133. %{_libexecdir}/w3m/
  134. %{_datadir}/applications/%{name}.desktop
  135. %{_datadir}/w3m/
  136. %{_datadir}/locale/*/LC_MESSAGES/*
  137. %{_mandir}/ja/man1/w3m.1*
  138. %{_mandir}/man1/w3m*
  139. %files img
  140. %{_libexecdir}/w3m/w3mimgdisplay
  141. %changelog
  142. * Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.3-3
  143. - change localtion of desktop file
  144. * Mon Sep 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.5.3-2
  145. - updated Source11 to call /usr/lib/rpm/perl.req
  146. - added Patch200 and 201 for building current environment
  147. - rebuilt for removing libpng12 dependency
  148. * Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 0.5.3-1
  149. - new upstream release
  150. - drop unnecessary patches: upstream fixed
  151. - ambwidth patch (Patch10)
  152. - sudden crash patch (Patch11)
  153. - x86_64 patch (Patch100)
  154. * Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.5.2-7
  155. - rebuild with openssl-1.0.0c
  156. - add Patch100 (w3m-0.5.2-x86_64-vine.patch)
  157. * Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-6
  158. - add Patch10 to fix display utf8 ambiguous width characters
  159. (from: http://www.j10n.org/files/w3m-cvs-1.914-ambwidth.patch)
  160. - add Patch11 to fix sudden crash
  161. (from: http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200708.month/4286.html)
  162. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-5
  163. - rebuilt with gcc-4.4.3-3 on ppc
  164. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-4
  165. - rebuilt with new toolchain
  166. * Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-2
  167. - spec in utf-8
  168. - remove Requires: indexhtml
  169. - set HTTP_HOME to http://vinelinux.org/
  170. - update w3m-term
  171. * Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.2-1
  172. - new upstream release
  173. - dropped Patch100 (merged into upstream)
  174. * Sun Jun 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1.20060815-0vl6
  175. - rebuilt with new toolchain and environment
  176. * Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl5
  177. - add Provides: pager
  178. - add Requires(post,preun): alternatives
  179. * Tue Apr 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl3
  180. - add update-alternatives: pager in %post and %preun scriptlet
  181. * Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  182. - 0.5.1.20060815-0vl2
  183. - rebuilt for VineSeed
  184. * Sat Dec 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  185. - 0.5.1.20060815-0vl1.1
  186. - add patch100 for fix "inputAnswer()" SSL Certificate Handling Vulnerabilit
  187. * Tue Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp>
  188. - update to cvs snapshot
  189. - use gtk2 for w3m-img instead of gdk-pixbuf
  190. * Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.5.1-0vl6
  191. - use filter-requires-w3m.sh as find-requires (rpm's bug?)
  192. * Sat Sep 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl5
  193. - use %%{_docdir}/Vine/index.html as default homepage
  194. * Sun Jul 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl4
  195. - change default editor to %%{_sysbindir}/vi
  196. - use ncurses explicitly as termlib
  197. * Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl3
  198. - fix typo
  199. - add BuildPrereq: gtk+-devel, gdk-pixbuf-devel
  200. * Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
  201. - rebuild without gpm
  202. * Wed May 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
  203. - new upstream release
  204. - Obsoletes: w3m-m17n
  205. * Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl2
  206. - add message catalogs to %%files
  207. * Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl1
  208. - new upstream release
  209. - fix w3mimgdisplay path in w3m-term
  210. * Sun Dec 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
  211. - new upstream release
  212. - split w3mimgdisplay to w3m-img subpackage.
  213. - Requires: gc >= 6.2
  214. * Sat May 31 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.4.1-0vl1
  215. - new upstream release
  216. * Tue Feb 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-0vl1
  217. - new upstream release
  218. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.2-0vl1
  219. - new upstream release.
  220. w3m 0.3.2.2 - 2002-12-06
  221. * security fix: html_quote for img alt attributes
  222. * Fri Nov 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl2
  223. - change default page path to /usr/doc/HTML.
  224. this should be changed to /usr/share/doc in next release.
  225. ( TODO: indexhtml package )
  226. * Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl1
  227. - new upstream release
  228. w3m 0.3.2.1 - 2002-11-27
  229. * security fix: html_quote for frame contents
  230. * backport from w3m 0.3.2+cvs
  231. - fix segmentation fault by large complex table.
  232. [w3m-dev 03371][w3m-dev 03438]
  233. * Wed Nov 6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
  234. - new upstream release
  235. w3m 0.3.2 - 2002-11-05
  236. * ~/.netrc: password for ftp
  237. * rc: display_lineinfo: display current line number
  238. * rc: passwd_file: passwd file for HTTP auth
  239. * func: MARK_WORD
  240. * rc: imgsize: obsoleted
  241. * w3m-img for framebuffer merged
  242. * Mon Sep 30 2002 Tomoya TAKA <taka@vinelinux.org> 0.3.1-0vl2
  243. - replace gc with an old version on alpha (Source20)
  244. * Wed Jul 17 2002 IWAI Masaharu <iwai@alib.jp> 0.3.1-0vl1
  245. - upstream release
  246. - coped new configure options
  247. * Sun Apr 21 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.3-0vl2
  248. - fixed configure option ([VineSeed:06372])
  249. - added openssl-devel version in {Build,}Requires
  250. * Mon Mar 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3-0vl1
  251. - updated in sync with upstream 0.3 release
  252. (now w3m-img patch is included in the upstream version)
  253. * Tue Feb 05 2002 Toru Sagami <sagami@vinelinux.org> 0.2.5-0vl1
  254. - w3m-0.2.5 with 0.2.5+cvs-1.302
  255. * Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl2
  256. - eliminate executable bit in %doc
  257. - spec cleanup
  258. * Wed Jan 16 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl1
  259. - updated to current stable release
  260. * Thu Jan 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3.2-0vl1
  261. - updated to new upstream release
  262. - FIXME: system-wide /etc/w3m/w3mconfig should be prepared. Anyone? :)
  263. * Fri Sep 28 2001 <masato@nets.ce.hiroshima-cu.ac.jp>
  264. - 0.2.1-0vl9
  265. - added sparc patch
  266. * Thu Aug 23 2001 <shom@vinelinux.org>
  267. - 0.2.1-0vl8: add w3m-term script
  268. * Mon Aug 06 2001 <sagami@vinelinux.org>
  269. - 0.2.1-0vl7: added imlib-devel ncurses-devel for BuildPreReq
  270. - update img patch to version 1.10 from 1.9
  271. * Mon Aug 6 2001 Jun Nishii <jun@vinelinux.org> 0.2.1-0vl6
  272. - added img patch
  273. * Mon Jul 16 2001 <sagami@vinelinux.org>
  274. - 0.2.1-0vl5: spec file clean up
  275. - openssl-devel for BuildPrereq, not openssl
  276. - install more sophisticated w3m.sh w3m.csh with any %%{_docdir} definition
  277. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  278. - 0.2.1-0vl4
  279. - rebuilt with openssl-0.9.6b
  280. * Sun Jun 24 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  281. - 0.2.1-0vl3
  282. - security fixes (http://www.lac.co.jp/security/snsadv/32.html)
  283. * Sat Jun 09 2001 <sagami@vinelinux.org>
  284. - 0.2.1-0vl2: minor spec fixes(URL, License and etc.)
  285. - actually rebuilt with ncurses5 (i386)
  286. * Sat Mar 24 2001 Yoichi Imai <yoichi@silver-forest.com>
  287. - 0.2.1-0vl1
  288. * Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  289. - 0.1.10-0vl6
  290. - use better macros
  291. - rebuilt with ncurses5
  292. * Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
  293. - w3m-0.1.10-0vl5
  294. - use applnk instead of wmconfig
  295. - use openssl
  296. * Thu Jul 27 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  297. - w3m-0.1.10-0vl4
  298. - fix typo in w3m.csh and w3m.wmconfig
  299. * Sun Jul 09 2000 Toru Sagami <czs14350@nifty.ne.jp>
  300. - w3m-0.1.10-0vl3
  301. - provide default HTTP_HOME in /etc/profile.d
  302. * Fri Jul 07 2000 Toru Sagami <czs14350@nifty.ne.jp>
  303. - Provides: webclient, Requires: indexhtml (capability of lynx)
  304. - added w3m.wmconfig
  305. - give them(who?) RPM_OPT_FLAGS(what?)
  306. - dont include duplicated man pages and CVS directory in doc
  307. * Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
  308. - 0.1.10-0vl1
  309. * Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
  310. - fix spec file
  311. * Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
  312. - updated from 0.1.4 to 0.1.6
  313. * Thu Jan 13 2000 Yoichi Imai <yoichi@silver-forest.com>
  314. - updated from 991203 to 0.1.4
  315. * Fri Dec 03 1999 Yoichi Imai <yoichi@silver-forest.com>
  316. - updated from 991028 to 991203
  317. * Sat Oct 30 1999 Yoichi Imai <bonaim@mutt.freemail.ne.jp>
  318. - updated from 990820 to 991028
  319. * Thu Aug 26 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
  320. - updated from 990716 to 990820
  321. * Wed Aug 11 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
  322. - initial Release to VinePlus