bogl-vl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256
  1. Summary: A terminal program for displaying Unicode on the console.
  2. Summary(ja): コンソール上でユニコードを表示するためのターミナルプログラム
  3. Name: bogl
  4. Version: 0.1.18
  5. Release: 10%{?_dist_release}
  6. URL: http://www.msu.edu/user/pfaffben/projects.html
  7. Source0: http://ftp.debian.org/debian/pool/main/b/bogl/bogl_0.1.18-1.5.tar.gz
  8. Source1: wlite-0.8.1.tar.gz
  9. Source4: 14x14cjk.bdf.gz
  10. Patch: bogl-0.1.18-1.5-vine.patch
  11. Patch1: bogl-0.1.9-fpic.patch
  12. Patch3: bogl-0.1.9-2.6fbdev.patch
  13. Patch5: bogl-0.1.18-noexecstack.patch
  14. Epoch: 0
  15. License: GPL
  16. Group: System Environment/Libraries
  17. BuildRoot: %{_tmppath}/%{name}-root
  18. BuildRequires: gd-devel, libpng-devel
  19. %description
  20. BOGL stands for Ben's Own Graphics Library. It is a small graphics
  21. library for Linux kernel frame buffers. It supports only very simple
  22. graphics.
  23. %package devel
  24. Summary: Development files required to build BOGL applications.
  25. Group: Development/Libraries
  26. Requires: bogl = %{epoch}:%{version}-%{release}
  27. %description devel
  28. The bogl-devel package contains the static libraries and header files
  29. for writing BOGL applications.
  30. %package bterm
  31. Summary: A Unicode capable terminal program for the Linux frame buffer.
  32. Group: Applications/System
  33. Requires: bogl = %{epoch}:%{version}-%{release}
  34. %description bterm
  35. The bterm application is a terminal emulator that displays to a Linux
  36. frame buffer. It is able to display Unicode text on the console.
  37. %prep
  38. %setup -q -a 1
  39. %patch -p1 -b .rh
  40. %patch1 -p1 -b .fpic
  41. %patch3 -p1 -b .26fbdev
  42. %patch5 -p1 -b .noexecstack
  43. %build
  44. make CFLAGS="$RPM_OPT_FLAGS"
  45. gunzip -c %{SOURCE4} > font.bdf
  46. ./bdftobogl -b font.bdf > font.bgf
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. make DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir} install
  50. make -C wlite prefix=$RPM_BUILD_ROOT/%{_prefix} libdir=$RPM_BUILD_ROOT/%{_libdir} install
  51. if [ -f wlite/libwlitediet.a ]; then
  52. install -m 644 wlite/libwlitediet.a $RPM_BUILD_ROOT/%{_libdir}
  53. fi
  54. mkdir -p $RPM_BUILD_ROOT/usr/lib/bogl/
  55. cp font.bgf $RPM_BUILD_ROOT/usr/lib/bogl/
  56. cp font.bdf $RPM_BUILD_ROOT/usr/lib/bogl/
  57. gzip -9 $RPM_BUILD_ROOT/usr/lib/bogl/font.bgf
  58. gzip -9 $RPM_BUILD_ROOT/usr/lib/bogl/font.bdf
  59. %clean
  60. rm -rf $RPM_BUILD_ROOT
  61. %post -p /sbin/ldconfig
  62. %postun -p /sbin/ldconfig
  63. %files
  64. %defattr(-,root,root)
  65. %doc README
  66. %{_libdir}/*.so.*
  67. %files devel
  68. %defattr(-,root,root)
  69. %{_bindir}/bdftobogl
  70. %{_bindir}/mergebdf
  71. %{_bindir}/pngtobogl
  72. %{_bindir}/reduce-font
  73. %{_libdir}/*.a
  74. %{_libdir}/*.so
  75. %{_includedir}/bogl
  76. %{_includedir}/wlite*
  77. %files bterm
  78. %defattr(-,root,root)
  79. %doc README.BOGL-bterm
  80. %{_bindir}/bterm
  81. %dir %{_datadir}/terminfo/b
  82. %{_datadir}/terminfo/b/bterm
  83. /usr/lib/bogl
  84. %changelog
  85. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 0.1.18-10
  86. - rebuilt with rpm-4.8.1-3
  87. * Sat Apr 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.18-9
  88. - add font.bdf for anaconda
  89. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.18-8
  90. - update to 0.1.18-1.5
  91. - spec in utf-8, new versioning policy
  92. - remove unused ucs fonts
  93. - remove unneeded font.bdf
  94. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.18-7vl1
  95. - initial build for Vine Linux
  96. * Fri Mar 4 2005 Miloslav Trmac <mitr@redhat.com> - 0:0.1.18-7
  97. - Add missing includes in bogl-0.1.18-rh.patch
  98. - Rebuild with gcc 4
  99. * Thu Feb 17 2005 Miloslav Trmac <mitr@redhat.com> - 0:0.1.18-6
  100. - Don't require executable stack
  101. - Fix build with gcc 4
  102. - Use $RPM_OPT_FLAGS
  103. * Tue Nov 23 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.18-5
  104. - don't build against dietlibc anymore on x86
  105. * Wed Oct 20 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.18-4
  106. - rebuild again
  107. * Tue Oct 19 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.18-3
  108. - rebuild against newer diet with fixed signal handling
  109. * Mon Sep 6 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.18-2
  110. - fPIC on ppc too (#130719)
  111. * Mon Jul 05 2004 Akira TAGOH <tagoh@redhat.com> 0:0.1.18-1
  112. - New upstream release.
  113. #113910 has been fixed in this release.
  114. - bogl-0.1.18-rh.patch: updated to be able to apply it for this release.
  115. - bogl-0.1.9-vga16-others.patch: removed. no need this patch anymore.
  116. * Fri Jun 18 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.9-33
  117. - fix build with gcc 3.4
  118. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  119. - rebuilt
  120. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  121. - rebuilt
  122. * Wed Feb 18 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.9-31
  123. - fix build
  124. * Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.9-30
  125. - fix to work with changed 2.6 fbdev semantics
  126. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  127. - rebuilt
  128. * Mon Dec 15 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-28
  129. - add BuildRequires: gd-devel, libpng-devel (#111165)
  130. * Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 0:0.1.9-27
  131. - add hack to fix #92240
  132. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  133. - rebuilt
  134. * Fri May 30 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-25
  135. - rebuild
  136. * Fri May 30 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-24
  137. - enable vga16 support on ia64
  138. - removed workaround for AMD64, kernel should be fixed now
  139. * Tue May 06 2003 Phil Knirsch <pknirsch@redhat.com> 0:0.1.9-23
  140. - Bumped release and rebuilt due to new gd version.
  141. * Wed Apr 2 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-22
  142. - add a workaround for AMD64 that calls iopl(3) in order to gain io
  143. port access until ioperm() is fixed (#87835). Workaround for
  144. (#86321)
  145. - gzip font.bgf
  146. * Wed Mar 19 2003 Jeremy Katz <katzj@redhat.com> 0:0.1.9-21
  147. - include vga16fb support on x86_64 (#86321)
  148. * Thu Feb 13 2003 Adrian Havill <havill@redhat.com> 0:0.1.9-20
  149. - Change the font combo to add zh, change ja to k14 (#81717, #82888)
  150. * Tue Feb 11 2003 Jeremy Katz <katzj@redhat.com> 0:0.1.9-19
  151. - actually do the test correctly
  152. - buildrequire dietlibc on i386
  153. * Tue Feb 11 2003 Jeremy Katz <katzj@redhat.com> 0:0.1.9-18
  154. - only fPIC on needed arches, and do it everywhere
  155. * Mon Feb 10 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-17
  156. - always use wlite for bogl/bterm (for now) (#83980)
  157. (this makes bterm useless for any non-UTF-8 locale)
  158. - fixed 'bterm' for the normal usage case
  159. * Mon Feb 3 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-16
  160. - add back the Epoch: to support upgrading from betas
  161. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  162. - rebuilt
  163. * Mon Dec 30 2002 Jeremy Katz <katzj@redhat.com> 0.1.9-14
  164. - build wlite with -fPIC
  165. - fix deps of subpackages
  166. * Sun Dec 29 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  167. - delete "Epoch: 0" line in spec file
  168. * Mon Dec 16 2002 Adrian Havill <havill@redhat.com> 0.1.9-12
  169. - added bogl.bdf.gz to allow us to reduce-font in loader build
  170. * Mon Dec 16 2002 Adrian Havill <havill@redhat.com> 0.1.9-11
  171. - fixed broken reduce-font to test ENCODING x instead of STARTCHAR x
  172. * Mon Dec 16 2002 Matt Wilson <msw@redhat.com> 0.1.9-10
  173. - made more changes to the rh patch to enable bogl embedding insode loader
  174. * Tue Dec 10 2002 Matt Wilson <msw@redhat.com>
  175. - use all fb drivers on non-i386
  176. - package wlite for use in loader
  177. - use %%{_libdir} to get lib64 right
  178. * Mon Dec 10 2002 Adrian Havill <havill@redhat.com>
  179. - swapped out utf8 code with new and improved wlite
  180. * Tue Nov 26 2002 Adrian Havill <havill@redhat.com>
  181. - re-write font loader so it can load uncompressed or gzipped files
  182. - utf8 lib updated
  183. - fixed bug in bogl_term_new() so struct is inited (s/malloc/calloc/)
  184. - added term bell (screen flash)
  185. - changed background/foreground to pretty pretty blue/white
  186. * Thu Nov 21 2002 Adrian Havill <havill@redhat.com>
  187. - updated utf8 library
  188. - made bogl_term_out reset the state at every call so glibc
  189. and utf8.c behave consistently
  190. - concatenated two Red Hat diff patches
  191. * Wed Nov 20 2002 Adrian Havill <havill@redhat.com>
  192. - changed behavior of bogl_term_out to queue and save UTF broken between two
  193. buffers
  194. - utf8 lib improvements
  195. * Thu Nov 14 2002 root <msw@redhat.com>
  196. - integrate havill's utf8 for diet libs
  197. - build and install font
  198. * Tue Jul 23 2002 Matt Wilson <msw@redhat.com>
  199. - Initial build.