beecrypt-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define with_python --with-python
  3. %define with_python_version %(echo `python -c "import sys; print sys.version[:3]"`)
  4. #define with_java --with-java
  5. Summary: An open source cryptography library.
  6. Name: beecrypt
  7. Version: 4.1.2
  8. Release: 14%{?_dist_release}
  9. Group: System Environment/Libraries
  10. License: LGPL
  11. URL: http://sourceforge.net/projects/beecrypt
  12. Source0: http://prdownloads.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
  13. Source1: http://prdownloads.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz.sig
  14. Patch0: beecrypt-4.1.2-base64.patch
  15. Patch1: beecrypt-4.1.2-python-api.patch
  16. #BuildRequires: doxygen
  17. %if %{?with_python:1}0
  18. BuildRequires: python-devel >= %{with_python_version}
  19. %endif
  20. BuildRoot: %{_tmppath}/%{name}-root
  21. Obsoletes: beecrypt-java =< 4.1.2-2
  22. %description
  23. Beecrypt is a general-purpose cryptography library.
  24. %package devel
  25. Summary: Files needed for developing applications with beecrypt.
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. %description devel
  29. Beecrypt is a general-purpose cryptography library. This package contains
  30. files needed for developing applications with beecrypt.
  31. ## to build compat32 for x86_64 architecture support
  32. %package -n compat32-%{name}
  33. Summary: An open source cryptography library.
  34. Group: System Environment/Libraries
  35. #BuildPreReq: doxygen
  36. %description -n compat32-%{name}
  37. Beecrypt is a general-purpose cryptography library.
  38. %package -n compat32-%{name}-devel
  39. Summary: Files needed for developing applications with beecrypt.
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. %description -n compat32-%{name}-devel
  43. Beecrypt is a general-purpose cryptography library. This package contains
  44. files needed for developing applications with beecrypt.
  45. %if %{?with_python:1}0
  46. %package python
  47. Summary: Files needed for python applications using beecrypt.
  48. Group: Development/Libraries
  49. Requires: python >= %{with_python_version}
  50. Requires: %{name} = %{version}-%{release}
  51. %description python
  52. Beecrypt is a general-purpose cryptography library. This package contains
  53. files needed for using python with beecrypt.
  54. %endif
  55. %if %{?with_java:1}0
  56. %package java
  57. Summary: Files needed for java applications using beecrypt.
  58. Group: Development/Libraries
  59. Requires: %{name} = %{version}-%{release}
  60. %description java
  61. Beecrypt is a general-purpose cryptography library. This package contains
  62. files needed for using java with beecrypt.
  63. %endif
  64. %prep
  65. %setup -q
  66. %patch0 -p1 -b .base64
  67. %patch1 -p1 -b .python-api
  68. %build
  69. %configure --enable-shared --enable-static \
  70. %{?with_python}%{!?with_python:--with-python=no} \
  71. %{?with_java}%{!?with_java:--with-java=no} \
  72. --with-cplusplus=no
  73. make %{?_smp_mflags} \
  74. %{?with_python:pythondir="%{_libdir}/python%{with_python_version}/site-packages"}
  75. #doxygen
  76. %install
  77. rm -fr $RPM_BUILD_ROOT
  78. make install DESTDIR=$RPM_BUILD_ROOT \
  79. %{?with_python:pythondir="%{_libdir}/python%{with_python_version}/site-packages"}
  80. # XXX nuke unpackaged files, artifacts from using libtool to produce module
  81. rm -f ${RPM_BUILD_ROOT}%{_libdir}/python%{with_python_version}/site-packages/_bc.*a
  82. # XXX delete next line to build with legacy, non-check aware, rpmbuild.
  83. make check || :
  84. cat /proc/cpuinfo
  85. make bench || :
  86. ## remove unuse files
  87. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  88. %clean
  89. rm -fr $RPM_BUILD_ROOT
  90. %post -p /sbin/ldconfig
  91. %postun -p /sbin/ldconfig
  92. %post -n compat32-%{name} -p /sbin/ldconfig
  93. %postun -n compat32-%{name} -p /sbin/ldconfig
  94. %files
  95. %defattr(-,root,root)
  96. %doc README BENCHMARKS
  97. %{_libdir}/libbeecrypt.so.*
  98. %files devel
  99. %defattr(-,root,root)
  100. %doc BUGS
  101. %{_includedir}/%{name}
  102. %{_libdir}/libbeecrypt.a
  103. #%{_libdir}/libbeecrypt.la
  104. %{_libdir}/libbeecrypt.so
  105. %if %{?with_python:1}0
  106. %files python
  107. %defattr(-,root,root)
  108. %{_libdir}/python%{with_python_version}/site-packages/_bc.so
  109. %endif
  110. %if %{?with_java:1}0
  111. %files java
  112. %defattr(-,root,root)
  113. %{_libdir}/libbeecrypt_java.a
  114. #%{_libdir}/libbeecrypt_java.la
  115. %{_libdir}/libbeecrypt_java.so*
  116. %endif
  117. ## to build compat32 for x86_64 architecture support
  118. %if %{build_compat32}
  119. %files -n compat32-%{name}
  120. %defattr(-,root,root)
  121. %{_libdir}/libbeecrypt.so.*
  122. %files -n compat32-%{name}-devel
  123. %defattr(-,root,root)
  124. %{_libdir}/libbeecrypt.a
  125. #%{_libdir}/libbeecrypt.la
  126. %{_libdir}/libbeecrypt.so
  127. %endif
  128. %changelog
  129. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 4.1.2-14
  130. - rebuilt with rpm-4.8.1-3
  131. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.2-13
  132. - rebuilt with gcc-4.4.3-3 on ppc
  133. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.2-12
  134. - rebuilt with rpm-4.8.0-3 (on ppc)
  135. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 4.1.2-11
  136. - rebuild with python-2.6
  137. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.2-10vl5
  138. - applied new versioning policy
  139. - removed *.la
  140. * Sat Dec 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.2-9vl5
  141. - removed %%if !%%{build_compat32} case condition
  142. * Wed May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.2-9vl4
  143. - rebuilt with new toolchain
  144. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-9vl3
  145. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  146. * Mon Jan 30 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-9vl2
  147. - added compat32-* packages for x86_64 architecture support
  148. - dropt doxygen
  149. * Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1,2-9vl1
  150. - initial build for Vine Linux based on FC-devel
  151. * Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
  152. - Use -with-cplusplus=no. The libs still require libstdc++, so
  153. this needs further cleanup.
  154. * Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-8
  155. - Remove dependencies on private symbols not present in Python 2.4 from
  156. beecrypt-python
  157. * Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-7
  158. - Doh, actually apply the patch
  159. * Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-6
  160. - Fix b64encode() for data starting with NUL (#123650)
  161. * Fri Apr 01 2005 Warren Togami <wtogami@redhat.com> 4.1.2-5
  162. - remove huge API docs
  163. * Fri Apr 01 2005 Paul Nasrat <pnasrat@redhat.com> 4.1.2-4
  164. - Obsolete older beecrypt-java
  165. * Tue Mar 29 2005 Paul Nasrat <pnasrat@redhat.com> 4.1.2-3
  166. - Disable beecrypt-java (#151294)
  167. * Fri Mar 4 2005 Jeff Johnson <jbj@redhat.com> 4.1.2-2
  168. - rebuild with gcc4.
  169. * Sat Feb 5 2005 Jeff Johnson <jbj@jbj.org> 4.1.2-1
  170. - upgrade to 4.1.2
  171. - put java components in sub-package.
  172. - check that /usr/lib64 is not used on alpha (#146583).
  173. * Fri Feb 4 2005 Miloslav Trmac <mitr@redhat.com> - 3.1.0-7
  174. - Rebuild against Python 2.4
  175. * Sun Aug 08 2004 Alan Cox <alan@redhat.com> 3.1.0-6
  176. - Build requires libtool (Steve Grubb)
  177. * Fri Jul 02 2004 Elliot Lee <sopwith@redhat.com> 3.1.0-5
  178. - rebuilt
  179. - Add _smp_mflags
  180. * Wed Mar 24 2004 Jeff Johnson <jbj@redhat.com> 3.1.0-3
  181. - fix: extgcd_w problem fixed by upgrading from CVS.
  182. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  183. - rebuilt
  184. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  185. - rebuilt
  186. * Mon Dec 22 2003 Jeff Johnson <jbj@jbj.org> 3.1.0-1
  187. - upgrade to 3.1.0.
  188. - recompile against python-2.3.3.
  189. * Mon Jun 30 2003 Jeff Johnson <jbj@redhat.com> 3.0.1-0.20030630
  190. - upstream fixes for DSA and ppc64.
  191. * Mon Jun 23 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-2
  192. - upgrade to 3.0.0 final.
  193. - fix for DSA (actually, modulo inverse) sometimes failing.
  194. * Fri Jun 20 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030619
  195. - avoid asm borkage on ppc64.
  196. * Thu Jun 19 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030618
  197. - rebuild for release bump.
  198. * Tue Jun 17 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030616
  199. - try to out smart libtool a different way.
  200. - use $bc_target_cpu, not $bc_target_arch, to detect /usr/lib64.
  201. * Mon Jun 16 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030615
  202. - use -mcpu=powerpc64 on ppc64.
  203. * Fri Jun 13 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030613
  204. - upgrade to latest snapshot.
  205. * Fri Jun 6 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030605
  206. - rebuild into another tree.
  207. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  208. - rebuilt
  209. * Tue Jun 3 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030603
  210. - update to 3.0.0 snapshot, fix mpmod (and DSA) on 64b platforms.
  211. * Mon Jun 2 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030602
  212. - update to 3.0.0 snapshot, merge patches, fix gcd rshift and ppc problems.
  213. * Thu May 29 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030529
  214. - update to 3.0.0 snapshot, fix ia64/x86_64 build problems.
  215. * Wed May 28 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030528
  216. - upgrade to 3.0.0 snapshot, adding rpm specific base64.[ch] changes.
  217. - add PYTHONPATH=.. so that "make check" can test the just built _bc.so module.
  218. - grab cpuinfo and run "make bench".
  219. - continue ignoring "make check" failures, LD_LIBRARY_PATH needed for _bc.so.
  220. - skip asm build failure on ia64 for now.
  221. - ignore "make bench" exit codes too, x86_64 has AES segfault.
  222. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030521
  223. - upgrade to 3.0.0 snapshot, including python subpackage.
  224. - ignore "make check" failure for now.
  225. * Fri May 16 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030516
  226. - upgrade to 3.0.0 snapshot, including ia64 and x86_64 fixes.
  227. - add %%check.
  228. - ignore "make check" failure on ia64 for now.
  229. * Mon May 12 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030512
  230. - upgrade to 3.0.0 snapshot.
  231. - add doxygen doco.
  232. - use /dev/urandom as default entropy source.
  233. - avoid known broken compilation for now.
  234. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  235. - rebuilt
  236. * Tue Nov 19 2002 Tim Powers <timp@redhat.com>
  237. - rebuild on all arches
  238. * Fri Aug 2 2002 Jeff Johnson <jbj@redhat.com> 2.2.0-6
  239. - install types.h (#68999).
  240. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  241. - automated rebuild
  242. * Wed Jun 5 2002 Jeff Johnson <jbj@redhat.com>
  243. - run ldconfig when installing/erasing (#65974).
  244. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  245. - automated rebuild
  246. * Mon May 13 2002 Jeff Johnson <jbj@redhat.com>
  247. - upgrade to latest 2.2.0 (from cvs.rpm.org).
  248. * Mon Jan 21 2002 Jeff Johnson <jbj@redhat.com>
  249. - use the same beecrypt-2.2.0 that rpm is using internally.
  250. * Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 2.1.0-1
  251. - initial package