mplayer-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560
  1. %global with_faac 1
  2. %global with_vaapi 1
  3. %global with_libvpx 1
  4. #% global with_ffmpeg 1
  5. %global ffmpegver 2.8.5
  6. #% global svndate 20120525
  7. %define codecdir %{_libdir}/codecs
  8. %global ttfontdir %{_datadir}/fonts
  9. %global ttfontlist TrueType-vlgothic/VL-PGothic-Regular \\\
  10. TrueType-sazanami-gothic/sazanami-gothic
  11. Summary: The Movie Player
  12. Summary(ja): 動画プレイヤー
  13. Name: mplayer
  14. Version: 1.2
  15. Release: 1%{?svndate:.%svndate}%{?_dist_release}
  16. Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
  17. #Source0: mplayer-export-%{svndate}.tar.xz
  18. Source1: http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
  19. Source10: mplayer-snapshot-vine.sh
  20. Source11: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.11.tar.bz2
  21. Source12: http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.8.tar.bz2
  22. Source13: http://www.mplayerhq.hu/MPlayer/skins/standard-1.11.tar.bz2
  23. Source14: http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
  24. # set defaults for Vine Linux
  25. Patch2: %{name}-1.1.1-config-vine.patch
  26. # use roff include statements instead of symlinks
  27. Patch8: %{name}-1.1.1-manlinks.patch
  28. # NOTE: need not this patch against v1.2
  29. # # erase any trace of libdvdcss
  30. # Patch14: %{name}-1.1.1-nodvdcss.patch
  31. # use system FFmpeg libraries
  32. Patch18: %{name}-1.1.1-ffmpeg.patch
  33. ## Vine
  34. %if 0%{!?_without_amr:1}
  35. License: GPLv3+
  36. %else
  37. License: GPLv2+
  38. %endif
  39. Group: Applications/Multimedia
  40. URL: http://www.mplayerhq.hu/
  41. BuildRequires: SDL-devel
  42. BuildRequires: aalib-devel
  43. BuildRequires: alsa-lib-devel
  44. BuildRequires: cdparanoia-devel
  45. BuildRequires: desktop-file-utils
  46. ##!!BuildRequires: em8300-devel
  47. BuildRequires: libdvdnav-devel
  48. BuildRequires: enca-devel
  49. BuildRequires: fontconfig-devel
  50. BuildRequires: freetype2-devel >= 2.0.9
  51. BuildRequires: fribidi-devel
  52. BuildRequires: giflib-devel
  53. BuildRequires: gtk2-devel
  54. BuildRequires: mesa-libGL-devel
  55. BuildRequires: libXinerama-devel
  56. BuildRequires: libXScrnSaver-devel
  57. BuildRequires: libXv-devel
  58. BuildRequires: libXvMC-devel
  59. BuildRequires: libXxf86dga-devel
  60. BuildRequires: libXxf86vm-devel
  61. BuildRequires: libass-devel
  62. BuildRequires: libpng-devel
  63. BuildRequires: libjpeg-devel
  64. BuildRequires: libdvdread
  65. BuildRequires: libmpcdec-devel >= 1.2.1
  66. BuildRequires: librtmp-devel >= 2.3
  67. BuildRequires: speex-devel >= 1.1
  68. %{?with_vaapi:BuildRequires:libva-devel}
  69. BuildRequires: libvdpau-devel
  70. BuildRequires: libvorbis-devel
  71. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.6}
  72. BuildRequires: lzo-devel >= 2
  73. BuildRequires: pulseaudio-lib-devel
  74. BuildRequires: speex-devel >= 1.1
  75. BuildRequires: twolame-devel
  76. BuildRequires: xorg-x11-devel
  77. BuildRequires: yasm
  78. BuildRequires: zlib-devel
  79. # *-devel packages provided by other self-build-* should only be listed
  80. # in self-build-%{name}.spec as PreReq.
  81. ##Requires: self-build-mplayer-codecs
  82. ##BuildRequires: self-build-libdvdcss
  83. ##BuildRequires: self-build-lame
  84. ##BuildRequires: self-build-libdca
  85. ##BuildRequires: self-build-x264 >= 0.129
  86. ##BuildRequires: self-build-xvidcore >= 0.9.2
  87. ##BuildRequires: self-build-faad2 >= 2.6.1
  88. ##BuildRequires: self-build-libmpeg2
  89. Requires: TrueType-vlgothic
  90. Requires: mesa-libGL
  91. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  92. Obsoletes: mplayer < %{version}-%{release}
  93. %description
  94. MPlayer can play most standard video formats out of the box and almost
  95. all others with the help of external codecs.
  96. MPlayer currently works best from the command line, but visual feedback
  97. for many functions is available from its onscreen status display (OSD),
  98. which is also used for displaying subtitles.
  99. MPlayer also has a GUI with skin support and several unofficial alternative
  100. graphical frontends are available.
  101. MEncoder is a command line video encoder for advanced users that can
  102. be built from the MPlayer source tree. Unofficial graphical frontends
  103. exist but arenot included.
  104. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  105. support for some newer codecs are not yet inpmlemented.
  106. You should install mplayer-codecs package if you want to play videos
  107. using those new codecs.
  108. %description -l ja
  109. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  110. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  111. で再生できます。
  112. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、
  113. 多くの操作は字幕と同様に、
  114. オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
  115. MPlayer には スキンを変更できる GUI も用意されていますし、
  116. また複数の非公式なフロントエンドも利用できます。
  117. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  118. 非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
  119. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  120. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  121. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  122. をインストールする必要があります。
  123. %prep
  124. #% setup -q -n mplayer-export-%{svndate}
  125. %setup -q -n MPlayer-%{version}
  126. %__rm -rf ffmpeg && %__tar xf %{SOURCE1} && mv ffmpeg-%{ffmpegver} ffmpeg || exit 1
  127. %patch2 -p1 -b .vine
  128. %patch8 -p1 -b .manlinks
  129. #%patch14 -p1 -b .nodvdcss
  130. %{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
  131. %build
  132. ./configure \
  133. --prefix=%{_prefix} \
  134. --bindir=%{_bindir} \
  135. --datadir=%{_datadir}/mplayer \
  136. --mandir=%{_mandir} \
  137. --confdir=%{_sysconfdir}/mplayer \
  138. --libdir=%{_libdir} \
  139. --codecsdir=%{codecdir} \
  140. \
  141. --extra-cflags="$RPM_OPT_FLAGS" \
  142. --language=ja,en \
  143. --enable-joystick \
  144. --enable-gui --enable-menu \
  145. --enable-radio --enable-radio-capture \
  146. --enable-runtime-cpudetection \
  147. --enable-unrarexec \
  148. \
  149. --disable-nemesi \
  150. \
  151. %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
  152. %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
  153. %{!?with_faac:--disable-faac} \
  154. --disable-libmpeg2-internal \
  155. --disable-libopenjpeg \
  156. \
  157. --disable-bitmap-font \
  158. --disable-dga1 --disable-dga2 \
  159. --disable-directfb \
  160. --disable-svga \
  161. --disable-termcap \
  162. --enable-xvmc \
  163. --with-xvmclib=XvMCW \
  164. \
  165. --disable-arts --disable-esd --disable-jack --disable-openal \
  166. --disable-live \
  167. ;
  168. %{__make} V=1 %{?_smp_mflags}
  169. %install
  170. %{__rm} -rf ${RPM_BUILD_ROOT}
  171. %{__make} install INSTALLSTRIP= \
  172. prefix=${RPM_BUILD_ROOT}%{_prefix} \
  173. BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
  174. DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
  175. CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
  176. LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
  177. MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
  178. ;
  179. ## install some default config files
  180. %{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  181. %{__install} -pm 644 etc/example.conf \
  182. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
  183. %{__install} -pm 644 etc/{input,menu,codecs}.conf \
  184. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  185. # # Icons
  186. # for iconsize in 16x16 22x22 24x24 32x32 48x48 256x256; do
  187. # install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps
  188. # install -pm 644 etc/mplayer$iconsize.png \
  189. # $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps/mplayer.png
  190. # done
  191. # install skins and set the default skin
  192. %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  193. pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  194. for x in %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14}; do
  195. %__tar xf ${x} || exit 1
  196. done
  197. %__ln_s Blue default || exit 1
  198. popd
  199. # make sybolic link to ttf font for subtitle
  200. for i in %{ttfontlist}; do
  201. if [ -e %{ttfontdir}/$i.ttf ];then
  202. %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  203. break;
  204. fi;
  205. done
  206. ## install TOOLS
  207. for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
  208. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
  209. done
  210. for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
  211. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
  212. done
  213. for file in vobshift.py ; do
  214. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
  215. done
  216. %__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
  217. %__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
  218. %clean
  219. %{__rm} -rf ${RPM_BUILD_ROOT}
  220. %post
  221. touch --no-create %{_datadir}/icons/hicolor
  222. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  223. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  224. fi
  225. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
  226. %postun
  227. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications
  228. touch --no-create %{_datadir}/icons/hicolor
  229. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  230. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  231. fi || :
  232. %files
  233. %defattr(-,root,root)
  234. #%doc AUTHORS Changelog Copyright LICENSE README
  235. %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
  236. %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
  237. %config(noreplace) %{_sysconfdir}/mplayer/input.conf
  238. %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
  239. %{_bindir}/mplayer
  240. %{_bindir}/gmplayer
  241. %{_bindir}/mencoder
  242. %{_datadir}/mplayer/skins/default
  243. %{_datadir}/mplayer/skins/Blue
  244. %{_datadir}/mplayer/skins/Blue-small
  245. %{_datadir}/mplayer/skins/OSX-Mod
  246. %{_datadir}/mplayer/skins/standard
  247. %{_datadir}/mplayer/subfont.ttf
  248. %{_datadir}/applications/mplayer.desktop
  249. %{_datadir}/icons/hicolor/*/apps/mplayer.png
  250. %{_mandir}/man1/mplayer.1*
  251. %{_mandir}/man1/mencoder.1*
  252. ## TOOLS
  253. %{_bindir}/aconvert
  254. %{_bindir}/calcbpp
  255. %{_bindir}/countquant
  256. %{_bindir}/divx2svcd
  257. %{_bindir}/dvd2divxscript
  258. %{_bindir}/mencvcd
  259. %{_bindir}/midentify
  260. %{_bindir}/mpconsole
  261. %{_bindir}/qepdvcd
  262. %{_bindir}/subsearch
  263. %{_bindir}/vobshift
  264. %{_datadir}/mplayer/*.fp
  265. %changelog
  266. * Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
  267. - new upstream release
  268. * Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-4
  269. - rebuilt
  270. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-3
  271. - rebuilt with ffmpeg-0.11.5
  272. * Mon Oct 7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
  273. - remove some obsolete comments
  274. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
  275. - updated to 1.1.1
  276. - build with new x264 (ABI 0.136) and ffmpeg 0.11.4 (libav 0.8.2 as of 2012-09-19)
  277. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-2
  278. - rebuilt with new x264 (ABI 0.129) and ffmpeg 0.11.2 (libav 0.8.2)
  279. * Wed Jun 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-1
  280. - updated to 1.1
  281. - built with ffmpeg-0.11.1
  282. - added some skins
  283. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
  284. - updated snapshot 20120525 with ffmpeg 0.11
  285. * Tue Jan 3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-46.20120102
  286. - updated snapshot 20120102
  287. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111210
  288. - updated snapshot 20111217 (with ffmpeg 0.9)
  289. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
  290. - s/self-build-libdvdnav/libdvdnav/
  291. * Fri Oct 7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
  292. - updated %%SOURCE1
  293. - update to 1.8
  294. * Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
  295. - dropped BuildRequires: esound-devel
  296. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
  297. - new upstream release
  298. - ready for Vine Linux 6
  299. - revived support for Vine Linux 5
  300. - added BuildRequires:
  301. - libass-devel
  302. - librtmp-devel >= 2.3
  303. - speex-devel >= 1.1
  304. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
  305. - added BuildRequires:
  306. - aalib-devel
  307. - enca-devel
  308. - lzo-devel
  309. - speex-devel
  310. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  311. - updated fixed %{name}-config.patch
  312. - applied %{name}-config-20100709-vine.patch
  313. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  314. - change release to sync with self-build-mplayer
  315. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  316. - updated source snapshot 20100709
  317. - renamed %%Source10 to mplayer-snapshot-vine.sh
  318. - applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  319. - added BuildRequires: libvpx-devel >= 0.9.1
  320. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  321. - updated source snapshot 20100621
  322. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
  323. - updated source snapshot 20100615
  324. - added BuildRequires: libXinerama-devel
  325. - dropped vl4 support
  326. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
  327. - updated source snapshot 20100410
  328. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  329. - updated source snapshot 20100401
  330. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
  331. - updated source snapshot 20100326
  332. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  333. - updated source snapshot 20100317
  334. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  335. - updated source snapshot 20100216
  336. - moved scripts from TOOLS
  337. - added --disable-libopenjpeg in configure options
  338. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
  339. - updated source snapshot 20100201
  340. - dropped obsolete patches
  341. - added BuildRequires:
  342. - libvdpau-devel
  343. - libXScrnSaver-devel
  344. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  345. - update mplayer-config-20091215-vine.patch
  346. - update mplayer-20091215-x86_32-compile.patch
  347. - added --enable-runtime-cpudetection in configure options
  348. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  349. - source snapshot 20091031
  350. - updated mplayer-20091031-x86_32-compile.patch
  351. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  352. - source snapshot 20091003
  353. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  354. - change release to sync with self-build-mplayer
  355. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  356. - source snapshot 20090905
  357. - added settings for vl6
  358. * Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  359. - source snapshot 20090821
  360. - replaced BR: libungif-devel with BR: giflib-devel
  361. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  362. - source snapshot 20090722
  363. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  364. - source snapshot 20090702
  365. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  366. - source snapshot 20090611
  367. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  368. - added Requires: TrueType-vlgothic
  369. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  370. - source snapshot 20090522
  371. - build with x264 >= 0.0.0-9.20090522
  372. - updated mplayer-20090522-nodvdcss.patch
  373. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  374. - change release to sync with self-build-mplayer
  375. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  376. - source snapshot 20090502
  377. - updated mplayer-20090503-x86_32-compile.patch
  378. - updated mplayer-20090502-nodvdcss.patch
  379. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  380. - applied mplayer-config-vine.patch
  381. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  382. - source snapshot 20090327
  383. - updated mplayer-20090327-x86_32-compile.patch
  384. - updated mplayer-20090325-nodvdcss.patch
  385. - dropped gmplayer-about-vine.patch
  386. - install some default config files
  387. - added configure options:
  388. - --disable-termcap
  389. - --enable-xvmc
  390. - --with-xvmclib=XvMCW
  391. - archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
  392. - fixed %%files for *.conf
  393. * Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
  394. - source snapshot 20090305
  395. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
  396. - source snapshot 20090227
  397. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
  398. - source snapshot 20090216
  399. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  400. - source snapshot 20090206
  401. - dropped mplayer-man-zh_CN.patch
  402. - updated mplayer-20090206-nodvdcss.patch
  403. - changed to PreReq: self-build-faad2 from faad2-devel
  404. - added PreReq: self-build-libmad
  405. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  406. - source snapshot 20090131
  407. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  408. - change release to sync with self-build-mplayer
  409. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  410. - source snapshot
  411. - update mplayer-20090122-nodvdcss.patch
  412. - added BuildRequires:
  413. - faad2-devel
  414. - libmpcdec-devel
  415. - twolame-devel
  416. - yasm
  417. - faac-devel (as PreReq in self-build-%{name})
  418. - lame-devel (as PreReq in self-build-%{name})
  419. - libdca-devel (as PreReq in self-build-%{name})
  420. - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
  421. - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
  422. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  423. - source snapshot
  424. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  425. --disable-faad-internal in configure options
  426. - dropped gmplayer-add-flv-extension.patch
  427. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  428. - source snapshot
  429. - fixed License
  430. - added some patches from RPM Fusion
  431. - updated gmplayer-about-vine.patch for 20081001 snapshot
  432. - added BuildRequires: libdvdread
  433. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  434. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  435. in configure options
  436. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  437. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  438. - fixed License
  439. - added some devel packages to support OpenGL
  440. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  441. - spec in utf8
  442. - fix sybolic link of subfont for vl5
  443. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  444. - add "Patch105: CVE-2008-1558.patch".
  445. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  446. - build with new versioning policy.
  447. - fix Source[01] URLs.
  448. - add "Patch200: gmplayer-about-vine.patch".
  449. - add "Patch201: gmplayer-add-flv-extension.patch".
  450. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  451. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  452. CVE-2008-0629, CVE-2008-0630)
  453. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  454. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  455. - change source download URL. <BTS:VineLinux:603>
  456. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  457. - fix CONFDIR for make install. <BTS:wishes:33>
  458. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  459. - initial build for Vine Linux