123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131 |
- Summary: C library for multiple precision complex arithmetic
- Name: libmpc
- Version: 1.0.2
- Release: 1%{?_dist_release}
- License: LGPLv3+
- Group: System Environment/Libraries
- URL: http://www.multiprecision.org/
- Source0: mpc-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- BuildRequires: gmp-devel >= 4.3.2
- BuildRequires: mpfr-devel >= 2.4.2
- BuildRequires: grep
- BuildRequires: texinfo
- %description
- MPC is a C library for the arithmetic of complex numbers with
- arbitrarily high precision and correct rounding of the result. It is
- built upon and follows the same principles as Mpfr.
- %package devel
- Summary: Header and shared development libraries for MPC
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: gmp-devel
- Requires: mpfr-devel
- Requires(post): /sbin/install-info
- Requires(preun): /sbin/install-info
- %description devel
- Header files and shared object symlinks for MPC is a C library.
- %prep
- %setup -q -n mpc-%{version}
- %build
- export CPPFLAGS="%{optflags} -std=gnu99"
- export CFLAGS="%{optflags} -std=gnu99"
- export EGREP=egrep
- %configure --disable-static
- make %{?_smp_mflags}
- %check
- make check
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- rm -f $RPM_BUILD_ROOT/%{_libdir}/libmpc.{l,}a
- rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %post devel
- if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
- /sbin/install-info %{_infodir}/mpc.info.gz %{_infodir}/dir || :
- fi
- %preun devel
- if [ $1 = 0 ]; then
- if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
- /sbin/install-info --delete %{_infodir}/mpc.info.gz %{_infodir}/dir || :
- fi
- fi
- %files
- %defattr(-,root,root,-)
- %doc README NEWS COPYING.LESSER
- %{_libdir}/libmpc.so.*
- %files devel
- %defattr(-,root,root,-)
- %{_libdir}/libmpc.so
- %{_includedir}/mpc.h
- %{_infodir}/*.info*
- %changelog
- * Fri Sep 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
- - updated to 1.0.2
- - change Group to System Environment/Libraries (libmpc)
- * Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
- - update to 1.0.1
- * Tue Nov 01 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 0.9-2
- - initial build for Vine Linux
- * Wed Jun 22 2011 <pmachata@redhat.com> - 0.9-1
- - Upstream 0.9
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-0.3.svn855
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Tue Nov 30 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.2.svn855
- - Bump for rebuild against the new mpfr
- * Fri Nov 19 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.1.svn855
- - Devel updates (to-be-0.8.3, SVN release 855)
- - New functions mpc_set_dc, mpc_set_ldc, mpc_get_dc, mpc_get_ldc
- - Speed-up mpc_pow_si and mpc_pow_z
- - Bug fixes in trigonometric functions, exp, sqrt
- - Upstream 0.8.2
- - Speed-up mpc_pow_ui
- - Adjust BuildRequires
- - Resolves: #653931
- * Wed Jan 20 2010 Petr Machata <pmachata@redhat.com> - 0.8.1-1
- - Upstream 0.8.1
- - acosh, asinh, atanh: swap of precisions between real and imaginary parts
- - atan: memory leak
- - log: wrong ternary value in data file; masked by bug in Mpfr 2.4.1
- - Resolves: #555471 FTBFS libmpc-0.8-3.fc13
- * Fri Nov 13 2009 Petr Machata <pmachata@redhat.com> - 0.8-3
- - Require mpfr-devel, gmp-devel in -devel subpackage
- - Don't pass --entry to install-info
- * Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-2
- - Rename the package to libmpc, it's a better choice of name
- - %%preun should uninstall mpc's info page, not make's
- - Move info page to -devel
- - BR on -devel packages
- - Drop postscript documentation
- * Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-1
- - Initial package.
|