automake-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. %define api_version 1.11
  2. Summary: A GNU tool for automatically creating Makefiles.
  3. Summary(ja): Makefile を自動生成するための GNU ツール
  4. Name: automake
  5. Version: %{api_version}.1
  6. Release: 2%{?_dist_release}
  7. License: GPL
  8. Group: Development/Tools
  9. Source: ftp://ftp.gnu.org/gnu/automake/automake-%{version}.tar.bz2
  10. URL: http://sources.redhat.com/automake
  11. Requires: perl, autoconf >= 2.58
  12. Buildrequires: autoconf >= 2.58
  13. Prereq: install-info
  14. BuildArchitectures: noarch
  15. Buildroot: %{_tmppath}/%{name}-%{version}-root
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: daisuke
  19. # run "make check" by default
  20. %{?_without_check: %define _without_check 1}
  21. %{!?_without_check: %define _without_check 0}
  22. %description
  23. Automake is an experimental Makefile generator. Automake was inspired
  24. by the 4.4BSD make and include files, but aims to be portable and to
  25. conform to the GNU standards for Makefile variables and targets.
  26. You should install Automake if you are developing software and would
  27. like to use its ability to automatically generate GNU standard
  28. Makefiles. If you install Automake, you will also need to install
  29. GNU's Autoconf package.
  30. %prep
  31. %setup -q -n automake-%{version}
  32. %build
  33. ./configure --prefix=%{_prefix}
  34. %{__make} %{?_smp_mflags}
  35. %if ! %{_without_check}
  36. %{__make} check
  37. %endif
  38. %install
  39. rm -rf ${RPM_BUILD_ROOT}
  40. %makeinstall
  41. # create this dir empty so we can own it
  42. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/aclocal
  43. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  44. %clean
  45. rm -rf ${RPM_BUILD_ROOT}
  46. %post
  47. /sbin/install-info %{_infodir}/automake.info.gz %{_infodir}/dir
  48. %preun
  49. if [ $1 = 0 ]; then
  50. /sbin/install-info --delete %{_infodir}/automake.info.gz %{_infodir}/dir
  51. fi
  52. %files
  53. %defattr(-,root,root)
  54. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
  55. %{_bindir}/*
  56. %{_infodir}/*.info*
  57. %{_datadir}/automake-%{api_version}
  58. %{_datadir}/aclocal-%{api_version}
  59. %dir %{_datadir}/aclocal
  60. %changelog
  61. * Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-2
  62. - rebuild for Vine 6
  63. * Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-1
  64. - new upstream release
  65. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.10.1-2
  66. - spec in utf-8
  67. * Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-1
  68. - new upstream release
  69. * Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.6-0vl1
  70. - new upstream release
  71. * Thu Jun 3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.5-0vl1
  72. - new upstream release
  73. * Wed May 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-0vl1
  74. - new upstream release
  75. * Thu Apr 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
  76. - new upstream release
  77. * Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 1.8.2-0vl3
  78. - rebuild
  79. * Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8.2-1vl2
  80. - rebuild
  81. * Thu Feb 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.2-0vl1
  82. - new upstream release
  83. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8-1vl1
  84. - based on 1.8-1 from Rawhide and built for Vine Linux
  85. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.9-0vl1
  86. - new upstream release
  87. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-0vl1
  88. - new upstream release
  89. * Mon Jun 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.5-1vl1
  90. - based on 1.7.5-1 from Rawhide and built for Vine Linux
  91. * Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.3-1vl1
  92. - based on 1.7.3-1 from Rawhide and built for Vine Linux
  93. * Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-1vl2
  94. - based on 1.6.3-1 from Rawhide and built for Vine Linux
  95. * Mon Jul 29 2002 Jens Petersen <petersen@redhat.com> 1.6.3-1
  96. - bug fix release 1.6.3
  97. * Thu Jul 11 2002 Jens Petersen <petersen@redhat.com> 1.6.2-2
  98. - add buildrequires autoconf 2.52 or greater (reported by Edward Avis)
  99. * Wed Jun 19 2002 Jens Petersen <petersen@redhat.com> 1.6.2-1
  100. - 1.6.2 (bug fix release)
  101. - do "make check" after building
  102. * Thu May 23 2002 Tim Powers <timp@redhat.com> 1.6.1-2
  103. - automated rebuild
  104. * Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 1.6.1-1
  105. - 1.6.1
  106. * Tue Mar 12 2002 Jens Petersen <petersen@redhat.com> 1.6-1
  107. - new package based on automake15
  108. - 1.6
  109. * Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-8
  110. - better aclocal versioning
  111. * Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-7
  112. - don't version datadir/automake
  113. * Tue Jan 15 2002 Jens Petersen <petersen@redhat.com> 1.5-6
  114. - version suffix programs and data directories
  115. - own symlinks to programs and /usr/share/aclocal
  116. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.5-5
  117. - automated rebuild
  118. * Wed Jan 9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-4
  119. - Completely back out the fix for #56624 for now, it causes more problems
  120. than it fixes in either form.
  121. * Wed Jan 9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-3
  122. - Don't use AS_DIRNAME, it doesn't work.
  123. * Tue Jan 7 2002 Jens Petersen <petersen@redhat.com> 1.5-2
  124. - Patch depout.m4 to handle makefiles passed to make with "-f" (#56624)
  125. * Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-1
  126. - Update to 1.5 - much better to coexist with autoconf 2.52...
  127. - Fix specfile
  128. - No patches
  129. * Fri Aug 24 2001 Jens Petersen <petersen@redhat.com> - 1.4p5-2
  130. - dont raise error when there is source in a subdirectory (bug #35156).
  131. This was preventing automake from working in binutuls/gas
  132. [patch from HJ Lu <hjl@gnu.org>]
  133. - format long lines of output properly with backslash + newlines as in 1.4
  134. (bug #35259) [patch from HJ Lu <hjl@gnu.org>]
  135. * Sat Jul 21 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  136. - 1.4-p5, fixes #48788
  137. * Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  138. - add the patch from #20559
  139. - really update to 1.4-p4
  140. * Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  141. - update to 1.4-p4
  142. * Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
  143. - Version 1.4-p1 to work with libtool-1.4
  144. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  145. - automatic rebuild
  146. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  147. - FHS packaging.
  148. * Fri Feb 04 2000 Nalin Dahyabhai <nalin@redhat.com>
  149. - fix bug #8870
  150. * Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
  151. - revert to pristine automake-1.4.
  152. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  153. - arm netwinder patch
  154. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  155. - Injected new description and group.
  156. * Mon Feb 8 1999 Jeff Johnson <jbj@redhat.com>
  157. - add patches from CVS for 6.0beta1
  158. * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
  159. - update to 1.4.
  160. * Mon Nov 23 1998 Jeff Johnson <jbj@redhat.com>
  161. - update to 1.3b.
  162. - add URL.
  163. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  164. - translations modified for de, fr, tr
  165. * Tue Apr 07 1998 Erik Troan <ewt@redhat.com>
  166. - updated to 1.3
  167. * Tue Oct 28 1997 Cristian Gafton <gafton@redhat.com>
  168. - added BuildRoot; added aclocal files
  169. * Fri Oct 24 1997 Erik Troan <ewt@redhat.com>
  170. - made it a noarch package
  171. * Thu Oct 16 1997 Michael Fulbright <msf@redhat.com>
  172. - Fixed some tag lines to conform to 5.0 guidelines.
  173. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  174. - updated to 1.2
  175. * Wed Mar 5 1997 msf@redhat.com <Michael Fulbright>
  176. - first version (1.0)