expat-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name expat
  3. %define version 2.2.10
  4. %define release 1%{?_dist_release}
  5. Summary: Expat is an XML 1.0 parser written in C
  6. Summary(ja): C で書かれた XML 1.0 パーサ
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. License: MIT/X
  11. Group: accessories
  12. URL: http://www.libexpat.org/
  13. Source: http://download.sourceforge.net/expat/%{name}-%{version}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. Requires: lib%{name} = %{version}-%{release}
  16. BuildRequires: libtool
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. This is Expat, a C library for parsing XML, written by James Clark.
  21. Expat is a stream-oriented XML parser. This means that you register
  22. handlers with the parser before starting the parse. These handlers
  23. are called when the parser discovers the associated structures in the
  24. document being parsed. A start tag is an example of the kind of
  25. structures for which you may register handlers.
  26. %package -n lib%{name}
  27. Summary: Runtime library of expat
  28. Summary(ja): Expat のための実行ライブラリ
  29. Group: system
  30. %description -n lib%{name}
  31. This package contains the runtime, shared library of expat, the C
  32. library for parsing XML.
  33. %description -n lib%{name} -l ja
  34. Expat を動作させるために必用となるライブラリです.
  35. %package devel
  36. Summary: Development environment for the expat XML parser
  37. Summary(ja): expat XML パーサ用開発環境
  38. Group: programming
  39. Requires: lib%{name} = %{version}-%{release}
  40. Requires: pkgconfig
  41. %description devel
  42. Development environment for the expat XML parser
  43. %description devel -l ja
  44. expat XML パーサ用開発環境です.
  45. ## to build compat32 for x86_64 architecture support
  46. %package -n compat32-lib%{name}
  47. Summary: Runtime library of expat
  48. Summary(ja): Expat のための実行ライブラリ
  49. Group: system
  50. Requires: lib%{name} = %{version}-%{release}
  51. %description -n compat32-lib%{name}
  52. This package contains the runtime, shared library of expat, the C
  53. library for parsing XML.
  54. %description -n compat32-lib%{name} -l ja
  55. Expat を動作させるために必用となるライブラリです.
  56. %package -n compat32-%{name}-devel
  57. Summary: Development environment for the expat XML parser
  58. Summary(ja): expat XML パーサ用開発環境
  59. Group: programming
  60. Requires: %{name}-devel = %{version}-%{release}
  61. Requires: compat32-lib%{name} = %{version}-%{release}
  62. %description -n compat32-%{name}-devel
  63. Development environment for the expat XML parser
  64. %description -n compat32-%{name}-devel -l ja
  65. expat XML パーサ用開発環境です.
  66. %debug_package
  67. %prep
  68. %setup -q
  69. %build
  70. export CFLAGS="$RPM_OPT_FLAGS -fPIC"
  71. %configure --enable-shared
  72. make %{?_smp_mflags}
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. rm -f examples/*.dsp
  76. chmod 644 AUTHORS README.md COPYING Changes doc/* examples/*
  77. make DESTDIR=$RPM_BUILD_ROOT install
  78. rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
  79. rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/expat
  80. mkdir -p %{buildroot}%{_mandir}/man1
  81. install -m644 doc/xmlwf.1 %{buildroot}%{_mandir}/man1/
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %post -n lib%{name} -p /sbin/ldconfig
  85. %postun -n lib%{name} -p /sbin/ldconfig
  86. %post -n compat32-lib%{name} -p /sbin/ldconfig
  87. %postun -n compat32-lib%{name} -p /sbin/ldconfig
  88. %files
  89. %defattr(-,root,root)
  90. %license COPYING
  91. %doc AUTHORS Changes README.md
  92. %{_bindir}/xmlwf
  93. %{_mandir}/man1/xmlwf.1*
  94. %files -n lib%{name}
  95. %defattr(-,root,root)
  96. %license COPYING
  97. %doc AUTHORS Changes README.md
  98. %{_libdir}/libexpat.so.*
  99. %files devel
  100. %defattr(-,root,root)
  101. %license COPYING
  102. %doc AUTHORS Changes README.md
  103. %doc doc/* examples
  104. %{_includedir}/*
  105. %{_libdir}/libexpat.a
  106. %{_libdir}/libexpat.so
  107. %{_libdir}/pkgconfig/%{name}.pc
  108. ## to build compat32 for x86_64 architecture support
  109. %if %{build_compat32}
  110. %files -n compat32-lib%{name}
  111. %defattr(-,root,root)
  112. %{_libdir}/libexpat.so.*
  113. %files -n compat32-%{name}-devel
  114. %defattr(-,root,root)
  115. %{_libdir}/libexpat.a
  116. %{_libdir}/libexpat.so
  117. %endif
  118. %changelog
  119. * Wed Feb 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.10-1
  120. - new upstream release.
  121. * Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
  122. - new upstream release.
  123. * Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-1
  124. - new upstream release.
  125. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
  126. - new upstream release.
  127. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
  128. - new upstream release.
  129. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-2
  130. - rebuild with VineSeed environment
  131. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
  132. - update to 2.1.0
  133. - remove old patches
  134. * Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
  135. - update patch100 to regrassion fix (same as debian bug #561658)
  136. - add Vendor and Distribution tags
  137. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
  138. - rebuilt with rpm-4.8.1-3
  139. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
  140. - rebuilt with gcc-4.4.3-3 on ppc
  141. * Mon Feb 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
  142. - rebuilt with new toolchains (for VineSeed)
  143. * Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
  144. - add patch110 for fix CVE-2009-3720 (xml parser)
  145. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
  146. - add Patch100 for fix CVE-2009-3560 (xml parser)
  147. * Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
  148. - added Requires: tag to compat32-* sub-packages.
  149. - removed unnecessary %%configure CC='gcc -m32' option
  150. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
  151. - applied new versioning policy and spec in utf-8
  152. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
  153. - removed %%if !%%{build_compat32} case condition
  154. * Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
  155. - new upstream release
  156. - drop Patch0
  157. - drop .la
  158. - chmod 644 the documentation
  159. - strip DSP files from examples
  160. - update description and drop description-ja
  161. - add -fPIC
  162. * Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
  163. - rebuilt
  164. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
  165. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  166. * Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
  167. - added compat32* packages for x86_64 architecture support
  168. * Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
  169. - add missing header file (expat_external.h) to %%files.
  170. * Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
  171. - updated/revised Patch1 (%%install will fail without this patch)
  172. * Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
  173. - new upstream release
  174. -- dropped patch1
  175. * Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
  176. - updated to 1.95.7
  177. - changed URL and Group
  178. - fixed License to MIT/X (based on rpm package at sourceforge)
  179. * Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
  180. - version up to 1.95.6
  181. - drop expat-xmlwf-dynamiclink.patch (Patch0)
  182. - add expat-1.95.6-mandir.patch for installing manpage (Patch0)
  183. - add manpage (xmlwf.1)
  184. * Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
  185. - fixed license ( s/MPL or GPL/distributable/ )
  186. - use License tag
  187. * Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
  188. - new sub-package libexpat.
  189. - added BuildPreReq: libtool
  190. * Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
  191. - updated to 1.95.2 release
  192. * Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  193. - 1.95.1-3vl1
  194. - based on 1.95.1-3mdk from Mandrake 8.0
  195. - added Japanese summary and description
  196. - modified spec macros for Vine
  197. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
  198. - real version is 1.95.1
  199. - reenable optimisations
  200. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
  201. - release .
  202. * Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
  203. - Don't try to use optimizations
  204. - Bzip2 sources
  205. * Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
  206. - first version