R-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515
  1. %define pkg_version 3.2.2
  2. %define pkg_release 2%{?_dist_release}
  3. Summary: A language for data analysis and graphics
  4. Summary(ja): データ解析・グラフィック化の言語
  5. Name: R
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: GPLv
  9. Group: Applications/Edutainment
  10. URL: http://www.r-project.org
  11. Source0: ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
  12. Source1: R.desktop
  13. # Patch0: R-release.diff.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gcc-c++
  16. BuildRequires: gcc-gfortran libgfortran
  17. BuildRequires: texinfo
  18. %if %{?_dist_release} == "vl6"
  19. BuildRequires: tcl tk
  20. %endif
  21. %if %{?_dist_release} == "vl7"
  22. BuildRequires: tcl-devel tk-devel
  23. %endif
  24. BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
  25. BuildRequires: readline-devel ncurses-devel
  26. BuildRequires: zlib-devel bzip2-devel
  27. BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
  28. BuildRequires: cairo-devel pango-devel
  29. BuildRequires: libicu-devel
  30. BuildRequires: texlive-common
  31. BuildRequires: texlive-collection-basic
  32. BuildRequires: texlive-collection-latexextra
  33. BuildRequires: texlive-collection-fontsextra
  34. %if %{?_dist_release} == "vl6"
  35. BuildRequires: texlive-collection-texinfo
  36. BuildRequires: java-1.6.0-openjdk-devel
  37. %endif
  38. %if %{?_dist_release} == "vl7"
  39. BuildRequires: texlive-collection-plainextra
  40. BuildRequires: texlive-collection-fontsrecommended
  41. BuildRequires: java-1.7.0-openjdk-devel
  42. %endif
  43. Requires: libgfortran
  44. Requires: libicu
  45. Requires: tcl tk
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. Packager: Toshiaki Ara <ara_t@384.jp>
  49. %description
  50. 'GNU S' - A language and environment for statistical computing and
  51. graphics. R is similar to the award-winning S system, which was
  52. developed at Bell Laboratories by John Chambers et al. It provides
  53. a wide variety of statistical and graphical techniques (linear and
  54. nonlinear modelling, statistical tests, time series analysis,
  55. classification, clustering, ...).
  56. R is designed as a true computer language with control-flow
  57. constructions for iteration and alternation, and it allows users to
  58. add additional functionality by defining new functions.
  59. For computationally intensive tasks, C, C++ and Fortran code
  60. can be linked and called at run time.
  61. %description -l ja
  62. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  63. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  64. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  65. 幅広い統計解析・視覚化手法を提供する。
  66. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  67. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  68. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  69. 使用することができる。
  70. %package devel
  71. Summary: files for development of R packages.
  72. Summary(ja): Rパッケージ開発用ファイル
  73. Group: Development/Libraries
  74. Requires: R = %{version}-%{release}
  75. %description devel
  76. Install R-devel if you are going to develop or compile R packages.
  77. This is just a stub package containing the documentation on
  78. "Writing R Extensions". However, installing it will ensure that
  79. the build environment for R packages is correct.
  80. %description -l ja devel
  81. Rパッケージを開発したりコンパイルする場合には、このR-develを
  82. インストールします。R-exts.pdf ("Writing R Extensions": 英文)
  83. が含まれているだけのサブパッケージですが、正しくRパッケージを
  84. 開発するための助けになるでしょう。
  85. %package -n libRmath
  86. Summary: standalone math library from the R project
  87. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  88. Group: System Environment/Libraries
  89. %description -n libRmath
  90. A standalone library of mathematical and statistical functions derived
  91. from the R project. This packages provides the shared libRmath library.
  92. %description -l ja -n libRmath
  93. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  94. 共有ライブラリを提供する。
  95. %package -n libRmath-devel
  96. Summary: standalone math library from the R project
  97. Summary(ja): libRmathの開発ライブラリ
  98. Group: Development/Libraries
  99. Requires: libRmath = %{version}-%{release}
  100. %description -n libRmath-devel
  101. A standalone library of mathematical and statistical functions derived
  102. from the R project. This packages provides the header files.
  103. %description -l ja -n libRmath-devel
  104. libRmathのヘッダファイル(Rmath.h)
  105. %package -n libRmath-static
  106. Summary: Static R Standalone math library
  107. Summary(ja): libRmath の静的ライブラリ
  108. Group: Development/Libraries
  109. Requires: libRmath-devel = %{version}-%{release}
  110. %description -n libRmath-static
  111. A standalone library of mathematical and statistical functions derived
  112. from the R project. This package provides the static libRmath library.
  113. %prep
  114. %{__rm} -rf ${RPM_BUILD_ROOT}
  115. %setup -q
  116. # %patch0 -p1
  117. %build
  118. export R_PDFVIEWER="%{_bindir}/xdg-open"
  119. export R_PRINTCMD="lpr"
  120. export R_BROWSER="%{_bindir}/xdg-open"
  121. %configure --enable-R-shlib --with-tcltk
  122. %{__make} %{?_smp_mflags}
  123. (cd src/nmath/standalone; %{__make} %{?_smp_mflags})
  124. LANG=C %{__make} check
  125. %{__make} pdf
  126. # We can only "make info" if we have an up to date version of texinfo
  127. %{?INFO: %{__make} info}
  128. %install
  129. %{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
  130. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  131. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  132. #Install libRmath files
  133. (cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
  134. mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  135. echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  136. #Fix lication of R_HOME_DIR in shell wrapper
  137. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  138. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  139. chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  140. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  141. > ${RPM_BUILD_ROOT}%{_bindir}/R
  142. chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  143. # add R into menu
  144. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
  145. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/icons
  146. cp -a %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/
  147. cp -a doc/html/logosm.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
  148. %clean
  149. %{__rm} -rf ${RPM_BUILD_ROOT}
  150. %post
  151. %if 0%{?INFO}
  152. # Create directory entries for info files
  153. # (optional doc files, so we must check that they are installed)
  154. for doc in admin data exts FAQ intro lang; do
  155. file=%{_infodir}/R-${doc}.info.gz
  156. if [ -e $file ]; then
  157. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  158. fi
  159. done
  160. %endif
  161. %{_syssbindir}/ldconfig
  162. %preun
  163. %if 0%{?INFO}
  164. if [ $1 = 0 ]; then
  165. # Delete directory entries for info files (if they were installed)
  166. for doc in admin data exts FAQ intro lang; do
  167. file=%{_infodir}/R-${doc}.info.gz
  168. if [ -e ${file} ]; then
  169. /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
  170. fi
  171. done
  172. fi
  173. %endif
  174. %postun -p %{_syssbindir}/ldconfig
  175. %post -n libRmath -p %{_syssbindir}/ldconfig
  176. %postun -n libRmath -p %{_syssbindir}/ldconfig
  177. %files
  178. %defattr(-, root, root)
  179. %{_bindir}/R
  180. %{_bindir}/Rscript
  181. %{_libdir}/R
  182. %{_datadir}/applications/*
  183. %{_datadir}/icons/*
  184. %{?INFO:%{_infodir}/R-*.info*}
  185. %{_mandir}/man1/*
  186. /etc/ld.so.conf.d/*
  187. %files devel
  188. %defattr(-, root, root)
  189. %doc doc/manual/R-exts.pdf
  190. %files -n libRmath
  191. %defattr(-, root, root)
  192. %{_libdir}/libRmath.so
  193. %files -n libRmath-devel
  194. %defattr(-, root, root)
  195. %{_libdir}/pkgconfig/*.pc
  196. %{_includedir}/Rmath.h
  197. %files -n libRmath-static
  198. %defattr(-, root, root)
  199. %{_libdir}/libRmath.a
  200. %changelog
  201. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
  202. - rebuild with icu-56.1
  203. * Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
  204. - Updated to 3.2.2
  205. * Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
  206. - add configure options: --with-tcltk
  207. - add BuildRequires: tcl-devel tk-devel
  208. - add Requires: tcl tk
  209. * Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
  210. - Updated to 3.2.1
  211. * Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
  212. - add "LIBS=-lbz2" to configure option
  213. * Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
  214. - Updated to 3.2.0
  215. * Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
  216. - Updated to 3.1.3
  217. - added BuildRequires: texlive-collection-fontsextra for Vine6
  218. - changed option "make check-all" to "make check"
  219. - to avoid error in checking of mgcv package
  220. - changed orders of BuildRequires
  221. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
  222. - rebuild with icu-54.1
  223. * Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
  224. - Updated to 3.1.2
  225. * Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
  226. - Updated to 3.1.1
  227. - add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
  228. * Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
  229. - add patch (2014-04-26)
  230. * Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
  231. - Updated to 3.1.0
  232. * Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
  233. - Updated to 3.0.3
  234. * Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
  235. - rebuild current VineSeed
  236. - add patch (2014-01-06)
  237. * Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
  238. - add Requires: libicu
  239. * Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
  240. - combine spec files Vine6 and VineSeed
  241. - correct the days of the week in changelog
  242. * Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  243. - delete BuildRequires: texlive-collection-texinfo
  244. - add BuildRequires: texlive-collection-plainextra
  245. - add BuildRequires: texlive-collection-latexextra
  246. - add BuildRequires: texlive-collection-fontsrecommended
  247. - for VineSeed
  248. * Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  249. - Updated to 3.0.2
  250. * Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
  251. - Updated to 3.0.1
  252. - add BuildRequires: java-1.6.0-openjdk-devel
  253. * Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
  254. - Updated to 3.0.0
  255. * Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
  256. - Updated to 2.15.3
  257. - use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
  258. - use BuildRequires ncurses-devel instead of libtermcap-devel
  259. * Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
  260. - Updated to 2.15.2
  261. * Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
  262. - changed group to Applications/Edutainment
  263. - added R to menu
  264. * Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
  265. - Updated to 2.15.1
  266. * Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
  267. - Updated to 2.15.0
  268. * Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
  269. - Updated to 2.14.2
  270. * Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
  271. - Updated to 2.14.1
  272. * Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
  273. - Updated to 2.14.0
  274. - add BuildRequires: texlive-collection-fontsextra
  275. * Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
  276. - Updated to 2.13.2
  277. - add BuildRequires: texlive-common
  278. - use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
  279. - removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
  280. * Sat Sep 3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
  281. - synchronized to VinePlus/5 package
  282. * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
  283. - Updated to 2.13.1
  284. * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
  285. - Updated to 2.13.0
  286. * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
  287. - Updated to 2.12.2
  288. * Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
  289. - add BuildRequires: libicu-devel
  290. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
  291. - synchronized to VinePlus/5 package
  292. * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
  293. - Updated to 2.12.1
  294. - added --enable-R-shlib option to %%configure
  295. - added static subpackage
  296. - use BR: texlive instead of tetex on VineSeed
  297. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  298. - rebuilt with rpm-4.8.1 for pkg-config
  299. * Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  300. - recompiled because tcl/tk were not linked
  301. * Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  302. - Updated to 2.11.0
  303. - added Requires: libgfortran
  304. * Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  305. - Updated to 2.10.1
  306. * Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  307. - patched to 2.10.0
  308. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  309. - spec in UTF-8
  310. * Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  311. - Updated to 2.10.0
  312. * Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  313. - Updated to 2.9.2
  314. - deleted BuildRequires: lapack-devel blas-devel
  315. - rewrote SPEC file
  316. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  317. - Updated to 2.5.1
  318. - added BuildRequires: gcc-gfortran for VineSeed
  319. - added BuildRequires: lapack-devel blas-devel
  320. v- fixed %preun script
  321. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  322. - Updated to 2.4.1
  323. - Added INFO option
  324. - Exclude Japanese Rprofile.site
  325. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  326. - Updated to 2.4.0
  327. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  328. - Added optimization flags
  329. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  330. - Packaged for VineLinux3.2
  331. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  332. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  333. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  334. - Packaged for VineLinux3.2
  335. - Slipped texinfo
  336. - Fixed preun error
  337. - Preset Japanese fonts
  338. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  339. - Packaged for VineLinux3.2
  340. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  341. - Restored CAPABILITIES file lost in 2.2.1beta
  342. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  343. - Configure uses --without-blas by default.
  344. - Install pdf manuals.
  345. - All toplevel documentation files are installed into _libdir/R
  346. as they may be required by R (qv note on AUTHORS and THANKS below).
  347. - Legacy scripts for rebuilding package indices removed.
  348. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  349. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  350. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  351. - The files AUTHORS and THANKS need to be installed into _libdir/R
  352. as they are required by the function contributors(). Previously
  353. they were installed only as documentation files.
  354. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  355. - Corrected date error in SPEC file.
  356. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  357. - Dropped support for Red Hat boxed set.
  358. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  359. including support for shared R library.
  360. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  361. with the default optimization flags, so there is a temporary work-around.
  362. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  363. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  364. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  365. - Install R-data.info file as well.
  366. - Make info processing conditional on texinfo version, not platform release,
  367. so that if a new enough version is installed, we will build and install info.
  368. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  369. - Built R 2.1.0. R now supports internationalization, so the patch
  370. to set the locale to "C" is now dropped.
  371. - install.packages() exits gracefully with a helpful message if
  372. the file INSTALL is not present, so this is now included in the
  373. R-devel package.
  374. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  375. - Added support for Scientific Linux (http://www.scientificlinux.org)
  376. A distribution based on RHEL. Thanks to Jon Peatfield.
  377. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  378. - Fixed file ownership in R-devel and libRmath packages
  379. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  380. - R-devel package is now a stub package with no files, except a documentation
  381. file (RPM won't accept sub-packages with no files). R now conflicts
  382. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  383. - Created libRmath subpackage with shared library.
  384. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  385. - Created R-devel and libRmath-devel subpackages
  386. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  387. - Built R 2.0.1
  388. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  389. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  390. gives "lpr".
  391. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  392. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  393. - Info support is now conditional on the macro Rinfo, which is only
  394. defined for Fedora 1 and 2.
  395. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  396. - Built R 2.0.0
  397. - There is no longer a BUGS file, so this is not installed as a
  398. documentation file.