MySQL-vl.spec 32 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850
  1. %define mysqld_user mysql
  2. %define mysqld_group mysql
  3. %define server_suffix -community
  4. %define mysqldatadir /var/lib/mysql
  5. %{?_with_static:%define STATIC_BUILD 1}
  6. %{!?_with_static:%define STATIC_BUILD 0}
  7. # Working around perl dependency problem
  8. %define __perl_requires %{SOURCE998}
  9. # We don't package all files installed into the build root by intention -
  10. # See BUG#998 for details.
  11. %define _unpackaged_files_terminate_build 0
  12. %define see_base For a description of MySQL see the base MySQL RPM or http://www.mysql.com
  13. %define mysql_version 5.5.15
  14. %define client_version 18
  15. %if %{?_dist_release}!="vl5"
  16. %define libpkgname libmysqlclient%{client_version}
  17. %else
  18. %define libpkgname MySQL-shared
  19. %endif
  20. Packager: tomop
  21. Name: MySQL
  22. Summary: MySQL: a very fast and reliable SQL database server
  23. Version: %{mysql_version}
  24. Release: 1%{_dist_release}
  25. Group: Applications/Databases
  26. # exceptions allow client libraries to be linked with most open source SW,
  27. # not only GPL code.
  28. License: GPLv2 with exceptions
  29. URL: http://www.mysql.com/
  30. Source: mysql-%{version}.tar.gz
  31. # Don't depend on lib::mtr*
  32. Source998: perl-requires-%{name}.sh
  33. Patch0: mysql-5.5.15-jp-all.patch
  34. # lib64 patch for vine
  35. Patch200: pysql-5.1.44-lib64.patch
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  37. BuildRequires: perl, readline-devel, libaio-devel
  38. BuildRequires: gcc-c++, ncurses-devel, zlib-devel, openssl-devel
  39. BuildRequires: groff, cmake, bison
  40. Requires: fileutils sh-utils
  41. Provides: msqlormysql MySQL-server mysql
  42. Obsoletes: mysql MySQL5
  43. # From the manual
  44. %description
  45. The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
  46. and robust SQL (Structured Query Language) database server. MySQL Server
  47. is intended for mission-critical, heavy-load production systems as well
  48. as for embedding into mass-deployed software. MySQL is a trademark of
  49. Sun Microsystems, Inc.
  50. Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc. All rights reserved.
  51. Use is subject to license terms.
  52. This software comes with ABSOLUTELY NO WARRANTY. This is free software,
  53. and you are welcome to modify and redistribute it under the GPL license.
  54. The MySQL web site (http://www.mysql.com/) provides the latest
  55. news and information about the MySQL software. Also please see the
  56. documentation and the manual for more information.
  57. %package server
  58. Release: %{release}
  59. Summary: MySQL: a very fast and reliable SQL database server
  60. Group: Applications/Databases
  61. Requires: fileutils sh-utils net-tools
  62. Provides: msqlormysql mysql-server mysql MySQL MySQL5-server
  63. Obsoletes: MySQL mysql mysql-server MySQL5-server MySQL-Max
  64. %description server
  65. The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
  66. and robust SQL (Structured Query Language) database server. MySQL Server
  67. is intended for mission-critical, heavy-load production systems as well
  68. as for embedding into mass-deployed software. MySQL is a trademark of
  69. Sun Microsystems, Inc.
  70. Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc. All rights reserved.
  71. Use is subject to license terms.
  72. This software comes with ABSOLUTELY NO WARRANTY. This is free software,
  73. and you are welcome to modify and redistribute it under the GPL license.
  74. The MySQL web site (http://www.mysql.com/) provides the latest
  75. news and information about the MySQL software. Also please see the
  76. documentation and the manual for more information.
  77. This package includes the MySQL server binary (incl. InnoDB) as well
  78. as related utilities to run and administrate a MySQL server.
  79. If you want to access and work with the database, you have to install
  80. package "MySQL-client" as well!
  81. %package client
  82. Summary: MySQL - Client
  83. Group: Applications/Databases
  84. Obsoletes: mysql-client MySQL5-client
  85. Provides: mysql-client MySQL5-client
  86. %description client
  87. This package contains the standard MySQL clients and administration tools.
  88. %{see_base}
  89. %package test
  90. Requires: %{name}-client = %{version}-%{release} perl-DBI perl
  91. Summary: MySQL - Test suite
  92. Group: Applications/Databases
  93. Obsoletes: mysql-bench MySQL5-bench MySQL-bench
  94. %description test
  95. This package contains the MySQL regression test suite.
  96. %{see_base}
  97. %package devel
  98. Summary: MySQL - Development header files and libraries
  99. Group: Development/Libraries
  100. Requires: %{libpkgname} = %{version}-%{release}
  101. Requires: openssl-devel, zlib-devel
  102. Provides: mysql-devel MySQL5-devel
  103. Obsoletes: mysql-devel MySQL5-devel
  104. %description devel
  105. This package contains the development header files and libraries
  106. necessary to develop MySQL client applications.
  107. %{see_base}
  108. %package -n %{libpkgname}
  109. Summary: The shared libraries required for MySQL clients
  110. Group: System Environment/Libraries
  111. %if %{?_dist_release}!="vl5"
  112. Obsoletes: MySQL-shared < %{version}
  113. %endif
  114. %description -n %{libpkgname}
  115. This package contains the shared libraries (*.so*) which certain
  116. languages and applications need to dynamically load and use MySQL.
  117. #%package embedded
  118. #Summary: MySQL as an embeddable library
  119. #Group: System Environment/Libraries
  120. #Obsoletes: mysql-embedded MySQL5-embedded
  121. #Provides: mysql-embedded MySQL5-embedded
  122. #%description embedded
  123. #MySQL is a multi-user, multi-threaded SQL database server. This
  124. #package contains a version of the MySQL server that can be embedded
  125. #into a client application instead of running as a separate process.
  126. #%{see_base}
  127. %package embedded-devel
  128. Summary: Development files for MySQL as an embeddable library
  129. Group: Development/Libraries
  130. Requires: %{name}-devel = %{version}-%{release}
  131. %description embedded-devel
  132. MySQL is a multi-user, multi-threaded SQL database server. This
  133. package contains files needed for developing and testing with
  134. the embedded version of the MySQL server.
  135. %{see_base}
  136. %prep
  137. %setup -q -n mysql-%{version}
  138. %patch0 -p1 -b .jp
  139. #%if %{_lib} == lib64
  140. #%patch200 -p0 -b .lib64
  141. #%endif
  142. #aclocal
  143. #autoheader
  144. #libtoolize --automake --force
  145. #automake --add-missing --copy
  146. #autoconf
  147. #perl -pi -e 's/-Werror"/"/' configure
  148. %build
  149. # Be strict about variables, bail at earliest opportunity, etc.
  150. set -eu
  151. # Optional package files
  152. touch optional-files-devel
  153. export PATH=${MYSQL_BUILD_PATH:-$PATH}
  154. export CC=${MYSQL_BUILD_CC:-${CC:-gcc}}
  155. export CXX=${MYSQL_BUILD_CXX:-${CXX:-gcc}}
  156. export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
  157. export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
  158. export LDFLAGS=${MYSQL_BUILD_LDFLAGS:-${LDFLAGS:-}}
  159. export CMAKE=${MYSQL_BUILD_CMAKE:-${CMAKE:-cmake}}
  160. export MAKE_JFLAG=${MYSQL_BUILD_MAKE_JFLAG:-}
  161. # Build full release
  162. mkdir release
  163. (
  164. cd release
  165. # XXX: MYSQL_UNIX_ADDR should be in cmake/* but mysql_version is included before
  166. # XXX: install_layout so we can't just set it based on INSTALL_LAYOUT=RPM
  167. ${CMAKE} ../ -DBUILD_CONFIG=mysql_release -DINSTALL_LAYOUT=RPM \
  168. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  169. -DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
  170. -DFEATURE_SET="community" \
  171. -DCOMPILATION_COMMENT="VineLinux MySQL RPM" \
  172. -DMYSQL_SERVER_SUFFIX="%{server_suffix}" \
  173. -DWITH_PIC="ON" \
  174. -DWITH_ZLIB="system" \
  175. -DWITH_EMBEDDED_SERVER="ON" \
  176. -DWITH_SSL="yes"
  177. echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
  178. make %{?_smp_mflags} VERBOSE=1
  179. )
  180. # Use the build root for temporary storage of the shared libraries.
  181. RBR=$RPM_BUILD_ROOT
  182. # Clean up the BuildRoot first
  183. [ "$RBR" != "/" ] && [ -d "$RBR" ] && rm -rf "$RBR";
  184. # For gcc builds, include libgcc.a in the devel subpackage (BUG 4921). This
  185. # needs to be during build phase as $CC is not set during install.
  186. if "$CC" -v 2>&1 | grep '^gcc.version' >/dev/null 2>&1
  187. then
  188. libgcc=`$CC $CFLAGS --print-libgcc-file`
  189. if [ -f $libgcc ]
  190. then
  191. mkdir -p $RBR%{_libdir}/mysql
  192. # install -m 644 $libgcc $RBR%{_libdir}/mysql/libmygcc.a
  193. # echo "%{_libdir}/mysql/libmygcc.a" >>optional-files-devel
  194. fi
  195. fi
  196. ##############################################################################
  197. %install
  198. RBR=$RPM_BUILD_ROOT
  199. MBD=$RPM_BUILD_DIR/mysql-%{mysql_version}
  200. rm -rf $RBR
  201. # Ensure that needed directories exists
  202. install -d $RBR%{_sysconfdir}/{logrotate.d,init.d}
  203. install -d $RBR%{mysqldatadir}/mysql
  204. install -d $RBR%{_datadir}/mysql-test
  205. install -d $RBR%{_includedir}
  206. install -d $RBR%{_libdir}
  207. install -d $RBR%{_mandir}
  208. install -d $RBR%{_sbindir}
  209. # Install all binaries
  210. # Install all binaries
  211. (
  212. cd $MBD/release
  213. make DESTDIR=$RBR install
  214. )
  215. # Install logrotate and autostart
  216. install -m 644 $MBD/release/support-files/mysql-log-rotate $RBR%{_sysconfdir}/logrotate.d/mysql
  217. install -m 755 $MBD/release/support-files/mysql.server $RBR%{_sysconfdir}/init.d/mysql
  218. # Create a symlink "rcmysql", pointing to the init.script. SuSE users
  219. # will appreciate that, as all services usually offer this.
  220. ln -s %{_sysconfdir}/init.d/mysql $RBR%{_sbindir}/rcmysql
  221. # Touch the place where the my.cnf config file might be located
  222. # Just to make sure it's in the file list and marked as a config file
  223. touch $RBR%{_sysconfdir}/my.cnf
  224. # Remove man pages we explicitly do not want to package, avoids 'unpackaged
  225. # files' warning.
  226. rm -f $RBR%{_mandir}/man1/make_win_bin_dist.1*
  227. ##############################################################################
  228. %pre server
  229. # Shut down a previously installed server first
  230. if test -x %{_sysconfdir}/init.d/mysql
  231. then
  232. %{_sysconfdir}/init.d/mysql stop > /dev/null 2>&1
  233. echo "Giving mysqld a couple of seconds to exit nicely"
  234. sleep 5
  235. elif test -x %{_sysconfdir}/rc.d/init.d/mysql
  236. then
  237. %{_sysconfdir}/rc.d/init.d/mysql stop > /dev/null 2>&1
  238. echo "Giving mysqld a couple of seconds to exit nicely"
  239. sleep 5
  240. fi
  241. %post server
  242. mysql_datadir=%{mysqldatadir}
  243. # Create data directory if needed
  244. if test ! -d $mysql_datadir; then mkdir -m 755 $mysql_datadir; fi
  245. if test ! -d $mysql_datadir/mysql; then mkdir $mysql_datadir/mysql; fi
  246. if test ! -d $mysql_datadir/test; then mkdir $mysql_datadir/test; fi
  247. # Make MySQL start/shutdown automatically when the machine does it.
  248. # use insserv for older SuSE Linux versions
  249. if test -x /sbin/insserv
  250. then
  251. /sbin/insserv %{_sysconfdir}/init.d/mysql
  252. # use chkconfig on Red Hat and newer SuSE releases
  253. elif test -x /sbin/chkconfig
  254. then
  255. /sbin/chkconfig --add mysql
  256. fi
  257. # Create a MySQL user and group. Do not report any problems if it already
  258. # exists.
  259. groupadd -r %{mysqld_group} 2> /dev/null || true
  260. useradd -M -r -d $mysql_datadir -s /bin/bash -c "MySQL server" -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
  261. # The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
  262. usermod -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
  263. # Change permissions so that the user that will run the MySQL daemon
  264. # owns all database files.
  265. chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
  266. # Initiate databases if needed
  267. %{_bindir}/mysql_install_db --rpm --user=%{mysqld_user}
  268. # Upgrade databases if needed would go here - but it cannot be automated yet
  269. # Change permissions again to fix any new files.
  270. chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
  271. # Fix permissions for the permission database so that only the user
  272. # can read them.
  273. chmod -R og-rw $mysql_datadir/mysql
  274. # Restart in the same way that mysqld will be started normally.
  275. %{_sysconfdir}/init.d/mysql start
  276. # Allow mysqld_safe to start mysqld and print a message before we exit
  277. sleep 2
  278. #echo "Thank you for installing the MySQL Community Server! For Production
  279. #systems, we recommend MySQL Enterprise, which contains enterprise-ready
  280. #software, intelligent advisory services, and full production support with
  281. #scheduled service packs and more. Visit www.mysql.com/enterprise for more
  282. #information."
  283. %preun server
  284. if test $1 = 0
  285. then
  286. # Stop MySQL before uninstalling it
  287. if test -x %{_sysconfdir}/init.d/mysql
  288. then
  289. %{_sysconfdir}/init.d/mysql stop > /dev/null
  290. # Remove autostart of mysql
  291. # for older SuSE Linux versions
  292. if test -x /sbin/insserv
  293. then
  294. /sbin/insserv -r %{_sysconfdir}/init.d/mysql
  295. # use chkconfig on Red Hat and newer SuSE releases
  296. elif test -x /sbin/chkconfig
  297. then
  298. /sbin/chkconfig --del mysql
  299. fi
  300. fi
  301. fi
  302. # We do not remove the mysql user since it may still own a lot of
  303. # database files.
  304. %post -n %{libpkgname}
  305. /sbin/ldconfig
  306. %postun -n %{libpkgname}
  307. /sbin/ldconfig
  308. # Clean up the BuildRoot
  309. %clean
  310. [ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
  311. %files server
  312. %defattr(-,root,root,0755)
  313. %doc COPYING README
  314. %doc Docs/ChangeLog
  315. %doc Docs/INFO_SRC*
  316. %doc release/Docs/INFO_BIN*
  317. %doc release/support-files/my-*.cnf
  318. %doc %attr(644, root, root) %{_infodir}/mysql.info*
  319. %doc %attr(644, root, man) %{_mandir}/man1/innochecksum.1*
  320. %doc %attr(644, root, man) %{_mandir}/man1/my_print_defaults.1*
  321. %doc %attr(644, root, man) %{_mandir}/man1/myisam_ftdump.1*
  322. %doc %attr(644, root, man) %{_mandir}/man1/myisamchk.1*
  323. %doc %attr(644, root, man) %{_mandir}/man1/myisamlog.1*
  324. %doc %attr(644, root, man) %{_mandir}/man1/myisampack.1*
  325. %doc %attr(644, root, man) %{_mandir}/man1/mysql_convert_table_format.1*
  326. %doc %attr(644, root, man) %{_mandir}/man1/mysql_fix_extensions.1*
  327. %doc %attr(644, root, man) %{_mandir}/man8/mysqld.8*
  328. %doc %attr(644, root, man) %{_mandir}/man1/mysqld_multi.1*
  329. %doc %attr(644, root, man) %{_mandir}/man1/mysqld_safe.1*
  330. %doc %attr(644, root, man) %{_mandir}/man1/mysqldumpslow.1*
  331. %doc %attr(644, root, man) %{_mandir}/man1/mysql_install_db.1*
  332. %doc %attr(644, root, man) %{_mandir}/man1/mysql_secure_installation.1*
  333. %doc %attr(644, root, man) %{_mandir}/man1/mysql_setpermission.1*
  334. %doc %attr(644, root, man) %{_mandir}/man1/mysql_upgrade.1*
  335. %doc %attr(644, root, man) %{_mandir}/man1/mysqlhotcopy.1*
  336. %doc %attr(644, root, man) %{_mandir}/man1/mysqlman.1*
  337. %doc %attr(644, root, man) %{_mandir}/man1/mysql.server.1*
  338. %doc %attr(644, root, man) %{_mandir}/man1/mysqltest.1*
  339. %doc %attr(644, root, man) %{_mandir}/man1/mysql_tzinfo_to_sql.1*
  340. %doc %attr(644, root, man) %{_mandir}/man1/mysql_zap.1*
  341. %doc %attr(644, root, man) %{_mandir}/man1/mysqlbug.1*
  342. %doc %attr(644, root, man) %{_mandir}/man1/perror.1*
  343. %doc %attr(644, root, man) %{_mandir}/man1/replace.1*
  344. %doc %attr(644, root, man) %{_mandir}/man1/resolve_stack_dump.1*
  345. %doc %attr(644, root, man) %{_mandir}/man1/resolveip.1*
  346. %ghost %config(noreplace,missingok) %{_sysconfdir}/my.cnf
  347. %attr(755, root, root) %{_bindir}/innochecksum
  348. %attr(755, root, root) %{_bindir}/my_print_defaults
  349. %attr(755, root, root) %{_bindir}/myisam_ftdump
  350. %attr(755, root, root) %{_bindir}/myisamchk
  351. %attr(755, root, root) %{_bindir}/myisamlog
  352. %attr(755, root, root) %{_bindir}/myisampack
  353. %attr(755, root, root) %{_bindir}/mysql_convert_table_format
  354. %attr(755, root, root) %{_bindir}/mysql_fix_extensions
  355. %attr(755, root, root) %{_bindir}/mysql_install_db
  356. %attr(755, root, root) %{_bindir}/mysql_secure_installation
  357. %attr(755, root, root) %{_bindir}/mysql_setpermission
  358. %attr(755, root, root) %{_bindir}/mysql_tzinfo_to_sql
  359. %attr(755, root, root) %{_bindir}/mysql_upgrade
  360. %attr(755, root, root) %{_bindir}/mysql_zap
  361. %attr(755, root, root) %{_bindir}/mysqlbug
  362. %attr(755, root, root) %{_bindir}/mysqld_multi
  363. %attr(755, root, root) %{_bindir}/mysqld_safe
  364. %attr(755, root, root) %{_bindir}/mysqldumpslow
  365. %attr(755, root, root) %{_bindir}/mysqlhotcopy
  366. %attr(755, root, root) %{_bindir}/mysqltest
  367. %attr(755, root, root) %{_bindir}/perror
  368. %attr(755, root, root) %{_bindir}/replace
  369. %attr(755, root, root) %{_bindir}/resolve_stack_dump
  370. %attr(755, root, root) %{_bindir}/resolveip
  371. %attr(755, root, root) %{_sbindir}/mysqld
  372. %attr(755, root, root) %{_sbindir}/rcmysql
  373. %attr(755, root, root) %{_libdir}/mysql/plugin/*.so
  374. %attr(644, root, root) %config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
  375. %attr(755, root, root) %{_sysconfdir}/init.d/mysql
  376. %attr(755, root, root) %{_datadir}/mysql/
  377. %files client
  378. %defattr(-, root, root, 0755)
  379. %attr(755, root, root) %{_bindir}/msql2mysql
  380. %attr(755, root, root) %{_bindir}/mysql
  381. %attr(755, root, root) %{_bindir}/mysql_find_rows
  382. %attr(755, root, root) %{_bindir}/mysql_waitpid
  383. %attr(755, root, root) %{_bindir}/mysqlaccess
  384. # XXX: This should be moved to %{_sysconfdir}
  385. %attr(644, root, root) %{_bindir}/mysqlaccess.conf
  386. %attr(755, root, root) %{_bindir}/mysqladmin
  387. %attr(755, root, root) %{_bindir}/mysqlbinlog
  388. %attr(755, root, root) %{_bindir}/mysqlcheck
  389. %attr(755, root, root) %{_bindir}/mysqldump
  390. %attr(755, root, root) %{_bindir}/mysqlimport
  391. %attr(755, root, root) %{_bindir}/mysqlshow
  392. %attr(755, root, root) %{_bindir}/mysqlslap
  393. %doc %attr(644, root, man) %{_mandir}/man1/msql2mysql.1*
  394. %doc %attr(644, root, man) %{_mandir}/man1/mysql.1*
  395. %doc %attr(644, root, man) %{_mandir}/man1/mysql_find_rows.1*
  396. %doc %attr(644, root, man) %{_mandir}/man1/mysql_waitpid.1*
  397. %doc %attr(644, root, man) %{_mandir}/man1/mysqlaccess.1*
  398. %doc %attr(644, root, man) %{_mandir}/man1/mysqladmin.1*
  399. %doc %attr(644, root, man) %{_mandir}/man1/mysqlbinlog.1*
  400. %doc %attr(644, root, man) %{_mandir}/man1/mysqlcheck.1*
  401. %doc %attr(644, root, man) %{_mandir}/man1/mysqldump.1*
  402. %doc %attr(644, root, man) %{_mandir}/man1/mysqlimport.1*
  403. %doc %attr(644, root, man) %{_mandir}/man1/mysqlshow.1*
  404. %doc %attr(644, root, man) %{_mandir}/man1/mysqlslap.1*
  405. %files devel -f optional-files-devel
  406. %defattr(-, root, root, 0755)
  407. %doc %attr(644, root, man) %{_mandir}/man1/comp_err.1*
  408. %doc %attr(644, root, man) %{_mandir}/man1/mysql_config.1*
  409. %attr(755, root, root) %{_bindir}/mysql_config
  410. %dir %attr(755, root, root) %{_includedir}/mysql
  411. %dir %attr(755, root, root) %{_libdir}/mysql
  412. %{_includedir}/mysql/*
  413. %{_datadir}/aclocal/mysql.m4
  414. %{_libdir}/*.so
  415. %exclude %{_libdir}/*.a
  416. %files -n %{libpkgname}
  417. %defattr(-, root, root, 0755)
  418. # Shared libraries (omit for architectures that don't support them)
  419. %{_libdir}/libmysql*.so.*
  420. #/etc/ld.so.conf.d/*
  421. %files test
  422. %defattr(-, root, root, 0755)
  423. %attr(-, root, root) %{_datadir}/mysql-test
  424. %attr(755, root, root) %{_bindir}/mysql_client_test
  425. %attr(755, root, root) %{_bindir}/mysql_client_test_embedded
  426. %attr(755, root, root) %{_bindir}/mysqltest_embedded
  427. %doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test.1*
  428. %doc %attr(644, root, man) %{_mandir}/man1/mysql-stress-test.pl.1*
  429. %doc %attr(644, root, man) %{_mandir}/man1/mysql-test-run.pl.1*
  430. %doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
  431. %doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
  432. %files embedded-devel
  433. %defattr(-,root,root)
  434. #{_libdir}/libmysqld.a
  435. %{_bindir}/mysql_client_test_embedded
  436. %{_bindir}/mysqltest_embedded
  437. %doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
  438. %doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
  439. %changelog
  440. * Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
  441. - new upstream release.
  442. - removed NDB cluster support.
  443. * Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
  444. - Added "BR: zlib-devel" to MySQL-devel.
  445. * Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
  446. - Added "BR: openssl-devel" to MySQL-devel.
  447. * Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
  448. - new upstream release.
  449. * Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
  450. - new upstream release.
  451. - updated jp-patch.
  452. - added ssl support.
  453. * Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
  454. - new upstream release.
  455. - replaced '%%__find_requires' to '%%__perl_requires'.
  456. - updated jp-patch.
  457. * Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
  458. - added mysql-5.1.44-lib64.patch (on x86_64)
  459. - added -fPIC (on x86_64)
  460. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
  461. - made embedded package again
  462. * Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
  463. - new upstream release.
  464. - updated jp-patch.
  465. * Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
  466. - VineSeed: rebuilt with new toolchain.
  467. * Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
  468. - new upstream release.
  469. - fixed CVE-2009-4484.
  470. * Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
  471. - new upstream release.
  472. * Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
  473. - added net-tools to 'Requires'.
  474. - added groff to 'BuildRequires'.
  475. - renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
  476. * Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
  477. - new upstream release.
  478. * Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
  479. - new upstream release.
  480. * Sun Jul 5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
  481. - new upstream release.
  482. - dropped %%Patch100 (fixed in upstream).
  483. * Sat Jun 6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
  484. - new upstream release.
  485. - add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
  486. * Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
  487. - new upstream release.
  488. - rename 'MySQL-bench' to 'MySQL-test'.
  489. - update Patch0.
  490. - change default charset to 'utf8'.
  491. * Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
  492. - new upstream release.
  493. - update Patch0.
  494. - add "--with-client-charset=ujis".
  495. - sync %%files to official RPM.
  496. - remove MySQL-Max.
  497. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
  498. - for VineSeed
  499. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
  500. - move shared library from /usr/lib/ to /usr/lib/mysql/
  501. - add /etc/ld.so.conf.d/*.conf
  502. - fix broken libmysqlcient*.la files (or should we remove them permanently?)
  503. * Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
  504. - rebuild <BTS:VineLinux:534>
  505. * Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
  506. - added -fPIC
  507. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
  508. - fixed dependency. <BTS:338>
  509. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
  510. - add %%Patch1. <BTS:320>
  511. * Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
  512. - new upstream release.
  513. * Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
  514. - new upstream release.
  515. * Sat Jun 3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
  516. - new upstream release.
  517. * Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
  518. - release++.
  519. * Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
  520. - new upstream release.
  521. - for VineSeed.
  522. * Wed Feb 8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
  523. - new upstream release.
  524. - replace Patch0 for MySQL-4.1.16.
  525. * Thu Oct 6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
  526. - new upstream release.
  527. - add Patch0.
  528. * Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
  529. - new upstream version
  530. -- mysql-4.0.25
  531. * Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
  532. - new upstream version
  533. -- mysql-4.0.23
  534. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
  535. - new upstream version
  536. -- mysql-4.0.22
  537. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
  538. - new upstream version
  539. -- mysql-4.0.21
  540. * Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
  541. - new upstream version
  542. -- mysql-4.0.20
  543. * Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
  544. - modify CFLAGS, CXXFLAGS and configure options for alpha
  545. * Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
  546. - Upgraded to MySQL-4
  547. - added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
  548. - merged to MySQL Official packages
  549. -- renamed package "MySQL" to "MySQL-server"
  550. -- when using gcc, _always_ use CXX=gcc
  551. -- replaced Copyright with License field (Copyright is obsolete)
  552. -- added myisam_ftdump to the Server package
  553. -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
  554. -- fixed file permissions (BUG 1672)
  555. -- removed dependency on MySQL-client from the MySQL-devel subpackage
  556. -- as it is not really required. (BUG 1610)
  557. -- Fixed BUG 1162 (removed macro names from the changelog)
  558. -- Really fixed BUG 998 (disable the checking for installed but
  559. -- unpackaged files)
  560. -- Fixed BUG 959 (libmysqld not being compiled properly)
  561. -- Fixed BUG 998 (RPM build errors): added missing files to the
  562. -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
  563. -- mysql_fix_privilege_tables.1), removed "-n" from install section.
  564. -- removed the GIF Icon (file was not included in the sources anyway)
  565. -- removed unused variable shared_lib_version
  566. -- do not run automake before building the standard binary
  567. -- (should not be necessary)
  568. -- add server suffix '-standard' to standard binary (to be in line
  569. -- with the binary tarball distributions)
  570. -- allow overriding CC and CXX (required when building
  571. -- with other compilers)
  572. * Thu Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
  573. - added BuildRequires: automake16
  574. * Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
  575. - add '-fPIC -DPIC' to CFLAGS on alpha
  576. - little fix of spec file
  577. * Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
  578. - enable MySQL-shared subpackage for alpha
  579. - delete 'BuildPrereq: kernel24-headers' for alpha
  580. - fix shared %files (exclude sparc)
  581. * Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
  582. - new upstream version
  583. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
  584. - fixed devel %files (dropped *.la files)
  585. * Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
  586. - new upstream version
  587. - fixed document permission
  588. * Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
  589. - new upstream version
  590. * Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
  591. - dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
  592. -- don't work
  593. * Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
  594. - new upstream version
  595. - diseble-assembler in configure on sparc,sparc64,alpha
  596. * Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
  597. - new upstream version
  598. - moved some man files to main package
  599. - added enable-local-infile in configure
  600. - changed --with-extra-charsets=all in configure
  601. * Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
  602. - fixed changelog
  603. * Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
  604. - updated to mysql-3.23.51
  605. * Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
  606. - rebuild on zlib-1.1.4(security fix.)
  607. * Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
  608. - updated to mysql-2.23.49
  609. * Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
  610. - add 'BuildPrereq: kernel24-headers' on alpha
  611. - remove shared library and max on alpha
  612. * Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
  613. - updated to mysql-3.23.48
  614. * Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
  615. - updated to mysql-3.23.47
  616. * Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
  617. - updated to mysql-3.23.46
  618. * Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
  619. - updated to mysql-3.23.45
  620. * Tue Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
  621. - updated to mysql-3.23.44
  622. * Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
  623. - updated to mysql-3.23.43
  624. - removed shared library and max on sparc
  625. * Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
  626. - updated to mysql-3.23.42
  627. - changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
  628. * Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
  629. - updated to mysql-3.23.41
  630. * Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
  631. - updated to mysql-3.23.40
  632. * Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
  633. - updated to mysql-3.23.39
  634. * Sat Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  635. - added configure --with-charset=ujis
  636. * Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  637. - used some rpmmacro
  638. * Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
  639. - updated to MySQL-3.23.38
  640. * Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
  641. - removed Bench pakages
  642. * Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
  643. - removed pt_BR locale
  644. - build on Vine Linux
  645. - partially used rpmmacros
  646. - added %clean tag
  647. * Fri Aug 18 2000 Tim Smith <tim@mysql.com>
  648. - Added separate libmysql_r directory; now both a threaded
  649. and non-threaded library is shipped.
  650. * Wed Sep 28 1999 David Axmark <davida@mysql.com>
  651. - Added the support-files/my-example.cnf to the docs directory.
  652. - Removed devel dependency on base since it is about client
  653. development.
  654. * Wed Sep 8 1999 David Axmark <davida@mysql.com>
  655. - Cleaned up some for 3.23.
  656. * Thu Jul 1 1999 David Axmark <davida@mysql.com>
  657. - Added support for shared libraries in a separate sub
  658. package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
  659. - The --enable-assembler switch is now automatically disables on
  660. platforms there assembler code is unavailable. This should allow
  661. building this RPM on non i386 systems.
  662. * Mon Feb 22 1999 David Axmark <david@detron.se>
  663. - Removed unportable cc switches from the spec file. The defaults can
  664. now be overridden with environment variables. This feature is used
  665. to compile the official RPM with optimal (but compiler version
  666. specific) switches.
  667. - Removed the repetitive description parts for the sub rpms. Maybe add
  668. again if RPM gets a multiline macro capability.
  669. - Added support for a pt_BR translation. Translation contributed by
  670. Jorge Godoy <jorge@bestway.com.br>.
  671. * Wed Nov 4 1998 David Axmark <david@detron.se>
  672. - A lot of changes in all the rpm and install scripts. This may even
  673. be a working RPM :-)
  674. * Sun Aug 16 1998 David Axmark <david@detron.se>
  675. - A developers changelog for MySQL is available in the source RPM. And
  676. there is a history of major user visible changed in the Reference
  677. Manual. Only RPM specific changes will be documented here.