ffmpeg-vl.spec 8.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290
  1. #TODO: Build with openjpeg
  2. #TODO: add make test to %%check section
  3. #% define svndate 20100625
  4. ## available for v0.6 or lower
  5. %define with_libfaad 1
  6. %define with_vaapi 1
  7. %define with_libvpx 1
  8. Summary: Digital VCR and streaming server
  9. Name: ffmpeg
  10. Version: 0.6
  11. Release: 3%{?svndate:.%svndate}%{?_dist_release}
  12. Source: %{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  13. Source1: %{name}-snapshot.sh
  14. # pre-built man files
  15. Source90: ffmpeg.1.gz
  16. Source91: ffplay.1.gz
  17. Source92: ffserver.1.gz
  18. Source93: ffprobe.1.gz
  19. License: GPLv2+
  20. Group: Applications/Multimedia
  21. URL: http://ffmpeg.org/
  22. BuildRequires: bzip2-devel
  23. ##BuildRequires: dirac-devel
  24. BuildRequires: gsm-devel
  25. BuildRequires: imlib2-devel
  26. BuildRequires: libdc1394-devel
  27. BuildRequires: libraw1394-devel
  28. BuildRequires: libtheora-devel
  29. %{?with_vaapi:BuildRequires:libva-devel}
  30. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.1}
  31. BuildRequires: libvdpau-devel
  32. BuildRequires: libvorbis-devel
  33. %{?_with_opencore_amr:BuildRequires: opencore-amr-devel}
  34. ##BuildRequires: openjpeg-devel
  35. BuildRequires: SDL-devel
  36. BuildRequires: speex-devel
  37. ##BuildRequires: texi2html
  38. BuildRequires: zlib-devel
  39. BuildRequires: libogg-devel
  40. %ifarch %{ix86} x86_64
  41. BuildRequires: yasm
  42. %endif
  43. # *-devel packages provided by other self-build-* should only be listed
  44. # in self-build-%{name}.spec as PreReq.
  45. #BuildRequires: xvidcore-devel, faac-devel, lame-devel
  46. #BuildRequires: x264-devel, libdca-devel, a52dec-devel
  47. #BuildRequires: faad2-devel
  48. Requires: %{name}-libs = %{version}-%{release}
  49. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  50. %description
  51. FFMpeg is a complete and free Internet live audio and video
  52. broadcasting solution for Linux/Unix. It also includes a digital
  53. VCR. It can encode in real time in many formats including MPEG1 audio
  54. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  55. %package libs
  56. Summary: Libraries for %{name}
  57. Group: System Environment/Libraries
  58. %description libs
  59. FFMpeg is a complete and free Internet live audio and video
  60. broadcasting solution for Linux/Unix. It also includes a digital
  61. VCR. It can encode in real time in many formats including MPEG1 audio
  62. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  63. This package contains the libraries for %{name}.
  64. %package devel
  65. Summary: Development package for %{name}
  66. Group: Development/Libraries
  67. Requires: %{name}-libs = %{version}-%{release}
  68. Requires: pkgconfig
  69. %description devel
  70. FFMpeg is a complete and free Internet live audio and video
  71. broadcasting solution for Linux/Unix. It also includes a digital
  72. VCR. It can encode in real time in many formats including MPEG1 audio
  73. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  74. This package contains development files for %{name}.
  75. %prep
  76. %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
  77. #% setup -q
  78. #%patch0 -p1 -b .textrel
  79. %build
  80. %ifarch ppc
  81. # compile with -mlongcall on ppc/ppc64 (rf804)
  82. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  83. %endif
  84. ./configure \
  85. --prefix=%{_prefix} \
  86. --incdir=%{_includedir}/%{name} \
  87. --shlibdir=%{_libdir} \
  88. --libdir=%{_libdir} \
  89. --mandir=%{_mandir} \
  90. --arch=%{_target_cpu} \
  91. %ifarch %{ix86}
  92. --cpu=%{_target_cpu} \
  93. %endif
  94. %ifarch ppc
  95. --cpu=g3 \
  96. %endif
  97. --enable-runtime-cpudetect \
  98. --extra-cflags="$RPM_OPT_FLAGS" \
  99. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
  100. --enable-bzlib \
  101. --enable-libdc1394 \
  102. --enable-libfaac --enable-nonfree \
  103. %{?with_libfaad:--enable-libfaad} \
  104. --enable-libgsm \
  105. --enable-libmp3lame \
  106. %{?_with_openjpeg:--enable-libopenjpeg} \
  107. --enable-libtheora \
  108. --enable-libvorbis \
  109. %{?with_libvpx:--enable-libvpx} \
  110. --enable-libx264 \
  111. --enable-libxvid \
  112. --enable-zlib \
  113. \
  114. --enable-x11grab \
  115. --enable-avfilter \
  116. --enable-avfilter-lavf \
  117. --enable-postproc \
  118. --enable-swscale \
  119. --enable-pthreads \
  120. --disable-static \
  121. --enable-shared \
  122. --enable-gpl \
  123. --disable-doc \
  124. --disable-debug \
  125. --disable-stripping
  126. %{__make} %{?_smp_mflags}
  127. #% {__make}
  128. #%{__make} documentation
  129. %install
  130. %__make install DESTDIR=$RPM_BUILD_ROOT
  131. ## install man
  132. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  133. %__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
  134. $RPM_BUILD_ROOT%{_mandir}/man1/
  135. %clean
  136. %{__rm} -rf $RPM_BUILD_ROOT
  137. %post libs -p /sbin/ldconfig
  138. %postun libs -p /sbin/ldconfig
  139. %files
  140. %defattr(-,root,root,-)
  141. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  142. %{_bindir}/ff*
  143. %{_mandir}/man1/ff*.1*
  144. %{_datadir}/ffmpeg
  145. %files libs
  146. %defattr(-,root,root,-)
  147. %{_libdir}/lib*.so.*
  148. %files devel
  149. %defattr(-,root,root,-)
  150. %doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
  151. %{_includedir}/ffmpeg
  152. %{_libdir}/pkgconfig/lib*.pc
  153. %{_libdir}/lib*.so
  154. %changelog
  155. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  156. - added BuildRequires: libvpx-devel >= 0.9.1
  157. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  158. - new upstream release
  159. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  160. - bumped version to pre-0.6
  161. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  162. - updated source snapshot 20100410
  163. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  164. - change release to sync with self-build-ffmpeg-vl.spec
  165. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  166. - change release to sync with self-build-ffmpeg-vl.spec
  167. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  168. - updated source snapshot 20100401
  169. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  170. - updated source snapshot 20100326
  171. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  172. - change release to sync with self-build-ffmpeg
  173. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  174. - updated source snapshot 20100216
  175. - rebuild with recent x264-devel
  176. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  177. - added BuildRequires: libvdpau-devel
  178. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  179. - change release to sync with self-build-ffmpeg
  180. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  181. - change release to sync with self-build-ffmpeg
  182. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  183. - applied ffmpeg-0.5-disable-texi2html.patch
  184. - dropped BuildRequires: texi2html
  185. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  186. - change release to sync with self-build-ffmpeg
  187. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  188. - corrected release number
  189. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  190. - new upstream release
  191. - added BuildRequires:
  192. - speex-devel
  193. - bzip2-devel
  194. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  195. - 20090227 snapshot
  196. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  197. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  198. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  199. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  200. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  201. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  202. - 20090202 snapshot
  203. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  204. - 20090110 snapshot
  205. - dropped some patches
  206. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  207. - source updated (r15488)
  208. - fixed License: GPLv2+
  209. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  210. - added BuildRequires: yasm (only %%ix86)
  211. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  212. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  213. - spec in utf8
  214. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  215. - change release to sync with self-build-ffmpeg
  216. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  217. - drop "Patch100: ffmpeg-vine.patch".
  218. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  219. - build with new versioning policy
  220. - change to use svn export from svn checkout on post install
  221. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  222. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  223. - [self-build-ffmpeg.spec]
  224. For all pre-required package that is provied by self-build,
  225. changed to its self-build package
  226. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  227. - initial build for Vine Linux 4.2
  228. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  229. ### end of file