swig-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195
  1. %define tcl 0
  2. %define guile 0
  3. Summary: Connects C/C++/Objective C to some high-level programming languages
  4. Summary(ja): C/C++/Objective C を高レベル言語から利用するためのツール
  5. Name: swig
  6. Version: 2.0.8
  7. Release: 1%{?_dist_release}
  8. License: GPLv3+ and BSD
  9. Group: Development/Tools
  10. URL: http://swig.sourceforge.net/
  11. Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
  12. Patch4: swig203-rh706140.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: perl, python-devel, pcre-devel
  15. %if %{tcl}
  16. BuildRequires: tcl-devel
  17. %endif
  18. %if %{guile}
  19. BuildRequires: guile-devel
  20. %endif
  21. BuildRequires: autoconf, automake, gawk, nkf
  22. Obsoletes: swig-runtime
  23. %description
  24. Simplified Wrapper and Interface Generator (SWIG) is a software
  25. development tool for connecting C, C++ and Objective C programs with a
  26. variety of high-level programming languages. SWIG is primarily used
  27. with Perl, Python and Tcl/TK, but it has also been extended to Java,
  28. Eiffel and Guile. SWIG is normally used to create high-level
  29. interpreted programming environments, systems integration, and as a
  30. tool for building user interfaces
  31. %package doc
  32. Summary: Documentation files for SWIG
  33. Summary(ja): Documentation files for SWIG
  34. License: BSD
  35. Group: Development/Tools
  36. BuildArch: noarch
  37. %description doc
  38. This package contains documentation for SWIG and useful examples
  39. %prep
  40. %setup -q -n swig-%{version}
  41. %patch4 -p1 -b .rh706140
  42. # as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
  43. # (specific req/prov filtering). Before you remove this hack make sure you don't
  44. # reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
  45. cat << \EOF > %{name}-prov
  46. #!/bin/sh
  47. %{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  48. EOF
  49. %define __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
  50. chmod +x %{__perl_provides}
  51. cat << \EOF > %{name}-req
  52. #!/bin/sh
  53. %{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  54. EOF
  55. %define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  56. chmod +x %{__perl_requires}
  57. for all in CHANGES README; do
  58. iconv -f ISO88591 -t UTF8 < $all > $all.new
  59. touch -r $all $all.new
  60. mv -f $all.new $all
  61. done
  62. %build
  63. ./autogen.sh
  64. %configure
  65. make %{?_smp_mflags}
  66. # Test suite is currently broken
  67. #make check
  68. %install
  69. rm -rf %{buildroot}
  70. pushd Examples/
  71. # Remove all arch dependent files in Examples/
  72. find -type f -name 'Makefile.in' | xargs rm -f --
  73. # We don't want to ship files below.
  74. rm -rf test-suite
  75. find -type f -name '*.dsp' | xargs rm -f --
  76. find -type f -name '*.dsw' | xargs rm -f --
  77. # Convert files to UNIX format
  78. for all in `find -type f`; do
  79. nkf --unix $all
  80. chmod -x $all
  81. done
  82. popd
  83. make DESTDIR=%{buildroot} install
  84. %clean
  85. rm -rf %{buildroot}
  86. %files
  87. %defattr(-,root,root,-)
  88. %{_bindir}/*
  89. %{_datadir}/swig
  90. %{_mandir}/man1/ccache-swig.1*
  91. %doc ANNOUNCE CHANGES CHANGES.current INSTALL LICENSE LICENSE-GPL
  92. %doc LICENSE-UNIVERSITIES COPYRIGHT README TODO
  93. %files doc
  94. %defattr(-,root,root,-)
  95. %doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  96. %changelog
  97. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  98. - update to 2.0.8
  99. - build with pcre-8.31
  100. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
  101. - rebuild with python-2.7.2
  102. * Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
  103. - update to 2.0.4
  104. * Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
  105. - add missing man file(s) to the filelist
  106. * Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
  107. - new upstream release
  108. - rebuild with new toolchain
  109. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
  110. - new upstream release
  111. * Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
  112. - new upstream release
  113. - removed php-devel and ruby-devel from BuildPreReq:.
  114. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
  115. - new upstream release
  116. - use %%configure
  117. - remove runtime subpackage
  118. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  119. - 1.3.21-0vl2
  120. - un-libtoolize (tarball have already been libtoolized).
  121. - fix %%clean.
  122. - add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
  123. * Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  124. - 1.3.21-0vl1
  125. - update version
  126. * Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  127. - 1.3.20-0vl1
  128. - update version
  129. * Mon Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  130. - update version
  131. * Mon Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  132. - update version
  133. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  134. - import to Vine Linux
  135. * Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
  136. - BM.
  137. - Clean up specs.
  138. - 1.3a3.
  139. * Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
  140. - Use makeinstall macros.
  141. * Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
  142. - Provides: swig
  143. * Mon Apr 3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
  144. - rebuild with new perl
  145. - cleanup
  146. * Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
  147. - Rebuilt on kenobi
  148. - Don't use prefix
  149. * Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
  150. - First RPM for Mandrake