libboost-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758
  1. %define major 1
  2. %define minor 54
  3. %define teeny 0
  4. %define tarname boost
  5. %define lnkver %{major}_%{minor}
  6. %define pkgver %{major}_%{minor}_%{teeny}
  7. %ifnarch %{ix86} x86_64
  8. # Avoid using Boost.Context on non-x86 arches. s390 is not
  9. # supported at all and there were _syntax errors_ in PPC code. This
  10. # should be enabled on a case-by-case basis as the arches are tested
  11. # and fixed.
  12. %bcond_with context
  13. %else
  14. %bcond_without context
  15. %endif
  16. Summary: Portable C++ source libraries
  17. Summary(ja): ポータブルな C++ ソースライブラリ
  18. Name: libboost
  19. Version: %{major}.%{minor}.%{teeny}
  20. Release: 1%{?_dist_release}
  21. Source0: http://downloads.sourceforge.net/%{tarname}/%{tarname}_%{pkgver}.tar.bz2
  22. Source1: user-config.jam
  23. License: distributable
  24. Group: System Environment/Libraries
  25. URL: http://www.boost.org/
  26. BuildRequires: python-devel apache2-devel bzip2-devel zlib-devel libicu-devel
  27. BuildRequires: libaio-devel lam
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. # https://svn.boost.org/trac/boost/ticket/6150
  30. Patch4: boost-1.50.0-fix-non-utf8-files.patch
  31. # Add a manual page for bjam, based on the on-line documentation:
  32. # http://www.boost.org/boost-build2/doc/html/bbv2/overview.html
  33. Patch5: boost-1.48.0-add-bjam-man-page.patch
  34. # https://bugzilla.redhat.com/show_bug.cgi?id=781859
  35. # The following tickets have yet to be fixed by upstream.
  36. # https://svn.boost.org/trac/boost/ticket/6413
  37. # https://svn.boost.org/trac/boost/ticket/8849
  38. Patch9: boost-1.53.0-attribute.patch
  39. # https://bugzilla.redhat.com/show_bug.cgi?id=828856
  40. # https://bugzilla.redhat.com/show_bug.cgi?id=828857
  41. Patch15: boost-1.50.0-pool.patch
  42. # https://bugzilla.redhat.com/show_bug.cgi?id=977098
  43. # https://svn.boost.org/trac/boost/ticket/8731
  44. Patch18: boost-1.54.0-__GLIBC_HAVE_LONG_LONG.patch
  45. # Upstream patches posted as release notes:
  46. # http://www.boost.org/users/history/version_1_54_0.html
  47. Patch19: 001-coroutine.patch
  48. Patch20: 002-date-time.patch
  49. Patch21: 003-log.patch
  50. # https://svn.boost.org/trac/boost/ticket/8826
  51. Patch22: boost-1.54.0-context-execstack.patch
  52. # https://svn.boost.org/trac/boost/ticket/8844
  53. Patch23: boost-1.54.0-bind-static_assert.patch
  54. # https://svn.boost.org/trac/boost/ticket/8847
  55. Patch24: boost-1.54.0-concept-unused_typedef.patch
  56. # https://svn.boost.org/trac/boost/ticket/5637
  57. Patch25: boost-1.54.0-mpl-print.patch
  58. # https://svn.boost.org/trac/boost/ticket/8859
  59. Patch26: boost-1.54.0-static_warning-unused_typedef.patch
  60. # https://svn.boost.org/trac/boost/ticket/8855
  61. Patch27: boost-1.54.0-math-unused_typedef.patch
  62. Patch28: boost-1.54.0-math-unused_typedef-2.patch
  63. # https://svn.boost.org/trac/boost/ticket/8853
  64. Patch31: boost-1.54.0-tuple-unused_typedef.patch
  65. # https://svn.boost.org/trac/boost/ticket/8854
  66. Patch32: boost-1.54.0-random-unused_typedef.patch
  67. # https://svn.boost.org/trac/boost/ticket/8856
  68. Patch33: boost-1.54.0-date_time-unused_typedef.patch
  69. Patch34: boost-1.54.0-date_time-unused_typedef-2.patch
  70. # https://svn.boost.org/trac/boost/ticket/8870
  71. Patch35: boost-1.54.0-spirit-unused_typedef.patch
  72. Patch36: boost-1.54.0-spirit-unused_typedef-2.patch
  73. # https://svn.boost.org/trac/boost/ticket/8871
  74. Patch37: boost-1.54.0-numeric-unused_typedef.patch
  75. # https://svn.boost.org/trac/boost/ticket/8872
  76. Patch38: boost-1.54.0-multiprecision-unused_typedef.patch
  77. # https://svn.boost.org/trac/boost/ticket/8874
  78. Patch42: boost-1.54.0-unordered-unused_typedef.patch
  79. # https://svn.boost.org/trac/boost/ticket/8876
  80. Patch43: boost-1.54.0-algorithm-unused_typedef.patch
  81. # https://svn.boost.org/trac/boost/ticket/8877
  82. Patch44: boost-1.54.0-graph-unused_typedef.patch
  83. # https://svn.boost.org/trac/boost/ticket/8878
  84. Patch45: boost-1.54.0-locale-unused_typedef.patch
  85. # https://svn.boost.org/trac/boost/ticket/8879
  86. Patch46: boost-1.54.0-property_tree-unused_typedef.patch
  87. # https://svn.boost.org/trac/boost/ticket/8880
  88. Patch47: boost-1.54.0-xpressive-unused_typedef.patch
  89. # https://svn.boost.org/trac/boost/ticket/8881
  90. Patch48: boost-1.54.0-mpi-unused_typedef.patch
  91. # https://svn.boost.org/trac/boost/ticket/8888
  92. Patch49: boost-1.54.0-python-unused_typedef.patch
  93. # https://svn.boost.org/trac/boost/ticket/8941
  94. Patch50: boost-1.54.0-lexical_cast-int128.patch
  95. # https://svn.boost.org/trac/boost/ticket/9038
  96. Patch51: boost-1.54.0-pool-test_linking.patch
  97. # https://svn.boost.org/trac/boost/ticket/9037
  98. Patch52: boost-1.54.0-thread-cond_variable_shadow.patch
  99. # This was already fixed upstream, so no tracking bug.
  100. Patch53: boost-1.54.0-pool-max_chunks_shadow.patch
  101. # https://svn.boost.org/trac/boost/ticket/9041
  102. Patch54: boost-1.54.0-thread-link_atomic.patch
  103. # https://bugzilla.redhat.com/show_bug.cgi?id=1002578
  104. # https://svn.boost.org/trac/boost/ticket/9065
  105. Patch55: boost-1.54.0-interprocess-atomic_cas32-ppc.patch
  106. Vendor: Project Vine
  107. Distribution: Vine Linux
  108. Obsoletes: %{name}-date-time-devel %{name}-filesystem-devel %{name}-graph-devel
  109. Obsoletes: %{name}-iostreams-devel %{name}-program-options-devel
  110. Obsoletes: %{name}-python-devel %{name}-regex-devel
  111. Obsoletes: %{name}-serialization-devel %{name}-signals-devel %{name}-test-devel
  112. Obsoletes: %{name}-thread-devel %{name}-wave-devel
  113. %description
  114. Boost provides free peer-reviewed portable C++ source libraries. The emphasis
  115. is on libraries which work well with the C++ Standard Library. The libraries
  116. are intended to be widely useful, and are in regular use by thousands of
  117. programmers across a broad spectrum of applications.
  118. A further goal is to establish "existing practice" and provide reference
  119. implementations so that Boost libraries are suitable for eventual
  120. standardization. Ten Boost libraries will be included in the C++ Standards
  121. Committee's upcoming C++ Standard Library Technical Report as a step toward
  122. becoming part of a future C++ Standard.
  123. %description -l ja
  124. Boost は公開レビューされたフリーのC++ライブラリ群です。 C++ の標準ライブラリに
  125. 準拠することに重点を置いて開発されています。使いやすく、広い分野のアプリ
  126. ケーションにおいて日常的に多くの開発者に用いられることを目指しています。
  127. さらなる目標は、最終的な標準化に適合した「存在する実例」としてリファレンス実装
  128. を提供することです。10 の Boost ライブラリが、将来の C++ 標準になるための一歩
  129. として、C++ 標準化委員会が策定中の C++ 標準ライブラリテクニカルレポートに
  130. 含まれる予定です。
  131. %package atomic
  132. Summary: Run-Time component of boost atomic library
  133. Group: System Environment/Libraries
  134. %description atomic
  135. Run-Time support for Boost.Atomic, a library that provides atomic data
  136. types and operations on these data types, as well as memory ordering
  137. constraints required for coordinating multiple threads through atomic
  138. variables.
  139. %package chrono
  140. Summary: Run-Time component of boost chrono library
  141. Group: System Environment/Libraries
  142. Requires: %{name}-system = %{version}-%{release}
  143. %description chrono
  144. Run-Time support for Boost.Chrono, a set of useful time utilities.
  145. %if %{with context}
  146. %package context
  147. Summary: Run-Time component of boost context switching library
  148. Group: System Environment/Libraries
  149. %description context
  150. Run-Time support for Boost.Context, a foundational library that
  151. provides a sort of cooperative multitasking on a single thread.
  152. %endif
  153. %package devel
  154. Summary: Header files and libraries for developing apps which will use %{name}
  155. Summary(ja): %{name}の開発に必要なヘッダファイル及びライブラリ
  156. Group: Development/Libraries
  157. Requires: %{name} = %{version}-%{release}
  158. %description devel
  159. The %{name}-devel package contains the header files and libraries needed
  160. to develop programs that use the Boost library.
  161. %description devel -l ja
  162. %{name}-devel パッケージは Boost ライブラリを使うプログラムの開発に必要な
  163. ヘッダファイルやライブラリを含んでいます。
  164. %package doc
  165. Summary: Documents of %{name}
  166. Summary(ja): %{name}のドキュメント
  167. Group: Applications/Documentation
  168. Requires: %{name} = %{version}-%{release}
  169. %description doc
  170. The %{name}-doc package contains the documents about the boost library.
  171. %description doc -l ja
  172. %{name}-doc パッケージは Boost ライブラリについてのドキュメントを含んでいます。
  173. %package date-time
  174. Summary: Set of data-time libralies in %{name}
  175. Group: System Environment/Libraries
  176. Requires: %{name} = %{version}-%{release}
  177. %description date-time
  178. Set of data-time libralies in %{name}
  179. %package filesystem
  180. Summary: Set of filesystem operation libralies in %{name}
  181. Group: System Environment/Libraries
  182. Requires: %{name} = %{version}-%{release}
  183. %description filesystem
  184. Set of filesystem operation libralies in %{name}
  185. %package graph
  186. Summary: Set of Graphviz libralies in %{name}
  187. Group: System Environment/Libraries
  188. Requires: %{name} = %{version}-%{release}
  189. %description graph
  190. Set of Graphviz libralies in %{name}
  191. %package iostreams
  192. Summary: Set of streams and i/o filters libralies in %{name}
  193. Group: System Environment/Libraries
  194. Requires: %{name} = %{version}-%{release}
  195. %description iostreams
  196. Set of streams and i/o filters libralies in %{name}
  197. %package locale
  198. Summary: Run-Time component of boost locale library
  199. Group: System Environment/Libraries
  200. Requires: %{name}-chrono = %{version}-%{release}
  201. Requires: %{name}-system = %{version}-%{release}
  202. Requires: %{name}-thread = %{version}-%{release}
  203. %description locale
  204. Run-Time support for Boost.Locale, a set of localization and Unicode
  205. handling tools.
  206. %package log
  207. Summary: Run-Time component of boost logging library
  208. Group: System Environment/Libraries
  209. %description log
  210. Boost.Log library aims to make logging significantly easier for the
  211. application developer. It provides a wide range of out-of-the-box
  212. tools along with public interfaces for extending the library.
  213. %package math
  214. Summary: Set of math libralies in %{name}
  215. Group: System Environment/Libraries
  216. Requires: %{name} = %{version}-%{release}
  217. %description math
  218. Set of math libralies in %{name}
  219. %package program-options
  220. Summary: Set of program options libralies in %{name}
  221. Group: System Environment/Libraries
  222. Requires: %{name} = %{version}-%{release}
  223. %description program-options
  224. Set of program options libralies in %{name}
  225. %package python
  226. Summary: Set of Python libralies in %{name}
  227. Group: System Environment/Libraries
  228. Requires: %{name} = %{version}-%{release}
  229. %description python
  230. Set of Python libralies in %{name}
  231. %package random
  232. Summary: Set of random number generation libralies in %{name}
  233. Group: System Environment/Libraries
  234. Requires: %{name} = %{version}-%{release}
  235. %description random
  236. Set of random number generation libralies in %{name}
  237. %package regex
  238. Summary: Set of regular expression libralies in %{name}
  239. Group: System Environment/Libraries
  240. Requires: %{name} = %{version}-%{release}
  241. %description regex
  242. Set of regular expression libralies in %{name}
  243. %package serialization
  244. Summary: Set of serialization libralies in %{name}
  245. Group: System Environment/Libraries
  246. Requires: %{name} = %{version}-%{release}
  247. %description serialization
  248. Set of serialization libralies in %{name}
  249. %package signals
  250. Summary: Set of signals and slots libralies in %{name}
  251. Group: System Environment/Libraries
  252. Requires: %{name} = %{version}-%{release}
  253. %description signals
  254. Set of signals and slots libralies in %{name}
  255. %package system
  256. Summary: Operating system support
  257. Group: System Environment/Libraries
  258. Requires: %{name} = %{version}-%{release}
  259. %description system
  260. Operating system support, including the diagnostics support
  261. that will be part of the C++0x standard library
  262. %package test
  263. Summary: Set of libraries for writing and executing tests in %{name}
  264. Group: System Environment/Libraries
  265. Requires: %{name} = %{version}-%{release}
  266. %description test
  267. Set of libraries for writing and executing tests in %{name}
  268. %package thread
  269. Summary: Set of multi-thread libraries in %{name}
  270. Group: System Environment/Libraries
  271. Requires: %{name} = %{version}-%{release}
  272. %description thread
  273. Set of multi-thread libraries in %{name}
  274. %package timer
  275. Summary: Run-Time component of boost timer library
  276. Group: System Environment/Libraries
  277. Requires: %{name}-chrono = %{version}-%{release}
  278. Requires: %{name}-system = %{version}-%{release}
  279. %description timer
  280. "How long does my C++ code take to run?"
  281. The Boost Timer library answers that question and does so portably,
  282. with as little as one #include and one additional line of code.
  283. %package wave
  284. Summary: Set of wave libraries in %{name}
  285. Group: System Environment/Libraries
  286. Requires: %{name} = %{version}-%{release}
  287. %description wave
  288. Set of wave libraries in %{name}
  289. %prep
  290. %setup -q -n %{tarname}_%{pkgver}
  291. cp %SOURCE1 user-config.jam
  292. %patch4 -p1
  293. %patch5 -p1
  294. %patch9 -p1
  295. %patch15 -p0
  296. %patch18 -p1
  297. %patch19 -p1
  298. %patch20 -p1
  299. %patch21 -p1
  300. %patch22 -p1
  301. %patch23 -p1
  302. %patch24 -p1
  303. %patch25 -p0
  304. %patch26 -p1
  305. %patch27 -p1
  306. %patch28 -p0
  307. %patch31 -p0
  308. %patch32 -p0
  309. %patch33 -p0
  310. %patch34 -p1
  311. %patch35 -p1
  312. %patch36 -p1
  313. %patch37 -p1
  314. %patch38 -p1
  315. %patch42 -p1
  316. %patch43 -p1
  317. %patch44 -p1
  318. %patch45 -p1
  319. %patch46 -p1
  320. %patch47 -p1
  321. %patch48 -p1
  322. %patch49 -p1
  323. %patch50 -p0
  324. %patch51 -p1
  325. %patch52 -p1
  326. %patch53 -p1
  327. %patch54 -p1
  328. %patch55 -p1
  329. %build
  330. ## ./configure --prefix=/usr --libdir=%{_libdir} --with-icu
  331. ## make EXPAT_INCLUDE=/usr/include EXPAT_LIBPATH=/usr/lib
  332. ./bootstrap.sh \
  333. --prefix=%{_prefix} \
  334. --libdir=%{_libdir} \
  335. --includedir=%{_includedir} \
  336. --with-icu=%{_prefix} \
  337. --with-python-version=%{pyver}
  338. ./bjam -sICU_LINK="-L%{_libdir} -licui18n" --user-config=./user-config.jam link=shared
  339. %install
  340. rm -rf $RPM_BUILD_ROOT
  341. ## ./tools/jam/src/bin.linux*/bjam -sICU_PATH=/usr -sEXPAT_INCLUDE=/usr/include -sEXPAT_LIBPATH=/usr/lib --user-config=user-config.jam --prefix=${RPM_BUILD_ROOT}/usr --libdir=${RPM_BUILD_ROOT}%{_libdir} install
  342. ./bjam \
  343. --prefix=${RPM_BUILD_ROOT}%{_prefix} \
  344. --libdir=${RPM_BUILD_ROOT}%{_libdir} \
  345. --user-config=./user-config.jam \
  346. link=shared \
  347. install
  348. ln -s ./%{tarname} ${RPM_BUILD_ROOT}/%{_includedir}/%{tarname}-%{lnkver}
  349. # remove unuse files
  350. rm -f ${RPM_BUILD_ROOT}/%{_libdir}/%{name}_*.a
  351. # unnead for libboost-1.42
  352. ## pushd $RPM_BUILD_ROOT/%{_libdir}
  353. ## for i in libboost_*-mt.so
  354. ## do
  355. ## ln -sf $i $(echo $i | cut -f1 -d-).so
  356. ## done
  357. ## popd
  358. ## %post devel
  359. ## if [ $1 = 2 ]; then
  360. ## rm -rf %{_includedir}/%{tarname}
  361. ## fi
  362. ## ln -s %{_includedir}/%{tarname}-%{lnkver}/%{tarname} %{_includedir}/%{tarname}
  363. ##
  364. ## %postun devel
  365. ## if [ $1 = 0 ]; then
  366. ## rm -rf %{_includedir}/%{tarname}
  367. ## fi
  368. %post atomic -p /sbin/ldconfig
  369. %post chrono -p /sbin/ldconfig
  370. %if %{with context}
  371. %post context -p /sbin/ldconfig
  372. %endif
  373. %post date-time -p /sbin/ldconfig
  374. %post filesystem -p /sbin/ldconfig
  375. %post graph -p /sbin/ldconfig
  376. %post iostreams -p /sbin/ldconfig
  377. %post locale -p /sbin/ldconfig
  378. %post log -p /sbin/ldconfig
  379. %post math -p /sbin/ldconfig
  380. %post program-options -p /sbin/ldconfig
  381. %post python -p /sbin/ldconfig
  382. %post regex -p /sbin/ldconfig
  383. %post serialization -p /sbin/ldconfig
  384. %post signals -p /sbin/ldconfig
  385. %post system -p /sbin/ldconfig
  386. %post test -p /sbin/ldconfig
  387. %post thread -p /sbin/ldconfig
  388. %post timer -p /sbin/ldconfig
  389. %post wave -p /sbin/ldconfig
  390. %postun atomic -p /sbin/ldconfig
  391. %postun chrono -p /sbin/ldconfig
  392. %if %{with context}
  393. %postun context -p /sbin/ldconfig
  394. %endif
  395. %postun date-time -p /sbin/ldconfig
  396. %postun filesystem -p /sbin/ldconfig
  397. %postun graph -p /sbin/ldconfig
  398. %postun iostreams -p /sbin/ldconfig
  399. %postun locale -p /sbin/ldconfig
  400. %postun log -p /sbin/ldconfig
  401. %postun math -p /sbin/ldconfig
  402. %postun program-options -p /sbin/ldconfig
  403. %postun python -p /sbin/ldconfig
  404. %postun regex -p /sbin/ldconfig
  405. %postun serialization -p /sbin/ldconfig
  406. %postun signals -p /sbin/ldconfig
  407. %postun system -p /sbin/ldconfig
  408. %postun test -p /sbin/ldconfig
  409. %postun thread -p /sbin/ldconfig
  410. %postun timer -p /sbin/ldconfig
  411. %postun wave -p /sbin/ldconfig
  412. %clean
  413. rm -rf $RPM_BUILD_ROOT
  414. %files
  415. %defattr(-,root,root)
  416. %doc LICENSE_1_0.txt
  417. %files atomic
  418. %defattr(-, root, root, -)
  419. %doc LICENSE_1_0.txt
  420. %{_libdir}/libboost_atomic.so*
  421. %files chrono
  422. %defattr(-, root, root, -)
  423. %doc LICENSE_1_0.txt
  424. %{_libdir}/libboost_chrono.so*
  425. %if %{with context}
  426. %files context
  427. %defattr(-, root, root, -)
  428. %doc LICENSE_1_0.txt
  429. %{_libdir}/libboost_context.so*
  430. %endif
  431. %files devel
  432. %defattr(-,root,root)
  433. %{_includedir}/boost/
  434. %{_includedir}/boost-%{lnkver}
  435. %files doc
  436. %doc index.htm index.html boost.css boost.png rst.css doc libs more
  437. %files date-time
  438. %doc LICENSE_1_0.txt
  439. %{_libdir}/%{name}_date_time*.so*
  440. %files filesystem
  441. %doc LICENSE_1_0.txt
  442. %{_libdir}/%{name}_filesystem*.so*
  443. %files graph
  444. %doc LICENSE_1_0.txt
  445. %{_libdir}/%{name}_graph*.so*
  446. %{_libdir}/%{name}_mpi*.so*
  447. %{_libdir}/mpi*.so*
  448. %files iostreams
  449. %doc LICENSE_1_0.txt
  450. %{_libdir}/%{name}_iostreams*.so*
  451. %files locale
  452. %defattr(-, root, root, -)
  453. %doc LICENSE_1_0.txt
  454. %{_libdir}/libboost_locale.so*
  455. %files log
  456. %defattr(-, root, root, -)
  457. %doc LICENSE_1_0.txt
  458. %{_libdir}/libboost_log.so*
  459. %{_libdir}/libboost_log_setup.so*
  460. %files math
  461. %doc LICENSE_1_0.txt
  462. %{_libdir}/%{name}_math_*.so*
  463. %files program-options
  464. %doc LICENSE_1_0.txt
  465. %{_libdir}/%{name}_program_options*.so*
  466. %files python
  467. %doc LICENSE_1_0.txt
  468. %{_libdir}/%{name}_python*.so*
  469. %files random
  470. %doc LICENSE_1_0.txt
  471. %{_libdir}/%{name}_random*.so*
  472. %files regex
  473. %doc LICENSE_1_0.txt
  474. %{_libdir}/%{name}_regex*.so*
  475. %files serialization
  476. %doc LICENSE_1_0.txt
  477. %{_libdir}/%{name}_serialization*.so*
  478. %{_libdir}/%{name}_wserialization*.so*
  479. %files signals
  480. %doc LICENSE_1_0.txt
  481. %{_libdir}/%{name}_signals*.so*
  482. %files system
  483. %doc LICENSE_1_0.txt
  484. %{_libdir}/%{name}_system*.so*
  485. %files test
  486. %doc LICENSE_1_0.txt
  487. %{_libdir}/%{name}_prg_exec_monitor*.so*
  488. %{_libdir}/%{name}_unit_test_framework*.so*
  489. %files thread
  490. %doc LICENSE_1_0.txt
  491. %{_libdir}/%{name}_thread*.so*
  492. %files timer
  493. %defattr(-, root, root, -)
  494. %doc LICENSE_1_0.txt
  495. %{_libdir}/libboost_timer.so*
  496. %files wave
  497. %doc LICENSE_1_0.txt
  498. %{_libdir}/%{name}_wave*.so*
  499. %changelog
  500. * Mon Nov 25 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.54.0-1
  501. - update tp boost_1_54_0
  502. - all package: including license file
  503. - drop boost_filesystem patch (Patch0)
  504. - sync Fedora boost-1.54.0-5.fc21
  505. - new packages: atomic, chrono, context, locale, log, timer
  506. - add patches
  507. - Patch4, 5, 9, 15, 18..28, 31..38, 42..55
  508. * Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.45.0-2
  509. - fixed crashing throwing exception
  510. "std::runtime_error: locale::facet::_S_create_c_locale name not valid"
  511. on some systems (FreeBSD and some linuxes) when current locale
  512. (LANG,LC_ALL) is not "C"
  513. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 1.45.0-1
  514. - updated to boost_1_45_0
  515. - added random sub-package
  516. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.42.0-4
  517. - rebuilt again on ppc
  518. * Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.42.0-3
  519. - rebuilt with libicu-4.4
  520. * Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-2
  521. - added "-licui18n" to bjam
  522. - added BR: lam
  523. * Sun Feb 07 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-1
  524. - updated to boost_1_42_0
  525. - rebuilt with new toolchain and python-2.6
  526. - added user-config.jam to make libboost_mpi
  527. - added BR: libaio-devel
  528. - added %%{post,postun} -p /sbin/ldconfig
  529. - dropt no use parameter EXPAT_INCLUDE and EXPAT_LIBPATH
  530. - dropt %{_libdir}/%{name}_test_exec_monitor-*.a in %%files %{name}-test
  531. - dropt %%{post,postun} devel section
  532. * Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.36.0-2vl5
  533. - rebuilt with libicu-4.0.1
  534. - changed Group to System Environment/Libraries (except devel package)
  535. * Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.36.0-1vl5
  536. - new upstream release
  537. - add -math subpackage
  538. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35.0-2vl5
  539. - build with python-2.5
  540. - add libboost_XXXX.so symlinks
  541. * Thu May 8 2008 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.35.0-1vl5
  542. - upstream release
  543. - applied new versioning policy
  544. - add EXPAT_INCLUDE and EXPAT_LIBPATH to enable GraphML support
  545. - add new package libboost-system
  546. - Obsolete: *-devel packages
  547. * Sat Sep 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.34.1-0vl3
  548. - rebuilt with libicu-3.6
  549. - changed doc Group to Applications/Documentation
  550. * Sat Aug 18 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.1-0vl2
  551. - upstream release
  552. * Thu Jun 14 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl3
  553. - add --libdir=%%{_libdir} to cope with x86_64 environment
  554. * Sun Jun 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl2
  555. - upstream release
  556. - use Easy Build and Install process with ./configure
  557. - add BuildRequires: libicu-devel
  558. - remove %%{_libdir}/libboost_test_exec_monitor-*.so* from %%files -n libboost-test
  559. - add new packages: libboost-graph, libboost-graph-devel, libboost-wave
  560. - add files to doc package
  561. * Sun May 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.1-0vl2
  562. - rebuilt with new toolchain
  563. * Sat Feb 4 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.1-0vl1
  564. - upstream release
  565. * Mon Dec 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.33.0-0vl3
  566. - fixed typo in Groups:
  567. - devel packages also moved to Development/Libraries group
  568. * Mon Sep 19 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.0-0vl2
  569. - spec modified to avoid errors on non-ix86 archtecture
  570. (previously the path linuxx86 was explicitly used)
  571. * Sun Sep 11 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl1
  572. - initial release for Vine Linux
  573. * Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.3
  574. - link /usr/include/boost_%{lnkver}/boost to /usr/include/boost
  575. * Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.2
  576. - change package name from boost to libboost
  577. - separated into sub-packages
  578. * Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.1
  579. - upstream release
  580. - add BuildRequires: bzip2-devel zlib-devel
  581. * Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.7
  582. - added so.* file
  583. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.6
  584. - moved %post, %postun script to -devel package
  585. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.5
  586. - moved doc/html to -devel package
  587. - make a symbolic link on %{_includedir}/boost
  588. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.4
  589. - fixed character code to euc-jp
  590. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.3
  591. - add %doc files
  592. * Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.2
  593. - remove Requires
  594. - split -devel package
  595. * Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.1
  596. - initial build for Vine Linux