tcl-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319
  1. %define majorver 8.5
  2. %define minorver 15
  3. %define version %{majorver}.%{minorver}
  4. %define htmlver %{majorver}.15
  5. %{!?sdt:%define sdt 0}
  6. Summary: A Tcl/Tk development environment: tcl
  7. Summary(ja): Tcl/Tk 開発環境: tcl
  8. Name: tcl
  9. Version: %{version}
  10. Release: 1%{?_dist_release}
  11. Group: Development/Languages
  12. License: TCL
  13. URL: http://tcl.sourceforge.net/
  14. Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  15. Source1: http://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
  16. # patches from Red Hat Enterprise Linux tcl-8.5.7-6.el6
  17. Patch100: tcl-8.5.1-autopath.patch
  18. Patch101: tcl-8.5.15-conf.patch
  19. Patch102: tcl-8.5.0-hidden.patch
  20. Buildroot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: libtool, util-linux, perl, gdbm, autoconf, imake
  22. %if %sdt
  23. BuildRequires: systemtap-sdt-devel
  24. %endif
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. Tcl is a simple scripting language designed to be embedded into
  29. other applications. Tcl is designed to be used with Tk, a widget
  30. set, which is provided in the tk package. This package also includes
  31. tclsh, a simple example of a Tcl application.
  32. %description -l ja
  33. Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
  34. ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
  35. デザインしています。このパッケージにはTclの簡単な例として、tclsh
  36. も含んでいます。
  37. %prep
  38. %setup -n %{name}%{version} -q -a 1
  39. mv tcl%{htmlver}/html .
  40. %patch100 -p1 -b .autopath
  41. %patch101 -p1 -b .conf
  42. %patch102 -p1 -b .hidden
  43. %build
  44. pushd unix
  45. autoconf
  46. %configure \
  47. %if %sdt
  48. --enable-dtrace \
  49. %endif
  50. --disable-threads \
  51. --enable-symbols \
  52. --enable-shared
  53. make %{?_smp_mflags} TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
  57. ln -s tclsh%{majorver} $RPM_BUILD_ROOT%{_bindir}/tclsh
  58. # for linking with -lib%{name}
  59. ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  60. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}
  61. # postgresql and maybe other packages too need tclConfig.sh
  62. # paths don't look at /usr/lib for efficiency, so we symlink into tcl8.5 for now
  63. ln -s %{_libdir}/%{name}Config.sh $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}/%{name}Config.sh
  64. mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic,unix}
  65. find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
  66. ( cd $RPM_BUILD_ROOT/%{_includedir}
  67. for i in *.h ; do
  68. [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
  69. done
  70. )
  71. # remove buildroot traces
  72. sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
  73. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tclAppInit.c
  74. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/ldAix
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %post -p /sbin/ldconfig
  78. %postun -p /sbin/ldconfig
  79. %files
  80. %defattr(-,root,root,-)
  81. %doc html/*
  82. %{_bindir}/tclsh*
  83. %{_datadir}/tcl%{majorver}
  84. %{_libdir}/libtcl%{majorver}.so
  85. %{_libdir}/tclConfig.sh
  86. %{_libdir}/tcl%{majorver}/tclConfig.sh
  87. %{_mandir}/man1/*
  88. %{_includedir}/*
  89. %{_datadir}/%{name}8
  90. %{_libdir}/libtclstub%{majorver}.a
  91. %{_libdir}/libtcl.so
  92. %{_mandir}/man3/*
  93. %{_mandir}/mann/*
  94. %changelog
  95. * Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.5.15-1
  96. - update to 8.5.15
  97. - update Patch101 (tcl-8.5.15-conf.patch)
  98. - remove Patch103 (tcl-8.5.7-sigabrt.patch)
  99. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
  100. - update to 8.5.7: sync Red Hat Enterprise Linux 6 tcl-8.5.7-6.el6
  101. - update License: TCL
  102. - drop obsolete patches
  103. - tclm4-soname patch (Patch1)
  104. - lib-perm patch (Patch2)
  105. - configure patch (Patch3)
  106. - no rpath patch (Patch4)
  107. - init lib64 patch (Patch10)
  108. - add some patches from RHEL tcl-8.5.7-6.el6
  109. - autopath patch (Patch100)
  110. - conf patch (Patch101)
  111. - hidden patch (Patch102)
  112. - sigabrt patch (Patch103)
  113. - update build and install section: sync RHEL tcl-8.5.7-6.el6
  114. - add BR: systemtap-sdt-devel: default disable
  115. * Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
  116. - added imake to BR:.
  117. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
  118. - rebuilt with rpm-4.8.1-3
  119. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
  120. - rebuilt with new environment
  121. - updated Patch3: tcl8.4.16-configure.patch
  122. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  123. - new upstream release
  124. * Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
  125. - spec in UTF-8
  126. - configure with disabled threads. See:
  127. https://bugzilla.redhat.com/show_bug.cgi?id=443246
  128. http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
  129. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  130. - rebuild with new environment
  131. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  132. - updated tcl to 8.4.18
  133. - updated tcl-html to 8.4.18
  134. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  135. - updated tcl to 8.4.16
  136. - updated tcl-html to 8.4.16
  137. - dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
  138. - added Patch3: tcl8.4.16-configure.patch
  139. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  140. - updated tcl to 8.4.15
  141. - updated tcl-html to 8.4.15
  142. - dropt Patch1: tcl-8.3.5-tclm4-soname.patch
  143. - added Patch10: tcl-8.4.15-init.lib64.patch
  144. - rebuilt with new toolchain
  145. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  146. - updated tcl to 8.4.13
  147. - updated tcl-html to 8.4.13
  148. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  149. - updated tcl to 8.4.12
  150. - updated patch4
  151. * Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
  152. - updated tcl to 8.4.11
  153. - updated Patch4
  154. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  155. - updated tcl to 8.4.6
  156. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  157. - merged with fedora
  158. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
  159. - removed rpath (patch 4)
  160. * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
  161. - put private header files under generic and unix subdirs
  162. - include real generic/tclPort.h not just a symlink to tclUnixPort.h
  163. - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
  164. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  165. - new package split out from tcltk
  166. - update to tcl 8.4.5 (#88429)
  167. - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
  168. and tcl8.3.5-koi8-u.enc-88806.patch
  169. - include private include headers under %{_includedir}/tcl-private
  170. - filtered changelog for tcl
  171. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  172. * Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  173. - update based on BitWalk's tcltk-8.4.2-83bw
  174. * Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
  175. - split source package.
  176. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  177. - expand some macros.. (FIXME)
  178. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  179. - use %configure macros
  180. - add Patch 47,50
  181. * Thu May 31 2001 <sagami@vinelinux.org>
  182. - 8.0.5_jp-10
  183. - unexpand old %%{configure}, new one causes build failure
  184. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  185. - install manpages into %%{_mandir} and mode 644
  186. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  187. - 8.0.5_jp-9
  188. - modified %install section to handle compressed man pages
  189. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  190. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  191. - changed default fonts
  192. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  193. - added defattr
  194. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  195. - added some symlinks, such as libtcl8.0.so.
  196. - obsoletes version number using _jp, now 8.0.5-31vl1
  197. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  198. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  199. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  200. - fix tclX symlinks.
  201. - compile on systems where SIGPWR == SIGLOST.
  202. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  203. - update tcl/tk to 8.0.5.
  204. - avoid "containing" in Tix (#2332).
  205. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  206. - use /usr/bin/write in kibitz (#1320).
  207. - use cirrus.sprl.umich.edu in weather (#1926).
  208. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  209. - auto rebuild in the new build environment (release 28)
  210. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  211. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  212. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  213. - expect does unaligned access on alpha (#989)
  214. - upgrade tcl/tk/tclX to 8.0.4
  215. - upgrade expect to 5.28.
  216. - add itcl 3.0.1
  217. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  218. - call libtoolize to allow building on the arm
  219. - build for glibc 2.1
  220. - strip binaries
  221. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  222. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  223. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  224. - expect: mkpasswd needs delay before sending password (problem #576)
  225. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  226. - translations modified for de, fr, tr
  227. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  228. - fixed expect binaries exec permissions
  229. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  230. - updated to Tix 4.1.0.006
  231. - updated version numbers of tcl/tk to relflect includsion of p2
  232. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  233. - updated tcl/tk to patch level 2
  234. - updated tclX to 8.0.2
  235. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  236. - fixed filelist for tix... replacing path to the expect binary in scripts
  237. was leaving junk files around.
  238. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  239. - added patch to remove libieee test in configure.in for tcl and tk.
  240. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  241. solution for all systems
  242. - fixed src urls
  243. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  244. - removed version numbers from descriptions
  245. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  246. - updated to tcl/tk 8.0 and related versions of packages
  247. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  248. - built against glibc
  249. - fixed dangling tclx/tkx symlinks