pinentry-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400
  1. Name: pinentry
  2. Version: 1.1.1
  3. Release: 1%{?_dist_release}
  4. Summary: Collection of simple PIN or passphrase entry dialogs
  5. Group: accessories
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. # qt & qt4 subpackage have different license, see subpackage definitions
  9. License: GPLv2+
  10. URL: http://www.gnupg.org/aegypten/
  11. Source0: https://gnupg.org/ftp/gcrypt/pinentry/pinentry-%{version}.tar.bz2
  12. Source1: https://gnupg.org/ftp/gcrypt/pinentry/pinentry-%{version}.tar.bz2.sig
  13. # borrowed from opensuse
  14. Source10: pinentry-wrapper
  15. BuildRequires: gcr-devel
  16. BuildRequires: gtk2-devel
  17. BuildRequires: libcap-devel
  18. BuildRequires: ncurses-devel
  19. BuildRequires: libgpg-error-devel
  20. BuildRequires: libassuan-devel
  21. BuildRequires: libsecret-devel
  22. BuildRequires: pkgconfig(Qt5Core) pkgconfig(Qt5Gui) pkgconfig(Qt5Widgets)
  23. Requires(pre): %{_sbindir}/update-alternatives
  24. Requires(post): /sbin/install-info
  25. Requires(preun): /sbin/install-info
  26. Provides: %{name}-curses = %{version}-%{release}
  27. %description
  28. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  29. utilize the Assuan protocol as described by the aegypten project; see
  30. http://www.gnupg.org/aegypten/ for details.
  31. This package contains the curses (text) based version of the PIN entry dialog.
  32. %package gnome3
  33. Summary: Passphrase/PIN entry dialog for GNOME 3
  34. Group: accessories
  35. Requires: %{name} = %{version}-%{release}
  36. Provides: %{name}-gui = %{version}-%{release}
  37. %description gnome3
  38. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  39. utilize the Assuan protocol as described by the aegypten project; see
  40. http://www.gnupg.org/aegypten/ for details.
  41. This package contains the GNOME 3 version of the PIN entry dialog.
  42. %package gtk
  43. Summary: Passphrase/PIN entry dialog based on GTK+
  44. Group: accessories
  45. Requires: %{name} = %{version}-%{release}
  46. Provides: %{name}-gui = %{version}-%{release}
  47. Provides: pinentry-gtk2 = %{version}-%{release}
  48. %description gtk
  49. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  50. utilize the Assuan protocol as described by the aegypten project; see
  51. http://www.gnupg.org/aegypten/ for details.
  52. This package contains the GTK GUI based version of the PIN entry dialog.
  53. %package qt
  54. Summary: Passphrase/PIN entry dialog based on Qt5
  55. Group: accessories
  56. Requires: %{name} = %{version}-%{release}
  57. Provides: %{name}-gui = %{version}-%{release}
  58. Obsoletes: pinentry-qt4 < 0.8.0-2
  59. Provides: pinentry-qt5 = %{version}-%{release}
  60. %description qt
  61. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  62. utilize the Assuan protocol as described by the aegypten project; see
  63. http://www.gnupg.org/aegypten/ for details.
  64. This package contains the Qt5 GUI based version of the PIN entry dialog.
  65. %package emacs
  66. Summary: Passphrase/PIN entry dialog based on emacs
  67. Group: accessories
  68. Requires: %{name} = %{version}-%{release}
  69. %description emacs
  70. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  71. utilize the Assuan protocol as described by the aegypten project; see
  72. http://www.gnupg.org/aegypten/ for details.
  73. This package contains the emacs based version of the PIN entry dialog.
  74. %debug_package
  75. %prep
  76. %setup -q
  77. %build
  78. %if 0%{?fedora} > 22
  79. # FTBFS on f23/gcc5 without this
  80. CXXFLAGS="%{optflags} -std=c++11"
  81. %endif
  82. %configure \
  83. --disable-rpath \
  84. --disable-dependency-tracking \
  85. --without-libcap \
  86. --enable-pinentry-gnome3 \
  87. --enable-pinentry-gtk2 \
  88. --enable-pinentry-qt5 \
  89. --enable-pinentry-emacs \
  90. --enable-libsecret
  91. make %{?_smp_mflags}
  92. %install
  93. make install DESTDIR=$RPM_BUILD_ROOT
  94. # Symlink for Backward compatibility
  95. ln -s pinentry-gtk-2 $RPM_BUILD_ROOT%{_bindir}/pinentry-gtk
  96. ln -s pinentry-qt $RPM_BUILD_ROOT%{_bindir}/pinentry-qt4
  97. install -p -m755 -D %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/pinentry
  98. # unpackaged files
  99. rm -fv $RPM_BUILD_ROOT%{_infodir}/dir
  100. %post
  101. if [ -f %{_infodir}/pinentry.info* ]; then
  102. /sbin/install-info %{_infodir}/pinentry.info %{_infodir}/dir ||:
  103. fi
  104. %preun
  105. if [ $1 -eq 0 -a -f %{_infodir}/pinentry.info* ] ; then
  106. /sbin/install-info --delete %{_infodir}/pinentry.info %{_infodir}/dir ||:
  107. fi
  108. %files
  109. %{!?_licensedir:%global license %%doc}
  110. %license COPYING
  111. %doc AUTHORS ChangeLog NEWS README THANKS TODO
  112. %{_bindir}/pinentry-curses
  113. %{_bindir}/pinentry
  114. %{_infodir}/pinentry.info*
  115. %files gnome3
  116. %{_bindir}/pinentry-gnome3
  117. %files gtk
  118. %{_bindir}/pinentry-gtk
  119. %{_bindir}/pinentry-gtk-2
  120. %files qt
  121. %{_bindir}/pinentry-qt
  122. # symlink for backward compatibility
  123. %{_bindir}/pinentry-qt4
  124. %files emacs
  125. %{_bindir}/pinentry-emacs
  126. %changelog
  127. * Thu Feb 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.1-1
  128. - new upstream release.
  129. * Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-2
  130. - updated Source10.
  131. * Thu Mar 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-1
  132. - new upstream release.
  133. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 0.9.7-4
  134. - rebuild with gcc-5.4.0
  135. * Sun May 22 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.7-3
  136. - initial build for Vine Linux.
  137. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.7-2
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  139. * Mon Dec 07 2015 Boris Ranto <branto@redhat.com> - 0.9.7-1
  140. - Rebase to latest upstream version
  141. * Tue Oct 27 2015 Stef Walter <stefw@redhat.com> - 0.9.6-4
  142. - Enable libsecret, which enables password caching in pinentry-gnome3
  143. - Resolves rhbz#1275567
  144. * Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 0.9.6-3
  145. - Add pinentry-gnome3 support to pinentry wrapper
  146. * Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 0.9.6-2
  147. - Build pinentry-gnome3
  148. * Fri Sep 11 2015 Boris Ranto <branto@redhat.com> - 0.9.6-1
  149. - Rebase to latest upstream version
  150. - Modify backwards compatible symlink for qt(4)
  151. - Enable pinentry-emacs since it was enabled by default in 0.9.5
  152. * Thu Jul 02 2015 Boris Ranto <branto@redhat.com> - 0.9.5-1
  153. - Rebase to latest upstream version
  154. - Removing qt4 pinentry patch -- got merged upstream
  155. - New package pinentry-emacs that hosts pinentry-emacs
  156. - New dependencies on libassuan and libgpg-error (de-bundling)
  157. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
  158. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  159. * Thu May 14 2015 Boris Ranto <branto@redhat.com> - 0.9.2-1
  160. - Rebase to latest upstream version
  161. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.9.1-2
  162. - Rebuilt for GCC 5 C++11 ABI change
  163. * Wed Mar 25 2015 Boris Ranto <branto@redhat.com> - 0.9.1-1
  164. - Rebase to latest upstream version
  165. - There are no longer any moc files so there is no need to patch them
  166. * Fri Mar 13 2015 Rex Dieter <rdieter@fedoraproject.org> - 0.9.0-3
  167. - fix FTBFS on f23/gcc5
  168. - drop deprecated configure flags
  169. * Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.9.0-2
  170. - Rebuilt for Fedora 23 Change
  171. https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
  172. * Wed Nov 12 2014 Boris Ranto <branto@redhat.com> - 0.9.0-1
  173. - Rebase to latest upstream version
  174. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
  175. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  176. * Tue Aug 12 2014 Boris Ranto <branto@redhat.com> - 0.8.3-6
  177. - fix bogus dates
  178. - upgrade pinentry-wrapper to handle corner cases better
  179. * Wed Jul 30 2014 Tom Callaway <spot@fedoraproject.org> - 0.8.3-5
  180. - fix license handling
  181. * Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> 0.8.3-4
  182. - /usr/bin/pinentry should not check if stderr is opened (#787775)
  183. * Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> - 0.8.3-3
  184. - .spec cleanup (drop support for old releases)
  185. - -gtk: Provides: pinentry-gtk2
  186. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-2
  187. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  188. * Thu Jan 30 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.3-1
  189. - Update to latest upstream version (0.8.3)
  190. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-11
  191. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  192. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-10
  193. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  194. * Wed Nov 14 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-9
  195. - Fix macros expansions so that conditionals work
  196. * Mon Nov 12 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-8
  197. - Fix up licenses for qt and qt4 subpackages (#875875)
  198. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-7
  199. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  200. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-6
  201. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  202. * Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 0.8.1-5
  203. - Rebuild for new libpng
  204. * Tue Jul 26 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-4
  205. - Improve wrapper to fallback to curses even with DISPLAY set (#622077)
  206. * Fri Feb 18 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-3
  207. - Fix pinentry-curses running as root by disabling capabilities (#677670)
  208. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
  209. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  210. * Tue Feb 1 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-1
  211. - Updated to latest upstream version (0.8.1)
  212. * Fri May 7 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-3
  213. - Fix X11 even race with gtk (#589998)
  214. - Fix qt4 problems with creating window in the background (#589532)
  215. * Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.8.0-2
  216. - -qt: build as qt4 version, and drop qt3 support (f13+ only)
  217. * Tue Apr 27 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-1
  218. - pinentry-0.8.0
  219. - pinentry-gtk keyboard grab fail results in SIGABRT (#585422)
  220. * Sun Apr 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-5
  221. - pinentry-gtk -g segfaults on focus change (#520236)
  222. * Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-4
  223. - Errors installing with --excludedocs (#515925)
  224. * Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-3
  225. - drop alternatives, use app-wrapper instead (borrowed from opensuse)
  226. - -qt4 experimental subpkg, -qt includes qt3 version again (#523488)
  227. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.6-2
  228. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  229. * Mon Jun 22 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-1
  230. - pinentry-0.7.6
  231. - -qt switched qt4 version, where applicable (f9+, rhel6+)
  232. - fixup scriptlets
  233. * Sat Apr 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.5-1
  234. - pinentry-0.7.5
  235. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-6
  236. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  237. * Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-5
  238. - pinentry failed massrebuild attempt for GCC 4.3 (#434400)
  239. * Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-4
  240. - s/qt-devel/qt3-devel/ (f9+)
  241. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.7.4-3
  242. - Autorebuild for GCC 4.3
  243. * Sun Feb 17 2008 Adam Tkac <atkac redhat com> - 0.7.4-2
  244. - rebuild against new libcap
  245. * Sun Dec 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.4-1
  246. - pinentry-0.7.4
  247. - BR: libcap-devel
  248. * Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-2
  249. - respin (BuildID)
  250. * Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-1
  251. - pinentry-0.7.3
  252. - License: GPLv2+
  253. * Thu May 10 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.2-15
  254. - respin (for ppc64)
  255. * Mon Dec 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-14
  256. - -14 respin (to help retire ATrpms pinentry pkg)
  257. * Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-3
  258. - fc6 respin
  259. * Wed Aug 09 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-2
  260. - fc6 respin
  261. * Wed Mar 01 2006 Rex Dieter <rexdieter[AT]users.sf.net>
  262. - fc5: gcc/glibc respin
  263. * Tue Oct 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.7.2-1
  264. - 0.7.2, docs patch applied upstream.
  265. - Switch to GTK2 in -gtk.
  266. - Fine tune dependencies.
  267. - Build with dependency tracking disabled.
  268. - Clean up obsolete pre-FC2 support.
  269. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.7.1-4
  270. - rebuilt
  271. * Wed Jun 30 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.3
  272. - BuildRequires qt-devel >= 3.2.
  273. * Sat May 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.2
  274. - Spec cleanups.
  275. * Sat Apr 24 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.1
  276. - Update to 0.7.1.
  277. * Fri Dec 26 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.0-0.fdr.1
  278. - Update to 0.7.0.
  279. - Split GTK+ and QT dialogs into subpackages.
  280. * Thu Jul 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.9-0.fdr.1
  281. - Update to 0.6.9.
  282. - Smoother experience with --excludedocs.
  283. - Don't change alternative priorities on upgrade.
  284. * Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.fdr.1
  285. - Update to current Fedora guidelines.
  286. * Wed Feb 12 2003 Warren Togami <warren@togami.com> 0.6.8-1.fedora.3
  287. - info/dir temporary workaround
  288. * Sat Feb 8 2003 Ville Skyttä <ville.skytta at iki.fi> - 0.6.8-1.fedora.1
  289. - First Fedora release.