jasper-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: jasper
  3. Summary: implementation of the JPEG-2000 standard, Part 1
  4. Version: 2.0.24
  5. Release: 1%{?_dist_release}
  6. Group: graphics
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: Modified BSD (see LICENSE)
  10. URL: https://www.ece.uvic.ca/~frodo/jasper/
  11. Source: https://github.com/mdadams/jasper/archive/version-%{version}.tar.gz#/%{name}-version-%{version}.tar.gz
  12. # skip hard-coded prefix/lib rpath
  13. Patch1: jasper-2.0.14-rpath.patch
  14. Patch1000: CVE-2021-3272.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: autoconf automake libtool
  17. BuildRequires: freeglut-devel
  18. BuildRequires: libGLU-devel
  19. BuildRequires: libjpeg-devel
  20. BuildRequires: pkgconfig
  21. BuildRequires: cmake
  22. BuildRequires: git
  23. Requires: %{name}-libs = %{version}-%{release}
  24. %description
  25. JasPer is a collection of software (i.e., a library and application
  26. programs) for the coding and manipulation of images. This software
  27. can handle image data in a variety of formats. One such format
  28. supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
  29. %package devel
  30. Summary: Include Files and Documentation for jasper
  31. Group: programming
  32. Requires: %{name}-libs = %{version}-%{release}
  33. Requires: libjpeg-devel
  34. %description devel
  35. This package contains libjasper, a library implementing the JPEG-2000
  36. image compression standard Part 1.
  37. %package libs
  38. Summary: Runtime libraries for %{name}
  39. Group: system
  40. %description libs
  41. This package contains runtime libraries for JasPer.
  42. # compat32
  43. %package -n compat32-%{name}-devel
  44. Summary: Include Files and Documentation for jasper
  45. Group: programming
  46. Requires: %{name}-libs = %{version}-%{release}
  47. Requires: compat32-libjpeg-devel
  48. %description -n compat32-%{name}-devel
  49. This package contains libjasper, a library implementing the JPEG-2000
  50. image compression standard Part 1.
  51. %package -n compat32-%{name}-libs
  52. Summary: Runtime libraries for %{name}
  53. Group: system
  54. %description -n compat32-%{name}-libs
  55. This package contains runtime libraries for JasPer.
  56. %debug_package
  57. %prep
  58. %autosetup -S git -n %{name}-version-%{version}
  59. %build
  60. mkdir -p builder
  61. pushd builder
  62. %cmake -DJAS_ENABLE_DOC:BOOL=OFF ..
  63. popd
  64. %make_build -C builder
  65. %install
  66. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  67. make install/fast DESTDIR=%{buildroot} -C builder
  68. # Unpackaged files
  69. rm -f doc/README
  70. rm -f %{buildroot}%{_libdir}/lib*.la
  71. rm -rf %{buildroot}%{_docdir}/JasPer
  72. %check
  73. make test -C builder
  74. %clean
  75. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  76. %post libs -p /sbin/ldconfig
  77. %postun libs -p /sbin/ldconfig
  78. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  79. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  80. %files
  81. %defattr(-,root,root)
  82. %{!?_licensedir:%global license %%doc}
  83. %{_bindir}/*
  84. %{_mandir}/man1/*
  85. %files libs
  86. %license COPYRIGHT LICENSE
  87. %doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
  88. %defattr(-,root,root)
  89. %{_libdir}/libjasper*.so.*
  90. %files devel
  91. %defattr(-,root,root)
  92. %{_includedir}/jasper
  93. %{_libdir}/libjasper*.so
  94. %{_libdir}/pkgconfig/jasper.pc
  95. # compat32
  96. %if %{build_compat32}
  97. %files -n compat32-%{name}-libs
  98. %defattr(-,root,root)
  99. %{_libdir}/libjasper*.so.*
  100. %files -n compat32-%{name}-devel
  101. %defattr(-,root,root)
  102. %{_libdir}/libjasper*.so
  103. %{_libdir}/pkgconfig/jasper.pc
  104. %endif
  105. %changelog
  106. * Thu Feb 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.24-1
  107. - new upstream release.
  108. - added Patch1000 to fix CVE-2021-3272.
  109. * Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.23-1
  110. - new upstream release.
  111. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.19-1
  112. - new upstream release.
  113. * Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.16-1
  114. - new upstream release.
  115. - dropped Patch1: fixed in upstream.
  116. - imported Patch1 from rawhide.
  117. * Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
  118. - new upstream release.
  119. - dropped all patches.
  120. - imported patch1 from rawhide.
  121. * Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
  122. - added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
  123. * Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
  124. - imported all patches from RawHide.
  125. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
  126. - rebuild with libpng-1.6.12
  127. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
  128. - rebuilt with current VineSeed
  129. * Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
  130. - added compat32 subpackage for x86_64 arch support.
  131. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
  132. - splited out runtime library to sub package
  133. - enable opengl again, add BuildRequires: freeglut-devel
  134. * Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
  135. - remove .la
  136. - add --disable-static to configure option
  137. * Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
  138. - added Patch0 from VinePlus/4.0
  139. * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
  140. - add patch100 for fix CVE-2007-2721
  141. - add Vendor/Distributin Tag
  142. * Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
  143. - remove BuildPrereq: freeglut-devel and Requires freeglut
  144. - add --disable-opengl to configure option
  145. * Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
  146. - add BuildPreReq: unzip (used in the %%pre section)
  147. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
  148. - new upstream release
  149. * Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
  150. - new upstream release
  151. - changed Group to System Environment/Libraries
  152. - added --mandir=%{_mandir}
  153. - added %post and %postun section
  154. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
  155. - added --libdir=%{_libdir} configure option
  156. * Tue Sep 5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
  157. - build with freeglut
  158. - change BuildPrereq and Requires
  159. * Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
  160. - new upstream version (jasper-1.701.0)
  161. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
  162. - rebuild for VineSeedPlus
  163. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
  164. - source upgrade
  165. - change spec to build for VineLinux
  166. * Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
  167. - spec file created