incron-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. Summary: Inotify cron system
  2. Name: incron
  3. Version: 0.5.12
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Base
  6. License: GPLv2
  7. URL: http://inotify.aiken.cz
  8. Source0: http://inotify.aiken.cz/download/incron/%{name}-%{version}.tar.gz
  9. Source1: incrond.init
  10. Patch0: incron-0.5.10-gcc.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. Requires(post): /sbin/chkconfig
  13. Requires(preun): /sbin/chkconfig, /sbin/service
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. Packager: tomop
  17. %description
  18. This program is an "inotify cron" system.
  19. It consists of a daemon and a table manipulator.
  20. You can use it a similar way as the regular cron.
  21. The difference is that the inotify cron handles
  22. filesystem events rather than time periods.
  23. %prep
  24. %setup -q
  25. %patch0 -p1 -b .gcc
  26. %build
  27. make %{?_smp_mflags} CXXFLAGS="%{optflags}"
  28. %install
  29. rm -rf %{buildroot}
  30. #install files manually since source Makefile tries to do it as root
  31. install -D -p incrond %{buildroot}%{_sbindir}/incrond
  32. install -D -p -m 4755 incrontab %{buildroot}%{_bindir}/incrontab
  33. install -d %{buildroot}%{_localstatedir}/spool/%{name}
  34. install -d %{buildroot}%{_sysconfdir}/%{name}.d
  35. install -D -p -m 0755 %{SOURCE1} %{buildroot}%{_initdir}/incrond
  36. install -D -p -m 0644 incron.conf.example %{buildroot}%{_sysconfdir}/%{name}.conf
  37. # install manpages
  38. make install-man MANPATH="%{buildroot}%{_mandir}" INSTALL="install -D -p"
  39. %post
  40. if [ $1 -eq 1 ]; then
  41. /sbin/chkconfig --add incrond
  42. fi
  43. %preun
  44. if [ $1 -eq 0 ]; then
  45. /sbin/service %{name} stop >/dev/null 2>&1 || :
  46. /sbin/chkconfig --del incrond
  47. fi
  48. %postun
  49. if [ $1 -ge 1 ]; then
  50. /sbin/service incrond condrestart >/dev/null 2>&1 || :
  51. fi
  52. %clean
  53. rm -rf %{buildroot}
  54. %files
  55. %defattr(-,root,root,-)
  56. %license COPYING LICENSE*
  57. %doc CHANGELOG README TODO
  58. %attr(4755,root,root) %{_bindir}/incrontab
  59. %{_sbindir}/incrond
  60. %{_initdir}/incrond
  61. %config(noreplace) %{_sysconfdir}/%{name}.conf
  62. %{_mandir}/man1/incrontab.1.gz
  63. %{_mandir}/man5/incrontab.5.gz
  64. %{_mandir}/man5/incron.conf.5.gz
  65. %{_mandir}/man8/incrond.8.gz
  66. %dir %{_localstatedir}/spool/%{name}
  67. %dir %{_sysconfdir}/%{name}.d
  68. %changelog
  69. * Thu Jul 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-1
  70. - new upstream release.
  71. * Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-2
  72. - rebuilt with current environment.
  73. * Fri May 04 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-1
  74. - new upstream release.
  75. - built for Vine Linux.
  76. * Thu Feb 16 2012 Jon Ciesla <limburgher@gmail.com> - 0.5.9-4
  77. - Migrate to systemd, BZ 789688.
  78. - gcc47 patch.
  79. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-3
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  81. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-2
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  83. * Mon Dec 21 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.9-1
  84. - Upstream released new version
  85. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.8-2
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  87. * Wed Feb 25 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.8-1
  88. - Upstream released new version
  89. - GCC 4.4 fixes
  90. - Drop GCC 4.3 patch, fixed upstream
  91. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.7-2
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  93. * Sat Feb 09 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 0.5.7-1
  94. - Sync with upstream
  95. * Tue Mar 13 2007 <ruben@rubenkerkhof.com> 0.5.5-1
  96. - Sync with upstream
  97. * Mon Feb 12 2007 <ruben@rubenkerkhof.com> 0.5.4-1
  98. - Update to new upstream version
  99. - Upstream fixed permissions on pidfile
  100. - New manpage for incron.conf
  101. - Upstream fixed example conf file
  102. * Sun Feb 04 2007 <ruben@rubenkerkhof.com> 0.5.1-1
  103. - Updated to new upstream version
  104. - Upstream fixed the incorrect encoding of the LICENSE-GPL file
  105. * Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.5.0-1
  106. - Updated to new upstream version
  107. - Changed the service name in the scriptlets
  108. - Added a configuration file
  109. - Included GPL License
  110. * Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.4.0-1
  111. - First try at packaging it up