self-build-k3b-extra-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132
  1. %define pkgname k3b-extra
  2. %define name self-build-%{pkgname}
  3. %define version 2.0.2
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://downloads.sourceforge.net/project/k3b/k3b/%{version}/k3b-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPLv2
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.8
  15. Requires(post): self-build-ffmpeg
  16. Requires(post): self-build-lame
  17. Requires(post): self-build-libmad
  18. Requires(post): desktop-file-utils
  19. Requires(post): gettext
  20. Requires(post): kdelibs4-devel
  21. Requires(post): kdemultimedia4-devel
  22. Requires(post): libdvdread-devel
  23. Requires(post): libmusicbrainz-devel
  24. Requires(post): libsamplerate-devel
  25. Requires(post): taglib-devel
  26. Requires: k3b >= %{version}
  27. BuildArch: noarch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. Packager: inagaki
  30. %description
  31. This package contains additional plugins for K3b.
  32. - FFMpeg decoder for decoding WMA file(s)
  33. - MAD decoder for decoding MP3 file(s)
  34. - Lame MP3 encoder for encoding MP3 file(s)
  35. If you install this package, it automaticaly downloads source
  36. code ,compile it, and create rpm packages of k3b-extra.
  37. And the created rpm packages are automatically installed
  38. if installation is executed by apt-get command or synaptic
  39. package manager.
  40. [Note]
  41. This package requires many other packages to compile
  42. targetsoftware. So it consume more disk space than usual.
  43. Also installation takes logner time because of compilation.
  44. (This will take a few minutes to quarter or half of an hour,
  45. depends on building environment)
  46. [About self-build package]
  47. For some kind of software, distributing of binary package
  48. may viorate the patent or law. Therefore we chose self-build
  49. packge, create binary package on your machine, for such kind
  50. of softwares instead of distributing binary package.
  51. Please obey the national law when you use the created binary
  52. packages. And if you want to use the softwares using patented
  53. thechnology, it may be required to get a permission, make an
  54. agreement or purchas a license. Please consider it with your
  55. purpose or way of use and take appropriate action.
  56. %description -l ja
  57. K3b 向けに以下の追加プラグインを提供します.
  58. - WMA ファイルをデコードするための FFMpeg デコーダ
  59. - MP3 ファイルをデコードするための MAD デコーダ
  60. - MP3 ファイルをエンコードするための Lame MP3 エンコーダ
  61. このパッケージをインストールすると、自動的にソースコードを
  62. ダウンロードしてコンパイルし、k3b-extra の rpm パッケージを作成します。
  63. また apt-get コマンドや synaptic パッケージマネージャから実行
  64. した場合は、作成された rpm パッケージのインストールも自動的に
  65. 行います。
  66. [注意]
  67. コンパイルに必要な多くの関連パッケージを要求するので通常より
  68. ディスクの領域を多く消費します。
  69. またインストール時にコンパイルを行うため、通常より時間がかか
  70. る場合があります。(環境にもよりますが数分から数十分程度)
  71. [self-build パッケージについて]
  72. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  73. 違反する可能性があるものがあります。その為、このような問題が
  74. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  75. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  76. ジという方法を採っています。
  77. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  78. アのライセンス、および利用する国の各種法令に従ってください。
  79. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  80. センスの購入などが必要となる場合がありますので、利用する目的
  81. や形態に応じて各自で判断し適切な対応を取ってください。
  82. %prep
  83. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  84. %install
  85. %{__rm} -rf ${RPM_BUILD_ROOT}
  86. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  87. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  88. %clean
  89. %{__rm} -rf ${RPM_BUILD_ROOT}
  90. %posttrans
  91. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}"
  92. %files
  93. %defattr(-,root,root)
  94. %{_datadir}/%{name}
  95. %changelog
  96. * Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-1
  97. - new upstream release
  98. * Sun Sep 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-2
  99. - fixed %%build section to remove qt-devel dependency
  100. * Wed Sep 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
  101. - new upstream release
  102. * Thu Jul 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
  103. - initial bulid for Vine Linux