kdevelop-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491
  1. Name: kdevelop
  2. Summary: Integrated Development Environment for C++/C
  3. Summary(ja): C++/C 向け統合開発環境
  4. Version: 4.2.0
  5. Release: 1%{?_dist_release}
  6. License: GPLv2
  7. URL: http://www.kdevelop.org/
  8. Group: Applications/Development
  9. Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
  10. Source1: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.md5sum
  11. # fixing https://bugs.kde.org/show_bug.cgi?id=236315
  12. Patch100: kdevelop-4.0.0-qmake_qt4.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: desktop-file-utils
  15. BuildRequires: gettext
  16. BuildRequires: kdebase-workspace-devel
  17. BuildRequires: kdevplatform-devel >= 1.2.0
  18. BuildRequires: kdelibs4-devel
  19. BuildRequires: valgrind
  20. Requires: %{name}-libs = %{version}-%{release}
  21. Requires: kdevplatform >= 1.2.0
  22. #Conflicts: kdevelop
  23. %description
  24. The KDevelop Integrated Development Environment provides many features
  25. that developers need as well as providing a unified interface to programs
  26. like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
  27. All development tools needed for C++ programming like Compiler,
  28. Linker, automake and autoconf; KAppWizard, which generates complete,
  29. ready-to-go sample applications; Classgenerator, for creating new
  30. classes and integrating them into the current project; File management
  31. for sources, headers, documentation etc. to be included in the
  32. project; The creation of User-Handbooks written with SGML and the
  33. automatic generation of HTML-output with the KDE look and feel;
  34. Automatic HTML-based API-documentation for your project's classes with
  35. cross-references to the used libraries; Internationalization support
  36. for your application, allowing translators to easily add their target
  37. language to a project;
  38. KDevelop also includes WYSIWYG (What you see is what you get)-creation
  39. of user interfaces with a built-in dialog editor; Debugging your
  40. application by integrating KDbg; Editing of project-specific pixmaps
  41. with KIconEdit; The inclusion of any other program you need for
  42. development by adding it to the "Tools"-menu according to your
  43. individual needs.
  44. %package libs
  45. Summary: %{name} runtime libraries
  46. Summary(ja): %{name} のランタイムライブラリ
  47. Group: System Environment/Libraries
  48. #Requires: %{name} = %{version}-%{release}
  49. Requires: kdelibs4
  50. %description libs
  51. %{summary}.
  52. %package devel
  53. Summary: Development files for %{name}
  54. Summary(ja): %{name} の開発用ファイル
  55. Group: Development/Libraries
  56. Requires: %{name}-libs = %{version}-%{release}
  57. %description devel
  58. %{summary}.
  59. %prep
  60. %setup -q -n kdevelop-%{version}
  61. #patch100 -p1 -b .qmake_qt4
  62. %build
  63. mkdir -p %{_target_platform}
  64. pushd %{_target_platform}
  65. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  66. %cmake \
  67. -DCMAKE_BUILD_TYPE=release \
  68. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  69. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  70. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  71. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  72. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  73. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  74. ..
  75. popd
  76. make %{?_smp_mflags} -C %{_target_platform}
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  80. %find_lang %{name} --all-name --with-kde
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %post
  84. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  85. %postun
  86. if [ $1 -eq 0 ] ; then
  87. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  88. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  89. update-desktop-database -q &> /dev/null
  90. update-mime-database %{_datadir}/mime &> /dev/null
  91. fi
  92. %posttrans
  93. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  94. update-desktop-database -q &> /dev/null
  95. update-mime-database %{_datadir}/mime &> /dev/null
  96. %post libs -p /sbin/ldconfig
  97. %postun libs -p /sbin/ldconfig
  98. %files -f %{name}.lang
  99. %defattr(-,root,root)
  100. %{_bindir}/*
  101. %config %{_datadir}/config/kdeveloprc
  102. %{_datadir}/applications/kde4/*.desktop
  103. %{_datadir}/kde4/apps/kdev*/
  104. %{_datadir}/kde4/services/*.desktop
  105. %{_datadir}/icons/hicolor/*/*/*
  106. %{_datadir}/mime/packages/kdevelop.xml
  107. #{_datadir}/servicetypes/*
  108. #doc %{_datadir}/doc/HTML/en/*
  109. %files libs
  110. %defattr(-,root,root,-)
  111. %{_libdir}/lib*.so
  112. %{_libdir}/kde4/*.so
  113. %files devel
  114. %defattr(-,root,root,-)
  115. %{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
  116. %{_includedir}/kde4/kdevelop/
  117. %changelog
  118. * Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
  119. - new upstream release
  120. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
  121. - new upstream release
  122. * Sat May 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
  123. - new upstream release
  124. - split shared libraries and header files
  125. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
  126. - new upstream release
  127. - applied new versioning policy, spec in UTF-8
  128. - changed Group to Applications/Development
  129. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
  130. - rebuild for VineSeed
  131. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
  132. - new upstream release
  133. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
  134. - rebuild for VineSeed
  135. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
  136. - new upstream release
  137. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
  138. - rebuild for VineSeed
  139. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
  140. - new upstream release
  141. - use ap?-config for Vine3.x and use ap?-1-config for VineSeed
  142. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  143. - rebuild for VineSeed
  144. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  145. - new upstream release
  146. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  147. - rebuild for VineSeed
  148. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  149. - new upstream release
  150. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
  151. - rebuild for VineSeed
  152. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
  153. - new upstream release
  154. - add BuildPrereq: apache2-devel subversion-devel
  155. * Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
  156. - new upstream release
  157. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
  158. - new upstream release
  159. - delete Patch0
  160. * Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
  161. - new upstream release
  162. - add Patch0
  163. - update %%files
  164. * Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
  165. - rebuild for VineSeed
  166. * Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  167. - new upstream release
  168. * Tue Jul 5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
  169. - rebuild for VineSeed
  170. * Tue Jul 5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  171. - new upstream release
  172. - add --disable-rpath to configure option
  173. - remove BuildPrereq: qt-static
  174. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
  175. - rebuild for VineSeed
  176. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
  177. - new upstream release
  178. - update %%files
  179. - add +w to %%{_prefix}/kdevbdb/*
  180. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
  181. - rebuild for VineSeed
  182. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  183. - new upstream release
  184. - update %%files
  185. * Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  186. - source upgrade
  187. - add BuildPrereq: qt-static
  188. * Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  189. - rebuild with qt32
  190. * Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  191. - source upgrade
  192. - remove lines about vine26
  193. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  194. - source upgrade
  195. - add Requires: ctags
  196. * Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
  197. - source upgrade
  198. - remove all patches
  199. - remove c references
  200. - add Requires: htdig
  201. * Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
  202. - change spec to build both VineSeed and Vine2.5/2.6
  203. - change configure options
  204. - add %%clean section
  205. - add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
  206. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
  207. - source upgrade
  208. - change spec to build both VineSeed and Vine2.5/2.6
  209. - change configure option (add -enable--final, remove -enable--debug)
  210. - update %%files section
  211. * Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
  212. - source upgrade
  213. - remove patch1 (rejected)
  214. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
  215. - BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
  216. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
  217. - source upgrade
  218. - revised Source1
  219. - remove Patch1 and Patch4
  220. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
  221. - merged with rawhide 2.1.1-3
  222. - clean up spec
  223. - add BuildPrereq: objprelink (i386 only)
  224. - remove Obsoletes: kdevelop-c_c++_ref
  225. - add BuildPrereq: autoconf252 automake15
  226. - There is Vine's previous changes, hacked for Vine
  227. -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
  228. - build for VineSeed
  229. - delete Epoch
  230. - update Patch1 and delete Patch2
  231. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  232. - automated rebuild
  233. * Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
  234. - don't forcibly strip binaries
  235. * Sun Jun 2 2002 Than Ngo <than@redhat.com> 2.1.1-1
  236. - 2.1.1
  237. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  238. - automated rebuild
  239. * Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
  240. - Use automake15
  241. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
  242. - Change sonames
  243. * Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
  244. - final
  245. * Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
  246. - update
  247. * Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
  248. - update to 2.1rc3
  249. * Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
  250. - update to 2.1rc2
  251. * Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
  252. - rebuild against new kdelibs
  253. * Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
  254. - fixed Strange characters appear in the output window (bug #59217)
  255. - fixed return-line feed sign in Kdevelop setup tool (bug #55032)
  256. * Wed Mar 8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
  257. - update to 2.1beta2
  258. * Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
  259. - rebuild against new kdelibs
  260. * Wed Jan 9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
  261. - update to 2.1 beta1
  262. - fix build against gcc 3
  263. - fix some typo bugs
  264. - get rid of libkfile
  265. - update c_cpp_reference to 2.0.1
  266. * Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
  267. - add patch to show non lattin1 font in build-in editor correct (bug #54457)
  268. * Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
  269. - fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
  270. - backport some major bugfixes from 2.0.1
  271. * Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
  272. - Don't crash on startup
  273. * Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
  274. - Fix file list
  275. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
  276. - Update
  277. * Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  278. - Yet another respin - printing was broken.
  279. * Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  280. - Update the C/C++ reference guide docs. The older version had a
  281. couple of examples that won't work with gcc 2.96-*
  282. * Thu Feb 22 2001 Than Ngo <than@redhat.com>
  283. - fix version number
  284. * Wed Feb 21 2001 Than Ngo <than@redhat.com>
  285. - 1.4-respin
  286. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  287. - 1.4
  288. * Wed Feb 14 2001 Than Ngo <than@redhat.com>
  289. - update (only bugfixes)
  290. - fix up kdelibs documentation path
  291. - fix a dependency problem with kde-i18n package (Bug #27675)
  292. - add qt-designer into requires
  293. * Sun Feb 11 2001 Than Ngo <than@redhat.com>
  294. - fixed to build on s390
  295. * Tue Feb 06 2001 Than Ngo <than@redhat.com>
  296. - update, only bugfixes
  297. * Wed Jan 24 2001 Than Ngo <than@redhat.com>
  298. - hacked for building of KDE references
  299. * Tue Jan 23 2001 Than Ngo <than@redhat.com>
  300. - work-around to build on alpha
  301. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  302. - Update
  303. * Wed Jan 10 2001 Than Ngo <than@redhat.com>
  304. - update new snapshot, only require KDE2/Qt2
  305. * Fri Dec 22 2000 Than Ngo <than@redhat.com>
  306. - fixed dependency problem with kde-i18n
  307. * Thu Dec 21 2000 Than Ngo <than@redhat.com>
  308. - updated to 1.4beta1 with KDE2 support
  309. - fixed to build on s390
  310. - fixed some broken codes
  311. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  312. - fixed for building on ia64
  313. * Wed Nov 15 2000 Than Ngo <than@redhat.com>
  314. - build snapshot 20001112, it works now with KDE2 and kde1-compat
  315. - fix libtool to build on sparc and alpha
  316. - don't use make -j
  317. * Sun Aug 13 2000 Than Ngo <than@redhat.com>
  318. - fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
  319. * Tue Aug 01 2000 Than Ngo <than@redhat.de>
  320. - add missing ldconfig in %post and %postun section (Bug #14924)
  321. - add missing C references stuff to kdevelop
  322. * Sun Jul 30 2000 Than Ngo <than@redhat.de>
  323. - rebuilt against compat-egcs-c++, put KDE1 under /usr
  324. - cleanup specfile
  325. * Tue Jul 25 2000 Than Ngo <than@redhat.de>
  326. - fix dependency problem
  327. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  328. - rebuilt against compat-libstdc++
  329. * Mon Jul 17 2000 Than Ngo <than@redhat.de>
  330. - install under /usr/share instead /usr/lib/kde1-compat/share,
  331. fix dependency problem
  332. * Sat Jul 15 2000 Than Ngo <than@redhat.de>
  333. - rebuilt with egcs-c++-1.1.2
  334. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  335. - automatic rebuild
  336. * Mon Jul 03 2000 Than Ngo <than@redhat.de>
  337. - fix docdir
  338. - add requires kdebase
  339. * Sun Jul 02 2000 Than Ngo <than@redhat.de>
  340. - rebuilt with kde1-compat
  341. * Sun Jun 18 2000 Than Ngo <than@redhat.de>
  342. - rebuilt in the new build environment, fix docdir
  343. - FHS packaging
  344. * Thu Jun 08 2000 Than Ngo <than@redhat.de>
  345. - update to 1.2
  346. - move from powertools to main CD
  347. - use %%configure
  348. * Mon Apr 3 2000 Ngo Than <than@redhat.de>
  349. - fix up reference (Bug #10368)
  350. * Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  351. - Fix up documentation path (Bug #7291)
  352. - Update to current stable branch - this should fix up the debugger problem
  353. - clean up spec file
  354. * Fri Jan 6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  355. - Update to current stable branch
  356. - Adapt to 6.2 Qt libraries
  357. - Use BuildPrereq
  358. * Wed Jan 05 2000 Ngo Than <than@redhat.de>
  359. - added patch for alpha
  360. * Tue Dec 21 1999 Ngo Than <than@redhat.de>
  361. - updated kdevelop-1.0 release
  362. * Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
  363. - kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
  364. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  365. - initial packaging for 6.1.