scim-bridge-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name scim-bridge
  3. %define version 0.4.16
  4. %define release 13%{?_dist_release}
  5. %define qt3_ver 3.3.8
  6. %define qt4_ver 4.7.1
  7. # build qt3 immodule ("--without qt3" to disable qt3)
  8. %bcond_without qt3
  9. # Qt3 version auto-detection -- inagaki
  10. %define _qt3_version %(rpm -q --queryformat "%%{version}" qt-devel 2>/dev/null || echo %{qt3_ver})
  11. %define _qt3_prefix %{_libdir}/qt-%{_qt3_version}
  12. %define _qt3_plugindir %{_qt3_prefix}/plugins
  13. # build qt4 immodule ("--without qt4" to disable qt4)
  14. %bcond_without qt4
  15. # Qt4 version auto-detection -- inagaki
  16. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  17. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  18. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  19. Summary: yet another IM client of SCIM
  20. Summary(ja): もう一つ別の SCIM IM クライアント
  21. Name: %{name}
  22. Version: %{version}
  23. Release: %{release}
  24. Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
  25. # Patch from Fedora 10
  26. Patch0: scim-bridge-0.4.15-fix-gdm.patch
  27. Patch1: scim-bridge-0.4.15-bz461373.patch
  28. # Patch from Mandriva 2009
  29. Patch2: bug-351920-should-return-retval.patch
  30. Patch3: scim-bridge-0.4.15.2-linkage.patch
  31. # Patch from Fedora development
  32. Patch4: scim-bridge-0.4.15-EOF.patch
  33. Patch5: scim-bridge-0.4.15-hotkey-help.patch
  34. Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
  35. Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
  36. URL: http://www.scim-im.org/projects/scim_bridge
  37. License: GPL/LGPL
  38. Group: System Environment/Libraries
  39. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  40. Prefix: %{_prefix}
  41. Requires: scim >= 1.4
  42. BuildRequires: scim-devel >= 1.4
  43. BuildRequires: pkgconfig >= 0.9.0
  44. BuildRequires: gtk2-devel >= 2.14.0
  45. %description
  46. Scim-bridge is yet another IM client of SCIM.
  47. The im-module of scim-bridge communicates with scim via socket.
  48. %description -l ja
  49. scim-bridge は、もう一つ別の SCIM IM クライアントです。
  50. scim-bridge の im-module はソケット経由で SCIM と通信します。
  51. %package gtk
  52. Summary: SCIM Bridge GTK IM Module
  53. Summary(ja): SCIM Bridge GTK IM モジュール
  54. Group: System Environment/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. Requires: gtk2 >= 2.14.0
  57. Requires(post): gtk2 >= 2.14.0
  58. Requires(postun): gtk2 >= 2.14.0
  59. Obsoletes: %{name} <= 0.1.7
  60. %description gtk
  61. This package provides the SCIM Bridge GTK IM module.
  62. %description -l ja gtk
  63. このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
  64. %if !%{without qt3}
  65. %package qt
  66. Summary: SCIM Bridge Qt IM Module
  67. Summary(ja): SCIM Bridge Qt IM モジュール
  68. Group: System Environment/Libraries
  69. Requires: %{name} = %{version}-%{release}
  70. Requires: qt = %{_qt3_version}
  71. BuildRequires: qt-devel
  72. %description qt
  73. This package provides the SCIM Bridge Qt IM module.
  74. %description -l ja qt
  75. このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
  76. %endif
  77. %if !%{without qt4}
  78. %package qt4
  79. Summary: SCIM Bridge Qt4 IM Module
  80. Summary(ja): SCIM Bridge Qt4 IM モジュール
  81. Group: System Environment/Libraries
  82. Requires: %{name} = %{version}-%{release}
  83. Requires: qt4 = %{_qt4_version}
  84. BuildRequires: qt4-devel
  85. %description qt4
  86. This package provides the SCIM Bridge Qt4 IM module.
  87. %description -l ja qt4
  88. このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
  89. %endif
  90. ## to build compat32 for x86_64 architecture support
  91. %package -n compat32-%{name}-gtk
  92. Summary: SCIM Bridge GTK IM Module
  93. Summary(ja): SCIM Bridge GTK IM モジュール
  94. Group: System Environment/Libraries
  95. Requires: %{name} = %{version}-%{release}
  96. Requires: gtk2 >= 2.14.0
  97. Requires(post): gtk2 >= 2.14.0
  98. Requires(postun): gtk2 >= 2.14.0
  99. %description -n compat32-%{name}-gtk
  100. This package provides the SCIM Bridge GTK IM module.
  101. %description -l ja -n compat32-%{name}-gtk
  102. このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
  103. %if !%{without qt3}
  104. %package -n compat32-%{name}-qt
  105. Summary: SCIM Bridge Qt IM Module
  106. Summary(ja): SCIM Bridge Qt IM モジュール
  107. Group: System Environment/Libraries
  108. Requires: %{name} = %{version}-%{release}
  109. Requires: qt = %{_qt3_version}
  110. BuildRequires: qt-devel
  111. %description -n compat32-%{name}-qt
  112. This package provides the SCIM Bridge Qt IM module.
  113. %description -l ja -n compat32-%{name}-qt
  114. このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
  115. %endif
  116. %if !%{without qt4}
  117. %package -n compat32-%{name}-qt4
  118. Summary: SCIM Bridge Qt4 IM Module
  119. Summary(ja): SCIM Bridge Qt4 IM モジュール
  120. Group: System Environment/Libraries
  121. Requires: %{name} = %{version}-%{release}
  122. Requires: qt4 = %{_qt4_version}
  123. BuildRequires: qt4-devel
  124. %description -n compat32-%{name}-qt4
  125. This package provides the SCIM Bridge Qt4 IM module.
  126. %description -l ja -n compat32-%{name}-qt4
  127. このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
  128. %endif
  129. %prep
  130. %setup -q
  131. %patch0 -p1 -b .0-fix-gdm
  132. %patch1 -p1
  133. %patch2 -p1
  134. %patch3
  135. %patch4 -p1
  136. %patch5 -p1
  137. pushd client-gtk
  138. %patch6 -p0
  139. popd
  140. %patch7 -p1
  141. %build
  142. %if !%{without qt3}
  143. export QT3_PREFIX=%{_qt3_prefix}
  144. %endif
  145. %if !%{without qt4}
  146. export QT4_PREFIX=%{_qt4_prefix}
  147. %endif
  148. %configure --disable-static \
  149. %if %{without qt3}
  150. --disable-qt3-immodule \
  151. %else
  152. --enable-qt3-immodule \
  153. %endif
  154. %if %{without qt4}
  155. --disable-qt4-immodule \
  156. %else
  157. --enable-qt4-immodule \
  158. %endif
  159. --enable-gtk2-immodule
  160. %__make %{?_smp_mflags}
  161. %install
  162. %__rm -rf %{buildroot}
  163. #%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
  164. %__make DESTDIR=%{buildroot} install
  165. # remove unneeded files
  166. %__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
  167. %__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
  168. %__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
  169. %clean
  170. %__rm -rf %{buildroot}
  171. %post gtk
  172. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  173. %postun gtk
  174. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  175. %post -n compat32-%{name}-gtk
  176. %{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
  177. %postun -n compat32-%{name}-gtk
  178. %{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
  179. %files
  180. %defattr(-,root,root)
  181. %doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
  182. %{_bindir}/scim-bridge
  183. %files gtk
  184. %defattr(-,root,root)
  185. %{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
  186. %if !%{without qt3}
  187. %files qt
  188. %defattr(-,root,root)
  189. %{_qt3_plugindir}/inputmethods/*.so
  190. %endif
  191. %if !%{without qt4}
  192. %files qt4
  193. %defattr(-,root,root)
  194. %{_qt4_plugindir}/inputmethods/*.so
  195. %endif
  196. ## to build compat32 for x86_64 architecture support
  197. %if %{build_compat32}
  198. %files -n compat32-%{name}-gtk
  199. %defattr(-,root,root)
  200. %{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
  201. %if !%{without qt3}
  202. %files -n compat32-%{name}-qt
  203. %defattr(-,root,root)
  204. %{_qt3_plugindir}/inputmethods/*.so
  205. %endif
  206. %if !%{without qt4}
  207. %files -n compat32-%{name}-qt4
  208. %defattr(-,root,root)
  209. %{_qt4_plugindir}/inputmethods/*.so
  210. %endif
  211. %endif
  212. %changelog
  213. * Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-13
  214. - rebuilt with qt4-4.7.1
  215. * Sat Oct 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.16-12
  216. - added compat32-* packages for x86_64 architecture support
  217. * Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-11
  218. - rebuilt with qt4-4.6.3
  219. * Tue Jun 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-10
  220. - used %{?_smp_mflags} macro on build
  221. - deleted in unused log in changelog
  222. - Patch8 was none, forgot to delete...
  223. * Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
  224. - added Patch6,7 from Fedora development
  225. - to fix Text input in firefox becomes increasingly sluggish (Patch6)
  226. - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
  227. - added configure --disable-static option
  228. * Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
  229. - updated Qt version detection macros to build properly
  230. * Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
  231. - rebuilt with qt4-4.6.1
  232. * Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
  233. - rebuilt with qt4-4.5.3
  234. * Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
  235. - cleaned up spec
  236. - renumbered patch
  237. - added Patch5 from Fedora
  238. * Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
  239. - rebuild with qt4-4.5.2
  240. * Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
  241. - dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
  242. * Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
  243. - rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
  244. * Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
  245. - new upstream release
  246. - dropt Pacth3,4,5 (these patches are merged)
  247. * Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
  248. - spec in UTF-8
  249. - fixed description in scim-bridge-qt4
  250. - added patch6,7 (import Fedora, Mandriva patches)
  251. * Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
  252. - new upstream release
  253. - added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
  254. * Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
  255. - rebuild with qt4-4.4.2
  256. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
  257. - add qt4 immodule
  258. - build gtk,qt3,qt4 immodule by default
  259. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
  260. - rebuild with gtk+-2.14
  261. * Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
  262. - new upstream release
  263. - apply new versioning policy
  264. * Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
  265. - drop unnecessary BuildRequires for qt3-immodule package
  266. - fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
  267. * Wed Jan 9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
  268. - new upstream release
  269. - drop unnecessary Qt fix patch ( Patch0 ): upstream merged
  270. - update BuildRequires
  271. - drop doxygen
  272. - add XOrg-gl-devel for building qt3-immodule
  273. - move libmng-devel for building qt3-immodule
  274. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
  275. - rebuild for Vine Linux 4.2.
  276. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
  277. - add patch0 to fix symbol lookup error with qt3.
  278. * Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
  279. - rebuild for Vine Linux 4.2.
  280. * Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
  281. - new upstrm release
  282. - detect qt version at build time.
  283. - add --disable-qt4-immodule configure option.
  284. - add BuildRequires libmng-devel.
  285. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
  286. - rebuild with libstdc++34
  287. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
  288. - new upstream release
  289. * Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
  290. - change License to GPL/LGPL
  291. - add doc/LICENSE.* as documents
  292. * Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
  293. - new upstream release
  294. - add BuildRequires: doxygen, qt-devel
  295. - add new sub-packages:
  296. - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
  297. - qt: Qt IM module
  298. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
  299. - new upstream release
  300. - add documents
  301. - running gtk-query-immodules-2.0 in post and postun scripts
  302. - add PreReq: gtk2 > 2.2
  303. * Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
  304. - new upstream release
  305. * Thu Apr 6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
  306. - initial release