phonon-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %define qt4_ver 4.7.1
  2. # Qt4 version auto-detection
  3. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  4. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  5. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/include)
  6. %global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
  7. Name: phonon
  8. Summary: Multimedia framework api
  9. Summary(ja): マルチメディアフレームワーク API
  10. Version: 4.4.4
  11. Release: 1%{?_dist_release}
  12. Group: System Environment/Libraries
  13. License: LGPLv2+
  14. URL: http://phonon.kde.org/
  15. Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.4.4/phonon-%{version}.tar.bz2
  16. Patch1: phonon-4.4.4-no_rpath.patch
  17. ## Mandriva/upstreamable patches
  18. Patch53: phonon-4.3.50-phonon-allow-stop-empty-source.patch
  19. ## Upstream patches
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: automoc4 >= 0.9.86
  22. BuildRequires: cmake >= 2.6.2
  23. BuildRequires: glib2-devel
  24. BuildRequires: libxcb-devel
  25. BuildRequires: libxml2-devel
  26. BuildRequires: qt4-devel >= 4.6.0
  27. BuildRequires: pulseaudio-libs-devel >= 0.9.15
  28. # TODO: enable the following Requires in next release
  29. #Requires: phonon-backend >= 4.4
  30. Requires: pulseaudio-libs >= %{pulseaudio_version}
  31. Requires: qt4 >= %{_qt4_version}
  32. %description
  33. Phonon is a cross-platform portable Multimedia Support Abstraction,
  34. which allows you to play multiple audio or video formats with the same
  35. quality on all platforms, no matter which underlying architecture is
  36. used.
  37. %package devel
  38. Summary: Development files for phonon
  39. Summary(ja): phonon の開発用ファイル
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. Requires: qt4-devel
  43. %description devel
  44. Header files for developing applications using phonon
  45. %prep
  46. %setup -q
  47. %patch1 -p1 -b .no_rpath
  48. %patch53 -p1 -b .phonon-allow-stop-empty-source
  49. %build
  50. %ifarch x86_64
  51. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  52. %endif
  53. mkdir -p %{_target_platform}
  54. pushd %{_target_platform}
  55. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  56. %cmake \
  57. ..
  58. popd
  59. make %{?_smp_mflags} -C %{_target_platform}
  60. %install
  61. rm -rf $RPM_BUILD_ROOT
  62. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  63. # symlink for qt/phonon compatibility
  64. ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
  65. # own these dirs
  66. mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
  67. mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
  68. mkdir -p $RPM_BUILD_ROOT%{_qt4_headerdir}
  69. pushd $RPM_BUILD_ROOT%{_qt4_headerdir}
  70. ln -sf %{_includedir}/phonon phonon
  71. popd
  72. %clean
  73. rm -rf $RPM_BUILD_ROOT
  74. %post -p /sbin/ldconfig
  75. %postun -p /sbin/ldconfig
  76. %files
  77. %defattr(-,root,root)
  78. %doc COPYING.LIB
  79. %{_libdir}/*.so.*
  80. %{_datadir}/dbus-1/interfaces/*
  81. # kde4-specific dirs
  82. %dir %{_libdir}/kde4/plugins/phonon_backend
  83. %dir %{_datadir}/kde4/services/phononbackends
  84. %files devel
  85. %defattr(-,root,root)
  86. %dir %{_includedir}/KDE
  87. %{_includedir}/KDE/Phonon/
  88. %{_includedir}/phonon/
  89. %{_qt4_headerdir}/phonon
  90. %{_qt4_prefix}/mkspecs/modules/qt_phonon.pri
  91. %{_libdir}/*.so
  92. %{_libdir}/pkgconfig/*.pc
  93. %{_datadir}/phonon-buildsystem/
  94. %changelog
  95. * Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
  96. - new upstream release
  97. - rebuilt with qt4-4.7.1 on VineSeed
  98. * Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
  99. - new upstream release
  100. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
  101. - added sybolic link in %%{_qt4_headerdir}
  102. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  103. - new upstream release
  104. - dropt Patch51 and 57
  105. - rebuilt with rpm-4.8.1
  106. * Sat Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
  107. - new upstream release
  108. - dropt Patch1, 50, 54 and 100
  109. - added Patch57
  110. * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
  111. - F11: patch/modularize pa device-manager bits
  112. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
  113. - added qmake path to PATH (if x86_64)
  114. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
  115. - new upstream release
  116. - built with new toolchain
  117. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
  118. - added Patch102 and 103 from FC
  119. * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
  120. - fix for '#' in filenames
  121. * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
  122. - restore patches to the xine backend
  123. * Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
  124. - added Patch100 and 101 from FC
  125. * Tue Mar 3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
  126. - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
  127. - added backend sub-pakcages
  128. * Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
  129. - new upstream release
  130. - add BuildPrereq: cmake
  131. * Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
  132. - new upstream release
  133. * Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
  134. - new upstream release
  135. - update %%files
  136. - add BuildPrereq: xine-lib-devel libxcb-devel
  137. * Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
  138. - new upstream release
  139. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
  140. - added script to append qmake path
  141. - added option -DLIB_INSTALL_DIR at cmake
  142. * Tue Oct 7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
  143. - initial release for VineSeed