tomoe-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258
  1. %define with_python 0
  2. # build ruby extension
  3. %define with_ruby %{?_with_ruby:1}%{!?_with_ruby:0}
  4. %define __libtoolize /bin/true
  5. Summary: Japanese handwritten input system
  6. Summary(ja): 日本語手書き文字認識エンジン
  7. Name: tomoe
  8. Version: 0.6.0
  9. Release: 2%{?_dist_release}
  10. Group: System Environment/Libraries
  11. License: LGPL
  12. URL: http://tomoe.sourceforge.jp/
  13. Source0: tomoe-%{version}.tar.gz
  14. Patch0: tomoe-0.6.0-multiarch-conflict.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gtk-doc >= 1.4, libxslt
  17. BuildRequires: glib2-devel >= 2.4.0
  18. #BuildRequires: neon-devel
  19. #BuildRequires: apr-devel, subversion-devel
  20. #BUildRequires: MySQL-devel
  21. BuildRequires: unzip
  22. Requires: glib2 >= 2.4.0
  23. Requires: ldconfig
  24. %description
  25. A program which does Japanese handwriting recognition.
  26. %description -l ja
  27. 日本語の手書き文字を認識するエンジンです。
  28. %package devel
  29. Summary: Header files for developing tomoe applications
  30. Summary(ja): tomoe アプリケーション開発用ヘッダファイル
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. Requires: pkgconfig
  34. %description devel
  35. The tomoe-devel package includes the header files for the tomoe package.
  36. Install this package if you want to develop programs which use tomoe.
  37. %description -l ja devel
  38. tomoe-devel パッケージには、tomoe を使うアプリケーションを開発するための
  39. ヘッダファイルが含まれています。
  40. %if %{with_python}
  41. %package -n python-tomoe
  42. Summary: Tomoe library for Python
  43. Summary(ja): Python から巴を使うためのライブラリ
  44. Group: System Environment/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. Requires: python
  47. BuildRequires: python-devel
  48. %description -n python-tomoe
  49. Python extension library to use Tomoe
  50. %description -l ja -n python-tomoe
  51. Python から巴を使うための拡張ライブラリです。
  52. %endif
  53. %if %{with_ruby}
  54. %package -n ruby-tomoe
  55. Summary: Tomoe library for Ruby
  56. Summary(ja): Ruby から巴を使うためのライブラリ
  57. Group: System Environment/Libraries
  58. Requires: %{name} = %{version}-%{release}
  59. Requires: ruby
  60. BuildRequires: ruby-devel, ruby-gnome2-devel
  61. %description -n ruby-tomoe
  62. Ruby extension library to use Tomoe
  63. %description -l ja -n ruby-tomoe
  64. Ruby から巴を使うための拡張ライブラリです。
  65. %package -n ruby-tomoe-devel
  66. Summary: Header files for developing ruby-tomoe applications
  67. Summary(ja): ruby-tomoe アプリケーション開発用ヘッダファイル
  68. Group: Development/Libraries
  69. Requires: ruby-tomoe = %{version}-%{release}
  70. Requires: %{name}-devel = %{version}-%{release}
  71. %description -n ruby-tomoe-devel
  72. The ruby-tomoe-devel package includes the header files for the ruby-tomoe
  73. package.
  74. Install this package if you want to develop programs which use ruby-tomoe.
  75. %description -l ja -n ruby-tomoe-devel
  76. ruby-tomoe-devel パッケージには、ruby-tomoe を使うアプリケーションを開発
  77. するためのヘッダファイルが含まれています。
  78. %endif
  79. %prep
  80. %setup -q
  81. %patch0 -p0 -b .multiarch-conflict
  82. %build
  83. autoreconf -vif
  84. %configure \
  85. --disable-static \
  86. --with-ruby-extdir=%{rarchdir} \
  87. --with-ruby-libdir=%{rlibdir}
  88. %__make %{?_smp_mflags}
  89. %install
  90. %__rm -rf $RPM_BUILD_ROOT
  91. %__make DESTDIR=%{buildroot} install
  92. %if !%{with_ruby}
  93. rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/tomoe.rb $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*-linux/*
  94. %endif
  95. chmod 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/xml2est.rb
  96. # remove unneeded files
  97. %__rm -f %{buildroot}%{_libdir}/tomoe/module/dict/libmysql.*
  98. %__rm -f %{buildroot}%{_libdir}/tomoe/module/dict/libsvn.*
  99. find ${RPM_BUILD_ROOT} -name '*.la' | xargs rm
  100. %if !%{with_python}
  101. %__rm -f %{buildroot}%{_libdir}/python?.?/site-packages/tomoe.so
  102. %endif
  103. %if !%{with_ruby}
  104. %__rm -rf %{buildroot}%{rarchdir}
  105. %__rm -rf %{buildroot}%{rlibdir}
  106. %endif
  107. %find_lang %{name}
  108. %clean
  109. %__rm -rf %{buildroot}
  110. %post
  111. %{_syssbindir}/ldconfig
  112. %postun
  113. %{_syssbindir}/ldconfig
  114. %files -f %{name}.lang
  115. %defattr(-,root,root,-)
  116. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  117. %dir %{_sysconfdir}/tomoe
  118. %config(noreplace) %{_sysconfdir}/tomoe/config
  119. %{_libdir}/*.so.*
  120. %dir %{_libdir}/tomoe
  121. %dir %{_libdir}/tomoe/module
  122. %dir %{_libdir}/tomoe/module/dict
  123. %{_libdir}/tomoe/module/dict/*.so
  124. %dir %{_libdir}/tomoe/module/recognizer
  125. %{_libdir}/tomoe/module/recognizer/*.so
  126. %{_datadir}/tomoe
  127. %files devel
  128. %defattr(-,root,root,-)
  129. %{_includedir}/tomoe
  130. %{_libdir}/pkgconfig/*.pc
  131. %{_libdir}/*.so
  132. %{_datadir}/gtk-doc/html/tomoe
  133. %if %{with_python}
  134. %files -n python-tomoe
  135. %defattr(-,root,root,-)
  136. %{_libdir}/python?.?/site-packages/tomoe.so
  137. %endif
  138. %if %{with_ruby}
  139. %files -n ruby-tomoe
  140. %defattr(-,root,root,-)
  141. %{rarchdir}/*.so.*
  142. %{rlibdir}/tomoe.rb
  143. %files -n ruby-tomoe-devel
  144. %defattr(-,root,root,-)
  145. %{rarchdir}/*.h
  146. %{rarchdir}/*.so
  147. %endif
  148. %changelog
  149. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2
  150. - rebuilt with rpm-4.8.1 for pkg-config
  151. * Sun May 31 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.6.0-1
  152. - new upstream release
  153. - added --disable-static in %%configure
  154. - applied tomoe-0.6.0-multiarch-conflict.patch
  155. * Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.5.1-1vl5
  156. - applied new versioning policy, spec in utf-8
  157. - remove *.la
  158. * Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.1-0vl1
  159. - new upstream release
  160. * Sun Jan 07 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl3
  161. - disable ruby extension by default
  162. * Fri Jan 05 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl2
  163. - move from tomoe-devel to tomoe
  164. - %%{_libdir}/tomoe/module/dict/*.so
  165. - %%{_libdir}/tomoe/module/recognizer/*.so
  166. * Sat Dec 31 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl1
  167. - new upstream release
  168. - add BuildRequires: unzip
  169. - update %%files section
  170. * Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.4.0-0vl1
  171. - new upstream release
  172. - update dependencies
  173. - drop BuildRequires: libxml2-devel, libxslt-devel, doxygen
  174. - add BuildRequires:
  175. - gtk-doc, libxslt, glib2-devel
  176. - ruby-devel, ruby-gnome2-devel
  177. - drop Requires: libxml2, libxslt
  178. - add Requires: glib2
  179. - add new sub-package: ruby-tomoe
  180. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.3.0-0vl2
  181. - oops, add Requires: libxml2, libxslt instead of *-devel
  182. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.3.0-0vl1
  183. - new upstream release
  184. - add BuildRequires: libxml2-devel, libxslt-devel, doxygen
  185. - add Requires: pkgconfig to -devel package
  186. - update %%files
  187. * Mon Nov 07 2005 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.2.1-3vl1
  188. - initial release for Vine Linux
  189. - disable %%__libtoolize
  190. - add Japanase summary and description
  191. * Sat Sep 3 2005 Warren Togami <wtogami@redhat.com> - 0.2.1-3
  192. - some spec cleanup
  193. * Sat Sep 2 2005 Ryo Dairiki <ryo-dairiki@mbm.nifty.com> - 0.2.1-2
  194. - Sync with Jens's spec file
  195. * Wed Aug 31 2005 Ryo Dairiki <ryo-dairiki@mbm.nifty.com> - 0.2.1-1
  196. - Initial packaging for Extras
  197. * Fri Jul 1 2005 Ichiro Nakai <ichiro@n.email.ne.jp>
  198. - (0.2.0-1m)
  199. - version 0.2.0
  200. - add a package tomoe-devel
  201. - add %%post and %%postun sections
  202. * Wed Mar 2 2005 Ichiro Nakai <ichiro@n.email.ne.jp>
  203. - (0.1.1-1m)
  204. - initial package for Momonga Linux
  205. - import %%description from cooker