tk-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278
  1. %define majorver 8.4
  2. %define minorver 19
  3. Summary: A Tcl/Tk development environment: tk
  4. Summary(ja): Tcl/Tk 開発環境: tk
  5. Name: tk
  6. Version: %{majorver}.%{minorver}
  7. Release: 4%{?_dist_release}
  8. Group: Development/Languages
  9. License: BSD
  10. URL: http://tcl.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  12. Patch2: tk-8.4.12-lib-perm.patch
  13. Patch3: tk-8.4-lastevent.patch
  14. Patch4: tk-8.4.18-tkBind.patch
  15. Buildroot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: tcl = %{version}, autoconf
  17. BuildRequires: libX11-devel
  18. BuildRequires: imake
  19. Requires: tcl >= %{majorver}
  20. Provides: libtk%{majorver}.so
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. Tk is a X Windows widget set designed to work closely with the tcl
  25. scripting language. It allows you to write simple programs with full
  26. featured GUI's in only a little more time then it takes to write a
  27. text based interface. Tcl/Tk applications can also be run on Windows
  28. and Macintosh platforms.
  29. %description -l ja
  30. Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
  31. System のウィジェットセットです。 テキストベースのインターフェースを
  32. 採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
  33. ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
  34. のプラットフォームで実行することもできます。
  35. %prep
  36. %setup -n %{name}%{version} -q
  37. %patch2 -p1 -b .rolib
  38. %patch3 -p0 -b .lastevent
  39. #%%patch4 -p1 -b .tkbind
  40. cd unix
  41. autoconf
  42. %build
  43. cd unix
  44. %configure \
  45. --with-tcl=%{_libdir} --enable-shared \
  46. --enable-threads --enable-64bit --with-x
  47. make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/tk%{majorver}
  48. %install
  49. rm -rf $RPM_BUILD_ROOT
  50. make install -C unix INSTALL_ROOT=%{buildroot} TK_LIBRARY=%{_datadir}/tk%{majorver}
  51. ln -s wish%{majorver} %{buildroot}%{_bindir}/wish
  52. # for linking with -ltk
  53. ln -s libtk%{majorver}.so %{buildroot}%{_libdir}/libtk.so
  54. mkdirhier %buildroot/%{_includedir}/tk-private/{generic,unix}
  55. cp -p generic/{default,tkInt,tkIntDecls,tkPort}.h %buildroot/%{_includedir}/tk-private/generic
  56. cp -p unix/tkUnix{Default,Port}.h %buildroot/%{_includedir}/tk-private/unix
  57. # Fix up the include files.
  58. cp generic/*.h $RPM_BUILD_ROOT%{_includedir}/tk-private/generic
  59. cp unix/*.h $RPM_BUILD_ROOT%{_includedir}/tk-private/unix
  60. # remove buildroot traces
  61. perl -pi -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/tk-private|" %buildroot/%{_libdir}/tkConfig.sh
  62. %clean
  63. rm -rf $RPM_BUILD_ROOT
  64. %post
  65. /sbin/ldconfig
  66. %postun
  67. /sbin/ldconfig
  68. %files
  69. %defattr(-,root,root,-)
  70. %doc
  71. %{_bindir}/wish*
  72. %{_datadir}/tk%{majorver}
  73. %{_libdir}/libtk%{majorver}.so
  74. %{_libdir}/tk%{majorver}
  75. %{_libdir}/tkConfig.sh
  76. %{_mandir}/man1/*
  77. %{_includedir}/*
  78. %{_libdir}/libtk.so
  79. %{_libdir}/libtkstub%{majorver}.a
  80. %{_mandir}/man3/*
  81. %{_mandir}/mann/*
  82. %changelog
  83. * Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
  84. - added "BuildRequires: imake".
  85. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
  86. - rebuilt with rpm-4.8.1-3
  87. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
  88. - rebuilt with tcl-8.4.19-2
  89. - dropt Patch4: tk-8.4.18-tkBind.patch
  90. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  91. - new upstream release
  92. - add Patch3,4 to fix bug (broken if built with xproto-7.x)
  93. * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
  94. - spec in utf-8
  95. * Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  96. - rebuild with xorg-x11-7.3
  97. - remove Requires: XFree86-libs
  98. - add BuildRequires: libX11-devel
  99. - use autoconf instead of autoconf217
  100. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  101. - updated tk to 8.4.18
  102. - included CVE-2008-0553
  103. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  104. - updated tk to 8.4.16
  105. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  106. - updated tk to 8.4.15
  107. - rebuilt with new toolchain
  108. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  109. - updated tk to 8.4.13
  110. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  111. - updated tk to 8.4.12
  112. - updated tk-%%{version}-lib-perm.patch
  113. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
  114. - dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
  115. - replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
  116. - dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
  117. - dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
  118. * Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
  119. - added tk-8.4.6-tkUnixWm.patch
  120. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  121. - updated tk to 8.4.6
  122. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  123. - syncd with fedora
  124. * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
  125. - add private header files needed to build tix in /usr/include/tk-private
  126. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
  127. - removed rpath (patch 3)
  128. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  129. - new package split out from tcltk
  130. - update to tk 8.4.5 (#88429)
  131. - filtered changelog for tk
  132. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  133. - remove build remnants from tkConfig.sh
  134. * Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
  135. - fix buildrequires and requires section
  136. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  137. - update based on BitWalk's tcltk-8.4.2-83bw
  138. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  139. - splite source package
  140. - add include files
  141. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  142. - expand some macros.. (FIXME)
  143. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  144. - use %configure macros
  145. - add Patch 47,50
  146. * Thu May 31 2001 <sagami@vinelinux.org>
  147. - 8.0.5_jp-10
  148. - unexpand old %%{configure}, new one causes build failure
  149. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  150. - install manpages into %%{_mandir} and mode 644
  151. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  152. - 8.0.5_jp-9
  153. - modified %install section to handle compressed man pages
  154. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  155. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  156. - changed default fonts
  157. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  158. - added defattr
  159. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  160. - added some symlinks, such as libtcl8.0.so.
  161. - obsoletes version number using _jp, now 8.0.5-31vl1
  162. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  163. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  164. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  165. - fix tclX symlinks.
  166. - compile on systems where SIGPWR == SIGLOST.
  167. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  168. - update tcl/tk to 8.0.5.
  169. - avoid "containing" in Tix (#2332).
  170. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  171. - use /usr/bin/write in kibitz (#1320).
  172. - use cirrus.sprl.umich.edu in weather (#1926).
  173. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  174. - auto rebuild in the new build environment (release 28)
  175. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  176. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  177. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  178. - expect does unaligned access on alpha (#989)
  179. - upgrade tcl/tk/tclX to 8.0.4
  180. - upgrade expect to 5.28.
  181. - add itcl 3.0.1
  182. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  183. - call libtoolize to allow building on the arm
  184. - build for glibc 2.1
  185. - strip binaries
  186. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  187. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  188. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  189. - expect: mkpasswd needs delay before sending password (problem #576)
  190. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  191. - translations modified for de, fr, tr
  192. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  193. - fixed expect binaries exec permissions
  194. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  195. - updated to Tix 4.1.0.006
  196. - updated version numbers of tcl/tk to relflect includsion of p2
  197. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  198. - updated tcl/tk to patch level 2
  199. - updated tclX to 8.0.2
  200. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  201. - fixed filelist for tix... replacing path to the expect binary in scripts
  202. was leaving junk files around.
  203. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  204. - added patch to remove libieee test in configure.in for tcl and tk.
  205. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  206. solution for all systems
  207. - fixed src urls
  208. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  209. - removed version numbers from descriptions
  210. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  211. - updated to tcl/tk 8.0 and related versions of packages
  212. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  213. - built against glibc
  214. - fixed dangling tclx/tkx symlinks