texlive-macros-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420
  1. ## -*- coding: utf-8-unix -*-
  2. %define tex_destdir %{_datadir}
  3. %define texmf %{_prefix}/share/texmf
  4. %define texlive_src %{tex_destdir}/texlive-sources
  5. %define build_tex_destdir %{buildroot}%{tex_destdir}
  6. %define build_texmf %{buildroot}%{texmf}
  7. %define build_texlive_src %{buildroot}%{tex_destdir}-sources
  8. %define knjfonts kanjifonts-3.1
  9. %define jsclasses_ver 100314
  10. %define jlisting_ver 0.2
  11. %define bkmk2uni convert-bkmk2uni
  12. %define exec_texhash [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
  13. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
  14. %define list_macros \
  15. jsclasses-%{jsclasses_ver} \
  16. jlisting-%{jlisting_ver}
  17. Summary: A collection of useful macro packages for texlive package
  18. Summary(ja): texlive パッケージで使うマクロパッケージ集
  19. Name: texlive-macros
  20. Version: 2009
  21. Release: 3%{?_dist_release}
  22. License: distributable
  23. Group: Applications/Publishing
  24. ## Vine Linux
  25. Source0: %{knjfonts}.tar.bz2
  26. Source1: sample.tex
  27. ## jsclasses
  28. Source10: http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/jsclasses-%{jsclasses_ver}.zip
  29. Source11: http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/index.html
  30. ## jlisting
  31. Source20: http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
  32. Requires: perl
  33. Requires: texlive = %{version}
  34. BuildRequires: texlive = %{version}
  35. BuildRequires: nkf unzip
  36. Buildroot: %{_tmppath}/%{name}-%{version}-root
  37. BuildArch: noarch
  38. %if %{?_dist_release} == "vl6"
  39. Obsoletes: tetex-macros <= 3.0
  40. %endif
  41. %if %{?_dist_release} == "vl5"
  42. Conflicts: tetex-macros
  43. %endif
  44. Obsoletes: pLaTeX2e_Macros
  45. Distribution: Vine Linux
  46. Vendor: Project Vine
  47. Packager: munepi
  48. %description
  49. A collection of useful macro packages for texlive package, including
  50. kanjifonts-3.1 (for Ricoh Fonts/DynaLab Fonts and JIS font metric)
  51. %{list_macros}
  52. # This package contained a perl script
  53. # http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
  54. %description -l ja
  55. texlive パッケージで使うマクロパッケージ集です。
  56. 以下のマクロを収録しています。
  57. kanjifonts-3.1 (Vine Linux 3.1R 付属のリコーフォント/ダイナフォントやJISフォントメトリックを使う)
  58. %{list_macros}
  59. # このパッケージには prosper, powerdot 用に
  60. # PDF ブックマークの文字化けを修正するための perl スクリプト
  61. # http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
  62. # を同梱しています.
  63. %prep
  64. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
  65. %setup -q -c -n %{name}-%{version}
  66. %__mkdir_p jsclasses
  67. (cd jsclasses
  68. %__mkdir_p jsclasses
  69. %__unzip -a -qq %{SOURCE10}
  70. %__cp -p %{SOURCE11} ./jsclasses/README.html
  71. )
  72. # get rid of unwanted files
  73. find . -type d -name CVS | xargs -r %__rm -frv
  74. find . -type f -name .cvsignore | xargs -r %__rm -fv
  75. (cd jsclasses
  76. %__mkdir_p tmp
  77. for i in *.*; do nkf $i > tmp/$i; done
  78. %__mv tmp/* .
  79. %__rm -rf tmp
  80. )
  81. %build
  82. (cd jsclasses
  83. for i in jsclasses okumacro okuverb morisawa; do
  84. platex ${i}.dtx && platex ${i}.dtx || exit 1
  85. done
  86. for i in jsclasses okumacro okuverb; do
  87. dvipdfmx $i || exit 1
  88. done
  89. %__cp *.dvi *.pdf jsclasses
  90. )
  91. %install
  92. %__rm -rf %{buildroot}
  93. # InstallClass(){
  94. # target=$1; shift
  95. # (cd $target
  96. # bzip2 -dc ${RPM_SOURCE_DIR}/$target.tar.bz2 | tar xf - -C %{build_texmf}/packages/
  97. # rm %{build_texmf}/packages/$target/*.{ins,def,bst,rtx,sty,cls,ltx,fnt,cyr,fdd} || :
  98. # if [ -f src/$target.ins ]; then
  99. # cp src/* .
  100. # fi
  101. # latex $target.ins
  102. # mkdir -p %{build_texmf}/tex/latex/$target
  103. # cp *.{ldf,sty,def,cls,rtx} %{build_texmf}/tex/latex/$target || :
  104. # if [ ! -z "$*" ]; then
  105. # cp -d $* %{build_texmf}/tex/latex/$target || :
  106. # fi
  107. # if [ -n "`ls *.bst`" ]; then
  108. # mkdir -p %{build_texmf}/bibtex/bst/$target
  109. # cp *.bst %{build_texmf}/bibtex/bst/$target || :
  110. # fi
  111. # )
  112. # }
  113. %__mkdir_p %{build_texmf}/packages/
  114. #InstallClass geometry
  115. ## install kanjifonts
  116. %__mkdir_p %{build_texmf}/ptex/platex/generic
  117. %__mv %{knjfonts}/*.sty %{build_texmf}/ptex/platex/generic
  118. %__mv %{knjfonts}/*.def %{build_texmf}/ptex/platex/generic
  119. # nkf --utf8 %{SOURCE25} | \
  120. # sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
  121. # %{buildroot}%{_bindir}/%{bkmk2uni}
  122. # chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
  123. ## install jsclasses
  124. (cd jsclasses
  125. %__mkdir_p %{build_texmf}/ptex/platex/js
  126. %__cp -fp *.dtx *.ins *.cls *.sty %{build_texmf}/ptex/platex/js/
  127. )
  128. ## install jlisting
  129. %__mkdir_p %{build_texmf}/ptex/platex/jlisting
  130. %__install -m 644 %{SOURCE20} %{build_texmf}/ptex/platex/jlisting/
  131. bunzip2 %{build_texmf}/ptex/platex/jlisting/jlisting.sty.bz2
  132. # ## install MORISAWA basic 5 fonts
  133. # #mkdir -p %{build_texmf}/dvips/config/extmap
  134. # %__mkdir_p %{build_texmf}/fonts/tfm/ptex
  135. # %__mkdir_p %{build_texmf}/fonts/tfm/dvips
  136. # %__mkdir_p %{build_texmf}/fonts/vf/ptex
  137. # #mv morisawa/morisawa.map %{build_texmf}/dvips/config/extmap/
  138. # %__mv morisawa/tfm/ptex/* %{build_texmf}/fonts/tfm/ptex/
  139. # %__mv morisawa/tfm/dvips/* %{build_texmf}/fonts/tfm/dvips/
  140. # %__mv morisawa/vf/* %{build_texmf}/fonts/vf/ptex/
  141. %post
  142. %{exec_texhash}
  143. # %{exec_updmap}
  144. exit 0
  145. %postun
  146. if [ "$1" = 0 ]; then
  147. %{exec_texhash}
  148. # %{exec_updmap}
  149. fi
  150. exit 0
  151. %clean
  152. %__rm -rf $RPM_BUILD_ROOT
  153. %files
  154. %defattr(-,root,root)
  155. %doc %{knjfonts}
  156. %doc jsclasses/jsclasses
  157. #%{_bindir}/%{bkmk2uni}
  158. %{texmf}/ptex/platex/generic/kanjifonts.sty
  159. %{texmf}/ptex/platex/generic/*.def
  160. %{texmf}/ptex/platex/js
  161. %{texmf}/ptex/platex/jlisting
  162. %changelog
  163. * Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  164. - dropped BuildRequires: jvf
  165. - for vl5, added Conflicts: tetex-macros
  166. * Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  167. - removed %%{exec_updmap} in %%post and %%postun
  168. * Tue May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  169. - ported from tetex-macros-3.0-7
  170. - TeX Live 2009
  171. * Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
  172. - added BuildRequires: unzip
  173. - updated jsclasses to 090826
  174. - updated pict2e to 0.2x
  175. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
  176. - dropped epsbox.sty, eclepsf.sty
  177. (bacause there style files for platex209 are obsolete)
  178. * Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
  179. - added jlisting v0.2
  180. - defined list_macros
  181. - used %%{list_macros} in %%description and %%description -l ja
  182. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
  183. - dropped convert-euc.txt
  184. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
  185. - updated prosper
  186. - added some contrib themes from CTAN
  187. - added prosper.cls v1.6 from CVS HEAD
  188. - added a perl script: convert-euc.txt
  189. - added powerdot v1.3
  190. - added xkeyval v2.5d
  191. - added beamer v3.07
  192. - added pgf v2.00
  193. - added pict2e v0.2w
  194. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
  195. - updated jsclasses to 20090222
  196. - updated jsclasses/index.html to 2009-02-22
  197. - removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
  198. * Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
  199. - applied new versioning policy, spec in utf-8
  200. * Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
  201. - update jsclasses/index.html to 2006-11-06.
  202. * Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
  203. - update jsclasses/index.html to 2006-02-12.
  204. * Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
  205. - update jsclasses/index.html to 2005-10-26.
  206. * Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
  207. - update jsclasses/index.html to 2005-4-30.
  208. - added breqn
  209. * Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
  210. - update jsclasses/index.html to 2004-12-29.
  211. * Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
  212. - add missing files in kanjifonts-3.0
  213. * Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
  214. - update to kanjifonts.sty-3.0.
  215. * Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
  216. - update jsclasses/index.html to 2004-11-03.
  217. * Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
  218. - update jsclasses/index.html to 2004-09-27.
  219. * Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
  220. - update jsclasses/index.html to 2004-02-25.
  221. - added eclepsf.sty.
  222. - removed epsf.sty (symlink to epsbox.sty).
  223. - removed geometry, which is in tetex-2.0.
  224. * Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
  225. - update jsclasses/index.html to 2003-04-18.
  226. - added morisawa.dvi.
  227. * Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
  228. - update jsclasses/index.html to 2003-03-06
  229. * Mon Feb 3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
  230. - remove natbib, which is in tetex-2.0
  231. - let version number same as tetex
  232. - added Requires: tetex
  233. * Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
  234. - update jsclasses/index.html to 2003-01-16
  235. * Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
  236. - update jsclasses to 2003-01-05
  237. - update index.html to 2003-01-12
  238. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
  239. - update jsclasses and index.html to 2002-11-27
  240. * Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
  241. - update jsclasses and index.html to 2002-11-01
  242. * Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
  243. - oops, packager was incorrect
  244. * Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
  245. - update jsclasses to 2002-06-29
  246. - update index.html to 2002-07-03
  247. * Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
  248. - update jsclasses to 2002-04-21
  249. - update index.html to 2002-04-09
  250. * Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
  251. - added MORISAWA basic 5 fonts
  252. * Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
  253. - update to kanjifonts-1.1
  254. * Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
  255. - update jsclasses and index.html to 2002-02-07
  256. * Tue Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
  257. - update jsclasses and index.html to 2002-01-27
  258. - fix typo in changelog
  259. * Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
  260. - update jsclasses and index.html to 2002-01-18
  261. * Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
  262. - update index.html (jsclasses)
  263. * Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
  264. - update jsclasses to 2001-11-29
  265. * Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
  266. - fixed spec file for Prosper and jsclasses
  267. - use RPM macro in %files
  268. - added BuildPrereq: jvf
  269. * Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
  270. - move revtex4 to texmacro-aps package
  271. * Sun Sep 9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
  272. - added prosper jsclasses
  273. * Mon Sep 6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
  274. - added revtex4 natbib
  275. * Mon Sep 3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
  276. - remove prereq tetex to avoid dependency-loop
  277. * Wed Aug 1 2001 Jun Nishii <jun@vinelinux.org>
  278. - tetex-macros-1.0-0vl1
  279. * Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
  280. - 2.0-2
  281. - added kanjifonts-1.0 and removed jisfontsmetric
  282. * Sun Jan 9 2000 Jun Nishii <jun@vinelinux.org>
  283. - 2.0-1
  284. - install ldf in babel
  285. * Sat Jan 8 2000 Jun Nishii <jun@vinelinux.org>
  286. - added jisfontmetric.tex
  287. * Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
  288. - change group.
  289. * Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
  290. - added babel
  291. * Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
  292. - added hoekwater
  293. * Mon Aug 3 1999 Jun Nishii <jun@flatout.org>
  294. - added psfrag
  295. * Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
  296. - added psnfss
  297. - Change directory tree according to the suggestion by Dr.Okumura.
  298. - remove many files from packages directory except documentations
  299. - disable mktexlsr and erase ls-R
  300. * Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
  301. - added url.sty
  302. * Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
  303. - pLaTeX2e_Macros-1-2
  304. - added fancyhdr.sty, boxedminipage.sty
  305. - added graphics.cfg, color.cfg (use dvips as default)
  306. - symlink from epsbox to epsf
  307. * Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
  308. - pLaTeX2e_Macros-1-1
  309. (rename as pLaTeX2e_Macros from pLaTeX-Classes)
  310. - added def files of graphics
  311. - added tools and hyperref
  312. - check the existence of mktexlsr
  313. * Tue Oct 5 1998 Jun Nishii <jun@flatout.org>
  314. - buildarch: noarch
  315. - added requires
  316. * Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
  317. - tiny bug fix and add %defattr
  318. * Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
  319. - first version fo platex-19980901