iverilog-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190
  1. # TODO for 1.0 release - redefine
  2. #Version: 0.9.%{snapshot}
  3. #Release: 6%{?dist}
  4. # to
  5. #Version: 1.0
  6. #Release: 1.snap%{snapshot}%{?dist}
  7. #
  8. # Test suite for iverilog is detailed on
  9. # https://fedorahosted.org/fedora-electronic-lab/wiki/Testing/iverilog
  10. # Please execute the testsuite as explained before pushed a new release to stable repos
  11. #
  12. %define snapshot 20091230
  13. Name: iverilog
  14. Version: 0.9.2
  15. Release: 1%{?_dist_release}
  16. Summary: Icarus Verilog is a verilog compiler and simulator
  17. Group: Applications/Engineering
  18. License: GPLv2
  19. URL: http://www.icarus.com/eda/verilog/index.html
  20. # Development Snapshot Download :
  21. # git clone git://icarus.com/~steve-icarus/verilog
  22. # cd verilog
  23. # git checkout --track -b v0_9-branch origin/v0_9-branch
  24. # This is the latest stable snapshot
  25. Source0: ftp://ftp.icarus.com/pub/eda/verilog/v0.9/verilog-%{version}.tar.gz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: zlib-devel
  28. BuildRequires: bzip2-devel
  29. BuildRequires: bison
  30. BuildRequires: flex
  31. BuildRequires: gperf
  32. BuildRequires: autoconf
  33. %description
  34. Icarus Verilog is a Verilog compiler that generates a variety of
  35. engineering formats, including simulation. It strives to be true
  36. to the IEEE-1364 standard.
  37. %package devel
  38. Summary: Icarus Verilog devel files
  39. Group: Development/Libraries
  40. Requires: %{name} = %{version}-%{release}
  41. %description devel
  42. Icarus Verilog devel files.
  43. %prep
  44. %setup -q -n verilog-%{version}
  45. #sh autoconf.sh
  46. # clean junks from tarball
  47. find . -type f -name ".git" -exec rm '{}' \;
  48. rm -rf `find . -type d -name "autom4te.cache" -exec echo '{}' \;`
  49. %build
  50. CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" \
  51. %configure
  52. make %{?_smp_mflags}
  53. %install
  54. rm -rf %{buildroot}
  55. make prefix=%{buildroot}%{_prefix} \
  56. bindir=%{buildroot}%{_bindir} \
  57. libdir=%{buildroot}%{_libdir} \
  58. libdir64=%{buildroot}%{_libdir} \
  59. includedir=%{buildroot}%{_includedir} \
  60. mandir=%{buildroot}%{_mandir} \
  61. vpidir=%{buildroot}%{_libdir}/ivl/ \
  62. INSTALL="install -p" \
  63. install
  64. %check
  65. make check
  66. %clean
  67. rm -rf %{buildroot}
  68. %files
  69. %defattr(-,root,root,-)
  70. # contents of QUICK_START.txt can be found also on README.txt, hence omitted
  71. %doc attributes.txt BUGS.txt COPYING extensions.txt glossary.txt ieee1364-notes.txt
  72. %doc README.txt swift.txt netlist.txt t-dll.txt vpi.txt tgt-fpga/fpga.txt
  73. %doc va_math.txt cadpli/cadpli.txt xilinx-hint.txt examples/
  74. %{_bindir}/*
  75. %{_libdir}/ivl
  76. %{_mandir}/man1/*
  77. %files devel
  78. %defattr(-,root,root,-)
  79. # headers for PLI: This is intended to be used by the user.
  80. %{_includedir}/*.h
  81. # RHBZ 480531
  82. %{_libdir}/*.a
  83. %changelog
  84. * Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.2-1
  85. - Initial build for Vine Linux
  86. * Wed Dec 30 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091230-1
  87. - New stable snapshot - 0.9.2
  88. * Sat Dec 12 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091212-1
  89. - New development snapshot - 0.9.2 final prerelease snapshot
  90. * Sat Dec 05 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091205-1
  91. - New development snapshot - 0.9.2 prerelease snapshot
  92. * Fri Dec 04 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091204-1
  93. - New development snapshot - 0.9.2 prerelease snapshot
  94. * Sat Nov 28 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091130-1
  95. - New development snapshot
  96. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.20090423-6
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  98. * Mon Jun 13 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20090423-5
  99. - Improved VPI support
  100. * Mon Mar 23 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20081118-4
  101. - new development release
  102. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.20081118-2
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  104. * Sun Dec 07 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20081118-1
  105. - new snapshot release upstream.
  106. * Fri Sep 12 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080905-1
  107. - new snapshot release upstream.
  108. * Mon May 26 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080429-1
  109. - new snapshot release upstream.
  110. * Fri Mar 28 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080314-1
  111. - new snapshot release upstream.
  112. - add check section for some tests
  113. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.20070608-2
  114. - Autorebuild for GCC 4.3
  115. * Sun Jun 10 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070608-1
  116. - new snapshot release upstream.
  117. * Mon Apr 23 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070421-1
  118. - new snapshot release upstream.
  119. * Thu Feb 27 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070227-1
  120. - new snapshot release.
  121. * Thu Feb 27 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070123-5
  122. - clean junks from tarball
  123. - exlude static library
  124. - smp build seems fine
  125. - use snapshot instead of cvsver macro
  126. - follow package n-v-r from fedora standard
  127. * Thu Feb 23 2007 Balint Cristian <cbalint@redhat.com> 20070123-4
  128. - use cvsver macro
  129. - move examples in main.
  130. - more spec cleanup
  131. * Thu Feb 23 2007 Balint Cristian <cbalint@redhat.com> 20070123-3
  132. - buildroot coherency in spec
  133. * Thu Feb 22 2007 Balint Cristian <cbalint@redhat.com> 20070123-2
  134. - first build for fedora-extras
  135. - request gnu/stubs-32.h to force working gcc in 32 bit enviroment
  136. - fix PAGE_SIZE wich is missing on some arch
  137. - dont use libdir macro, all library always will be 32 bit
  138. * Thu Feb 22 2007 Balint Cristian <cbalint@redhat.com> 20070123-1
  139. - initial release