indent-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. Summary: A GNU program for formatting C code.
  2. Summary(ja): C のコードを整形する GNU プログラム
  3. Name: indent
  4. Version: 2.2.9
  5. Release: 5%{?_dist_release}
  6. License: GPL
  7. Group: Applications/Text
  8. URL: http://www.gnu.org/software/indent/
  9. Source: ftp://ftp.gnu.org/pub/gnu/indent-%{version}.tar.gz
  10. Patch0: indent-2.2.9-indent_h.patch
  11. Prereq: /sbin/install-info
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. %description
  14. Indent is a GNU program for beautifying C code, so that it is easier to
  15. read. Indent can also convert from one C writing style to a different
  16. one. Indent understands correct C syntax and tries to handle incorrect
  17. C syntax.
  18. Install the indent package if you are developing applications in C and
  19. you want a program to format your code.
  20. %description -l ja
  21. Indent は C のコードを読みやすく整形する GNU プログラムです.Indent を
  22. 使うと,C コードのあるスタイルから別のスタイルへと返還することも出来ます.
  23. Indent は C 文法を理解しますので,間違った C の文法を可能な限り解釈しよう
  24. とします.
  25. C によるアプリケーション開発を行っていて,プログラムコードを整形したい
  26. 場合には indent パッケージをインストールして下さい.
  27. %prep
  28. %setup -q
  29. %patch0 -p0 -b .indent_h
  30. %build
  31. %configure
  32. export PATH=$PATH:.
  33. make
  34. %install
  35. rm -rf $RPM_BUILD_ROOT
  36. %makeinstall
  37. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir $RPM_BUILD_ROOT/usr/bin/texinfo2man \
  38. $RPM_BUILD_ROOT/usr/doc/indent/indent.html
  39. %find_lang %name
  40. %clean
  41. rm -rf $RPM_BUILD_ROOT
  42. %post
  43. /sbin/install-info %{_infodir}/indent.info.gz %{_infodir}/dir --entry="* indent: (indent). Program to format source code."
  44. %preun
  45. if [ "$1" = 0 ]; then
  46. /sbin/install-info --delete %{_infodir}/indent.info.gz %{_infodir}/dir --entry="* indent: (indent). Program to format source code."
  47. fi
  48. %files -f %{name}.lang
  49. %defattr(-,root,root)
  50. %{_bindir}/indent
  51. %{_mandir}/*/*
  52. %{_infodir}/*
  53. %changelog
  54. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.2.9-5
  55. - rebuilt with rpm-4.8.1-3
  56. * Tue Sep 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.9-4vl5
  57. - applied new versioning policy, spec in utf-8
  58. - added indent-2.2.9-indent_h.patch
  59. * Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.9-3vl2
  60. - rebuilt for x86_64 architecture
  61. * Mon Jul 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3vl1
  62. - rebuild with new toolchains
  63. - based on Redhat Rawhide 2.2.9-3
  64. * Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  65. - 2.2.6-1vl2
  66. - Oops the spec was in Shift_JIS. Fixed.
  67. * Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  68. - 2.2.6-1vl1
  69. - rebuilt for Vine Linux
  70. * Sun Nov 19 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  71. - update to 2.2.6
  72. * Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
  73. - rebuild
  74. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  75. - automatic rebuild
  76. * Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  77. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir}
  78. and %%{_tmppath}
  79. - don't use %%{_prefix}
  80. * Wed May 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  81. - added URL
  82. - remove manual stripping
  83. * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
  84. - man pages are compressed
  85. * Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
  86. - 2.2.5
  87. * Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
  88. - 2.2.0
  89. * Fri Jul 16 1999 Bill Nottingham <notting@redhat.com>
  90. - update to 2.1.1
  91. * Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
  92. - update to 1.10.0.
  93. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  94. - auto rebuild in the new build environment (release 11)
  95. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  96. - build for 6.0 tree
  97. * Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
  98. - build root
  99. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  100. - translations modified for de, fr, tr
  101. * Tue Oct 21 1997 Otto Hammersmith <otto@redhat.com>
  102. - use install-info
  103. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  104. - built against glibc