grep-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305
  1. Summary: The GNU versions of grep pattern matching utilities.
  2. Summary(ja): GNU版 grep パターンマッチングユーティリティ
  3. Name: grep
  4. Version: 2.7
  5. Release: 1%{?_dist_release}
  6. License: GPLv3+
  7. Group: System Environment/Base
  8. URL: http://www.gnu.org/software/grep/
  9. Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}.tar.xz
  10. Source1: colorgrep.sh
  11. Source2: colorgrep.csh
  12. Source3: GREP_COLORS
  13. Patch0: grep-2.7-const-range-exp.patch
  14. Requires(post): install-info
  15. Requires(preun): install-info
  16. Buildroot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: pcre-devel, texinfo, gettext, gzip
  18. %description
  19. The GNU versions of commonly used grep utilities. Grep searches
  20. through textual input for lines which contain a match to a specified
  21. pattern and then prints the matching lines. GNU's grep utilities
  22. include grep, egrep and fgrep.
  23. You should install grep on your system, because it is a very useful
  24. utility for searching through text.
  25. %description -l ja
  26. 一般に使われるgrepユーティリティのGNU版です。Grep は指定したパターンと一致
  27. する行を入力ファイルから捜し出して、その行を表示します。GNUのgrepユーティリ
  28. ティにはgrep, egrep, fgrepが入っています。
  29. テキストファイルの検索や、システム管理にとても役に立つので、是非インストール
  30. してください。
  31. %prep
  32. %setup -q
  33. %patch0 -p1 -b .const-range-exp
  34. %build
  35. %configure CPPFLAGS="-I%{_includedir}/pcre" \
  36. --without-included-regex
  37. %__make %{?_smp_mflags}
  38. %install
  39. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  40. %__make DESTDIR=$RPM_BUILD_ROOT install
  41. gzip $RPM_BUILD_ROOT%{_infodir}/grep*
  42. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  43. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  44. install -pm 644 %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  45. install -pm 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
  46. mkdir -p $RPM_BUILD_ROOT/bin
  47. mv $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT/bin/
  48. rm -rf $RPM_BUILD_ROOT%{_bindir}
  49. %find_lang %{name}
  50. %check
  51. make check
  52. %clean
  53. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  54. %post
  55. [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.gz || :
  56. %preun
  57. if [ $1 = 0 ]; then
  58. [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.gz
  59. fi
  60. %files -f %{name}.lang
  61. %defattr(-,root,root)
  62. %doc ABOUT-NLS AUTHORS THANKS TODO NEWS README ChangeLog COPYING
  63. /bin/*
  64. %config(noreplace) %{_sysconfdir}/profile.d/colorgrep.*sh
  65. %config(noreplace) %{_sysconfdir}/GREP_COLORS
  66. %{_infodir}/*.info.gz
  67. %{_mandir}/*/*
  68. %changelog
  69. * Tue Feb 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  70. - new upstream release
  71. - drop unneeded old patches
  72. - add BR: pcre-devel
  73. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-60
  74. - rebuilt against current toolchain
  75. - fix license tag
  76. - use CPPFLAGS= argument to configure to add an -I option.
  77. - Do not set LDFLAGS=-s for "make install".
  78. * Wed Sep 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-57
  79. - rebuilt for VineSeed (previous version in VineSeed was 2.5.1-50 somehow)
  80. - Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.1-50vl5
  81. - applied new versioning policy, spec in utf-8
  82. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl0.1
  83. - rebuild for Vine Linux 4.x
  84. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl1
  85. - add Patch100 to fix infinite loop with 'grep -F'
  86. thanks to M.H (<BTS:484>)
  87. - based on Fedora devel 2.5.1-57
  88. * Mon Jan 22 2007 Tim Waugh <twaugh@redhat.com> 2.5.1-57
  89. - Make preun scriptlet unconditionally succeed (bug #223697).
  90. * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-56
  91. - Fixed count of patterns when the last is an empty string (bug #204255).
  92. * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-55
  93. - Fix 'memory exhausted' errors by limiting in-memory buffer (bug #198165).
  94. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-54.1
  95. - rebuild
  96. * Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-54
  97. - Applied upstream patch to fix '-D skip' (bug #189580).
  98. * Mon Feb 20 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-53
  99. - Applied Tim Robbins' patch for 'grep -w' (bug #179698).
  100. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.2
  101. - bump again for double-long bug on ppc(64)
  102. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.1
  103. - rebuilt for new gcc4.1 snapshot and glibc changes
  104. * Fri Feb 3 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-52
  105. - Prevent 'grep -P' from segfaulting (bug #171379).
  106. * Sat Oct 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl2
  107. - changed Group to System Environment/Base
  108. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl1
  109. - based on Fedora development 2.5.1-50
  110. * Tue Jun 28 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-50
  111. - Futher fixing for bug #161700.
  112. * Mon Jun 27 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-49
  113. - Fix 'grep -Fw' for encodings other than UTF-8 (bug #161700).
  114. * Wed Apr 13 2005 Tim Waugh <twaugh@redhat.com>
  115. - Build requires recent pcre-devel (bug #154626).
  116. * Fri Jan 7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-47
  117. - Run 'make check'.
  118. - Fixed -w handling for EGexecute. Now 'make check' passes.
  119. - Cache MB_CUR_MAX value in egf-speedup patch.
  120. - Fixed variable shadowing in egf-speedup patch.
  121. - Removed redundant (and incorrect) code in prline.
  122. * Fri Jan 7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-46
  123. - More -w tests from Jakub Jelinek.
  124. - Rebased on 2.5.1a.
  125. * Fri Dec 31 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-45
  126. - More tests (Jakub Jelinek).
  127. - Jakub Jelinek's much improved -Fi algorithm.
  128. - Removed bogus part of grep-2.5.1-fgrep patch.
  129. * Tue Dec 21 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-44
  130. - Fixed -Fi for multibyte input (bug #143079).
  131. * Thu Dec 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-43
  132. - Bypass kwset matching when ignoring case and processing multibyte input
  133. (bug #143079).
  134. * Tue Dec 14 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-42
  135. - Further UTF-8 processing avoided since a '\n' byte is always an
  136. end-of-line character in that encoding.
  137. * Fri Dec 3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-41
  138. - Fixed a busy loop in the egf-speedup patch (bug #140781).
  139. * Thu Nov 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-40
  140. - Fixed a bug in the fgrep patch, exposed by the dfa-optional patch
  141. (bug #138558).
  142. * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-39
  143. - Fixed last patch.
  144. * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-38
  145. - Applied patch from Karsten Hopp to fix background colour problems with
  146. --color output (bug #138913).
  147. * Wed Nov 10 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-37
  148. - Prevent false matches when DFA is disabled (bug #138558).
  149. * Mon Nov 8 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-36
  150. - Automatically disable DFA when processing multibyte input. GREP_USE_DFA
  151. environment variable overrides.
  152. * Fri Nov 5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-35
  153. - Fixes to egf-speedup patch: now it does not change any functionality,
  154. as intended.
  155. - GREP_NO_DFA now turns off the DFA engine, for performance testing.
  156. * Thu Nov 4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-34
  157. - More improvements to egf-speedup patch (bug #138076).
  158. * Thu Nov 4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-33
  159. - Small improvements to egf-speedup patch.
  160. * Wed Nov 3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-32
  161. - Remove mb-caching hack.
  162. - Better multibyte handling in EGexecute() and Fexecute().
  163. - Don't need regex.c changes in grep-2.5-i18n.patch.
  164. * Wed Oct 13 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-31
  165. - Make 'grep -F' avoid UTF-8 processing if the pattern contains no
  166. multibyte characters (bug #133932).
  167. * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-30
  168. - Applied patch from Robert Scheck to tidy spec file and add a URL
  169. tag (bug #135185).
  170. * Sun Sep 5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-29vl1
  171. - based on Fedora development 2.5.1-29
  172. * Fri Jun 4 2004 Tim Waugh <twaugh@redhat.com>
  173. - More build requirements (bug #125323).
  174. * Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27
  175. - Fix dfa multibyte character class matching when -i is used (bug #123363).
  176. - Use bracket patch before i18n patch to make it clear that the bug exists
  177. upstream.
  178. * Thu Feb 26 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-26
  179. - Fix fgrep (bug #116909).
  180. * Mon Jan 5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-24
  181. - Work around glibc bug #112869 (segfault in re_compile_pattern).
  182. - Avoid patching Makefile.am, to avoid automake/autoconf weirdness.
  183. * Wed Dec 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-23
  184. - Another multibyte efficiency bug-fix (bug #111800).
  185. * Mon Dec 8 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-22
  186. - Fixed [:alpha:]-type character classes (bug #108484).
  187. - Fixed -o -i properly (bug #111489).
  188. * Sat Dec 6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-21
  189. - Fixed 'fgrep -i' (bug #111614).
  190. * Fri Nov 21 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-20
  191. - Another two multibyte efficiency bug-fixes (bug #110524).
  192. * Thu Nov 6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-19
  193. - Fixed a multibyte efficiency bug.
  194. * Thu Nov 6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-18
  195. - Turn on multibyte efficiency patch again to shake out bugs.
  196. * Wed Oct 8 2003 Tim Waugh <twaugh@redhat.com>
  197. - Fixed man page bug (bug #106267).
  198. * Thu Sep 18 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-17
  199. - Use symlinks for egrep/fgrep, rather than shell script wrappers.
  200. * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com>
  201. - Fix debuginfo package.
  202. * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-16
  203. - Finally give up on making grep go fast. :-(
  204. * Thu Jun 26 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-15
  205. - Fixed grep -i bug introduced by cache.
  206. * Mon Jun 23 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-14
  207. - Redo the gofast patch (bug #97785).
  208. * Thu Jun 12 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-13
  209. - Fixed a bug in the gofast patch (bug #97266).
  210. * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-12
  211. - Go faster (bug #69900).
  212. - Fix man page.
  213. * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-10
  214. - Use system regex again.
  215. * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-9
  216. - Fixed bug in go-fast patch.
  217. * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-8
  218. - Go fast (bug #69900).
  219. - Run test suite.
  220. - rebuild with new toolchains
  221. - build with --disable-prel-regexp option
  222. * Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-7vl3
  223. - based on Rawhide 2.5.1-7
  224. - Don't install /usr/share/info/dir.
  225. - Fix -o -i (bug #72641).
  226. - i18n patch.
  227. * Sat Jul 6 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  228. - 2.5-0vl1
  229. - update to 2.5
  230. - change i18n patch
  231. * Sat Jan 20 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  232. - 2.5-0vl1
  233. - update to 2.5
  234. - change i18n patch
  235. * Sat Jan 20 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  236. - 2.4.2-4vl1
  237. - usr better macros (%%configure/%%makeinstall)
  238. * Mon Jun 19 2000 Jun Nishii <jun@vinelinux.org>
  239. - 2.4-3vl1
  240. - merge ja patch
  241. * Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  242. - gzip info pages (Bug #9035)
  243. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  244. - fix description
  245. * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
  246. - update to 2.4.
  247. * Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
  248. - prereq install-info
  249. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  250. - auto rebuild in the new build environment (release 2)
  251. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  252. - upgraded to grep 2.3, added install-info %post/%preun for info
  253. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  254. - Injected new description and group.
  255. * Sat May 09 1998 Prospector System <bugs@redhat.com>
  256. - translations modified for de, fr, tr
  257. * Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
  258. - updated to 2.2
  259. * Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
  260. - updated from 2.0 to 2.1
  261. - spec file cleanups
  262. - added BuildRoot
  263. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  264. - built against glibc