gdb-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401
  1. Summary: A GNU source-level debugger for C, C++ and other languages.
  2. Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
  3. Name: gdb
  4. Version: 7.2
  5. Release: 2%{?_dist_release}
  6. License: GPL
  7. Group: Development/Debuggers
  8. Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.bz2
  9. Buildroot: %{_tmppath}/%{name}-%{version}-root
  10. URL: http://sources.redhat.com/gdb/
  11. BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
  12. BuildRequires: python-devel
  13. BuildRequires: zlib-devel
  14. Requires: install-info
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: Takemikaduchi
  18. %description
  19. GDB, the GNU debugger, allows you to debug programs written in C, C++,
  20. and other languages, by executing them in a controlled fashion and
  21. printing their data.
  22. %description -l ja
  23. GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
  24. 使うツールです.プログラムの実行を制御し,データを出力することができます.
  25. %prep
  26. %setup -q
  27. %build
  28. export CFLAGS="$RPM_OPT_FLAGS"
  29. rm -fr dejagnu tcl expect
  30. ./configure \
  31. --prefix=%{_prefix} \
  32. --sysconfdir=%{_sysconfdir} \
  33. --mandir=%{_mandir} \
  34. --infodir=%{_infodir} \
  35. %{_target_platform}
  36. make
  37. make info
  38. cp gdb/NEWS .
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. %makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
  42. # install the gcore script in /usr/bin
  43. install -m755 $RPM_BUILD_DIR/gdb-%{version}/gdb/gdb_gcore.sh $RPM_BUILD_ROOT%{_bindir}/gcore
  44. # The above is broken, do this for now:
  45. #mkdir -p $RPM_BUILD_ROOT/%{_infodir}
  46. #cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
  47. # These are part of binutils
  48. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  49. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
  50. rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
  51. rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
  52. rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
  53. rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,iberty*,opcodes*}
  54. rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
  55. rm -rf $RPM_BUILD_ROOT%{_includedir}
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %post
  59. [ -f %{_infodir}/annotate.info ] && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
  60. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  61. [ -f %{_infodir}/gdb.info ] && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
  62. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  63. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info %{_infodir}/gdbint.info %{_infodir}/dir || :
  64. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  65. [ -f %{_infodir}/stabs.info ] && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir || :
  66. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  67. %preun
  68. if [ $1 = 0 ]; then
  69. [ -f %{_infodir}/annotate.info ] && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir || :
  70. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  71. [ -f %{_infodir}/gdb.info ] && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir || :
  72. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  73. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir || :
  74. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  75. [ -f %{_infodir}/stabs.info ] && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir || :
  76. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  77. fi
  78. %files
  79. %defattr(-,root,root)
  80. %doc COPYING COPYING.LIB README NEWS
  81. %{_bindir}/*
  82. %{_mandir}/*/*
  83. %{_datadir}/gdb/syscalls
  84. %{_infodir}/annotate.info*
  85. %{_infodir}/gdb.info*
  86. %{_infodir}/gdbint.info*
  87. %{_infodir}/stabs.info*
  88. %exclude %{_infodir}/dir
  89. %ifarch %{ix86} x86_64
  90. %{_libdir}/libinproctrace.so
  91. %endif
  92. ## don't include the files in include, they are part of binutils
  93. #%{_includedir}/*
  94. #%{_infodir}/bfd.info*
  95. #%{_infodir}/configure.info*
  96. #%{_infodir}/standard.info*
  97. #%{_libdir}/*
  98. #%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
  99. #%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
  100. %changelog
  101. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
  102. - add BuildRequires: python-devel, zlib-devel
  103. - fix %%files
  104. * Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
  105. - updated gdb to 7.2
  106. * Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
  107. - updated gdb to 7.0.1
  108. - rebuilt with new environment
  109. * Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
  110. - applied new versioning policy, spec in utf-8
  111. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
  112. - rebuild with expat-2.0.1
  113. - add BuildRequires: expat-devel
  114. * Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
  115. - dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
  116. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
  117. - dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
  118. * Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
  119. - new upstream release
  120. * Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
  121. - new upstream release
  122. * Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
  123. - new upstream release
  124. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
  125. - Oops, spec was written in Shift-JIS. Fixed.
  126. * Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
  127. - based on 5.2.1-4 from Rawhide and built for Vine Linux
  128. * Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  129. - added mainframe patch from developerworks
  130. * Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
  131. - Add changelogs to the previous patch
  132. * Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
  133. - Add some patches from Elena Zannoni <ezannoni@redhat.com>
  134. * Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
  135. - 5.2.1
  136. * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  137. - compile on mainframe
  138. * Mon Jul 8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
  139. - Rebuild
  140. * Tue May 7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
  141. - Rebuild
  142. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
  143. - 5.2
  144. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
  145. - 5.1.92. Hopefully identical to 5.2 final
  146. * Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
  147. - 5.1.91. 5.2 expected in a week
  148. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
  149. - Update to current
  150. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
  151. - Update to current
  152. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
  153. - Update to current
  154. * Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
  155. - Update to current
  156. * Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
  157. - Update to current 5.2 branch
  158. * Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
  159. - 5.1.1
  160. - add URL
  161. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  162. - automated rebuild
  163. * Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
  164. - Fix some thread+fpu problems
  165. * Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
  166. - 5.1
  167. * Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
  168. - 5.0.94. Almost there....
  169. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
  170. - Add patch from jakub@redhat.com to improve handling of DWARF
  171. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
  172. - 5.0.93
  173. - handle missing info pages in post/pre scripts
  174. * Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
  175. - 5.0.92
  176. * Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
  177. - New snapshot
  178. - Use the 5.0.91 versioning from the snapshot
  179. * Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
  180. - New snapshot
  181. * Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  182. - New snapshot
  183. * Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
  184. - New snapshot
  185. * Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
  186. - Don't buildrequire compat-glibc (#51690)
  187. * Thu Aug 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  188. - New snapshot, from the stable branch eventually leading to gdb 5.1
  189. * Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
  190. - s/Copyright/License/
  191. - Add texinfo to BuildRequires
  192. * Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
  193. - New snapshot
  194. * Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  195. - New snapshot
  196. - Add ncurses-devel to buildprereq
  197. - Remove perl from buildprereq, as gdb changed the way
  198. version strings are generated
  199. * Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
  200. - New snapshot
  201. * Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  202. - New snapshot - this had thread fixes for curing #39070
  203. - New way of specifying version
  204. * Tue May 1 2001 Trond Eivind Glomsr <teg@redhat.com>
  205. - New tarball
  206. - Kevin's patch is now part of gdb
  207. * Mon Apr 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  208. - Add patch from kevinb@redhat.com to fix floating point + thread
  209. problem (#24310)
  210. - remove old workarounds
  211. - new snapshot
  212. * Thu Apr 5 2001 Trond Eivind Glomsr <teg@redhat.com>
  213. - New snapshot
  214. * Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
  215. - on ia64, there are no old headers :)
  216. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  217. - build with old headers, new compiler
  218. * Wed Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  219. - new snapshot
  220. * Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
  221. - new snapshot which should fix some more IA64 problems (#29151)
  222. - remove IA64 patch, it's now integrated
  223. * Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
  224. - add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
  225. - use perl instead of patch for fixing the version string
  226. * Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
  227. - don't use kgcc anymore
  228. - mark it as our own version
  229. - new snapshot
  230. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  231. - Link with ncurses 5.x even though we're using kgcc.
  232. No need to drag in requirements on ncurses4 (Bug #24445)
  233. * Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  234. - new snapshot
  235. * Thu Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  236. - new snapshot
  237. * Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
  238. - new snapshot
  239. - new alpha patch - it now compiles everywhere. Finally.
  240. * Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  241. - new snapshot
  242. * Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  243. - new CVS snapshot
  244. - disable the patches
  245. - don't use %%configure, as it confuses the autoconf script
  246. - enable SPARC, disable Alpha
  247. * Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
  248. - added patch from GDB team for C++ symbol handling
  249. * Mon Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
  250. - upgrade to CVS snapshot
  251. - excludearch SPARC, build on IA61
  252. * Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
  253. - rebuild
  254. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  255. - automatic rebuild
  256. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  257. - rebuild
  258. * Fri Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  259. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
  260. and %%{_tmppath}
  261. - the install scripts for info are broken(they don't care about
  262. you specify in the installstep), work around that.
  263. - don't build for IA64
  264. * Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
  265. - upgraded to 5.0 - dump all patches. Reapply later if needed.
  266. - added the NEWS file to the %%doc files
  267. - don't delete files which doesn't get installed (readline, texinfo)
  268. - let build system handle stripping and gzipping
  269. - don't delete libmmalloc
  270. - apply patch from jakub@redhat.com to make it build on SPARC
  271. * Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
  272. - rebuilt against new ncurses
  273. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  274. - rebuild for sparc baud rates > 38400.
  275. * Tue Feb 8 2000 Jakub Jelinek <jakub@redhat.com>
  276. - fix core file handling on i386 with glibc 2.1.3 headers
  277. * Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
  278. - fix reading registers from core on sparc.
  279. - hack around build problems on i386 with glibc 2.1.3 headers
  280. * Thu Oct 7 1999 Jim Kingdon
  281. - List files to install in /usr/info specifically (so we don't pick up
  282. things like info.info from GDB snapshots).
  283. * Thu Oct 7 1999 Jim Kingdon
  284. - Update GDB to 19991004 snapshot. This eliminates the need for the
  285. sigtramp, sparc, xref, and threads patches. Update sparcmin patch.
  286. * Mon Aug 23 1999 Jim Kingdon
  287. - Omit readline manpage.
  288. * Tue Aug 7 1999 Jim Kingdon
  289. - Remove H.J. Lu's patches (they had been commented out).
  290. - Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
  291. from code fusion CD-ROM).
  292. * Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
  293. - merge H.J. Lu's patches into 4.18.
  294. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  295. - updated the kern22 patch with stuff from davem
  296. * Thu Apr 1 1999 Jeff Johnson <jbj@redhat.com>
  297. - sparc with 2.2 kernels no longer uses sunos ptrace (davem)
  298. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  299. - auto rebuild in the new build environment (release 3)
  300. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  301. - Sparc fiddles for Red Hat 6.0.