gcdemu-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %global python_module_name gcdemu
  3. Summary: A GNOME panel applet to control CDEmu daemon
  4. Summary: CDEmu daemon を制御するための GNOME パネルアプレット
  5. Name: gcdemu
  6. Version: 1.3.0
  7. Release: 2%{?_dist_release}
  8. License: GPLv2+
  9. Group: Applications/Accessories
  10. URL: http://cdemu.sourceforge.net
  11. Source: http://downloads.sourceforge.net/cdemu/%{name}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. BuildRequires: dbus-python-devel
  15. BuildRequires: gettext
  16. BuildRequires: intltool >= 0.21
  17. BuildRequires: gnome-panel-devel
  18. BuildRequires: gnome-python-devel
  19. BuildRequires: perl-XML-Parser
  20. BuildRequires: pygtk2-devel >= 2.6
  21. BuildRequires: python-devel
  22. BuildRequires: gnome-doc-utils >= 0.3.2
  23. Requires: dbus-python >= 0.80
  24. Requires: gnome-python-applet
  25. Requires: hicolor-icon-theme
  26. Requires: pygtk2 >= 2.6
  27. Requires(pre): GConf2
  28. Requires(post): GConf2
  29. Requires(preun): GConf2
  30. Requires(post): scrollkeeper
  31. Requires(postun): scrollkeeper
  32. %description
  33. This is gCDEmu, a GNOME applet for controlling CDEmu daemon. It is part of the
  34. userspace-cdemu suite, a free, GPL CD/DVD-ROM device emulator for linux.
  35. It provides a graphic interface that allows performing the key tasks related to
  36. controlling the CDEmu daemon, such as loading and unloading devices, displaying
  37. devices' status and retrieving/setting devices' debug masks.
  38. In addition, applet listens to the signals emitted by CDEmu daemon and provides
  39. the notification via libnotify's notifications (provided that python bindings
  40. are installed).
  41. %prep
  42. %setup -q
  43. %build
  44. %{configure} --disable-schemas-install --disable-scrollkeeper
  45. %{__make} %{?_smp_mflags}
  46. %install
  47. %{__rm} -rf $RPM_BUILD_ROOT
  48. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  49. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  50. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  51. %find_lang gcdemu --with-gnome
  52. %clean
  53. %{__rm} -rf $RPM_BUILD_ROOT
  54. %pre
  55. if [ "$1" -gt 1 ]; then
  56. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  57. gconftool-2 --makefile-uninstall-rule \
  58. %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
  59. fi
  60. %post
  61. scrollkeeper-update -q
  62. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  63. gconftool-2 --makefile-install-rule \
  64. %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
  65. %preun
  66. if [ "$1" -eq 0 ]; then
  67. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  68. gconftool-2 --makefile-uninstall-rule \
  69. %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
  70. fi
  71. %postun
  72. scrollkeeper-update -q
  73. %files -f gcdemu.lang
  74. %defattr(-,root,root,-)
  75. %doc AUTHORS ChangeLog COPYING NEWS README
  76. %{_datadir}/pixmaps/*
  77. #%{_datadir}/omf/gcdemu/gcdemu-C.omf
  78. %{_libdir}/bonobo/servers/*
  79. %{_libexecdir}/*
  80. %dir %{python_sitelib}/%{python_module_name}/
  81. %{python_sitelib}/%{python_module_name}/*.py*
  82. %{_sysconfdir}/gconf/schemas/*
  83. %changelog
  84. * Fri Nov 19 2010 IWAI, Masaharu <iwai@alib.jp> - 1.3.0-2
  85. - add BuildRequires: gnome-doc-utils >= 0.3.2
  86. * Fri Sep 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
  87. - new upstream release
  88. * Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
  89. - rebuilt with python-2.6.4
  90. * Fri Sep 25 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
  91. - initial build for VineSeed
  92. * Sat Jun 28 2008 Rok Mandeljc <rok.mandeljc@email.si> - 1.1.0-1
  93. - Updated to 1.1.0
  94. * Thu Dec 20 2007 Rok Mandeljc <rok.mandeljc@email.si> - 1.0.0-1
  95. - Initial RPM release.