chkconfig-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336
  1. Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
  2. Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
  3. Name: chkconfig
  4. Version: 1.3.51
  5. Release: 2%{?_dist_release}
  6. License: GPL
  7. Group: System Environment/Base
  8. Source: %{name}-%{version}.tar.bz2
  9. Source2: chkconfig.8
  10. Source3: ntsysv.8
  11. Source4: update-alternatives.ja.8
  12. Patch1: chkconfig-1.3.51-vine.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: newt-devel
  15. BuildRequires: popt-devel
  16. Conflicts: initscripts <= 5.30-1
  17. %description
  18. Chkconfig is a basic system utility. It updates and queries runlevel
  19. information for system services. Chkconfig manipulates the numerous
  20. symbolic links in /etc/rc.d, to relieve system administrators of some
  21. of the drudgery of manually editing the symbolic links.
  22. %description -l ja
  23. chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
  24. runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
  25. 多数のシンボリックリンクを操作しますので、システム管理者は手動で
  26. シンボリックリンクをたびたびエディットしなくてもよい。
  27. %package -n ntsysv
  28. Summary: A tool to set the stop/start of system services in a runlevel.
  29. Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
  30. Group: System Environment/Base
  31. %description -n ntsysv
  32. Ntsysv provides a simple interface for setting which system services
  33. are started or stopped in various runlevels (instead of directly
  34. manipulating the numerous symbolic links in /etc/rc.d). Unless you
  35. specify a runlevel or runlevels on the command line (see the man
  36. page), ntsysv configures the current runlevel (5 if you're using X).
  37. %description -n ntsysv -l ja
  38. ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
  39. ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
  40. 操作することから解放する。
  41. %package -n alternatives
  42. Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
  43. Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  44. Group: System Environment/Base
  45. %description -n alternatives
  46. maintain symbolic links determining default commands (from Debian dpkg utilities)
  47. %description -n alternatives -l ja
  48. コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  49. %prep
  50. %setup -q
  51. %patch1 -p1
  52. %build
  53. %ifarch sparc
  54. LIBMHACK=-lm
  55. %endif
  56. %__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. %__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
  60. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  61. ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
  62. for n in 0 1 2 3 4 5 6; do
  63. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
  64. ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
  65. done
  66. mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
  67. cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
  68. # alternatives
  69. mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
  70. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
  71. mkdir -p $RPM_BUILD_ROOT/var/lib/rpm/alternatives
  72. install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
  73. ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
  74. %clean
  75. rm -rf $RPM_BUILD_ROOT
  76. %files
  77. %defattr(-,root,root)
  78. /sbin/chkconfig
  79. /etc/init.d
  80. /etc/rc.d/init.d
  81. /etc/rc[0-6].d
  82. /etc/rc.d/rc[0-6].d
  83. %{_mandir}/*/chkconfig*
  84. %{_mandir}/ja/*/chkconfig*
  85. %{_localedir}/*/LC_MESSAGES/chkconfig.mo
  86. %files -n ntsysv
  87. %defattr(-,root,root)
  88. /usr/sbin/ntsysv
  89. %{_mandir}/*/ntsysv.8*
  90. %{_mandir}/ja/*/ntsysv.8*
  91. %files -n alternatives
  92. %defattr (-, root, root)
  93. /sbin/alternatives
  94. /sbin/update-alternatives
  95. %{_sysconfdir}/alternatives
  96. %{_mandir}/man8/*
  97. %{_mandir}/ja/man8/*
  98. /var/lib/rpm/alternatives
  99. %changelog
  100. * Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.51-2
  101. - change BuildRequires: popt-devel intead of popt
  102. * Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
  103. - new upstream release
  104. - enable fedora version of alternatives
  105. - add alternatives subpackage, replace debian's alternatives
  106. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
  107. - new upstream release
  108. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
  109. - applied new versioning policy and spec in utf-8
  110. * Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
  111. - dropped obsoleted Makefile.x86_64.patch
  112. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
  113. - new upstream release
  114. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
  115. - add Makefile.x86_64.patch
  116. * Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
  117. - add Patch10 to skip xinetd parsing if not exist.
  118. * Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
  119. - rebuild
  120. * Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
  121. - Requires -> Conflicts.
  122. apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
  123. Conflicts/Pre-Depends-loop does not happen.
  124. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
  125. - Oops not PreReq but Requires. Fixed.
  126. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
  127. - change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
  128. to avoid Conflicts/Pre-Depends loop on apt
  129. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  130. - 1.2.17-1vl3
  131. - change checkbox color
  132. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  133. - 1.2.17-1vl2
  134. - rebuilt for VineSeed
  135. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
  136. - 1.2.17-1vl1
  137. * Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
  138. - ignore .rpmnew files (#18915)
  139. - fix typo in error message (#17575)
  140. * Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  141. - make xinetd config files mode 0644, not 644
  142. * Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
  143. - updated it and es translations
  144. * Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
  145. - get man pages in proper packages
  146. * Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
  147. - new translations
  148. * Tue Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  149. - don't worry about extra whitespace on chkconfig: lines (#16150)
  150. * Wed Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  151. - i18n merge
  152. * Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
  153. - new translations for de fr it es
  154. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  155. - change prereqs
  156. * Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
  157. - fix ntsysv's handling of xinetd/init files with the same name
  158. * Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
  159. - fix segv when reading malformed files
  160. * Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
  161. - put links, rc[0-6].d dirs back, those are necessary
  162. * Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
  163. - add quick hack support for reading descriptions from xinetd files
  164. * Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  165. - don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
  166. * Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
  167. - move back to old file layout
  168. * Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
  169. - bump copyright date
  170. * Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
  171. - no %pre today. Maybe tomorrow.
  172. * Thu Jul 6 2000 Bill Nottingham <notting@redhat.com>
  173. - put initscripts %pre here too
  174. * Mon Jul 3 2000 Bill Nottingham <notting@redhat.com>
  175. - oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
  176. * Sun Jul 2 2000 Bill Nottingham <notting@redhat.com>
  177. - add xinetd support
  178. * Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
  179. - changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
  180. - fixed sumary and description where a global string replace nuked them
  181. * Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
  182. - what Bill said, but actually build this version
  183. * Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
  184. - don't own /etc/rc.*
  185. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  186. - typo in man page
  187. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  188. - fix description
  189. * Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
  190. - link chkconfig statically against popt
  191. * Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
  192. - fix querying alternate levels
  193. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  194. - don't use strchr to skip unwanted files, look at extension instead (#4166).
  195. * Thu Aug 5 1999 Bill Nottingham <notting@redhat.com>
  196. - fix --help, --verson
  197. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  198. - rebuilt ntsysv against newt 0.50
  199. * Mon Aug 2 1999 Jeff Johnson <jbj@redhat.com>
  200. - fix i18n problem in usage message (#4233).
  201. - add --help and --version.
  202. * Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
  203. - release for Red Hat 6.0
  204. * Thu Apr 8 1999 Matt Wilson <msw@redhat.com>
  205. - added support for a "hide: true" tag in initscripts that will make
  206. services not appear in ntsysv when run with the "--hide" flag
  207. * Thu Apr 1 1999 Matt Wilson <msw@redhat.com>
  208. - added --hide flag for ntsysv that allows you to hide a service from the
  209. user.
  210. * Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
  211. - fix glob, once and for all. Really. We mean it.
  212. * Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
  213. - revert fix for services@levels, it's broken
  214. - change default to only edit the current runlevel
  215. * Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
  216. - don't remove scripts that don't support chkconfig
  217. * Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
  218. - made glob a bit more specific so xinetd and inetd don't cause improper matches
  219. * Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
  220. - removed debugging output when starting ntsysv
  221. * Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
  222. - fixed globbing error
  223. - fixed ntsysv running services not at their specified levels.
  224. * Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
  225. - print the value of errno on glob failures.
  226. * Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
  227. - rebuilt for newt 0.40 (ntsysv)
  228. * Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
  229. - add ru.po.
  230. * Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
  231. - build for Raw Hide (slang-1.2.2)
  232. * Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
  233. - translation updates
  234. * Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
  235. - updated czech translation (and use cs instead of cz)
  236. * Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
  237. - added pt_BR translations
  238. - added more translatable strings
  239. - support for i18n init.d scripts description
  240. * Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
  241. - built against newt 0.30
  242. - split ntsysv into a separate package
  243. * Thu May 07 1998 Erik Troan <ewt@redhat.com>
  244. - added numerous translations
  245. * Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
  246. - added i18n support
  247. * Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
  248. - added --back