udisks-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247
  1. %define glib2_version 2.6.0
  2. %define dbus_version 1.2
  3. %define dbus_glib_version 0.82
  4. %define polkit_version 0.92
  5. %define parted_version 2.3
  6. %define eudev_version 1.7
  7. %define mdadm_version 2.6.7
  8. %define device_mapper_version 1.02
  9. %define libatasmart_version 0.12
  10. %define sg3_utils_version 1.27
  11. %define smp_utils_version 0.94
  12. Summary: Storage Management Service
  13. Name: udisks
  14. Version: 1.0.5
  15. Release: 1%{?_dist_release}
  16. Group: System Environment/Libraries
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. License: GPLv2+
  20. URL: http://www.freedesktop.org/wiki/Software/udisks
  21. Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
  22. # https://bugs.freedesktop.org/show_bug.cgi?id=90778
  23. Patch0: udisks-1.0.5-fix-build-with-glibc-2.20.patch
  24. Patch1: fix_bash_completion.patch
  25. # https://bugzilla.redhat.com/show_bug.cgi?id=1238664
  26. Patch2: udisks-1.0.5-fix-service-file.patch
  27. Patch3: udisks-1.0.5-fix-makedev-failure.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  29. BuildRequires: glib2-devel >= %{glib2_version}
  30. BuildRequires: dbus-devel >= %{dbus_version}
  31. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  32. BuildRequires: polkit-devel >= %{polkit_version}
  33. BuildRequires: parted-devel >= %{parted_version}
  34. BuildRequires: device-mapper-devel >= %{device_mapper_version}
  35. BuildRequires: intltool
  36. BuildRequires: libatasmart-devel >= %{libatasmart_version}
  37. BuildRequires: eudev-libgudev1-devel >= %{eudev_version}
  38. BuildRequires: eudev-libudev-devel >= %{eudev_version}
  39. BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
  40. # needed to pull in the system bus daemon
  41. Requires: dbus >= %{dbus_version}
  42. # needed to pull in the udev daemon
  43. Requires: eudev >= %{eudev_version}
  44. # we need at least this version for bugfixes / features etc.
  45. Requires: libatasmart >= %{libatasmart_version}
  46. Requires: mdadm >= %{mdadm_version}
  47. # for smp_rep_manufacturer
  48. Requires: smp_utils >= %{smp_utils_version}
  49. # for mount, umount, mkswap
  50. Requires: util-linux-ng
  51. # for mkfs.ext3, mkfs.ext3, e2label
  52. Requires: e2fsprogs
  53. # for mkfs.xfs, xfs_admin
  54. Requires: xfsprogs
  55. # for mkfs.vfat
  56. Requires: dosfstools
  57. # for mlabel
  58. Requires: mtools
  59. # for mkntfs - no ntfsprogs on ppc, though
  60. %ifnarch ppc ppc64
  61. Requires: ntfsprogs
  62. %endif
  63. # for /proc/self/mountinfo, only available in 2.6.26 or higher
  64. Conflicts: kernel < 2.6.26
  65. # we need liblvm2app at least this recent since the ABI changed (sizes
  66. # reported in number of bytes instead of number of sectors) without
  67. # the sonumber changing
  68. #
  69. Requires: lvm2-libs >= %{lvm2_version}
  70. # Obsolete and Provide DeviceKit-disks - udisks provides exactly the same
  71. # ABI just with a different name and versioning-scheme
  72. #
  73. Obsoletes: DeviceKit-disks <= 009
  74. Provides: DeviceKit-disks = 010
  75. %description
  76. udisks provides a daemon, D-Bus API and command line tools
  77. for managing disks and storage devices.
  78. %package devel
  79. Summary: D-Bus interface definitions for udisks
  80. Group: Development/Libraries
  81. Requires: %{name} = %{version}-%{release}
  82. Requires: gtk-doc
  83. # See comment above
  84. #
  85. Obsoletes: DeviceKit-disks-devel <= 009
  86. Provides: DeviceKit-disks-devel = 010
  87. %description devel
  88. D-Bus interface definitions and documentation for udisks.
  89. %prep
  90. %setup -q
  91. %autopatch -p1
  92. # https://bugzilla.redhat.com/show_bug.cgi?id=673544#c15
  93. rm -f src/*-glue.h tools/*-glue.h
  94. autoreconf --force --install
  95. %build
  96. %configure \
  97. --enable-gtk-doc \
  98. %{nil}
  99. make %{_smp_mflags}
  100. %install
  101. rm -rf $RPM_BUILD_ROOT
  102. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  103. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  104. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  105. # for now, include a compat symlink for the command-line tool
  106. # and man page
  107. ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
  108. ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
  109. # TODO: should be fixed upstream
  110. chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/udisks-bash-completion.sh
  111. %find_lang %{name}
  112. %clean
  113. rm -rf $RPM_BUILD_ROOT
  114. %files -f %{name}.lang
  115. %defattr(-,root,root,-)
  116. %license COPYING
  117. %doc README AUTHORS NEWS HACKING doc/TODO
  118. %{_sysconfdir}/avahi/services/udisks.service
  119. %{_sysconfdir}/dbus-1/system.d/*.conf
  120. %{_sysconfdir}/profile.d/*.sh
  121. /lib/udev/rules.d/*.rules
  122. /lib/udev/udisks-part-id
  123. /lib/udev/udisks-dm-export
  124. /lib/udev/udisks-probe-ata-smart
  125. /lib/udev/udisks-probe-sas-expander
  126. /sbin/umount.udisks
  127. %{_bindir}/*
  128. %{_libexecdir}/*
  129. %{_mandir}/man1/*
  130. %{_mandir}/man7/*
  131. %{_mandir}/man8/*
  132. %{_datadir}/polkit-1/actions/*.policy
  133. %{_datadir}/dbus-1/system-services/*.service
  134. %attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
  135. %files devel
  136. %defattr(-,root,root,-)
  137. %{_datadir}/dbus-1/interfaces/*.xml
  138. %{_datadir}/pkgconfig/udisks.pc
  139. %dir %{_datadir}/gtk-doc/html/udisks
  140. %{_datadir}/gtk-doc/html/udisks/*
  141. # Note: please don't forget the %{?dist} in the changelog. Thanks
  142. #
  143. %changelog
  144. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.5-1
  145. - new upstream release.
  146. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-4
  147. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  148. - change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
  149. * Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-3
  150. - rebuild with parted-3.1
  151. * Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
  152. - rebuild with parted-3.0
  153. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  154. - new upstream release
  155. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  156. - new upstream release
  157. - drop Patch0
  158. * Sun Aug 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
  159. - add Patch0 (10-ide-cd-support.patch) from ubuntu
  160. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
  161. - new upstream release
  162. * Tue Nov 9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1-2
  163. - rebuilt with parted 2.3
  164. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
  165. - new upstream release
  166. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
  167. - Initial build for Vine Linux
  168. * Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2%{?dist}
  169. - Bump release and rebuild so we link to the new libparted.
  170. * Mon Mar 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-1%{?dist}
  171. - Update to release 1.0.0
  172. * Tue Feb 23 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100223.1%{?dist}
  173. - Update to new git snapshot
  174. * Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.3%{?dist}
  175. - Require lvm2-libs >= 2.02.61 to get the right ABI for liblvm2app
  176. * Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.2%{?dist}
  177. - Update for new liblvm2app library
  178. * Mon Feb 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.1%{?dist}
  179. - Update to git snapshot
  180. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.2%{?dist}
  181. - Rebuild
  182. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.1%{?dist}
  183. - New git snapshot with LVM support
  184. * Tue Jan 12 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.3%{?dist}
  185. - Rebuild for new libparted
  186. * Mon Dec 07 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.2%{?dist}
  187. - Rebuild
  188. * Fri Dec 04 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.1%{?dist}
  189. - Updated for package review (#543608)
  190. * Wed Dec 02 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202%{?dist}
  191. - Git snapshot for upcoming 1.0.0 release