libcap-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Library for getting and setting POSIX.1e capabilities
  3. Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
  4. Name: libcap
  5. Version: 2.33
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2
  11. Source: https://mirrors.edge.kernel.org/pub/linux/libs/security/linux-privs/libcap2/%{name}-%{version}.tar.xz
  12. Source1: getpcaps.8
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: libattr-devel
  15. BuildRequires: pam-devel
  16. BuildRequires: glibc-static
  17. %description
  18. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  19. draft 15 capabilities.
  20. %package devel
  21. Summary: Development files for libcap
  22. Summary(ja): libcap の開発用ファイル
  23. Group: Development/Libraries
  24. Requires: %{name} = %{version}-%{release}
  25. %description devel
  26. Development files (Headers, libraries for static linking, etc) for libcap.
  27. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  28. draft 15 capabilities.
  29. Install libcap-devel if you want to develop or compile applications using
  30. libcap.
  31. %package static
  32. Summary: static library of libcap
  33. Summary(ja): libcap のスタティックライブラリ
  34. Group: Development/Libraries
  35. Requires: %{name}-devel = %{version}-%{release}
  36. %description static
  37. This package includes the static library of libpcap
  38. # compat32
  39. %package -n compat32-%{name}
  40. Summary: Library for getting and setting POSIX.1e capabilities
  41. Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
  42. Group: System Environment/Libraries
  43. %description -n compat32-%{name}
  44. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  45. draft 15 capabilities.
  46. %package -n compat32-%{name}-devel
  47. Summary: Development files for libcap
  48. Summary(ja): libcap の開発用ファイル
  49. Group: Development/Libraries
  50. Requires: compat32-%{name} = %{version}-%{release}
  51. Requires: %{name}-devel = %{version}-%{release}
  52. %description -n compat32-%{name}-devel
  53. Development files (Headers, libraries for static linking, etc) for libcap.
  54. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  55. draft 15 capabilities.
  56. Install libcap-devel if you want to develop or compile applications using
  57. libcap.
  58. %prep
  59. %setup -q
  60. # %patch0 -p1
  61. sed -i \
  62. -e 's| -O2 | $(RPM_OPT_FLAGS) |' \
  63. -e 's| #-g| $(RPM_LD_FLAGS) #-g|' \
  64. Make.Rules
  65. %build
  66. # libcap can not be build with _smp_mflags:
  67. make PREFIX=%{_prefix} LIBDIR=%{_libdir} SBINDIR=%{_sbindir} \
  68. INCDIR=%{_includedir} MANDIR=%{_mandir} COPTFLAG="$RPM_OPT_FLAGS"
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. make install RAISE_SETFCAP=no \
  72. DESTDIR=${RPM_BUILD_ROOT} \
  73. LIBDIR=/%{_lib} \
  74. SBINDIR=%{_sbindir} \
  75. INCDIR=%{_includedir} \
  76. MANDIR=%{_mandir}/ \
  77. PKGCONFIGDIR=%{_libdir}/pkgconfig/ \
  78. COPTFLAG="$RPM_OPT_FLAGS"
  79. mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man{2,3,8}
  80. #mv -f doc/*.2 ${RPM_BUILD_ROOT}/%{_mandir}/man2/
  81. mv -f doc/*.3 ${RPM_BUILD_ROOT}/%{_mandir}/man3/
  82. chmod +x $RPM_BUILD_ROOT/%{_lib}/*.so.*
  83. # need to build init.lxc.static
  84. mv %{buildroot}/%{_lib}/libcap.a %{buildroot}/%{_libdir}/libcap.a
  85. mv %{buildroot}/%{_lib}/libpsx.a %{buildroot}/%{_libdir}/libpsx.a
  86. cp -f %{SOURCE1} %{buildroot}/%{_mandir}/man8/
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %post -p /sbin/ldconfig
  90. %postun -p /sbin/ldconfig
  91. %post -n compat32-%{name} -p /sbin/ldconfig
  92. %postun -n compat32-%{name} -p /sbin/ldconfig
  93. %files
  94. %defattr(-,root,root)
  95. %license License
  96. %doc doc/capability.notes
  97. /%{_lib}/*.so.*
  98. %{_sbindir}/*
  99. %{_mandir}/man1/*
  100. %{_mandir}/man8/*
  101. /%{_lib}/security/pam_cap.so
  102. %files devel
  103. %defattr(-,root,root)
  104. %{_includedir}/*
  105. /%{_lib}/*.so
  106. %{_libdir}/pkgconfig/*
  107. %{_mandir}/man3/*
  108. %files static
  109. %defattr(-,root,root)
  110. %{_libdir}/*.a
  111. # compat32
  112. %if %{build_compat32}
  113. %files -n compat32-%{name}
  114. %defattr(-,root,root)
  115. /%{_lib}/*.so.*
  116. %files -n compat32-%{name}-devel
  117. %defattr(-,root,root)
  118. /%{_lib}/*.so
  119. %endif
  120. %changelog
  121. * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.33-1
  122. - new upstream release.
  123. - dropped Patch1: made to get same effect by another way.
  124. * Mon Sep 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.27-1
  125. - new upstream release.
  126. * Sun Jun 26 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.25-1
  127. - new upstream release.
  128. - added Source1.
  129. - added libcap-static.
  130. * Thu Jul 9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.24-1
  131. - new upstream release
  132. - change tarfile format
  133. - change flags in install section
  134. - add patch1, drop patch0 (patch1 from fedora)
  135. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-4
  136. - rebuild with VineSeed environment
  137. * Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-3
  138. - add BuildRequires: pam-devel
  139. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-2
  140. - rebuilt with current VineSeed
  141. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16-1
  142. - new upstream release
  143. - remove compat library (libpcap-1.10)
  144. * Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.06-2
  145. - added compat32 package for x86_64 arch support
  146. * Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-1
  147. - source updated
  148. - built with libattr 2.4.41
  149. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl2
  150. - rebuilt
  151. * Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl1
  152. - initial build for Vine Linux based on FC package
  153. * Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 1.10-22
  154. - build with gcc-4
  155. * Wed Feb 09 2005 Karsten Hopp <karsten@redhat.de> 1.10-21
  156. - rebuilt
  157. * Tue Aug 31 2004 Phil Knirsch <pknirsch@redhat.com> 1.10-20
  158. - Fix wrong typedef in userland patch (#98801)
  159. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  160. - rebuilt
  161. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  162. - rebuilt
  163. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  164. - rebuilt
  165. * Tue Jan 27 2004 Karsten Hopp <karsten@redhat.de> 1.10-17
  166. - use _manpath
  167. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  168. - rebuilt
  169. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  170. - rebuilt
  171. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 1.10-14
  172. - set execute bits on library so that requires are generated.
  173. * Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 1.10-13
  174. - Removed %%name macro sillyness from package Summary, description text, etc.
  175. - Removed archaic Prefix: tag
  176. - lib64 fixes everywhere to use _lib, _libdir, etc
  177. - Removed deletion of RPM_BUILD_DIR from %%clean section
  178. - Added -q flag to setup macro
  179. - Severely cleaned up spec file, and removed usage of perl
  180. * Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.10-12
  181. - CFLAGS was using COPTFLAG variable, not COPTFLAGS
  182. - build with -fpic
  183. - apply the IA-64 patch everywhere, use capget/capset from glibc,
  184. not directly as _syscall (as it is broken on IA-32 with -fpic)
  185. - reenable alpha
  186. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  187. - automated rebuild
  188. * Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-10
  189. - Exclude alpha for now, apparent gcc bug.
  190. * Fri Nov 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-6
  191. - Fix sys/capabilities.h header (#55727)
  192. - Move to /lib, some applications seem to be using this rather early
  193. (#55733)
  194. * Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  195. - Add post,postun scripts
  196. * Tue Jul 10 2001 Jakub Jelinek <jakub@redhat.com>
  197. - don't build libcap.so.1 with ld -shared, but gcc -shared
  198. * Wed Jun 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  199. - Rebuild - it was missing for alpha
  200. * Wed Jun 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  201. - add s390/s390x support
  202. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-1
  203. - initial RPM
  204. - fix build on ia64